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How to Use This Software Guide
This software guide provides a step-by-step guide to configuring the VMX300(-E) server and operating the VMX300 (-E) client. Follow the steps in 
the table to configure the server and operate the client.

Refer to the VMX300(-E) Server Configuration Manual for complete information about configuring the server.

Refer to the VMX300(-E) Client Operation Manual for complete information about using the client software.

Note that you must install the VMX300(-E) workstation and then connect it to your system network before you can begin these configuration 
steps. Refer to the VMX300 Installation manual for instructions.

IMPORTANT NOTE. PLEASE READ.
The network implementation in step 10 of this document is shown as a general representation only and is not intended to show a detailed 
topology. Your actual network will differ, requiring changes or perhaps additional network equipment to accommodate the systems as 
illustrated. Please contact your local Pelco Representative to discuss your specific requirements.

Table A.  VMX300(-E) Configuration and Operation Steps

Server Configuration

Step  1 Log on and configure operating system settings.

Step  2 Start the server and register the software.

Step  3 Launch the server’s configuration mode.

Step  4 Start VMX300(-E) device drivers.

Step  5 Add clients to the server.

Step  6 Configure custom windows.   

Step  7 Define a canvas for each window. 

Step  8 Add device drivers to the server configuration.

Step  9 Add devices.

Step 10 Define analog connections between devices.

Step 11 Add user groups.

Step 12 Add users.

Step 13 Add maps.

Step 14 Customize and automate your system.

Step 15 Backup the server database to external media.

Step 16 Exit configuration mode and launch server in run mode.

Step 17 Test the configuration and evaluate the CPU workload.

Client Operation

Step 18* Specify which servers are available to the client.

Step 19* Configure a workspace.

Step 20 Start the client.

Step 21 Work with maps.

Step 22 Work with devices.

Step 23 Use custom windows.

Step 24 Use the Event Picker.

Shutdown Step 25 Shut down the VMX300(-E) software.

*NOTE:  Steps 18 and 19 are completed with the VMX300(-E) cilent application and can be completed by an operator, but the system 
administrator may want to complete these steps ahead of time as part of the server configuration.
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1 Log On and Configure Operating System Settings

1. Connect the VMX300(-E) workstation power cord to the workstation power input and then to an uninterruptible power supply (UPS).

2. On the front panel of the workstation, press the power button to power on the unit.

3. The VMX300(-E) boots, and then the Microsoft® Windows® log on dialog box appears.

4. Log on to the Windows desktop with the following user name and password:

User Name: AvUser
Password: 1234

5. Click OK. The Windows XP desktop appears.

6. Configure the operating system settings, as described in the following sections.

7. Repeat steps 1-6 for each VMX300(-E) workstation in your system.

CONFIGURE OPERATING SYSTEM SETTINGS
Before starting the VMX300(-E), you must configure the following operating system settings; instructions for the first three tasks are provided in 
the subsequent sections. If you are using a DX8000 Series DVR, refer to the DX8000 Installation manual for instructions on disabling the IPSec 
security services.

• Assign the VMX300(-E) IP address to the workstation.

• Identify the VMX300(-E) workstation on the network.

• If you are not using a DX9000 Series DVR, disable the NetBIOS service in the Windows operating system.

• If you are using a DX8000 Series DVR, disable the IPSec security services in all DX8000 Series DVR units (including any remote DX8000 
Client units).

ASSIGN AN IP ADDRESS TO THE VMX300(-E) WORKSTATION

1. Click Start > Settings > Network Connections. The Network Connections window 
appears.

2. Right-click Local Area Connection, and then select Properties from the pop-up 
menu.

3. In the Local Area Connection Properties dialog box, double-click the Internet 
Protocol (TCP/IP) listing. The Internet Protocol (TCP/IP) Properties dialog box 
appears.

CAUTION:  Contact your network administrator to assist you in configuring the network features of the VMX300(-E) workstation.

A NOTE ON WINDOWS XPSP2 SETTINGS:  The VMX300(-E) workstation is configured with Windows XP and the XP Service Pack 2 
(XPSP2). Note, however, that the XPSP2 firewall protection and automatic update features are turned off by default in the VMX300(-E) 
workstation. To enable these features for your VMX300(-E) system refer to the Windows XP Service Pack 2 instructions available on the 
Microsoft website (www.microsoft.com).

CAUTION:  Each device driver and device added to the VMX300(-E) system is iden-
tified with the VMX300(-E) server IP address. Therefore, it is essential to assign the 
VMX300(-E) IP address before continuing with the VMX300(-E) configuration.

Figure 1.  Opening the Local Area
Connection Properties Dialog Box
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By default, the properties are set to “Obtain an IP address automatically” 
and “Obtain DNS server address automatically.”

4. Click “Use the following IP address,” and then complete the following steps:

a. Enter the IP address of the VMX300(-E) workstation.

b. Enter the subnet mask address.

c. If applicable, enter the default gateway address, and the preferred 
and alternate DNS server addresses; otherwise, skip this step and 
proceed to step 5.

5. Click OK to close the Internet Protocol (TCP/IP) Properties dialog box, and 
then click OK to close the Local Area Connection Properties dialog box.

6. Close the Network Connections window by clicking the X in the upper 
right-hand corner of the window.

IDENTIFY THE VMX300(-E) WORKSTATION 
ON THE NETWORK

This procedure includes assigning a unique computer name to the VMX300(-E) workstation and then assigning the VMX300(-E) workstation to a 
workgroup or a domain. If these steps are not applicable in your system, skip this procedure. Note that if you are using a DX9000 Series DVR in 
your system, you must assign the VMX300(-E) to the appropriate DX9000 workgroup.

To identify the VMX300(-E) on the network, complete the following steps:

1. On the Windows XP desktop, right-click the My Computer icon, and then click Properties. The System Properties dialog box appears.

2. Click the Computer Name tab, and then click Change. The Computer Name Changes dialog box appears.

Figure 3.  Identify the VMX300(-E) Workstation on the Network

3. In the “Computer name” field type the new name.

NOTE:  You must assign a unique IP address to each VMX300(-E) work-
station in your system.

Figure 2.  Internet Protocol (TCP/IP) Properties 
Dialog Box
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4. (Optional) Assign the VMX300(-E) to be a member of a workgroup or a domain:

To assign the VMX300(-E) to a workgroup enter the workgroup name in the Workgroup field.

To assign the VMX300(-E) to a domain click Domain, and then enter the domain name. Click OK, and then enter the user name and pass-
word in the Domain Username and Password dialog box.

5. Click OK. The Computer Name Changes message appears indicating that the VMX300(-E) has been assigned to the specified workgroup or 
domain.

6. Click OK. The restart message appears.

7. Click OK, close all windows, and then restart the VMX300(-E) workstation.

DISABLE NETBIOS

A workstation running the NetBIOS service on a network can be vulnerable to attack from outside sources. If you are not using a DX9000 Series 
DVR, you should complete the following steps to disable the NetBIOS service in the Windows operating system. Note, however, that you should 
contact your network administrator before changing any NetBIOS settings.

To disable NetBIOS, complete the following tasks; instructions are provided in the following sections:

• Disable the NetBIOS setting in the Advanced TCP/IP Settings dialog box.

• Disable the NetBIOS Helper in the Services window.

After completing these tasks, restart the workstation.

Disable NetBIOS in the Advanced TCP/IP Settings Dialog Box

1. Click Start > Settings > Network Connections. The Network Connections window appears.

2. Right-click Local Area Connection, and then select Properties from the pop-up menu.

3. In the Local Area Connection Properties dialog box, double-click the Internet Protocol (TCP/IP) listing. The Internet Protocol (TCP/IP) 
Properties dialog box appears (refer to Figure 2).

4. Click Advanced. The Advanced TCP/IP Settings dialog box appears.

Figure 4.  Advanced TCP/IP Settings Dialog Box–WINS Page

CAUTION:  The NetBIOS service is required for the DX9000. Do not complete this procedure if you are using a DX9000 Series DVR or if any 
other applications in your system require the NetBIOS service. You should follow proper security measures to limit the network’s exposure 
to potential threats when the NetBIOS service is enabled.
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5. Click the WINS tab, and then click “Disable NetBIOS over TCP/IP.”

6. Click OK.

7. Click No in any messages regarding bindings (you do not need any bindings).

8. Click Yes in any additional messages that appear, and then click OK to close the remaining open dialog boxes.

9. Continue with the steps described in the next section to disable the NetBIOS Helper service.

Disable the NetBIOS Helper Service

1. Click the Windows Start button, and then select Settings > Control Panel > Administrative Tools > Services. The Services window appears.

Figure 5.  Windows Operating System Services Window

2. Right-click the service named TCP/IP NetBIOS Helper, and then click Properties. The TCP/IP NetBIOS Helper Properties dialog box appears.

Figure 6.  TCP/IP NetBIOS Helper Properties Dialog Box

3. Click the down arrow in the “Startup type” drop-down box, and then click Disabled.

4. Click OK, close all windows, and then restart the VMX300(-E) workstation.
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2 Start VMX300(-E) Server and Register the Software

1. Click the Windows® Start button, and then choose Programs > VMX300 > VMX300 Server.

2. The Base License message prompts you to type a base license. Click Yes to open the Add License dialog box.

3. Enter your license ID in the Add License dialog box. The 
base license ID and any additional license IDs (each ID 
is a four-part number) are provided on the VMX300(-E) 
Licenses sheet. The hardware ID is entered by Pelco at 
the factory.

4. Obtain your activation code.  

a. Open your Internet browser and go to the 
VMX Series Activation page at 
Pelco.com. http://www.pelco.com/
vmxactivation.

b. Enter your hardware ID and license ID, 
and then complete the remaining fields.

c. Click Activate. A confirmation screen 
appears, containing your activation code.

OR

Call Pelco Technical Support:  
1-800-289-9100 or 
1-559-292-1981

IMPORTANT:  Once you have entered your License ID, 
you must obtain your activation code (step 4) and then 
enter it (step 5) within 45 days.

License ID

Figure 7.   Adding License ID
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5. Enter your activation code in the Add License dialog box. 

6. Click Apply.

If you purchased additional license IDs, repeat steps 1-4 for each license ID.

Note that licenses are applied as follows:

VMX300 Client Application Five licenses for each additional client (licenses for the first client application are covered by the 
base license)

VMX300-E Client Application Ten licenses for each additional client (licenses for the first client application are covered by the 
base license)

Cameras One license for each camera

7. Click Close.
ˇ

NOTE:  To refer to the installation ID or activation 
code at a later time, complete the following 
steps:

• Select Tools > License Manager from the 
menu bar. The License Manager dialog box 
appears.

• Click your license, and then click Properties. 
The License Properties dialog box appears.

Figure 8.  Adding Activation Code

Figure 9.  License Manager Dialog Box
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3 Launch the Server’s Configuration Mode
1. The Corrupt or Missing Database message appears because VMX300(-E) must create a new database the first time you use it. Click Create.

Figure 10.  Corrupt or Missing Database Message

2. The VMX300(-E) start-up screen appears. Click Configure.

3. The VMX300(-E) Server Login dialog box appears. Enter the administrator user name and password:

User Name: administrator
Password: 2899100

4. Click OK. The VMX300(-E) Configuration window appears.   

Figure 11.  VMX300(-E) Configuration Window
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4 Start VMX300(-E) Device Drivers
1. Click the Windows Start button, and then select Programs > VMX300. Select the appropriate device driver from the list of VMX300(-E) 

components. 

The Corrupt or Missing Database message appears because VMX300(-E) must create a new driver database the first time you use the 
driver.

Figure 12.  Corrupt or Missing Database Message

2. Click Create. The Configure Driver dialog box appears. 

Figure 13.  Sample Configure Driver Dialog Box

3. Enter a listening port number between 2,000 and 10,000, and use this port number when you add the driver to the server configuration. To 
run more than one driver or multiple instances of the same driver, select a different port for each instance.

4. Select the appropriate mode from the following options:

• Start the driver as an executable:
If the server is shut down, each driver running as an executable must be manually started when the server is launched again.

• Install the driver as a service:
If the server is shut down, each driver running as a service is restarted when the server is launched again.
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5. Click OK. If you selected “Install the driver as a service,” you must start the driver manually using either of the following methods:

• Click the Windows Start button, and then select > Settings > Control Panel > Administrative Tools > Services. Right-click the driver, 
and then select Start from the pop-up menu.

Figure 14.  The Windows Operating System Services Window

• Restart the workstation the driver is installed on.

The device driver is active when the driver icon appears in the Windows system tray.

6. Repeat steps 1-5 for each device driver necessary to control all the devices in your system.

NOTE:  Each instance of the Pelco ASCII device driver can support a single switcher and multiple cameras. If you have more than one 
switcher to configure, add the device driver to the server configuration once for each switcher.
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5 Add VMX300(-E) Clients to the Server
Before an operator can use the VMX300(-E) client software to view video or monitor the system, each workstation that will log in to the server 
must be added as a VMX300(-E) client in the server configuration. Then you must configure custom windows and canvases for each client. 

1. Navigate the Object Browser tree to [project name] > Clients.

2. Double-click <Add New Client>. The Add New Client dialog box appears.

Figure 15.  Add New Client Dialog Box

3. Type the name of the client workstation, or click Browse to select from a list of all clients visible on the network. The computer name must 
match the computer name listed in Start > Settings > Control Panel > System on the client workstation.

4. Optional: Once you have defined one or more workspaces in the VMX300(-E) client application, you can assign a default workspace. Refer 
to Step 19, Configure a Workspace.

5. Click OK.
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6 Configure Custom Windows for the VMX300(-E) Clients
The number of custom windows that you need to configure will vary based on your specific system parameters. In general, configure as many 
custom windows as you want the operator using this client to view at any one time.

For example, a total of nine custom windows are required for an operator to view the following types of content at one time:

• A map (operators can view maps in custom windows as well as in the viewport)

• A web page

• Three analog video streams

• Four digital video streams

Note, however, that your specific system parameters will limit the number of digital video streams that an operator can view at any one time. 
Refer to Table B in Step 7, Define a Canvas for Each VMX300(-E) Client Window for an overview of the maximum number of streams 
recommended for specific digital settings.

1. Navigate the Object Browser tree to [project name] > Clients > [client name] > Windows.

2. Double-click <Add New Window>. The Add New Window dialog box appears. 

3. Type a window name that is unique within the client configuration.

4. Click OK.

5. Repeat steps 1-4 to add additional windows. (Note that you can use the Copy and Paste functions to create multiple windows with the 
same properties; refer to the appendix of the VMX300(-E) Server Configuration Manual for instructions.)

Figure 16.  Add New Window Dialog Box
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7 Define a Canvas for Each VMX300(-E) Client Window
Canvases are required if the window will be used to view video. Canvases define the video display technology available to that client, and they 
can include both analog and digital (IP-based) technologies.

1. Navigate the Object Browser tree to [project name] > Clients > [client name] > Windows > [window name] > Canvases for the window you 
just added.

2. Double-click <Add New Canvas>. The Add New Canvas dialog box appears. 

Figure 17.  Add New Canvas Dialog Box

3. Select the appropriate canvas from the drop-down box.

4. Click Settings to configure settings specific to the selected canvas (not available for all canvas types). 

For example, if you select Quad Video Display, click Settings, and then click the input connector (differentiated by color) used by the device 
for which this canvas is used to view video. If you select MPEG click Settings to sort or edit the list of video signal types.

5. Click OK. 

6. If the operator needs to view more than one type of video in this specific window, repeat these steps to add a canvas for each type of video. 
(Note that the system chooses which canvas to use based on the order the canvases are listed in the Object Browser.)

NOTE:  The type of video signal that you select for an MPEG device’s canvas will affect the total number of digital video streams that an 
operator can view at any one time. Refer to Table B for an overview of the maximum number of streams recommended for specific digital 
settings.
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HOW TO CHOOSE THE VIDEO STREAM SETTINGS FOR YOUR CONFIGURATION
VMX300(-E) can combine analog and digital video streams for viewing on the VMX300(-E) client. The total number of digital streams that can be 
displayed is limited by the size and type of images selected for viewing. Table B identifies the CPU workload and bandwidth amounts used for 
each type of video stream. 

Table B includes the recommended PelcoNet™ setting, identified by the gray row. Your selections may vary, depending on system bandwidth 
limitations or other restrictions.

Table B.  Digital Video Stream Settings

CAUTION:  System performance will be compromised if the number of video streams is exceeded or if the PelcoNet settings exceed the 
recommendations provided in Table B. 

Also note that CPU workload could vary, depending on additional system activity that may be occurring at the same time. For example, 
using scripts, viewing analog video, or using hyperlinks to change map displays could all affect the CPU workload. It is recommended that 
you monitor the CPU workload level under a variety of system conditions while testing your system configuration to identify the optimal 
number of digital video windows allowed for your configuration. 

Note that if the VMX300(-E) client is operated from a separate workstation (instead of the same workstation running the VMX300(-E) 
server), then you may be able to display more digital windows, since the VMX300(-E) client would not be using the VMX300(-E) server’s 
CPU. 

A NOTE ABOUT MULTIPLE CLIENTS:  If your system requires only one client, the client and server applications can both run on the 
same workstation. To optimize system performance in a multiple-client system, each client application should run from a dedicated client 
workstation. Additional servers in the same system (VMX300-E only) should be run from dedicated server workstations as well. 

Settings Maximum Number of Streams

PelcoNet NET300 Series and NET350 Series Transmission Systems

VMX High Quality (Stream 1) [“Optimize” setting] 16

VMX Standard (Stream 2) [“Optimize” setting] 16

High Quality (CIF) [Factory default setting]  4

DX9000 Series Digital Video Recorders

Half Frame Rate

Live Video 16

Archived Video 16

Full Frame Rate

Live Video 16

Archived Video 16

PelcoNet NET4001A Transmission System

MPEG4

High Quality (CIF) [Factory default setting] 12

VMX Standard [“Optimize” setting] 16

MPEG2

5 MBps High Quality [Factory default setting]  5

2 MBps Low Delay [“Optimize” setting]  5

DX8000 Series Digital Video Recorders

320x240 5 IPS [”Normal” image quality setting] 16

740x480 30 IPS [“Normal” image quality setting]  3
(or 6, if using two DX8000 units)

640x480 10 IPS [“Normal” image quality setting] 16
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8 Add Device Drivers to the Server Configuration

1. Navigate the Object Browser tree to [project name] > Device Drivers.

2. Two functions are provided for adding devices—Add New Driver or Autodiscover All Drivers. Use either option.

Figure 18.  Device Drivers

ADD NEW DRIVER
If you know a driver’s IP address and port number, you can enter it manually by completing the following steps:

1. Double-click <Add New Driver> in  the right pane of the Object Browser. The Add New Driver dialog box appears.

2. By default, the server’s IP address appears in the Driver IP Address box. If the device driver is not installed on the server, type the IP address 
of the workstation the driver is installed on.

OR

Click Browse to browse the network for drivers that are currently running. The Browse Drivers dialog box lists all device drivers that are 
running at a network location visible to the server you are configuring, except drivers that are already configured on the server. Select the 
driver you want to add, and then click OK. 

3. Type the listening port for the device driver you want to add. This is the port that was entered in the Configure Driver window when the 
device driver was launched. Refer to Step 4: Start VMX300(-E) Device Drivers for more information.

4. Optional: To verify that a device driver is running at the specified IP address and port number, click Check Now.

5. Click Add.

6. Repeat these steps for each device driver that you launched in Step 4, Start VMX300(-E) Device Drivers.

AUTODISCOVER ALL DRIVERS
The Autodiscover All Drivers function locates all drivers running on the local area network (LAN) that are visible to the VMX300(-E) server. To add 
a driver that is running on a wide area network (WAN), use the Add New Driver option, described above.

1. Double-click <Autodiscover All Drivers> in the right pane of the Object Browser. A caution message appears.

2. Click Yes. The process may take several seconds; when it is complete, the new driver names appear in the Object Browser.

3. If the autodiscover function did not find every driver that you wanted to add, use the Add New Driver option to add the remaining drivers. 
In order for the VMX300(-E) system to locate a device driver automatically, the driver must be running at a network location that is visible to 
the VMX300(-E) server.

NOTE:  To add a device driver to the server configuration, the driver must be running—either on the server workstation or on the network. 
Refer to Step 4, Start VMX300(-E) Device Drivers.
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9 Add Devices
1. Navigate the Object Browser tree to [project name] > Device Drivers > [device driver name] > Devices.

Some device drivers, such as the PelcoNet MPEG driver or the ASCII driver, do not list the generic “Devices” label under the driver name. 
These drivers list either a specific type of device, such as “Switchers” or “Cameras,” or they list the device model, such as “PelcoNet 3xx 
Encoders.” To navigate to a specific device, click the label listed under the driver name, such as the PelcoNet model, as shown below.

Figure 19.  Sample Add Device Navigation

2. Two functions are provided for adding devices—Add New Device and Autodiscover All Devices. Use either option.

ADD NEW DEVICE
You can enter a device manually by completing the following steps:

1. Double-click <Add New Device> in the right pane of the Object Browser. The Add New Device dialog box appears.

2. Enter a location name and an optional description on the General tab.

3. Configure the settings on any additional Add New Device dialog box tabs. The specific settings contained on these tabs vary, depending on 
the features supported by the device. Sample tabs include the following:

Properties Use this tab to specify display settings, such as a device icon’s color when it is in a normal state versus an alarm state.

Communications Use this tab to specify how the driver communicates with the device (serial or IP).

For information on device configuration settings, refer to the Devices section in the VMX300(-E) Server Configuration Manual.

4. Click OK.

AUTODISCOVER ALL DEVICES
The Autodiscover All Devices function locates all IP devices of the selected type that are running on the local area network (LAN). To add a device 
that is running on a wide area network (WAN), use the Add New Device option, described above.

1. Double-click < Autodiscover All Devices > in the right pane of the Object Browser.

2. Wait several seconds. When the process is complete, the new devices appear in the Object Browser.

3. To change any specific device settings, right-click the device, and then select Edit from the pop-up menu.

.

NOTES:

• You can only locate IP devices automatically. You cannot automatically locate devices that are connected serially.

• In order for the VMX300(-E) server to locate a device automatically, the device driver must running on the network and configured on 
the VMX300(-E) server. In addition, the device must be installed at a network location that is visible to the server.
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10 Define Analog Connections Between Devices
To view analog video from a VMX300(-E) workstation, you must identify the switch path of each analog connection in the VMX300(-E) system. 
This includes video sources connected directly to a VMX300(-E) workstation, or video input or output devices (such as a camera or monitor) 
connected by coaxial cable to a switching device (such as a switcher or a PelcoNet MPEG Series transmission system); the connection between 
the switching device and the VMX300(-E) workstation can be either a direct connection or over the network.

1. Navigate the Object Browser tree to [project name] > Connections.

2. In the right pane, double-click Analog Video Connections. The Analog Video Connections dialog box appears.

3. Click the appropriate Source Device in the left pane, and then double-click the Destination Device in the right pane that you want to 
connect the Source Device to. The Destination Device moves to the left pane and is displayed as part of the analog video connection. 
Repeat steps until all connections have been set.

4. Click File > Close to close the Analog Video Connections dialog box.

Figure 20.  Sample Connections for a System Using a Matrix

Figure 21.  Sample Connections for a System Using PelcoNet Transmission Systems

LOBBY MONITOR

LOBBY CAMERAREAR DOCK CAMERA

VMX300 (-E)

BUILDING 1 MATRIX

NETWORK

FRONT DOOR
CAMERA

HALLWAY
CAMERA

FRONT DOOR ENCODER

HALLWAY ENCODER

VMX300 (-E)
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11 Add User Groups
This procedure is optional.

1. Navigate the Object Browser tree to [project name] > User Groups.

2. Double-click <Add New User Group> in the right pane. The Add New Group dialog box appears.

 

Figure 22.  Add New Group Dialog Box

3. Assign a group name, and then select the permissions you want members of the new group to have by checking the desired permissions in 
the Group Permissions tree.

If necessary, click any check boxes that have a plus sign in them to expand the list.

NOTE:  The VMX300(-E) system is configured at the factory with a predefined user group, named Users, which has all permissions except 
the administrative permission.
C1561M-A (4/05) 19

Download from Www.Somanuals.com. All Manuals Search And Download.



step

12 Add Users
This procedure is optional.

1. Navigate the Object Browser tree to [project name] > Users.

2. Double-click <Add New User> in the right pane. The Add New User dialog box appears.

Figure 23.  Add New User Dialog Box

3. Assign a user name and password, and then provide a full name and description, if desired. Note that the password is case sensitive, but 
the user name is not.

4. In the Member of Group(s) section, click the check box to select each user group you want the user to belong to.

5. Click OK.

NOTE: The VMX300(-E) system is configured at the factory with a predefined user account that allows you to log in to the client without 
having to add a new user. The predefined user name is “user” and the account does not require a password.
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13 Add Maps to the Server Configuration
This procedure is optional.

1. Navigate the Object Browser tree to [project name] > Maps.

2. Double-click <Add New Map>. The Add New Map dialog box appears.   

3. Click Browse to locate the map file. VMX300(-E) accepts .jpg, .bmp, 
.wmf, and .emf file formats.

4. Select the desired file, and then click Open.

5. Click OK.

6. Optional: You may want to add some device icons to system maps so 
that they will be useful for system operators. To do so, complete the 
following steps:

a. Click the map name in the Object Browser tree, and then drag the 
map to the map viewport.

b. Release the mouse. The map appears in the viewport.

Figure 25.  Viewing a Map in the Map Viewport

c. Click the device name in the Object Browser tree and drag the device to the map.

d. Click the mouse again to release the device.

e. Repeat steps c and d for additional devices.

7. Repeat steps 2-6 for additional maps.

NOTE:  To reduce the CPU workload, map files should be as small as 
possible. Avoid using files with a file size over 1 MB.

Figure 24.  Add New Map Dialog Box
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14 Customize and Automate Your System
The following procedures are optional.

CUSTOMIZATION
VMX300(-E) provides numerous ways to customize your system. The following features are described in detail in the VMX300(-E) Server 
Configuration Manual:

• Configure device settings (configure device properties, local settings, and interlocks; view read properties; and assign write properties)

• Customize maps with device icons, named views, hotlinks, and labels

• Configure server ties if you have more than one server and wish to share video between servers

AUTOMATION
VMX300(-E) provides powerful automation tools to manage your security system. The following automation features are described in detail in 
the VMX300(-E) Server Configuration Manual:

• Scripts–custom programs used to automate common tasks; includes global scripts and global tags

• Prompts–custom dialog boxes, such as error messages

• Timers and Schedules–features that allow you to execute system actions and scripts at a specific time

• Alarms and Events–configure alarm and event actions that are executed when specific conditions occur within the system

• Icons–add alarm and event icons to maps

• Recipient Groups–operators who are notified of scheduled actions and alarms and events
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15 Backup a Database
Use the Backup utility to create a backup of the server database and to save backup databases to alternative media (such as a CD).

1. Click File > Save to save the server configuration.

2. Click Tools > Database Utilities > Backup. The Backup Database dialog box opens.

Figure 26.  Backup Database Dialog Box

3. Type an appropriate filename, and then navigate to a new folder location. Name the file with a recognizable filename, and save the file in a 
unique folder location that is separate from the backup files that are automatically generated by VMX300(-E). If you have to restore a 
database it will be very important to select the correct backup file.

Refer to the VMX300(-E) Server Configuration Manual for instructions on restoring a database.

4. Click Save.

NOTE: The Backup utility backs up the server database only. The Backup utility does not back up maps, workspace files, driver databases, 
archive server databases, or the client database.
C1561M-A (4/05) 23

Download from Www.Somanuals.com. All Manuals Search And Download.



step

16 Exit Server Configuration and Launch the Server in Run Mode
1. Click File > Exit and Run.

2. The save changes prompt appears. Click Yes to save changes.

3. When the verification procedure is complete, the server enters Run mode. The VMX300(-E) icon appears in the Windows system tray when 
the server is in Run mode.

How to Return to the Server Configuration

To return to server configuration mode while the VMX300(-E) server is running, complete the following steps:

1. Double-click the VMX300 icon in the Windows system tray, and then select Configure from the pop-up menu (you can also access the 
pop-up menu by right-clicking the icon). The VMX300 Server Login dialog box appears.

2. Type your user name and password, and then click OK. After several seconds, the VMX300(-E) Configuration window appears.

3. After making changes to the server configuration, click File > Close or click the Close button at the right of the configuration window title 
bar. The confirmation dialog box prompts you to save your changes.

4. Click Yes. After the system verifies the configuration changes the VMX300(-E) Configuration window closes, momentarily interrupting 
operators logged in to the client. The server then resumes operation.
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17 Test the Configuration and Evaluate the CPU Workload
Testing the configuration ensures that system devices are connected and configured correctly, and that custom windows are configured correctly.

1. Start the VMX300(-E) client: Start the client on any workstation that you added as a client. Select the VMX300(-E) client from the Windows 
Start menu, or double-click the VMX300(-E) client icon on the desktop.

2. Specify which servers are available to the client: Click the Servers button at the bottom of the Client Login dialog box. Click Discover All to 
autodiscover servers. Select the server and then click Set as Home Server. Refer to Step 18, Specify Which Servers Are Available to the 
Client for more information.

3. Log in: Use the predefined user account (user name: user; no password) to log in to the client.

4. Build workspace: When asked whether you want the system to build a workspace for you, click Yes.

5. Test devices: Drag a PTZ camera from the Device List to a custom window with the appropriate type of canvas to make sure you can view 
video from the camera. Right-click the camera in the Device List, and then select Show Control Dialog to open the camera’s Device Control. 
Test controlling the camera. Repeat this for all cameras that are configured.

Test the other devices in the Device List. Refer to Step 22, Work with Devices for more information.

6. Evaluate the CPU workload: It is recommended that you monitor the CPU workload under a variety of system conditions while testing your 
system configuration. If your system frequently exceeds 85% CPU usage, you may experience system performance problems. The following 
factors can contribute to a high CPU workload:

• The number of custom windows that an operator is using at one time to view digital video streams

• The quality, bit rate, and type of digital video streams

• The file size of a map that an operator is viewing

• The size of device icons and alarm/event icons on maps

• The size and function of hotlinks on maps

• Whether a device icon or alarm/event icon is flashing to indicate an alarm state 

To monitor the CPU workload, you can use either the VMX300(-E) Session Manager (in the client application) or the Windows Task Manager.

Using the Windows Task Manager to Evaluate CPU Workload
Open the Windows Task Manager, and then click the Performance tab. The CPU Usage portion of the window displays the current workload level. 
You can also click on the Processes tab to see which programs are using which percentage of the CPU.

Figure 27.  Windows Task Manager

Using the Session Manager to Evaluate CPU Workload
The rectangle at the right end of the Session Manager tool bar represents the CPU usage of the workstation you are logged in to. As usage 
increases, the rectangle fills with color. Position the pointer over the rectangle to see a dynamic numeric readout of the CPU usage percentage.

Figure 28.  Session Manager Tool Bar

IMPORTANT:  If the client is on a workstation separate from the server, you may need to log on to the Windows desktop (user name: 
AvUser; password: 1234).
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18 Specify Which Servers are Available to the Client
This procedure is optional for the system administrator. If the system administrator does not specify the servers, the operator can complete this 
step the first time he uses the VMX300(-E) client.

The first time the VMX300(-E) client is run on a workstation, you must specify which VMX300(-E) server(s) to connect to the client. Once 
specified, a client will connect to the configured servers by default. A user with appropriate permission can select different servers when logging 
on to the client. Server selection is client-specific. The same list of servers applies for every user who logs in from that client, unless the user 
changes the server list.

1. Click the Windows Start button, and then choose Programs > VMX300 > VMX300 Client.

2. The Corrupt or Missing Database message appears because VMX300(-E) must create a new database the first time you use it. Click Create.

3. The VMX300(-E) Client Login dialog box appears.

  

Figure 29.  Client Login Dialog Box

4. Type the user name and password. Note that the password is case sensitive, but the user name is not.

5. Click Servers. The Configure Servers dialog box appears.

Figure 30.  Configure Servers Dialog Box

6. Click either Discover All or Add to specify which server or servers the client will connect to.

The Add function adds servers to the Configured Servers list without clearing the existing list. The Discover All function clears any servers 
that are currently configured, and then adds each server that is running on the local network (LAN). To specify a server that is running on a 
wide area network (WAN), use the Add option.

To use the Add function, complete the following additional steps:

a. Click Add. The Add Server dialog box appears.
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Figure 31.  Add Server Dialog Box

b.  Type the IP address and port number of the server in the Primary Server fields.

OR

Click Browse to browse the network for a list of servers. The Browse Servers dialog box lists the servers that are running at a network 
location available to the client. Select the server, and then click OK.

c. Optional (VMX300-E only): To designate a backup server, type the IP address and port number of the backup server.

d. Click Add.

e. Optional: Repeat these steps to add another server to the Configured Servers list. Each time a user logs in to this VMX300(-E) client, 
he will be logged into every server in this list.

7. Click the server designated as a home server for the user, and then click Set as Home Server. The selected server is highlighted in bold in 
the server list.

8. Optional: If there are any servers in the server list that the user should not be logged in to, click the server, and then click Remove.

9. Click OK to close the Configured Servers dialog box.

10. Click OK to log in. If the user is a member of more than one user group, the Select User Group dialog box appears. Select the desired user 
group from the drop-down box, and then click OK.

11. The Workspace Not Found dialog box appears. Click Yes to have the system create a default workspace. The VMX300(-E) main user 
interface appears, displaying the default workspace configured by the system.

Figure 32.  Main User Interface
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19 Configure a Workspace
This procedure is optional for the system administrator. If the system administrator does not configure a workspace, VMX300(-E) provides several 
workspace configuration options, as described below.

A workspace controls which windows are displayed in the VMX300(-E) client and their size, position, and content. The system administrator may 
want to log into the client in order to configure a default workspace for users. VMX300( E) provides the following workspace options:

• The system administrator can specify a default workspace in the client configuration to load when a user logs in. 

• VMX300(-E) can create a default workspace for each user upon login.

• A user with Client Workspace permissions can open a workspace once he is logged in.

DEFAULT WORKSPACE: 
To configure a workspace, a user must belong to a user group with Client Workspace permissions. To provide a default workspace for any users 
that are restricted from Client Workspace permissions, the system administrator should perform the following procedures:

• Log in to the client application with a user name that has full Client Workspace permissions.

• Create and save a workspace; instructions are provided below.

• Log in to the Server and specify the default workspace in the Edit Client Properties dialog box (right-click the client computer name, and 
then select Edit from the pop-up menu).

1. Use the mouse to resize and reposition the windows as desired.

2. Click File > Save Workspace. The Save Workspace dialog box appears.

3. Type a workspace name, and then click OK. The workspace name appears in the main window title bar.

ALTERNATE OPTION 1
Click File > Autogenerate Workspace, and then select the number of windows you want to 
appear in the workspace.

The VMX300(-E) generates a workspace with the specified number of windows.

ALTERNATE OPTION 2
1. Click File > Edit Workspace. The Edit Workspace dialog box appears.

The Appearance, Size, and Position tabs control the appearance of each window. The Content tab controls window content. The Details tab 
provides troubleshooting information.

2. Click the name of the window you want to change, and then click the desired settings on the Edit Workspace dialog box tabs. To assign the 
same setting(s) to more than one window at a time, use the Shift or Ctrl key with the mouse to select more than one window, and then click 
the desired settings.

Refer to the VMX300(-E) Client Operation Manual for information on the setting options available in the Edit Workspace dialog box.

3. Click Close to close the Edit Workspace dialog box.

4. Click File > Save Workspace to save the changes.

NOTE:  The number of windows that the operator can use for viewing video is limited 
to the number of windows configured with a canvas. Refer to Step 7, Define a Canvas 
for Each VMX300(-E) Client Window. Also note that your specific system parameters 
will limit the number of digital video streams that an operator can view at any one 
time. Refer to Table B in Step 7, Define a Canvas for Each VMX300(-E) Client Window 
for an overview of the maximum number of streams recommended for specific digital 
settings.

Figure 33.  Creating Workspaces with 
the Autogenerate Feature
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20 Start the Client
VMX300 provides the following ways to log in to the VMX300(-E) client:

• Launch the client and log in.

• Log in as a new user when the client is already running.

Instructions for each log-in method are provided in the following sections.

LAUNCH THE CLIENT AND LOG IN
1. Click the Windows Start button, and then choose Programs > VMX300 > VMX300 Client.

2. If this is the first time the VMX300(-E) client has been launched on this workstation, the Corrupt or Missing Database message appears 
because VMX300(-E) must create a new database the first time you use it. Click Create.

3. The VMX300(-E) Client Login dialog box appears.

  

Figure 34.  Client Login Dialog Box

4. Type your user name and password. Note that the password is case sensitive, but the user name is not.

5. (Optional) If this is the first time you have logged in, or if you want to log in to a server other than your usual server, click Servers. For more 
information on selecting a server, refer to Step 18, Specify Which Servers are Available to the Client.

6. Click OK to log in. The VMX300(-E) main user interface appears (refer to Figure 37 for a sample view of the interface).

LOG-IN NOTES:  

• If you are a member of more than one user group, the Select User Group dialog box appears, as illustrated in Figure 35. Select the 
desired user group from the drop-down box, and then click OK. If you belong to more than one user group, you should know what 
privileges each group has been granted. For more information, refer to the User Groups section in the VMX300(-E) Client Operation 
manual.

Figure 35.  Select Group Dialog Box

• If the Workspace Not Found dialog box appears (as illustrated in Figure 36), click Yes to have the system create a default workspace.
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Figure 36.  Workspace Not Found Dialog Box

Figure 37.  Main User Interface

LOG IN WHEN THE CLIENT IS RUNNING
If the client is already running on the workstation you want to log in from, you can use the Log In As New User function to log in to the same 
server(s) as the previous user. The previous user is logged out when you log in.

Note that the Log In As New User function logs you in to the same server(s) as the previous user. To log in to server(s) that are not currently 
configured for that client, you must shut down the client, then start it as described in the previous section, Launch the Client and Log In.

1. Select File > Log In As New User. The Client Login dialog box appears.

Figure 38.  Client Login Dialog Box

2. Type your user name and password, and then click OK to log in. The VMX300(-E) main user interface appears (refer to Figure 37 for a 
sample view of the interface).

The previous user is logged out and you are logged in to all the configured servers that are available.

TIP:  If you belong to more than one user group and you want to work under a different user group, use the Log In As New User option to 
log out of the one group and into the other.
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USER GROUPS
When the system administrator sets up a user account for you, you are assigned to one or more user groups. Each user group provides a set of 
privileges to the members of the group. These privileges control which parts of the VMX300(-E) system you have access to and what events you 
are notified of. Your system administrator will tell you which user groups you belong to and what privileges you have.

When you log in, if you belong to more than one group, you must select one of the groups you belong to. For the duration of that session, your 
privileges are limited to those allowed by the group you selected when you logged in. To exercise the privileges of a different user group, you 
must log out and log in again, this time specifying the other user group.

SETTING A DEFAULT USER GROUP

To save yourself the trouble of selecting a user group every time you log in, you can set a user group to log in to by default. Thereafter, the client 
will log you in automatically under the default group, providing you are connecting to the same server from the same client as when you set the 
default. You can later override the default (refer to the VMX300(-E) Client Operation manual for instructions).

1. In the Select Group Dialog Box select the desired user group from the drop-down box.

Figure 39.  Setting a Default User Group

2. Click the “Always log in to this server as this group from this location” check box.

3. Click OK.

LOG-IN NOTES:

• If you are a member of more than one user group, the Select User Group dialog box appears, as illustrated in Figure 35. Select the 
desired user group from the drop-down box, and then click OK. If you belong to more than one user group, you should know what 
privileges each group has been granted. For more information, refer to the User Groups section in the VMX300(-E) Client Operation 
manual.

• If the Workspace Not Found dialog box appears (as illustrated in Figure 36), click Yes to have the system create a default workspace.

• The previous user is not logged out until you have completed logging in. If you cancel out of the login procedure, the previous user 
remains logged in.
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21 Work with Maps
Maps can provide VMX300 operators with a representation of the site, complete with the devices and alarms installed. The map display is an 
active display, showing the current status of devices and alarms.

HOW TO LOAD A MAP
You can load a map into the map viewport, which is part of the main window, or into a custom window. Note that the map viewport always 
remains on the bottom level of the VMX300(-E) main window. When you open custom windows, they appear over the map viewport, and multiple 
windows can cover the map viewport completely. If this is the case, you may want to view a map in a custom window. Refer to Viewing Maps in 
a Custom Window in Step 23, Use Custom Windows.

To load a map into the map viewport from the maps drop-down list, complete the following steps:

1. Click the down arrow in the Maps drop-down box. A list appears of all the maps configured on the servers you are connected to.

Figure 40.  Loading a Map into the Map Viewport

2. Click the map you want to load in the viewport. The selected map appears in the viewport.

Note that you can also drag a map from the Device List to the map viewport or to a custom window. Refer to Load a Map from the Device 
List in Step 22, Work with Devices.

Additional information about map tools, including predefined views, hotlinks, and labels, is provided in the VMX300(-E) Client Operation Manual.

NOTE:  To see the top portion of the map viewport, you may need to move or minimize any custom windows that may be covering the top 
of the map viewport, which contains the Maps drop-down box.
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HOW TO ADJUST THE MAP DISPLAY

ZOOM IN

Use the Zoom-in tool in either of the ways described below:

ZOOM IN INCREMENTALLY:
1. Click the Zoom-in tool and position the pointer over the map. The pointer displays as a magnifying glass with a plus sign in it.

2. Click anywhere on the map. The map displays at about 110% of its previous scale.

3. Repeat steps 1 and 2 to continue zooming in.

ZOOM IN ON A SELECTED AREA:
1. Click the Zoom-in tool and position the pointer over the map. The pointer displays as a magnifying glass with a plus sign in it.

2. Position the pointer at one corner of the area you want to magnify, and then click and hold the left mouse button.

3. Drag the pointer to the opposite corner of the area you want to magnify, and then Release the mouse button.

The selected area is displayed as large as possible to fit within the current size of the display area.

ZOOM OUT

Each time the Zoom-out tool is clicked, it decreases the size of the displayed map by about 10%.

PREVIOUS VIEW TOOL

The Previous View tool retrieves whatever was last displayed in the map viewport, allowing you to step back through the history of the viewport. 
Every time the display in the viewport changes, either because you have loaded a different map or predefined view, or because you have 
adjusted the display by zooming or scrolling, VMX300(-E) records the view.

To display the previous view, click the Previous View tool.

ICONS
Your system administrator can customize maps by placing icons on them that represent alarms, events, and devices installed in the field.

Device icons provide tools that allow you to monitor your system’s equipment.  

Alarm icons can 

• indicate when an alarm has been triggered,

• indicate when an alarm has been handled by an operator,

• indicate whether the condition that triggers the alarm is true or false,

• allow an operator to acknowledge an alarm.

For instructions on using device icons refer to Step 22, Work with Devices. For more information on working with alarms, refer to the VMX300(-E) 
Client Operation Manual.
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22 Work with Devices
System devices are represented in VMX300(-E) through device icons placed on maps and the Device List. The Device List and device icons enable 
you to

• switch devices,

• access device controls,

• view device gadgets,

• run scripts and stop scripts.

DEVICE ICONS
Device icons represent the equipment installed at your site. You can position the cursor over a device icon to display information on the device 
and its driver, including the device name, and the IP address and port of the workstation the device driver is running on.

Figure 41.  Device Icons

A device icon that appears as a hollow outline indicates that the device driver for that device is not running. Notify your system adminsitrator if 
you see a hollow device icon, as shown in the following graphic. 

 

Figure 42.  Device Driver Not Running

DEVICE LIST
The Device List provides a list of devices configured on the servers the client is connected to (as long as you have access privileges for the 
devices). The Device List allows you to switch and control devices without using a map.

To open the Device List window, click the View menu, and then click Device List. The Device List window appears and a check mark appears next 
to Device List on the View menu. To close the Device List window, click the Close button in the right corner of the window’s title bar, or uncheck 
Device List in the View menu.

If you have permission to edit workspaces, you can open and close the Device List window using the Edit Workspace option of the File menu.

NOTE:  To view the Device List, you must belong to, and log in under, a user group that allows you to edit workspaces. If the Device List 
does not appear in the list of items on the View menu, then you have no control over its display.
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Figure 43.  Device List

The Device List is organized into sublists. The sublist named All Devices lists all devices configured on connected servers in alphabetical order. To 
view the devices in the All Devices sublist, expand the list by clicking the plus sign. Note that the All Devices sublist is not visible if you do not 
have access privileges for All Devices.

Below the All Devices sublist is a sublist for each map you have access to. Expand the sublist for a map to view the devices on the map. A map 
only appears in the Device List if it has at least one device icon on it. A device can appear in the Device List more than once. If the device has an 
icon on more than one map, the device is listed under each map’s sublist, as well as under the All Devices sublist.

LOAD A MAP FROM THE DEVICE LIST

You can load a map that is listed in the Device List by dragging the map from the Device List to the map viewport or to a custom window.

SWITCHING A DEVICE
Switching refers to sending the source device’s signal to a destination. Cameras are source devices. Custom windows, external monitors, and 
recording devices are destinations. To switch a particular analog device to a particular destination, your system administrator must configure the 
server to allow it. The system administrator should tell you which devices can be switched to which destinations.

To switch a device in VMX300(-E) drag the source device to the destination. You can drag either device icons placed on maps or devices listed in 
the Device List. Table C lists the methods of switching devices.

Table C.  How to Switch Devices from VMX300(-E)

Drag Source To Destination

Device listed in Device List Device listed in Device List

Device listed in Device List Device icon placed on map

Device listed in Device List Custom window

Device icon placed on map Device listed in Device List

Device icon placed on map Device icon placed on map

Device icon placed on map Custom window
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VIEWING A DEVICE’S GADGET
A gadget is a tool bar that provides tools for controlling a particular type of device. For example, the gadget for a particular model of camera 
might have tools to move the camera to a preset, make the camera run a pattern, and lock the camera. Refer to the Devices section in the 
VMX300(-E) Client Operation Manual for information on the tools available in a device’s gadget.

VIEW A DEVICE’S GADGET IN A CUSTOM WINDOW

Switch the device to a custom window. The gadget appears at the top of the custom window.

Figure 44.  Viewing a Gadget in a Custom Window

VIEW A DEVICE’S GADGET FROM A DESTINATION DEVICE

1. Switch the device to a destination device, such as an external monitor.

Figure 45.  Viewing Gadget from Destination Device

2. Right-click the destination device in the Device List, or right-click its icon on a map. A pop-up menu opens.

3. Click Show Gadgets, and then select the gadget from the submenu.

The gadget appears in its own window with a title bar that identifies the destination device. Click the X in the upper right corner of the 
gadget window to close it.

ACCESSING A DEVICE’S CONTROLS
To access the Device Control dialog box for a particular device, you must belong to, and log in under, a user group that allows you to access the 
dialog box. Note that not all devices have controls. Devices that cannot be controlled such as fixed cameras and external monitors, do not have a  
Device Control dialog box.

To open the Device Control dialog box use one of the following methods:

• Double-click the device icon on a map.

• Double-click the device in the Device List.

• Right-click the device in the Device List, and then select Show Device Control from the pop-up menu.

• Click the Device Control button in the device’s gadget. 

NOTE:  Only devices that are controllable have a gadget. Devices that cannot be controlled, such as fixed cameras and external monitors, 
do not have a gadget. To view a device’s gadget you must belong to, and log in under, a user group that allows you to access the device.

NOTE:  If a device’s driver is not running when you double-click the device, you will get a connection error. Notify your system administrator.
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23 Use Custom Windows
Custom windows are windows defined by your system administrator. They can be used to

• view live and archived video,

• display an Internet browser,

• connect to a remote computer,

• display maps.

Custom windows that are used for viewing video are defined by the system administrator to display specific types of analog or digital video. 
Depending on your system’s specific settings, you may be able to display more than one digital video window at a time. The number of digital 
video windows that can be displayed at one time is limited by the size and type of images selected for viewing. Table B in Step 7, Define a 
Canvas for Each VMX300(-E) Client Window provides an overview of the CPU workload and bandwidth amounts used for each type of video 
stream (the video in a custom window).

To open a custom window, click View > Windows > [custom window name]. To close a custom window, click the X in the upper right corner, or 
click the window, press Alt+Space Bar, and select Close from the pop-up menu.

To load a particular type of content into a custom window (such as live video, archived video, or maps), the following conditions must be met:

• You must be logged in under a user group that permits you to access that type of content. Refer to Step 11, Add User Groups for more 
information.

• The workspace must permit that type of content. If you have permission to work with workspaces, you can edit the workspace and set the 
types of permitted content.

• To view live or archived video, the window must be configured for video on the server (by the system administrator).

VIEWING LIVE VIDEO
1. Click the desired window, and then press Alt+Space Bar. The Custom Window pop-up menu appears.

2. Select Live Video. The Live Video control bar appears above the display area.

If a device is switched to the window, a gadget will display in the window’s control bar. If no device is switched to the window, 
“<< no controls available >>” appears in the control bar.

3. Switch the source of the video (generally a camera) into the custom window. The video appears in the display area and the source device’s 
gadget displays in the window’s control bar.

NOTE:  If you have permission to edit workspaces, you can open and close a custom window using the Edit Workspace option of the File 
menu.

Figure 46.  Custom Window Menu Figure 47.  Live Video with Gadget
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CAPTURING LIVE VIDEO

Some canvas gadgets have a Capture and Save Image button that allows you to capture an image of the video displayed in the window. Images 
are saved in JPEG file format.

To capture a live video image complete the following steps: 

1. Click the Gadgets button , and then select the canvas gadget from the drop-down list. The canvas gadget displays in the window’s 
control bar.

2. Click the Capture and Save Image button . The Save JPEG As dialog box opens.

3. Browse to the desired folder and type in a file name.

4. Click Save. The image file is saved and the Save JPEG As dialog box closes.

VIEWING ARCHIVED VIDEO
Note that you can view video from a server other than your home server only if your system administrator has configured the servers to allow it.

1. Click the desired window, and then press Alt+Space Bar. The Custom Window pop-up menu appears.

2. Select Archived Video. The Event Picker appears below the window’s display area. If a device is switched to the window, a gadget appears 
in the window’s control bar. If no device is switched to the window, “<< no controls available >>“ appears in the control bar.

3. Switch the source device (generally a camera) to the window. Note that the source device is the device the video originated from, not the 
device that recorded the video.

4. Select and load the archived video using the date/time selector. Refer to the Event Picker section for instructions. The archived video 
appears in the display area.

 

Figure 48.  Sample Archived Video Display
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CONTROLLING AN ARCHIVE DEVICE

The particular tools available for controlling an archive device depend on the model of archive device. Typically, there are these tools:

• Play: Play the video.

• Pause: Pause playing video. Click the Pause button again to resume playing.

• Stop: Stop playing video and unload it from the custom window.

• Rewind: Rewind the video.

• Fast forward: Advance the video.

• Date and time: Indicates the playback date and time of the currently playing video.

For information on the tools available for a particular model of archive device, refer to the Devices section.

Archived video automatically starts playing when it is loaded into a custom window. If a date/time is selected in the Event Picker, the video will 
be cued to that date/time. If no date/time is selected, the video will be cued at or near the current date/time. While archived video is playing, the 
green arrow in the Event Picker advances across the Event row. Refer to Event Picker for instructions on locating, selecting and loading archived 
video.

If you have stopped or paused the video, you can resume it by clicking the Play button.

VIEWING MAPS IN A CUSTOM WINDOW
1. Click the desired window, and then press Alt+Space Bar. The Custom Window pop-up menu appears.

2. Select Map. The Map control bar appears above the display area.

The Map control bar has the same tools as the main window’s Map Viewport tool bar. The tools work the same way, except they act on the 
map in the custom window rather than the map in the Main window’s map viewport. For information on using the zoom tools, the Previous 
View tool, and the predefined views drop-down list, refer to Step 21, Work with Maps.

3. Click the arrow in the map name field, and then select a map from the drop-down list.

Figure 49.  Selecting a Map
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step

24 Use the Event Picker
Use the Event Picker to retrieve archived video and archived alarms and events. You can access the Event Picker through either

• a custom window that has archived video selected for it, or

• through the Session Manager Archive View (refer to the VMX300(-E) Client Operation manual for more information about the Session 
Manager).

You can have more than one Event Picker open at a time: one in the Session Manager, and one in each custom window in Archived Video mode.

Figure 50.  Event Picker in Session Manager

The easiest way to locate an archive is to zero in on the date/time of the archive as closely as you can, and then browse or filter the retrieved 
archives:

1. Select a date/time as close to the date/time of the archive as possible, either by building a date/time from the year down or by zooming to 
a time unit. Refer to the following sections on Building a Date/Time and Zooming to a Time Unit for instructions.

The selected date/time appears in the bottom row of the Event Picker.

Figure 51.  Selecting Date/Time
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2. Click the date/time in the bottom row of the Event Picker.

The Event Picker retrieves all the archives for the time period selected. For example, if you specified a date/time down to the hour, all 
archives for that hour appear. Each archived alarm or event is represented in the Event Picker as a small vertical bar in the Event row. 
The number of retrieved events is given in the bottom row between parentheses.

Figure 52.  Retrieved Events

The double vertical bar in the Event row is the Picker, which indicates the selected event. The date, time, and description of the selected 
event appear in the top row of the Event Picker. Drag the Picker to the left or right to change the Event Picker date/time and to select a 
different event. Or, click -Event or +Event to jump the Picker to the previous event or next event.

3. You can browse the archives to locate the ones you want. Refer to the Browsing Archives section in the following pages for instructions.

You can filter the archives by specifying event criteria. Refer to the Filtering Archived Alarms and Events section in the VMX300(-E) Client 
Operation Manual. You can also view the details of an archived event. Refer to the Archive View—Details section in the VMX300(-E) Client 
Operation Manual for instructions.

BUILDING A DATE/TIME
The Event Picker’s date/time selector allows you to build a date/time starting with the year, then the month, day, hour, and then down to the 
minute. Narrow it down as much as you can, and then retrieve the archives and browse or filter to locate the desired events. The date/time 
appears in the bottom row of the date/time selector as you build it.

1. If “Click to select a Date/Time” does not appear in the bottom row of the Event Picker, right-click the Event Picker, and then select Clear 
from the pop-up menu. “Click to select a Date/Time” will appear in the bottom row of the Event Picker.

 

Figure 53.  Clearing the Event Picker

2. Click anywhere on the bottom row of the Event Picker. The Year row appears above the bottom row.

Figure 54.  Selecting Year

3. Click anywhere on the Year row. A year appears in the Year row, as well as in the bottom row. The bottom row displays “-Year” at the left 
end and “+Year” at the right end. The Month row appears above the Year row.

Figure 55.  Selecting Month

NOTE:  If you are using the Event Picker in a custom window and a camera is switched to the window, VMX300(-E) will automatically load 
and play the archived video for that camera, cued to the date/time selected in the Event Picker. Rewind or advance the video using the tools 
in the gadget to locate the video you want.

NOTE:  You cannot select a date/time in the future.
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4. Continue clicking across the Year row until you locate the year you want. Years are distributed across the row, with the current year at the 
far right. Or, you can click -Year and +Year to change the year.  The selected year appears in the Year row and the bottom row.

5. If you know what month of archive you want to view, click on the Month row. Otherwise, go to step 8.

The selected month appears in the Month row, as well as in the date you are building in the bottom row. The bottom row displays -Month 
at the left end and +Month at the right end. The Day row appears above the Month row.

6. Continue clicking across the Month row until you locate the month you want. Months are distributed across the row, with the current month 
at the far right. Or, you can click -Month and +Month to change the month.

The selected month appears in the Month row and the bottom row.

7. Continue building the date until you have narrowed it down as much as you can. Select the day, if you know the day, and the hour, if you 
know the hour, and the minute, if you know the minute. The date/time you have built appear in the bottom row.

8. Click the date/time in the bottom row of the date/time selector.

The archive server retrieves all the archives for the time period selected. For example, if you specified a date/time down to the hour, all 
archives for that hour appear. Each archived event is represented in the Event Picker as a small vertical bar in the Event row.

Figure 56.  Retrieved Events

You can back out of a date you are building by clicking Clear at the right end of any row in the Event Picker. For example, if you have 
narrowed down a date to the minute, clicking Clear at the end of the Day row clears the minute, hour, and day, leaving just the month and 
year.

ZOOMING TO A TIME UNIT

The Event Picker provides a pop-up menu that allows you to zoom to a time unit. Right-click the Event Picker’s bottom row to open the pop-up 
menu. Table D describes the options provided on the pop-up menu.

The options have a different effect depending on whether an event is already selected or not. If no event is currently selected, the zoom options 
zoom to the current date/time. If an event is currently selected, the zoom options zoom to the time unit of the selected event.

Figure 57.  Event Picker Pop-up Menu

NOTE:  If you are using the Event Picker in a custom window and a camera is switched to the window, VMX300(-E) will automatically load 
and play the archived video for that camera, cued to the date/time selected in the Event Picker. Rewind or advance the video using the tools 
in the gadget to locate the video you want.
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Table D.  Event Picker Pop-up Menu Options

BROWSING ARCHIVES
1. Select an event by clicking its bar in the Event row of the Event Picker. Your selection is highlighted in the Event Picker. The date/time the 

event was archived and its description appear in the top row of the Event Picker.

2. Move to another event by clicking the Event row or by dragging the slider bar in the Event row.

Figure 58.  Browsing Archived Events

Go to the next event by clicking +Event at the right of the Event row. Or, go to the previous event by clicking -Event at the left of the 
Event row. 

3. To reduce the number of events displayed, zoom to a smaller time unit. To increase the number of events displayed, zoom to a larger time 
unit. Refer to the Zooming to a Time Unit section for instructions.

Menu Option Function

Cursor Mode
Determines what date/time is displayed in the top row of the Event Picker. The Cursor Mode option is only available 
when you are using the Event Picker in a custom window. Refer to the Viewing Archived Video–Cursor Mode section in 
the VMX300(-E) Client Operation manual for more information.

Zoom to Minutes If no event is selected, displays the current date/time down to the minute in the bottom row of the date/time selector. If 
an event is selected, lists all the events archived in the same minute as the selected event.

Zoom to Hours If no event is selected, displays the current date/time down to the hour in the bottom row of the date/time selector. If an 
event is selected, lists all the events archived in the same hour as the selected event.

Zoom to Days If no event is selected, displays the current date/time down to the day in the bottom row of the date/ time selector. If an 
event is selected, lists all the events archived in the same day as the selected event.

Zoom to Months If no event is selected, displays the current month and year in the bottom row of the date/time selector. If an event is 
selected, lists all the events archived in the same month as the selected event. 

Zoom to Years If no event is selected, displays the current year in the bottom row of the date/time selector. If an event is selected, lists 
all the events archived in the same year as the selected event.

Clear Deselects the currently selected event, if there is one.

Refresh Updates the list of events. Useful for viewing newly archived events. 

NOTE:  You cannot step to an event outside the selected time range.
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step

25 How to Shut Down the VMX300(-E) Software

HOW TO SHUT DOWN THE CLIENT
Select File > Exit. The VMX300(-E) client logs you out and shuts down. Note that the monitor screen may appear black for about five seconds, and 
then the Windows desktop appears. This is part of the normal shutting down process.

SHUTTING DOWN WHILE IN RUN MODE

1. Right-click the VMX300 icon in the Windows system tray, and then select Exit from the pop-up menu.

2. The shutdown prompt appears.

3. Click Yes. The server shuts down.

SHUTTING DOWN WHILE IN CONFIGURATION MODE ONLY

1. If the server is in Configuration mode only, click File > Exit.

Figure 60.  File Menu

2. If the server configuration has not changed, the server shuts down immediately.

If you made any changes to the configuration, the Save Changes prompt appears. Click Yes to save changes.

If any scripts or expressions contain errors, the Script and Expression Verification window appears. Use this window to correct the errors 
(refer to Syntax Error Checking in the Scripts section of the VMX300(-E) Server Configuration Manual for instructions), and then click OK. 
The Script and Expression Verification window closes and the server shuts down.

HOW TO SHUT DOWN A DEVICE DRIVER
1. Right-click the appropriate device driver icon in the Windows system tray, and then select Exit from the pop-up menu. A confirmation dialog 

box appears.

2. Click Yes. The driver shuts down.

NOTE:  If the server is in both Run mode and Configuration mode, you must shut it down through Run mode. You cannot shut down the 
server from Configuration mode when the server is running. Closing the configuration when the server is in Run mode leaves the server 
running.

Figure 59.  Run Mode Pop-upMenu

NOTE:  If the device driver is running as a service, you can shut it down manually by selecting Start > Settings > Control Panel 
Administrative Tools > Services. Right-click the driver, and then click Stop.
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PRODUCT WARRANTY AND RETURN INFORMATION

WARRANTY
Pelco will repair or replace, without charge, any merchandise proved defective in material or
workmanship for a period of one year after the date of shipment. 

Exceptions to this warranty are as noted below:

• Five years on FT/FR8000 Series fiber optic products.

• Three years on Genex® Series products (multiplexers, server, and keyboard).

• Three years on Camclosure® and fixed camera models, except the CC3701H-2,
CC3701H-2X, CC3751H-2, CC3651H-2X, MC3651H-2, and MC3651H-2X camera models,
which have a five-year warranty.

• Two years on standard motorized or fixed focal length lenses.

• Two years on Legacy®, CM6700/CM6800/CM9700 Series matrix, and DF5/DF8 Series
fixed dome products.

• Two years on Spectra®, Esprit®, ExSite™, and PS20 scanners, including when used in
continuous motion applications.

• Two years on Esprit® and WW5700 Series window wiper (excluding wiper blades).

• Eighteen months on DX Series digital video recorders, NVR300 Series network video
recorders, and Endura™ Series distributed network-based video products.

• One year (except video heads) on video cassette recorders (VCRs). Video heads will be
covered for a period of six months.

• Six months on all pan and tilts, scanners or preset lenses used in continuous motion
applications (that is, preset scan, tour and auto scan modes).

Pelco will warrant all replacement parts and repairs for 90 days from the date of Pelco
shipment. All goods requiring warranty repair shall be sent freight prepaid to Pelco, Clovis,
California. Repairs made necessary by reason of misuse, alteration, normal wear, or accident
are not covered under this warranty.

Pelco assumes no risk and shall be subject to no liability for damages or loss resulting from
the specific use or application made of the Products. Pelco’s liability for any claim, whether
based on breach of contract, negligence, infringement of any rights of any party or product
liability, relating to the Products shall not exceed the price paid by the Dealer to Pelco for
such Products. In no event will Pelco be liable for any special, incidental or consequential
damages (including loss of use, loss of profit and claims of third parties) however caused,
whether by the negligence of Pelco or otherwise.

The above warranty provides the Dealer with specific legal rights. The Dealer may also have
additional rights, which are subject to variation from state to state.

If a warranty repair is required, the Dealer must contact Pelco at (800) 289-9100 or
(559) 292-1981 to obtain a Repair Authorization number (RA), and provide the following
information:
1. Model and serial number
2. Date of shipment, P.O. number, Sales Order number, or Pelco invoice number
3. Details of the defect or problem

If there is a dispute regarding the warranty of a product which does not fall under the
warranty conditions stated above, please include a written explanation with the product
when returned.

Method of return shipment shall be the same or equal to the method by which the item was
received by Pelco.

RETURNS
In order to expedite parts returned to the factory for repair or credit, please call the factory at
(800) 289-9100 or (559) 292-1981 to obtain an authorization number (CA number if returned
for credit, and RA number if returned for repair).

All merchandise returned for credit may be subject to a 20% restocking and refurbishing
charge.

Goods returned for repair or credit should be clearly identified with the assigned CA or RA
number and freight should be prepaid. Ship to the appropriate address below.

If you are located within the continental U.S., Alaska, Hawaii or Puerto Rico, send goods to:
Service Department
Pelco
3500 Pelco Way
Clovis, CA 93612-5699

If you are located outside the continental U.S., Alaska, Hawaii or Puerto Rico and are
instructed to return goods to the USA, you may do one of the following:

If the goods are to be sent by a COURIER SERVICE, send the goods to:
Pelco
3500 Pelco Way
Clovis, CA 93612-5699 USA

If the goods are to be sent by a FREIGHT FORWARDER, send the goods to:
Pelco c/o Expeditors
473 Eccles Avenue
South San Francisco, CA 94080 USA
Phone: 650-737-1700
Fax: 650-737-0933

REVISION HISTORY

Manual # Date Comments
C1561M 8/04 Original version.
C1561M-A 4/05 Revised to reflect software changes (as a result of ECO 04-10212).

Pelco and the Pelco logo are registered trademarks of Pelco. ©Copyright 2005, Pelco. All rights reserved.
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Microsoft and Windows are registered trademarks of the Microsoft Corporation.
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