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1. INTRODUCTION 

The 1U643 Breakout Box and Data Logger is a tool for monitoring aircraft systems by 

providing a test point breakout between various electronic modules and their associated 

interconnects with the aircraft. The 1U643 was designed as a dual purpose tool. The 1U643 

can be used stand alone as a normal breakout box or,  when connected to a notebook 

computer via the RS232 serial port, as a data viewing, logging, and recording instrument. 

At the heart of the 1U643 electronics is the industry standard 80C552 processor which 

when connected to a notebook computer via RS232 serial communications becomes a very 

powerful diagnostics tool. The 1U643 data logger allows diagnosis of aircraft system 

malfunctions by enabling the user to record data from aircraft systems for later viewing by 

knowledgeable systems engineers or technicians. 
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2. HARDWARE/SOFTWARE REQUIREMENTS 

To use the 1U643 as a data logger/recorder the following is required: 

 IBM or compatible Personal Computer with; 

• RS-232 serial port  

• At least 1 Meg free hard disk space  

• Windows 3.1 or later 

3. INITIAL SETUP 

Insert 1U643 Data Logger Software Set up disk into computer and run the “setup.exe” 

program on the set up disk. Follow the instructions on the computer screen. 
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4. STARTUP 

To start viewing or recording data connect the computer to the 1U643 Breakout Box via an 

RS-232 Cable. Connect the breakout box to the aircraft system to be monitored per 

applicable aircraft system maintenance procedures. Turn on the power switch on the 

breakout box and then run the 1U643.exe program. The user will be greeted with a start up 

screen. 

 

 

At this point the user is given the option to ‘Continue’ or ‘Exit’. 
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5. SOFTWARE OPERATION 

After clicking ‘Continue’ on the start up screen the main program screen will appear. 

Please note the menu and toolbar at the top of the screen.  

 

Some of the toolbar buttons have matching operations, which can be accessed through the 

menu. From left to right the toolbar button functions are: 

• Open a recorded file for playback 

• Save a recorded file as *.dat 

• Start acquiring data 

• Stop acquiring data 

• Set focus to previous window 

• Set focus to next window 

• Load an oscilloscope/line graph window 

• Load the DC viewing window 

• Reverse playback 

• Stop playback 

• Pause playback or recording 

• Start playback 

• One Touch Recording 
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The status bar appears at the bottom of the screen. Included in the status bar are: 

• The present status of data acquisition 

• The time of day or when in play back mode the real time when the displayed block of 

data was recorded. 

• The number of data blocks received from the breakout box during the present 

acquisition run. 

 

Under the ‘File’ menu are the following items: 

• ‘Open’ Opens a previously recorded data file for playback 

• ‘Save As…’ Saves a recorded file as *.dat 

• ‘Export’ Exports recorded data in a ‘csv’ (comma separated values) format, which can 

be loaded into most spreadsheet programs such as MS Excel. 

• ‘Exit’ Exits this window and returns to the start up window 
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The ‘Options’ menu has the following function: 

Select the serial communications port through which to receive data from the breakout box. 

The communications port selected must match the physical port to which the breakout box 

is connected.  In order to properly communicate with the breakout box the serial port must 

be configured correctly. The default serial port is ‘Comm 1’. If the use of a different 

communications port number is desired or required, the selection must be made here each 

time the software is restarted.  Please refer to the computer operation manuals for 

information regarding a particular computer serial port configuration. 

 

The ‘Run’ menu has ‘Start’, which starts data acquisition and ‘Stop’, which stops 

acquisition of data. 

 

The ‘View’ menu is used for loading or unloading the DC viewing window and for loading 

an Oscilloscope/Line Graph window. There can be one Oscilloscope/Line Graph window 

loaded for each breakout box pin. 

 

The ‘Window’ menu is used to automatically arrange the windows for easier viewing. 
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The ‘Help’ menu displays the ‘About’ window, which displays information such as the 

current revision of this software. 

 

5.1 DC Viewing Window 

Before viewing of acquired data can begin the user must select the mode of display. One 

method of viewing data acquisition is the DC viewing window. 

 

When ‘DC Volt’ is selected the DC Voltage Viewing window appears. It is unloaded 

in the same manner. The DC Viewing window can be turned on and off through the 

corresponding toolbar button. This window displays all pins simultaneously. 
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5.2 Oscilloscope/Line Graph Windows 

The Oscilloscope/Line Graph window is loaded through the View menu or through the 

corresponding toolbar button. Up to 39 such windows can be opened, one for each pin, if 

desired. 

 

The Pin # box determines which breakout box pin will be displayed on this window. 

Numbers can be entered directly into the box by clicking on it and typing the number, or by 

clicking the up or down arrows the number can be spun up or down. The Points box sets 

the number of samples to be displayed in one sweep of the line graph. The maximum 

number of points is 32000 the minimum is 1. 
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5.3 Starting Data Acquisition 

Once the mode of viewing has been set up the acquisition is started by clicking ‘Run/Start’ 

in the menu or by clicking the corresponding toolbar button. If the Breakout Box power is 

on and the Communications port has been configured properly the display windows should 

show data. 

 

Note that the ‘VDC’ field in the upper right corner of the Oscilloscope window displays the 

DC Voltage of the last acquired data point for the corresponding breakout box pin selected. 
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To allow for easier viewing of multiple windows the user can select ‘Window/Tile’ in the 

menu. 

 

The windows are automatically arranged in a tile fashion. 

Rev. B Page 10 86M065 

Download from Www.Somanuals.com. All Manuals Search And Download.



 

 

The windows can then be easily manipulated to allow the user to see the specific 

information of interest. 
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5.4 Recording Data Files 

Recording of data can be started at anytime while data is being acquired by clicking on the 

toolbar button with the red dot. 

 

Once recording has begun it can be paused temporarily by clicking the pause button. 

Recording will resume by clicking pause again. 

5.5 Playback of Data Files 

To playback a recording that was just recorded simply click on the play button.  

 

The mode of display at the time of recording does not determine the mode of display at 

playback. All data is recorded.  Therefore the mode of display can be setup however the 

user chooses and this is accomplished in the same manner as it was for acquisition. The 

user can pause playback at any point during playback of a recorded file by clicking the 

pause button. Playback is resumed by clicking the pause button again. It is also possible to 

play in reverse by clicking the reverse play button. 

 

Playback is returned to normal by clicking the reverse play button again. 

Once a recording has been reviewed the user can save it permanently by saving it to a 

permanent file. If the recording is not saved to a permanent file then that recording will be 

lost the next time a recording is initiated. 
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5.6 Saving Recorded Data Files 

To permanently save a recorded file it must save from the temporary record file to a user 

named file. To achieve this click on ‘File/Save As…’ in the menu or click on the 

corresponding toolbar button. 

 

The following dialog prompts the user to name the file. The file can be saved anywhere on 

the computers disk drives by selecting the destination directory, or if a network drive has 

been set up in the Windows operating system the user can direct the file there. The file 

‘temp.dat’ is the default filename for the temporary storage of the recording function and 

should not be used for permanent storage, as it will be overwritten. 
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5.7 Opening Data Files For Playback 

To playback a file other than the most recently recorded one the user must first open that 

file by clicking ‘File/Open’ in the menu or by clicking on the corresponding toolbar button. 

 

The user is prompted to select the file to open. 

Once the file has been opened the user must set up the display windows for viewing 

playback. Then by clicking on the ‘Play’ button on the toolbar the playback of the file will 

be initiated. The user can replay the file as many times as desired but once the ‘Stop’ 

button has been clicked or the user declines to replay the file, the user selected file is closed 

and the default file ‘temp.dat’ is used. 
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5.8 Exporting Data 

It may be desirable to view and analyze data using another program such as a spreadsheet, 

and for this reason a data export function is included. The export data function exports data 

to a comma separated value (csv) file, which is compatible with most spreadsheet or data 

base programs. In order to export data the user must first open the recording for which 

exported data is desired. Then the user must click ‘File/Export’. 

 

The user is then prompted to enter a file name to export data to. The data is then exported. 

The csv file can then be loaded using a program of the users choice. 

6. TROUBLESHOOTING 

If the data logger program fails to receive data from the breakout box then the following 

should be verified: 

• The proper communications port has been selected under ‘Options’ menu. 

• The breakout box is powered on. 

• The RS-232 cable and connections are good. 

• There are no serial port IRQ conflicts on the computer (see computer documentation on 

setting up communications ports). 

• The Breakout Box is receiving the proper power from the aircraft or other power 

source. 
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7.0 1S643-( ) DATA LOGGER SYSTEM COMPONENTS 

7.1 1U643-( ) Data Logger Unit Technical Specifications 
Supply Voltage: 28 Volt DC (18 to 32 VDC) at 80 ma nominal 
Input Loading: 1 Meg ohm  
Input Protection: 1000V 
Processor: 80C552 (clock Speed =11.059 MHZ) 
A/D Converter Resolution: 10 bit with Linearity of +/- 2 LSB 
Measurement Method: SAR 
Front End Divider Accuracy: 2 % 
Absolute DCV Accuracy: +\-(1% of reading + 3 digits) 
RS-232 Communications: 9600/8/1/1/N 
Block Conversion/Transfer Speed: 6 blocks per second (39 pins) 
Weight: 6 lbs. (basic unit) 
Operating Environment: -20 to 55 C 
Storage Environment: -40 to 70 C 

7.2 Data Logger System Component Outlines 

The components that make up the 1S643-001 or 1S643-002 Data Logger System are shown 
in Figures 7-1 (Data Logger), 7-2 (Cables) and 7-3 (Extender Cards). 

1S643-001 Data Logger System Description: 

1 ea. 1U643(-001) Data Logger Unit (see Figure 7-1) 
1 ea. 1V643-801 Power Cable (see Figure 7-2) 
1 ea. 1V643-802 Computer Serial port Cable  (see Figure 7-2) 
1 ea. 1U643-803 Extender Card Cable (see Figure 7-2) 
1 ea. 1V643-901 25 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-902 27 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-901 37 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-902 37 pin Side Console Extender Card (see Figure 7-3) 

1S643-002 Data Logger System Description: 

1 ea. 1U643-002 Data Logger Unit (see Figure 7-1) 
1 ea. 1V643-801 Power Cable (see Figure 7-2) 
1 ea. 1V643-802 Computer Serial port Cable  (see Figure 7-2) 
1 ea. 1U643-803 Extender Card Cable (see Figure 7-2) 
1 ea. 1V643-901 25 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-902-1 27 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-901 37 pin J-Box Extender Card (see Figure 7-3) 
1 ea. 1V643-902 37 pin Side Console Extender Card (see Figure 7-3) 

The 1S643-002 System allows starting of Fuel Pumps during fuel control test. 
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Figure 7-1 
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Figure 7-2 

Rev. B Page 18 86M065 

Download from Www.Somanuals.com. All Manuals Search And Download.



 

Figure 7-3 
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