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1 Functional Description

1.1 Description Overview

User's Guide
SLEU069A–February 2006–Revised July 2006

TVP5154EVM User's Guide

The TVP5154EVM evaluation module is a printed circuit board designed for evaluation of the TVP5154
quad video decoder. The board includes the TMS320DM642 digital signal processor (DSP) and is
designed with a 120-pin connector, which allows a connection to multiple backends; the evaluation module
(EVM) is shipped with a professional encoder module. The board is designed to provide ease of use, while
allowing full evaluation of the video decoder.

The TVP5154EVM uses the PC parallel port to emulate the I2C bus, which provides communication with
the TVP5154 video decoder, DM642, and the video encoder. The Windows™ Video Control Center
(WinVCC) application software that communicates with the devices via the I2C is provided on the EVM
CD-ROM.

The analog video inputs supported by the TVP5154EVM include composite video and S-video. More detail
about the video inputs is discussed in section 2.3 Video Input Description. In general, the video decoder
converts the analog video input signal into digital component data. This data and the associated clocks
from the video decoder are sent to the DM642, which provides various image capture and display modes.
The DM642 is setup in I2C slave mode and is controlled through virtual I2C registers. The video encoder
then converts the digital data from the DM642 back into analog video. The analog video outputs supported
by the EVM include composite video, S-video, and component video. These are all output simultaneously.

To experiment with the programmable features of the TVP5154 video decoder and the video encoder, the
parallel port of the TVP5154 is connected to the parallel port of a PC. WinVCC, a Windows-compatible
application provides the user interface for performing register-level and high-level control of the TVP5154
video decoder and the video encoder.

Code Composer Studio is a trademark of Texas Intruments.
All other trademarks are the property of their respective owners.
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2 Board Level Description

2.1 Test Points and Jumpers

Board Level Description

The TVP5154EVM consists of the TVP5154EVM module and the encoder EVM module. A 4-row 120-pin
connector connects the boards. The block diagram of the EVM set is shown in Figure 1.

Figure 1. TVP5154EVM Block Diagram

The TVP5154EVM was designed with test points and jumpers to help in evaluation and troubleshooting.
Each jumper is set by default in its preferred state for the TVP5154EVM. There are test points for SCL,
SDA, 3.3 V, and 1.8 V. All digital video data for each decoder core are brought out to a dual-row header,
which allows easy hookup to test equipment. The I2C address selection is made with two shunt jumpers,
which are only read after a reset or at power up. The default address is 0xB8. If the address needs to be
changed, the TVP5154 must receive a reset.

Table 1. I2C Address Selection Jumpers
(I2CSEL1, JP9 and I2CSEL2, JP10)

JP9 JP10 I2C ADDRESS

2-3 2-3 0xB8

1-2 2-3 0xBA

2-3 1-2 0xBC

1-0 1-2 0xBE

Table 2. Power-Down-Mode Selection Jumper
(PDN, JP11)

PWDN

1-2 Normal operation

2-3 Power down
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2.2 Common Board Interface

2.3 Video Input Description

2.4 Video Output Description

Board Level Description

Note: If the I2C address is changed on either the TVP5154 board or the encoder board while the
TVP5154EVM is powered up, that device will not recognize the new I2C address. The reset
button on the TVP5154EVM must be pressed and WinVCC must be reconfigured for the new
I2C address.

The TVP5154EVM uses a 4-row 120-pin connector to share common signals and the 5-V power supply
between the boards. This connection allows multiple backends to be connected to the TVP5154EVM. The
EVM package is shipped with an encoder module. This connector shares all digital video bits (Y[7:0]), all
video clocks (VS, HS, GLCO/FID, and DATACLK), 5 V, ground, I2C bus (SCL and SDA), and reset.

The TVP5154EVM decoder has an analog input channel that accepts two video inputs for each decoder
core. The decoder supports a maximum input voltage range of 0.75 V, therefore, an attenuation of
one-half is needed for most input signals with a peak-to-peak variation of 1.5 V. The parallel termination
before the input to the device is 75 Ω. The two analog inputs can be connected as either two selectable
composite video inputs, or one S-video input.

The TVP5154EVM allows the user to have up to two composite inputs or one S-video input for each of the
four-channels. The EVM software sets up and controls this input selection. The S-video input uses two
connectors, one for the luma channel and one for the chroma channel.

The EVM has a resistor network on each of the inputs. These networks attenuate the signal and allow a
75-Ω resistor to ground to be placed after the anti-alias filter for termination.

Each input has an anti-alias filter that can be in-circuit or bypassed by jumpers (JP1–JP8). To select the
filter, the shunts need to be positioned to short positions 1-3 and 2-4. To bypass the filter, the shunts need
to be moved to short positions 1-2 and 3-4 as shown in Figure 2. The boards are shipped with the filter
bypassed.

Figure 2. Anti-Aliasing Filter Selection

The 8-bit digital video outputs of the TVP5154 are routed to the four 32-pin headers (H2–H5), the DM642,
and finally to the 120-pin edge connector along with all video clocks on the TVP5154 module. The
encoder module connects to the 120-pin connector, and is capable of receiving digital video with or
without embedded syncs. The analog outputs of the encoder module are composite, S-video, and
component. For the user’s convenience, all of these outputs come out of the encoder module
simultaneously.
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3 System-Level Description

4 Required Hardware and Equipment

5 Hardware Setup

System-Level Description

A system-level block diagram incorporating the TVP5154 is shown in Figure 3. Typical
commercially-available test equipment is also shown. The primary features of this configuration are:

• Power is provided by a single 5-V power supply provided with the EVM and is shared between both
modules via the 120-pin connector.

• Supported analog inputs include composite video and S-video.
• Re-encoded composite video and S-video are output via the encoder module.
• Component (YPbPr) video is output via the encoder module.
• I2C bus initializes the video devices via a PC parallel port.
• The TVP5154 video decoder performance parameters may be measured with a video analyzer.

Figure 3. TVP5154EVM System-Level Block Diagram

The required hardware and equipment necessary to use the TVP5154EVM are:

• TVP5154EVM (provided)
• Universal 5-V power supply (provided)
• Parallel cable (provided)
• Windows-based PC with CD-ROM drive and Win95™ or later
• Composite or S-video cables for inputs
• Composite, S-video, or component cable for output
• Video sources (security camera, pattern generator, Quantum generator, DVD player, etc.)
• Display monitor that supports composite, S-video, or component video input

Figure 1 shows the TVP5154EVM layout and indicates the location of the power supply and the
appropriate connectors. All connectors are labeled according to their function. To prepare the EVM for
evaluation, connect the following:

1. TVP5154 module to encoder module
2. Parallel port cable from TVP5154EVM to the PC
3. Analog video sources to TVP5154EVM inputs
4. Analog video out from TVP5154EVM to monitor
5. 5-V power supply to the dc jack on the TVP5154 board. A green LED on each board should now be lit.
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6 Software Installation

7 WinVCC Quick Start

Software Installation

The system comes with the anti-alias filters bypassed. To connect the filters, you must rotate the
appropriate jumpers (JP1–JP8) as described in section 2.3.

The I2C slave address can be selected with jumpers JP9 and JP10. There are four possible addresses:
B8, BA, BC, and BE. The default setting for these jumpers is for the shunt to short pins 2-3, which selects
0xB8. These are connected to pins 117 and 118, which are read at power up. If you move both the
jumpers to positions 1-2 and reset the board, the video decoder now responds to I2C slave address 0xBE.
If you choose to change the address, you must exit, restart WinVCC, and configure the software to use
the new I2C slave address.

WinVCC is a Windows application that uses the PC parallel port to emulate I2C, providing access to each
device on the I2C bus. WinVCC makes use of CMD files, a text editable file that allows preset video
setups to be programmed easily.

This feature allows the user to easily set multiple I2C registers with the press of a button. WinVCC also
has property sheets for the TVP5154, which allows the user to control the I2C registers with a GUI.

All necessary software for the TVP5154EVM is provided on the enclosed CD. Perform the following steps
to install WinVCC:

1. Explore the provided TVP5154EVM Software CD.
2. Install Port95NT.exe. This is the parallel port driver used by WinVCC. This driver must be installed and

the PC must be rebooted before WinVCC operates correctly. This does not affect normal parallel port
operation.

3. Install Setup.exe. Click Next at all prompts and click Finish to complete the installation process. This
installs WinVCC onto the PC. No reboot is required.

4. Run WinVCC.exe.

Note: A shortcut to WinVCC should now be available on the desktop. WinVCC and additional
TVP5154-related documentation can also be found at Start→Programs→TVP5154EVM
Software.

Perform the following steps in order to see a video output from the TVP5154EVM.

1. Once WinVCC is executed, the WinVCC Configuration screen appears, as shown in Figure 4. This
dialog box configures the I2C bus. Next to VID_DEC, select the TVP5154 and ensure the I2C address
is set to 0xB8 (default setting on EVM.) This must match the I2C ADDR jumper on the TVP5154 board.

2. Next to VID_ENC, select the 7311 Encoder and ensure the I2C address is set to 0x54 (default setting
on EVM.) This must match the I2C ADDR jumper on the encoder board.

Note: If WinVCC is running and the TVP5154 or encoder board I2C address is changed, power
must be cycled on the EVM.
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WinVCC Quick Start

Figure 4. WinVCC – I2C Configuration Screen

3. Ensure that all other boxes are selected as “Not Used” and that all program options buttons are set to
ENABLE. Click OK.

4. If there are no I2C communication issues, the Real-Time Polling dialog window displays next as shown
in Figure 5. If there are I2C issues, an I2C Test Report box displays. Completely exit out of WinVCC,
double-check the parallel port cable connections, I2C address settings, cycle power on the
TVP5154EVM, and re-run WinVCC.

5. When using the TVP5154 EVM with a composite output from the 7311 encoder, it is required to disable
auto-switch polling in the Real-Time Polling dialog box by clicking on the ENABLED button. Click OK
and then the Main Control Window is seen, as shown in Figure 7.
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WinVCC Quick Start

Figure 5. Real-Time Polling Dialog

6. The TVP5154 I2C Write Enable(s) and Read Enable pop-up window is displayed as shown in Figure 6.
This is used to select which decoder or decoders (any combination of all four) will receive I2C Write
commands, and which decoder (only one) will receive I2C Read commands. Decoder 1 is Enabled by
default; enable the other three decoders by clicking on each decoder’s enable button.

Figure 6. Decoder I2C Write and Read Enable

7. Load the provided Initialization command (CMD) file into WinVCC by clicking on Tools→System
Initialization→Browse. The default directory is C:\Program Files\Texas
Instruments\TVP5154EVM\Initialization.

Figure 7. WinVCC – Main Screen

8. In the System Initialization Window (see Figure 8), click the “TVP5154 ROM – Initialize for NTSC...” or
“TVP5154 ROM – Initialize for PAL...” dataset in the window and then click the PROGRAM Device(s)
Using Selected Dataset button to initialize the TVP5154EVM.
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8 WinVCC in Depth

8.1 Starting WinVCC

WinVCC in Depth

Figure 8. WinVCC – System Initialization

9. With video sources provided at the BNC connectors and the EVM output connected to a monitor, video
from the source connected to CH1 should be viewable on the display monitor.

10. The other datasets in the command file are provided to demonstrate examples of 5154 scaling
performance. Refer to the TVP5154 data sheet (SLES163) or Scaler application report for more details
on programming the TVP5154 scaler. The DM642 settings can be controlled by using the DM642
Control Window, which is found by clicking on Tools→DM642 Control. Refer to Chapter 9 for details on
programming the DM642 through this window or through the Generic I2C registers.

The following sections describe how to use Windows™ Video Control Center (WinVCC) in depth. It
discusses various features and screens that the user may encounter while evaluating the TVP5154EVM.

The Port95NT parallel port driver must be installed before using WinVCC. WinVCC may be started by
clicking on Start→All Programs→TVP5154EVM Software→WinVCC.

If the dialog box shown in Figure 9 is displayed, it means one of two things:
• WinVCC did not run to completion the last time it ran. In this case, click OK to exit the program and

restart WinVCC.
• There is more than one instance of WinVCC running at the same time. In this case, click OK to exit the

program. Then, press CTRL-ALT-DELETE to bring up the Task Manager. Select and click End Task
on all occurrences of WinVCC or WinVCC CONFIGURATION. Then restart WinVCC.

Figure 9. WinVCC Multiple Occurrences Error Message
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8.2 WinVCC Configuration Dialog Box

8.3 I2C System Test

WinVCC in Depth

The WinVCC Configuration dialog box (see Figure 10) should now be visible. This dialog box configures
the I2C bus on the TVP5154EVM. All settings from this dialog box are stored in the Windows registry and
are restored the next time the program is started. After initial installation, VID_DEC is set to TVP5154 and
VID_ENC is set to 7311 Encoder.

The I2C slave address for each device must match the I2C slave address selected by jumpers on the
TVP5154EVM. These jumpers are set by the factory to use 0xB8 for the TVP5154 and 0x54 for the
Encoder. It is also important to select the correct Specific Device type for the video decoder. TVP5154 and
7311 Encoder must be selected for this EVM.

All Program Options must be enabled. Disabling these options is only required if debugging a problem
with the I2C bus.

Clicking OK begins I2C communication with the selected devices.

Figure 10. WinVCC I2C Address Configuration

The I2C system test of selected registers runs immediately after closing the WinVCC Configuration dialog
box with OK (unless the I2C system test program options button was disabled).

If the I2C system test passes, only a PASS message appears. If the test failed, a dialog box like the one
shown in Figure 11 appears. See Section 10, Troubleshooting, for details on how to resolve this issue.
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8.4 Real-Time Polling

WinVCC in Depth

The I2C system test can be run at anytime by clicking Run System I2C Test in the Tools menu.

Figure 11. I2C System Failure

Real-time polling provides polling functions that execute continuously in the background, when enabled via
the Real-Time Polling dialog. There are two polling functions. The function that applies to the TVP5154 is
VIDEO-STANDARD AUTO-SWITCH POLLING.

When the TVP5154 detects a change in the input video standard, it automatically switches to operation in
the detected standard (which includes all necessary I2C register initialization) for proper decoding of the
input video. To enable auto-switch on the TVP5154, the Set Video Standard register must be set to
auto-switch mode (Reg 0x28 = 0x00).

If the WinVCC auto-switch polling function is enabled, the detected video standard status from the
TVP5154 is polled until a change in the input video standard (or in the TVP5154 sampling mode) is
detected. When a change is detected, the video encoder is reprogrammed as needed for the detected
standard. Using this feature, the video source can change its video standard and the system displays
using the new standard, without user intervention.

When using the TVP5154 EVM with the DM642 and a composite output from the 7311 encoder, it is
required to disable auto-switch polling by clicking on the ENABLED button in the Real-Time Polling dialog
box as shown in Figure 12.

The real-time polling dialog can also be accessed once WinVCC is up and running by clicking Real-Time
Polling in the Tools menu.
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8.5 Main Menu

WinVCC in Depth

Figure 12. Real-Time Polling Dialog

After closing the real-time polling dialog, the main menu is displayed as shown in Figure 13. The menus,
which are used to operate WinVCC, are File, Edit, Tools, Window, and Help. The File menu’s only function
is Exit, which terminates the program. Table 3 summarizes the main menu contents.

Figure 13. WinVCC – Main Screen

Table 3. Main Menu Summary

MENU CONTENTS

File Exit

Edit Register Map
TVP5154
7311 Encoder Module
Generic I2C

Memory Map
TVP5154
7311 Encoder Module

Property Sheets
TVP5154
7311 Encoder Module

Tools System Initialization
Real-time Polling
TV Tuner Control (FQ12xx series only)
Multiple-Byte I2C Transfers
Set I2C Bit Rate
Run System I2C Test
Run Continuous I2C Test
Read VBI FIFO
Capture Live VBI Data
DM642 Control

Window Allows selection of the active window. Multiple windows can be open at the same time.

Help Displays program version
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8.5.1 System Initialization

WinVCC in Depth

The TVP5154 I2C Write Enable(s) and Read Enable pop-up window is displayed as shown in Figure 14.
This is used to select which decoder or decoders (any combination of all four) will receive I2C Write
commands, and which decoder (only one) will receive I2C Read commands. Decoder 1 is Enabled by
default; enable the other three decoders by clicking on each decoder’s enable button.

Figure 14. Decoder I2C Write and Read Enable

Clicking System Initialization in the Tools menu displays the dialog box shown in Figure 15. This dialog
box provides the means for initializing the TVP5154 decoder(s) and/or video encoder for a particular video
mode, as well as programming settings for the DM642 through the Generic I2C registers. The details of
the initialization are contained in the command file (with a CMD file extension).

The command file is loaded using the Browse… button. Once the command file is opened, a text list
displays descriptions of the individual datasets contained within the command file.

Click once on the desired dataset description to select it. Click the Program Device(s) Using Selected
Dataset button to run the selected dataset, which loads the devices via the I2C bus. When the device
initialization has completed, the status indicator reads Ready.

Note: If Ready does not display, the devices are not initialized and the I2C bus is not
communicating. See Chapter 10, Troubleshooting, for possible solutions.

Click the OK button to close the dialog box. Each time the System Initialization dialog box is closed, the
initialization file pathname and the dataset selection number are saved in the Windows registry to allow
these settings to be retained for the next time WinVCC runs.
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8.5.1.1 Adding a Custom Dataset

WinVCC in Depth

Figure 15. System Initialization

After programming the EVM via the System Initialization tool using the factory-supplied command file, you
can customize the device register settings to fit your needs. Perform the following steps to save your
custom settings:

1. Reopen the System Initialization dialog box via the Tools menu.
2. Click the Append Current Device Settings to Command File button. A dialog box requesting a

description of the new dataset appears.
3. Optionally, click the drop-down box and select one of the existing descriptions.
4. Modify the description text or type your own description.
5. Click OK. All nondefault register values from the TVP5154, DM642, and encoder are appended to the

current command file as an additional dataset.

Now, you can select your custom dataset and send it with a press of the Program… button.

By using the same procedure above with the Replace Selected Dataset with Current Device Settings
button you can overwrite an existing dataset with the current settings.

Note: If editing the command file (.CMD) using a standard editor, the file must be saved as plain
text.
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8.5.1.2 Command Files

8.5.1.3 Example Command File

WinVCC in Depth

The command file is a text file that can be generated using any common editor; however, it must be saved
as plain text. Command files are especially useful for quickly switching between the various system
configurations. These .CMD files are unrelated to the typical Windows .CMD files.

A default command file is provided on the CD. This command file contains many examples of the desired
setups. This command file is located at:

c:\Program Files\Texas Instruments\TVP5154EVM\Initialization\

A command file can contain up to 250 datasets. A dataset is a set of register settings to initialize the
TVP5154 decoder, 7311 encoder, and/or DM642 for a particular video mode. Each dataset includes a
description that is displayed in one row of the dataset descriptions list. The register settings may be
located in the command file itself and/or may be stored in separate include file(s) (with an .INC file
extension) and be included into the command file using the INCLUDE statement.

An example of one dataset within a command file is shown below.
BEGIN_DATASET

DATASET_NAME,”TVP5154, Auto–switch, Stable Sync, Fast-lock, 656 Out”
// Initialize video encoder using an include file
INCLUDE, EncoderNTSC656_RTC.INC
// Program TVP5154 registers
WR_REG,VID_DEC,1,0x7F,0x00 // Reset 5154 microprocessor
WR_REG,VID_DEC,1,0x03,0x0D // Enable YCbCr outputs and syncs
WR_REG,VID_DEC,1,0x15,0x81 // Enable Stable Sync mode
WR_REG,VID_DEC,1,0x02,0x80 // Enable Fast-lock mode

END_DATASET

Each command file may contain individual write-to-register (WR_REG) commands.

• The comment indicator is the double-slash //.
• The command file is not case sensitive and ignores all white-space characters.
• All numbers can be entered as hexadecimal (beginning with 0x) or as decimal.
• Every dataset in a command file begins with BEGIN_DATASET and ends with END_DATASET. The

maximum number of datasets is 250.
• The dataset text description is entered between double quotes using the DATASET_NAME command.

The enclosed text can be up to 128 characters in length. This text appears in the System Initialization
dialog box when the command file is opened.

• The INCLUDE command inserts the contents of an include file (with an .INC file extension) in-line in
place of the INCLUDE command. Therefore, the include file must not contain the BEGIN_DATASET,
END_DATASET, and DATASET_NAME commands.

Note: All included files must be located in the same directory as the command (CMD) file.

• The write-to-register command is written as:
WR_REG, <DeviceFamily>, <Number of data bytes (N)>, <subaddress>, <Data1>,…, <DataN>
or
WR_REG, <Literal slave address>, <Number of data bytes (N)>, <subaddress>, <Data1>,…, <DataN>
The valid device family mnemonics are:
VID_DEC for the video decoders
VID_ENC for the video encoders
THS8200 for the THS8200 device
WinVCC translates the device family mnemonic to the slave address that was selected in the WinVCC
Configuration dialog box upon program startup. This eliminates having to edit command files if the
alternate slave address must be used.
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8.5.2 Register Editing

8.5.2.1 Register Map Editor

WinVCC in Depth

If the literal slave address method is used, the slave address entered is used directly. This method is
normally used for programming the video encoder.

The slave address 0x40h is used to access the DM642.
• A delay may be inserted between commands using the WAIT command, which is written as:

WAIT,<# milliseconds>

The next section describes the five available modes of register editing: TVP5154 Register Map editor,
7311 Encoder Module Register Map editor, Generic I2C Register Map editor, TVP5154 memory map
editor, and TVP5154 Property Sheets. Each of these functions can be selected from the Edit menu.

The TVP5154 Register Map editor (see Figure 16) allows the display and editing of the entire used
register space of the device within a simple scrolling text box. To open this, click on Edit Register Map in
the Edit menu and click on the device type to edit. Table 4 describes how to use each of the controls in
the TVP5154 Register Map editor.

Figure 16. TVP5154 Register Map Editor
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8.5.2.2 Encoder Module Register Map Editor

8.5.2.3 Generic I2C Register Editor

WinVCC in Depth

Table 4. TVP5154 Register Map Editor Controls

CONTROL DEFINITION

Register Window Scrolling text box that displays the address and data for the I2C registers that are defined for the device

Contains the I2C subaddress that will be accessed using the Write and Read buttons. Clicking on a row selectsAddress Edit Box an address, which then appears in the address edit box.

NOTE: After clicking on a row, the Data Edit box contains the data that was in the register window. The device
has not yet been read.

The address up/down arrows are used to jump to the next/previous subaddress that is defined for the device. If
an address is not defined for the device, it can still be accessed by typing the subaddress in the Address Edit
box.

Data Edit Box Contains the data which will be written to, or was read from, the I2C subaddress.

The data up/down arrows increment/decrement the data value by 1.

Write Button Writes the byte in the Data Edit box to the address in the Address Edit box.

The I2C register is written to whether or not the data is different from the last time the register was read.

Read Button Reads the data from the address in the Address Edit box into the Data Edit box and the register window.

Read All Button Reads all defined readable registers from the device and updates the register window.

Hex Button Converts all values in the register window and address and data edit boxes to hexadecimal.

Dec Button Converts all values in the register window and address and data edit boxes to decimal.

Close Button Closes the dialog.

NOTE: Multiple edit register map windows can be open at the same time (one for each device). Use the
Window menu to navigate.

Causes subsequent write, read, or read all operations to be performed N times. N is entered as a decimalLoop Count number from 1 to 999.

The Encoder Module Register Map editor (see Figure 17) allows the display and editing of the video
encoder registers. This editor works like the TVP5154 Register Map editor.

To open this, click on Register Map in the Edit menu and click on 7311 Encoder Module.

Figure 17. 7311 Encoder Module Register Map Editor

The Generic I2C Register editor (see Figure 18) allows the display and editing of any device on the I2C
bus. This editor works like the TVP5154 Register Map editor, except that the I2C slave address must be
entered and the Read All button is disabled.

To open this, click on Register Map in the Edit menu and then click on Generic I2C.
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8.5.2.4 Memory Map Editor

WinVCC in Depth

The DM642 I2C registers can be edited using I2C sub-address 0x40. See Section 9 for details about the
DM642 registers.

The video encoder module registers can be edited using I2C sub-address 0x54 (default) or 0x56 if the
alternate slave address is being used.

Figure 18. Generic I2C Register Map Editor

The memory map editor (see Figure 19) allows the display and editing of the data memory and hardware
registers of the device, such as the scaler setting registers.

To open this, click on Memory Map in the Edit menu and click on the device type to edit. The operation of
the memory map editor controls are explained in Table 5.

Figure 19. Memory Map Editor
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8.6 TVP5154 Property Sheets

WinVCC in Depth

Table 5. Memory Map Editor Controls

CONTROL DEFINITION

Base Address Selector The hardware registers use a 10-bit address internally. The base address selector allows quick entry
of the base address. The list contains base addresses for the major functional blocks of the
TVP5154.

Address Offset Edit Box Contains the lowest byte of the 10-bit internal address. The full 10-bit address is formed by adding
the base address to the address offset. The address up/down arrows increment/decrement the
address offset by 1.

Data Edit Boxes Contains the 16-bit data word that is written to or read from the register address. The LSB data is at
the lowest address. The data is written/read LSB first. The data up/down arrows
increment/decrement the data value by 1.

Write Button Writes the (2) bytes in the data edit boxes starting at the 10-bit register address BASE+OFFSET.

Read Button Reads (2) consecutive data bytes starting at the 10-bit register address BASE+OFFSET to the data
edit boxes.

Loop Count Edit Box Causes subsequent write or read operations to be performed N times. N is entered as a decimal
number from 1 to 999.

Histogram on Creates a histogram of the results from the Loop Count Reads.
Loop Count Reads

Close Button Closes the dialog.

Note: The memory map editor can remain open with other
windows. Use the Window menu to navigate.

The property sheets represent the register data in a user-friendly format. The data is organized by
function, with each function having its own page and being selectable via tabs at the top (see Figure 20).

To open this, click on Edit Property Sheets in the Edit menu and select the device type to edit.

When the property sheet function is started or whenever the user tabs to a different page, all readable
registers in the device are read from hardware to initialize the dialog pages. Values on the page are
changed by manipulating the various dialog controls as described in Table 6.

OK, Cancel, and Apply buttons are at the bottom of each property page. These are described in Table 7.
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8.6.1 Property Sheet Refresh

8.6.1.1 Auto-Update From Device

WinVCC in Depth

Figure 20. TVP5154 Property Sheets

The property sheets are designed so that the data displayed is always current. Certain actions cause the
entire register map to be read from the device and to update the property sheets. This happens when:
• Property sheets are initially opened.
• When tabbing from one page to another.
• When Read All is clicked.
• When making the TVP5154 Property Sheets window the active window (by clicking on it).
• When making a TVP5154 Register Map editor window the active window (by clicking on it).

The last two items in the Property Sheet Refresh list (see section 8.6.1) are referred to as the
Auto-Update feature. Auto-Update can be disabled by setting its program option button to DISABLED.
This button is located on the initial dialog box (WinVCC Configuration).

With Auto-Update enabled (default), the user can open both the TVP5154 Property Sheets and the
TVP5154 Register Map editor at the same time. Changes made to the property sheets (and applied) are
updated in the register map window as soon as the Register Map window is clicked on. Additionally,
changes made in the TVP5154 Register Map editor are updated in the TVP5154 Property Sheets as soon
as the property sheets window is clicked on.
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9 Programming the TMS320DM642

9.1 Development and Purpose of DM642 Code

Programming the TMS320DM642

Table 6. Use of Property Sheet Controls

PROPERTY SHEETS DIALOG CONTROL WHAT DO I DO WITH IT?

When is Hardware Updated?

Read-Only Edit Box Read status information N/A

Check Box Toggle a single bit After Apply

Drop-Down List Select from a text list After Apply

Edit Box Type a number After Apply

Up/Down arrows: ImmediatelyEdit Box with Up/Down arrows Use up/down arrows or type a number Type a number: After Apply

Slider Slide a lever Immediately

Pushbutton Initiate an action Immediately

Table 7. Property Sheet Button Controls

BUTTON DEFINITIONCONTROL

OK Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
written is different from the value last read from that address.
Closes the dialog.

Cancel Causes all changes made to the property page since the last Apply to be discarded. Changes made to dialog
controls with ‘immediate hardware update’ are not discarded, since they have already been changed in
hardware.
Does not write to hardware.
Closes the dialog.

Apply Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
written is different from the value last read from that address.

This chapter discusses how to change settings for the TMS320DM642 on this EVM. The DM642 settings
can be controlled by using the DM642 Control Window, which is found by clicking on Tools→DM642
Control, or through the Generic I2C registers.

The TVP5154EVM was developed by the TI Digital Video Department, which is responsible for the
TVP5146 and TVP5150AM1 video decoders currently used on the DM642EVM released by Spectrum
Digital. The TVP5154EVM hardware and software are both based on this DM642EVM.

The TVP5154EVM was designed specifically for security customers interested in a quad video decoder.
The TVP5154EVM showcases the TVP5154 with various scaled/unscaled display modes, while making
the DM642 transparent to the customer during evaluation. This is made possible by placing the DM642
into an I2C slave mode and controlling the capture/display modes using virtual I2C registers. The entire
TVP5154EVM is controlled by a PC emulating I2C via the parallel port. By downloading the DM642 code
from flash at power up, it is not required to use Code Composer Studio™ software to program the DM642;
all relevant DM642 control registers can be accessed and controlled through a generic I2C address.

In addition to the command file provided with this EVM, additional command files to be used with TI’s EVM
control software (WinVCC) can be provided from TI to support easy programming of the TVP5154 and
DM642 registers to show the most common scaling configurations for both NTSC and PAL formats. When
using these command files or when setting the register values through a standard I2C bus interface, it is
important to enable and program the 5154 outputs before configuring the DM642 registers. The DM642
portion of the TVP5154EVM consists only of the DM642, SDRAM, and flash memory.
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9.2 Details of the DM642 Code and Control Registers

9.2.1 DM642 Control Window

Programming the TMS320DM642

Details of the DM642 code and control registers are:
• The DM642 device address is 0x40h by default. The DM642 is setup as an I2C slave.
• The DM642 executes code on power up from the flash using the PCI GPIO to control the address

MSB.
• Virtual I2C registers are created within the DM642 in order to control the capture and display of the

scaled/unscaled data from the TVP5154 video decoder. These registers are described in Table 9.
• The virtual I2C registers support scaled and unscaled video outputs independently for each of the four

video decoders, with the option to overlay scaled video onto unscaled video, and to define the
quadrant location of each scaled channel.

• The virtual I2C registers provide easy control/access to the GPIOs currently tied to LEDs. Please refer
to the TVP5154EVM schematics for options to associate an LED on/off with a register setting.

• The DM642 is not responsible for any scaling. All video scaling is performed by the TVP5154. The
DM642 is only responsible for image capture and display.

• The DM642 virtual registers can be controlled by using the DM642 Control Window or through the
Generic I2C registers.

The DM642 settings can be easily controlled by using the DM642 Control window. This window represents
the DM642 register data in a user-friendly format. The data is organized for each of the four decoders (see
Figure 21).

To open this, click on DM642 Control in the Tools menu.

Figure 21. DM642 Control Window
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9.2.2 DM642 Virtual I2C Register Map

Programming the TMS320DM642

When the DM642 Control window is opened, all readable registers for the device are read from software
to initialize the dialog page. Register details are given in Table 8. Values on the page are changed by
manipulating the various dialog controls as described in Table 8. The data is organized for each of the
four decoders, allowing independent control of each decoder.

Table 8. DM642 Control Window Controls

CONTROL DEFINITION

Read All Reads all defined readable registers from the device and updates the register window.

Causes all changes made to the page since the last Apply to be discarded. Changes made to dialog controls
with ‘immediate register update’ are not discarded, since they have already been changed in the DM642

Close registers.
Does not write to registers.
Closes the dialog.

Image Capture Enables image capture in the DM642 for that given decoder (1–4). Immediate register update.

Used to inform the DM642 of the input color standard for that given decoder (1–4). No change in register until
Video Standard Apply is clicked.

Does not change the video standard setting for the TVP5154.

Used to inform the DM642 of the input image size for that given decoder (1–4). No change in register until Apply
Image Size is clicked.

Actual scaling is done in the TVP5154.

Image Position Defines the quadrant location for the input of that given decoder (1–4). Immediate register update.

Immediately changes DM642 registers for input image size and input color standard for that given decoder
(1–4).Apply Enables TVP5154 scaler and programs correct scaling register settings into TVP5154 based on selected input
standard and image size for that given decoder (1–4).

Flash Reads the data from the Flash Version registers and writes it into the register window.Major/Minor

LED Control Changes LED (1–7) status. Checked: LED is ON. Unchecked: LED is OFF. Immediate register update.

Table 9. DM642 Virtual I2C Register Map

REGISTER DESCRIPTION ADDRESS DATA (DEFAULT)

Decoder 1 Register 00h 02h

Decoder 2 Register 01h 12h

Decoder 3 Register 02h 22h

Decoder 4 Register 03h 32h

Decoder 1 Input Format Register 04h 01h

Decoder 2 Input Format Register 05h 01h

Decoder 3 Input Format Register 06h 01h

Decoder 4 Input Format Register 07h 01h

LED Control 08h 00h

Flash Version: Major 09h 01h

Flash Version: Minor 0Ah 00h
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9.2.3 DM642 Virtual I2C Register Details

Quad 1 Quad 2

Quad 3 Quad 4

Decoder 1

Scaled

Decoder 2

Unscaled

Decoder 2

Unscaled

Decoder 4

Scaled

Programming the TMS320DM642

Table 10. Decoder 1 Register

Address 00h

Default 02h

7 6 5 4 3 2 1 0

CaptureReserved Position Capture SizeEnable

Capture Size Bit 2 Bit 1 Bit 0

Unscaled 0 0 0

QSIF – 176 × 120 0 0 1

SIF – 352 × 240 (1/4 NTSC)
0 1 0

(default)

QCIF – 176 × 144 0 1 1

CIF – 352 × 288 (1/4 PAL) 1 0 0

QVGA – 320 × 240 1 0 1

VGA – 640 × 480 1 1 0

Reserved 1 1 1

Capture Enable Bit 3

Disable (default) 0

Enable 1

Position Bit 5 Bit 4

Quadrant 1 (default) 0 0

Quadrant 2 0 1

Quadrant 3 1 0

Quadrant 4 1 1

Scaled capture sizes always take priority over unscaled capture sizes.

Decoder priorities are always such that Decoder 1 is the highest priority, Decoder 2 is the second highest,
etc.

For example, if Decoders 1 and 4 are scaled to 1/4 size and Decoders 2 and 3 are unscaled, this display
results:
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Quad 1 Quad 2

Quad 3 Quad 4

Programming the TMS320DM642

Note: The unscaled Decoder 2 displays in both Quadrant 2 and 3 since Decoder 2 takes priority
over Decoder 3 when both are unscaled.

Table 11. Decoder 2 Register

Address 01h

Default 12h

7 6 5 4 3 2 1 0

CaptureReserved Position Capture SizeEnable

Capture Size Bit 2 Bit 1 Bit 0

Unscaled 0 0 0

QSIF – 176 × 120 0 0 1

SIF – 352 × 240 (1/4 NTSC)
0 1 0

(default)

QCIF – 176 × 144 0 1 1

CIF – 352 × 288 (1/4 PAL) 1 0 0

QVGA – 320 × 240 1 0 1

VGA – 640 × 480 1 1 0

Reserved 1 1 1

Capture Enable Bit 3

Disable (default) 0

Enable 1

Position Bit 5 Bit 4

Quadrant 1 0 0

Quadrant 2 (default) 0 1

Quadrant 3 1 0

Quadrant 4 1 1
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Quad 1 Quad 2

Quad 3 Quad 4

Programming the TMS320DM642

Table 12. Decoder 3 Register

Address 01h

Default 22h

7 6 5 4 3 2 1 0

CaptureReserved Position Capture SizeEnable

Capture Size Bit 2 Bit 1 Bit 0

Unscaled 0 0 0

QSIF – 176 × 120 0 0 1

SIF – 352 × 240 (1/4 NTSC)
0 1 0

(default)

QCIF – 176 × 144 0 1 1

CIF – 352 × 288 (1/4 PAL) 1 0 0

QVGA – 320 × 240 1 0 1

VGA – 640 × 480 1 1 0

Reserved 1 1 1

Capture Enable Bit 3

Disable (default) 0

Enable 1

Position Bit 5 Bit 4

Quadrant 1 0 0

Quadrant 2 0 1

Quadrant 3 (default) 1 0

Quadrant 4 1 1

Table 13. Decoder 4 Register

Address 01h

Default 32h

7 6 5 4 3 2 1 0

CaptureReserved Position Capture SizeEnable

Capture Size Bit 2 Bit 1 Bit 0

Unscaled 0 0 0

QSIF – 176 × 120 0 0 1

SIF – 352 × 240 (1/4 NTSC)
0 1 0

(default)

QCIF – 176 × 144 0 1 1

CIF – 352 × 288 (1/4 PAL) 1 0 0

QVGA – 320 × 240 1 0 1

VGA – 640 × 480 1 1 0

Reserved 1 1 1
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Quad 1 Quad 2

Quad 3 Quad 4

Programming the TMS320DM642

Capture Enable Bit 3

Disable (default) 0

Enable 1

Position Bit 5 Bit 4

Quadrant 1 0 0

Quadrant 2 0 1

Quadrant 3 1 0

Quadrant 4 (default) 1 1

Table 14. Decoder 1 Input Format Register

Address 04h

Default 01h

7 6 5 4 3 2 1 0

Reserved Input Color Standard

Input Color Standard Bit 2 Bit 1 Bit 0

NTSC 0 0 0

(B, D, G, H, I, N) PAL
0 0 1

(default)

Reserved . . .

The Input Color Standard register is used to inform the DM642 of the input color standard for that given
decoder (1–4). The output format of the DM642 is set to the standard with the largest majority based on
Registers 04h–07h. If the number of input color standards is equal, the DM642 automatically default to
PAL output.

Table 15. Decoder 2 Input Format Register

Address 05h

Default 01h

7 6 5 4 3 2 1 0

Reserved Input Color Standard

Input Color Standard Bit 2 Bit 1 Bit 0

NTSC 0 0 0

(B, D, G, H, I, N) PAL
0 0 1

(default)

Reserved . . .
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Programming the TMS320DM642

Table 16. Decoder 3 Input Format Register

Address 06h

Default 01h

7 6 5 4 3 2 1 0

Reserved Input Color Standard

Input Color Standard Bit 2 Bit 1 Bit 0

NTSC 0 0 0

(B, D, G, H, I, N) PAL
0 0 1

(default)

Reserved . . .

Table 17. Decoder 4 Input Format Register

Address 07h

Default 01h

7 6 5 4 3 2 1 0

Reserved Input Color Standard

Input Color Standard Bit 2 Bit 1 Bit 0

NTSC 0 0 0

(B, D, G, H, I, N) PAL
0 0 1

(default)

Reserved . . .

Table 18. LED Control Register

Address 08h

Default 00h

7 6 5 4 3 2 1 0

Reserved LED 7 Status LED 6 Status LED 5 Status LED 4 Status LED 3 Status LED 2 Status LED 1 Status

LED (1–7) Status

= 0 (LED off)

= 1 (LED on)

Table 19. Flash Major Version Register

Address 09h

Default 01h

7 6 5 4 3 2 1 0

Flash Major Version

Table 20. Flash Minor Version Register

Address 0Ah

Default 00h

7 6 5 4 3 2 1 0

Flash Minor Version
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10 Troubleshooting

10.1 Troubleshooting Guide

Troubleshooting

This chapter discusses ways to troubleshoot the TVP5154EVM.

If you are experiencing problems with the TVP5154EVM hardware or the WinVCC software, see Table 21
for available solutions.

Table 21. TVP5154EVM Troubleshooting

SYMPTOM CAUSE SOLUTION

At startup, the error message Cannot find The parallel port driver supplied with the Run Port95NT.EXE on the CD to install
DLL file DLPORTIO.DLL appears. EVM has not been installed. the driver.

Go to Edit→Property Sheets→TVP5154,
Analog Video page, select the correct

Wrong video input is selected. video input(s) and click Apply.
(The composite video input 1 is selected
by default.)

Blank screen Source is connected to the wrong input Connect source to the correct input
connector. connector.

Go to Edit→Property Sheets→TVP5154,
Output Control page, check the enableYCbCr outputs or clock output is disabled. YCbCr outputs and enable clock outputs
check boxes and click Apply.

Go to Edit→Property Sheets→TVP5154,Wrong mode is selected for color Synchronization page, set the Fsc controlsubcarrier genlock output. format to RTC and click Apply.
No color Go to Edit→Property Sheets→TVP5154,

GLCO pin is not set to output the GLCO Output Control page, set the drop down
signal. box labeled FID/GLCO (pin 23) to genlock

output (GLCO) and click Apply.

Go to Edit→Property Sheets→TVP5154,
Output Control page, set the YCbCrScreen colors are only magenta and Wrong YCbCr output format output format to 8-bit 4:2:2 YCbCrgreen. w/ITU-R BT.656 embedded sync mode
and click Apply.

Go to Edit→Property Sheets→TVP5154,
Mode Selection page, uncheck allAuto-switch masks are not set correctly. standards to be included in auto-switch

Video standard auto-switch does not work processing and click Apply.
on the video decoder side.

Go to Edit→Property Sheets→TVP5154,
Video decoder is not in auto-switch mode. Mode Selection page, set the drop-down

box to multistandard and click Apply.

Click real-time polling in the Tools menu.Video standard auto-switch does not work Auto-switch polling is not enabled. Click Enable All and OK. This should beon the video encoder side. disabled if using a composite output.
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Troubleshooting

Table 21. TVP5154EVM Troubleshooting (continued)

SYMPTOM CAUSE SOLUTION

Make sure I2C slave address jumpers on
Decoder I2C slave address is wrong. the TVP5154 decoder module are across

pins 2 and 3.

Slave address is hard coded to be 0x54 in
the command file. Make sure the I2C slaveEncoder I2C slave address is wrong. address jumper on encoder module is
across pins 2 and 3.

Parallel cable is not connected from PC
parallel port to the TVP5154 decoder Connect cable
module DB25 connector.

Power supply must be plugged into a
100-V to 240-V/47-Hz to 63-Hz powerEVM is not powered on. source, and the cord must be plugged into
the power connector on the EVM.

Some parallel cables are not wired
Wrong type of parallel cable. straight through pin for pin. Use the cable

No I2C communication supplied with the EVM.

Press the Reset button on the TVP5154Device was placed in power-down mode. Decoder Module.

EVM was configured for an external I2C Reinstall 0-Ω resistors R5 and R6. Control
master. EVM using the PC parallel port.

DO THIS AS A LAST RESORT. Reboot
PC, enter BIOS setup program, and set
parallel port LPT1 mode (Addr 378h) to
ECP mode or bidirectional modePC parallel port mode is not set correctly. (sometimes called PS/2 mode or byte
mode). If already set to one of these two
modes, switch to the other setting (see
Section 10.2).

PC may not be capable of operating in the
required parallel port mode. This is true ofStill no I2C communication some laptop computers. Use a different
computer, preferably a desktop PC.

When WinVCC is started and the WinVCC Configuration dialog box is closed with OK, the I2C system test
is performed (unless the I2C System Test program options button was disabled).

If the I2C system test fails, a dialog box (see Figure 22) appears. This example reports that a read from
TVP5154 failed, using slave address 0xB8, sub-address 0xD0. The data read was 0x78. The expected
data was 0x00.

After noting which device had a problem, click OK to continue. Next, the Corrective Action Dialog box
appears to fix the problem.
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10.2 Corrective Action Dialogs

Troubleshooting

Figure 22. I2C System Failure Dialog Box

After closing the I2C system test report dialog box, a dialog box (see Figure 23) appears.

Figure 23. Corrective Action Dialog Box

1. If the parallel port cable is NOT connected between to PC and the TVP5154EVM, or if the EVM power
is not on:

a. Click NO.
b. The dialog box shown in Figure 23 appears instructing you to correct the problem.
c. Correct the problem.
d. Click OK to continue. The Real-Time Polling dialog appears.
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10.2.1 Setting the PC Parallel Port Mode

Troubleshooting

Figure 24. Corrective Action Required

2. If the cable is connected from the PC parallel port to the TVP5154EVM and the EVM power is on:

a. Click Yes.
b. The dialog box shown in Figure 24 appears. This dialog box appears if the PC parallel

port mode setting may need to be changed.

Note: Only run the PC BIOS setup program if the I2C communication problem cannot be
resolved in another way (correct slave address settings, reset or power cycle the
EVM, and/or check that the device type selected was TVP5154).

c. Click OK to continue.
d. The real-time polling dialog appears. Click OK to close it and get to the main menu.
e. Click Exit in the File menu to exit the program.
f. See the troubleshooting guide in Table 21.

Figure 25. Corrective Action Required

Note: Only run the PC BIOS setup program if the I2C communication problem cannot be
resolved in another way (correct slave address settings, reset or power cycle the EVM,
and/or check that the device type selected was TVP5154).

1. Restart the PC.
2. During the boot process, enter the BIOS setup program by pressing the required key (usually the initial

text screen indicates which key to press).
3. Find the place where the parallel port settings are made.
4. Set the parallel port LPT1 at address 378h to ECP mode or bidirectional mode (sometimes called PS/2

mode or byte mode). If one of these two modes is already selected, change to the opposite mode.
5. Exit and save changes.
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10.2.2 General I2C Error Report

11 TVP5154EVM Schematics

TVP5154EVM Schematics

The I2C Error Report shown in Figure 26 appears when an I2C error occurs at any time other than after
the I2C system test. In this example, there is acknowledge error at slave address 0x54 (the video encoder
module). The error occurred on Read Cycle Phase 1 on the device (slave) address byte.

Figure 26. I2C Error
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56

TE
D

52

TE
D

60

TE
D

32

TE
D

61

TE
D

35

TE
D

57

TE
D

47
TE

D
46

TE
D

45
TE

D
44

TE
D

51

TE
D

53

TE
D

63

TE
D

54

TE
D

62

TE
D

55

TE
D

50

TE
D

48

TE
D

58

TE
D

33

TE
D

43

TE
D

40

TE
D

59

TE
D

36

TE
D

39

TE
D

41

TE
D

37
TE

D
38

TE
D

42

1 2 3 4 5 6 7 8
910111213141516

R
N

11

R
PA

C
K

8-
33

R6433

1 2 3 4 5 6 7 8
910111213141516

RN2
RPACK8-33

1
2
3
4
5
6
7
8 9

10
11
12
13
14
15
16

RN12 RPACK8-33

R6733

1 2 3 4 5 6 7 8
910111213141516

R
N

9

R
PA

C
K

8-
33

R6233

R41
10k

R89
4.7k

1 2 3 4 5 6 7 8
910111213141516

R
N

3

R
PA

C
K

8-
33

1 2 3 4 5 6 7 8
910111213141516

RN5
RPACK8-33

R6533

EMIF and Emulation

ED
0

B
24

ED
1

A
24

ED
2

B
23

ED
3

B
22

ED
4

C
22

ED
5

A
23

ED
6

C
21

ED
7

B
21

ED
8

D
21

ED
9

A
21

ED
10

C
20

ED
11

B
20

ED
12

D
20

ED
13

A
20

ED
14

D
19

ED
15

C
19

ED
16

H
24

ED
17

H
23

ED
18

G
26

ED
19

G
23

ED
20

G
25

ED
21

G
24

ED
22

F2
6

ED
23

F2
3

ED
24

F2
5

ED
25

F2
4

ED
26

E2
5

ED
27

E2
4

ED
28

D
25

ED
29

D
26

ED
30

C
25

ED
31

C
26

EA03 M24

EA04 M23

EA05 N26

EA06 N24

EA07 N23

EA08 P26

EA09 P24

EA10 P23

EA11 R24

EA12 R23

EA13 T25

EA14 T24

EA15 U26

EA16 U25

EA17 U24

EA18 V23

ECLKINSEL0 / EA19 V26

ECLKINSEL1 / EA20 V25

BOOTMODE0 / EA21 V24

BOOTMODE1 / EA22 U23

BE0 L24

BE1 L23

BE2 M26

BE3 M25

BE4 R26

BE5 R25

BE6 T23

BE7 T22

CE0 K25

CE1 K24

CE2 K23

CE3 L26

SDRAS/AOE J24

SDCAS/ARE J25

SDWE/AWE K26

SDCKE L25

SOE3 R22

PDT M22

ECLKOUT1 J26

ECLKOUT2 J23

HOLDA N22

BUSREQ P22

ED
32

A
D

26

ED
33

A
D

25

ED
34

A
C

25

ED
35

A
C

26

ED
36

A
B

24

ED
37

A
B

25

ED
38

A
B

23

ED
39

A
A

24

ED
40

A
A

25

ED
41

A
A

23

ED
42

A
A

26

ED
43

Y
24

ED
44

Y
25

ED
45

Y
23

ED
46

Y
26

ED
47

W
23

ED
48

A
D

19

ED
49

A
C

19

ED
50

A
F2

0

ED
51

A
C

20

ED
52

A
E2

0

ED
53

A
D

20

ED
54

A
F2

1

ED
55

A
C

21

ED
56

A
E2

1

ED
57

A
D

21

ED
58

A
E2

2

ED
59

A
D

22

ED
60

A
D

23

ED
61

A
E2

3

ED
62

A
F2

3

ED
63

A
F2

4
HOLDW24

ARDYL22

TMSE15

TDIA18

TCLKA16

TRSTD14

TDOB18

EMU0A15 EMU1C14 EMU2B15 EMU3C15

EMU4D15 EMU5B16 EMU6C16 EMU7A17 EMU8D16 EMU9B17

EMU10C17 EMU11D17

U25A

TMX320DM642CGDK

R6833

1
2
3
4 5

6
7
8

RN14 RPACK4-33

1
2
3
4
5
6
7
8 9

10
11
12
13
14
15
16

RN7 RPACK8-33

1 2 3 4 5 6 7 8
910111213141516

R
N

10

R
PA

C
K

8-
33

R6333

1 2 3 4 5 6 7 8
910111213141516

R
N

8

R
PA

C
K

8-
33

1 2 3 4 5 6 7 8
910111213141516

RN4
RPACK8-33

R6633

1
2
3
4 5

6
7
8

RN13 RPACK4-33

1
2
3
4
5
6
7
8 9

10
11
12
13
14
15
16

RN6 RPACK8-33

R6933

D3.3V

TBE2#

TBE0#

TEA[22..3]

TBE3#

TED[63..0]

TSDRAS#

TBE1#

TECLKOUT1

TSDCKE

TBE6#
TBE7#

TSDWE#
TSDCAS#

TBE4#

TCE0#

TBE5#

DSP_TCLK

DSP_TDI
DSP_TRST#

DSP_TDO

DSP_TMS

DSP_EMU[11..0]

NOTE: PLACE ALL 33-OHM RESISTORS AND RESISTOR NETWORKS AS CLOSE AS POSSIBLE TO THE CORRESPONDING U25 PINS.

TE
D

5
TE

D
6

TE
D

4

TE
D

7

TE
D

1

TE
D

3

TE
D

0

TE
D

2

TE
D

30
TE

D
31

TE
D

10

TE
D

27

TE
D

19

TE
D

16

TE
D

9

TE
D

11

TE
D

22

TE
D

17

TE
D

12

TE
D

29

TE
D

24

TE
D

15

TE
D

13

TE
D

8

TE
D

25
TE

D
26

TE
D

21

TE
D

18

TE
D

28

TE
D

20

TE
D

14

TE
D

23

TP
1

TP12
TP

TP
1

TP13
TP

TP
1

TP16
TP

R19
NO POP

R17
NO POP

R20
NO POP

R18
NO POP

D3.3V

EMIF_ECLKINSEL[1:0]

0

1

ECLKIN( DEFAULT)

CPU CLOCK /4 EMIF CLOCK

MODE SELECTEDTEA20 TEA19

0

11

10

0 CPU CLOCK /6 EMIF CLOCK

RESERVED

R35

1k

R36

1k

R21
NO POP

D3.3V
0 NO BOOT (DEFAULT)

BOOT_MODE[1:0]

MODE SELECTED

HPI/PCI BOOT MODE (PCIEN)

TEA22 TEA21

0

0 1

RESERVED

EMIF 8 BIT ROM BOOT

1

1 1

0

TEA21

TEA22

TEA19

TEA20

DSP_EMU[11..0]

TP
1

TP11
TP

TCE0#
TCE1#
TCE2#
TCE3#

TCE0#
TCE1#
TCE2#
TCE3#

TP
1

TP14
TP

TP
1

TP15
TP

PDT#

PDT#

TSOE3#

TSOE3#

TP
1

TP17
TP

TECLKOUT2

TECLKOUT2

TP
1

TP18
TP

TEA[22..3]

TED[63..0]

TCE1#

R22
NO POP
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Orcad B 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

DM642 PCI/HPI/EMAC

R24
NO POP

R25
NO POP

PCI / HPI / EMAC

HD00 / AD00 Y3

HD01 / AD01 AA1

HD03 / AD03 Y2

HD04 / AD04 W3

HWDTHSEL / HD05 / AD05 Y1

HD06 / AD06 W4

HD07 / AD07 W2

HD08 / AD08 V2

HD09 / AD09 V3

HD02 / AD02 Y4

HD10 / AD10 V1

HD11 / AD11 U4

HD12 / AD12 U2

HD13 / AD13 U3

HD14 / AD14 U1

HD15 / AD15 T3

MTXD0 / HD16 / AD16 M3

MTXD1 / HD17 / AD17 M2

MTXD2 / HD18 / AD18 M4

MTXD3 / HD19 / AD19 L2

MTXEN / HD20 / AD20 L3

MCOL / HD21 / AD21 K2

MTCLK / HD22 / AD22 L4

HD23 / AD23 K1

MRXD0 / HD24 / AD24 K4

MRXD1 / HD25 / AD25 J1

MRXD2 / HD26 / AD26 J3

MRXD3 / HD27 / AD27 H2

MRXDV / HD28 / AD28 J4

MRXER / HD29 / AD29 G2

MCRS / HD30 / AD30 H3

MRCLK / HD31 / AD31 G1

PSERR / HDS1R2

PCBE1 / HDS2T2

PTRDY / HHWILN3 PFRAME / HINTN4

PCBE2 / HR/WM1

PIRDY / HRDYN1

PCBE0V4

PCIENE2

PCBE3 / GP10J2

PREQ / GP11F1

PGNT / GP12H4

PINTA / GP13G4

PCLK / GP14C1

PRST / GP15G3

PIDSEL / GP9K3

PPAR / HASP3

PSTOP / HCNTL0R3

PDEVSEL / HCNTL1P1

PPERR / HCSR1

XSPCST4

XSPDIR4

XSPDO / MDIOP5

XSPCLK / MDCLKR5

U25D

TMX320DM642CGDK
D3.3V

HWDTHSEL

HWDTHSEL

GP13_A19

GP15_A21

GP14_A20

R76
10k

D3.3V

A
2

K
1

5

BLUE_LED

R77
150

A
2

K
1

6

BLUE_LED

R78
150

A
2

K
1

7

BLUE_LED

R79
150

R23
NO POP

R37
1k

D3.3V

PCIEN

PCIEN

R45
10k

R44
10k

R43
10k

R42
10k

HWDTHSEL

0

1

HPI WIDTH SELECTION

MODE SELECTED

16 BITS

32-BITS

PCIEN

0

1

PCI SELECTION

MODE SELECTED

PCI DISABLED

PCI ENABLED
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C 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

DM642 POWER PINS

C30

0.01uF

C33

0.01uF

C31

0.01uF

C24

0.01uF

C28

0.01uF

C18

0.01uF

C15

0.01uF

C66

0.1uF

+
C175

33uF

C45

0.1uF

C11

0.1uF

+
C170

10uF

C22

0.01uF

C38

0.1uF

C29

0.01uF

C20

0.01uF

C10

0.1uF

C12

0.1uF

+
C174

33uF

C57

0.1uF

+
C173

33uF

C37

0.1uF

C50

0.1uF

C56

0.01uF

C34

0.01uF

C27

0.01uF

C14

0.01uF

C23

0.01uF

C19

0.01uF

C26

0.01uF

C36

0.1uF

C47

0.1uF

C46

0.1uF

C41

0.1uF

C21

0.01uF

C43

0.1uF

C32

0.01uF

C7

0.1uF

C59

0.1uF

C49

0.1uF

C39

0.1uF

C44

0.1uF

C13

0.01uF

C25

0.01uF

+
C172

10uF

C8

0.1uF

C63

0.1uF

C9

0.1uF

C69

0.1uF

Power and Ground��Connections

CVDDF6

CVDDF7

CVDDF20

CVDDF21

CVDDG6

CVDDG7

CVDDG8

CVDDG10

CVDDG11

CVDDG13

CVDDG16

CVDDG17

CVDDG19

CVDDG20

CVDDG21

CVDDH20

CVDDK7

CVDDK20

CVDDL7

CVDDL20

CVDDN7

CVDDP20

CVDDT7

CVDDT20

CVDDU7

CVDDU20

CVDDW20

CVDDY6

CVDDY7

CVDDY8

CVDDY10

CVDDY11

CVDDY14

CVDDY16

CVDDY17

CVDDY19

CVDDY20

CVDDY21

CVDDAA6

CVDDAA7

CVDDAA20

CVDDAA21

DVDD A2

DVDD A25

DVDD B1

DVDD B14

DVDD B26

DVDD E7

DVDD E8

DVDD E10

DVDD E17

DVDD E19

DVDD E20

DVDD F9

DVDD F12

DVDD F15

DVDD F18

DVDD G5

DVDD G22

DVDD H5

DVDD H22

DVDD J21

DVDD K5

DVDD K22

DVDD M6

DVDD M21

DVDD N2

DVDD P25

DVDD R21

DVDD U5

DVDD U22

DVDD V21

DVDD W5

DVDD W22

DVDD Y5

DVDD Y22

DVDD AA9

DVDD AA12

DVDD AA15

DVDD AA18

DVDD AB7

DVDD AB8

DVDD AB10

DVDD AB17

DVDD AB19

DVDD AB20

DVDD AE1

DVDD AE13

DVDD AE26

DVDD AF2

DVDD AF25
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4
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1
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6
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9
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26
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A
C

3
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A
C

5
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A
C

18
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A
C

22
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A
C

24

V
SS

A
D

2

DVDD B2

DVDD B25

DVDD C3

DVDD C24

DVDD D4

DVDD D23

DVDD E5

DVDD E22

CVDDG14

DVDD J6CVDDN20

CVDDP7

DVDD W25

CVDDY13

DVDD AB5

DVDD AB22

DVDD AC23

DVDD AD24

DVDD AE2

DVDD AE25

CVDDM12

V
SS

M
13

CVDDM14

V
SS

M
15

V
SS

N
12

CVDDN13

V
SS

N
14

CVDDN15

CVDDP12

V
SS

P1
3

CVDDP14

V
SS

P1
5

V
SS

R
12

CVDDR13

V
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R
14

CVDDR15

V
SS

H
21

V
SS

H
26

V
SS

J5

V
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J7

V
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J2
0

V
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J2
2

V
SS

K
6
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K
21
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L1
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L6
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L2
1
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M
7
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M
20

V
SS

N
5
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N
6

V
SS

N
21
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25
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A
D

4

V
SS

A
D

18

V
SS

A
E3

V
SS

A
E8

V
SS

A
E1

0

V
SS

A
E1

2

V
SS

A
E1

4

V
SS

A
E1

9

V
SS

A
E2

4

V
SS

A
F1

V
SS

A
F7

V
SS

A
F9

V
SS

A
F1

1

V
SS

A
F1

3

V
SS

A
F1

5

V
SS

A
F1

9

V
SS

A
F2

2

V
SS

A
F2

6

CVDDMONH7

DVDDMONR6

VSSMONW7

U25C

TMX320DM642CGDK
101562-0001

C42

0.1uF

C40

0.1uFC17

0.01uF

C48

0.1uF

+
C171

10uF

R90 0
R91 0

C35

0.1uF

C16

0.01uF

C61

0.1uF

C60

0.1uF

C67

0.1uF

C58

0.1uF

C71

0.1uF

C64

0.1uF

C52

0.01uF

C54

0.01uF

C53

0.01uF

C55

0.01uF

C51

0.01uF

C65

0.1uF

C70

0.1uF

C68

0.1uF

C62

0.1uF

DSP_CVDD

DSP_CVDD

D3.3V

D3.3V

D3.3V

D3.3V

D3.3V

D3.3V

D3.3V
DSP_CVDDD3.3V

DSP_CVDD

DSP_CVDD

DSP_CVDD

DSP_CVDD

D3.3V

D3.3V

DSP_CVDD

CORE CAPACITORS ARE 0402 SIZE
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TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

FLASH MEMORY

R51
10k

C73

0.1uF

C72

0.1uF

R52
10k

A021

A120

A219

A318

A417

A516

A615

A714

A88

A97

A1036

A116

A125

A134

A143

A152

A161

A1740

A1813

A2129

DQ0 25

DQ1 26

DQ2 27

DQ3 28

DQ4 32

DQ5 33

DQ6 34

DQ7 35

V
C

C
2

31

ACC11

A2038

CE22

OE24

WE9

RDY-BY 12

RESET10

A1937

V
C

C
30

V
SS

1
23

V
SS

2
39

U4

AM29LV033C-90EI

R53 10k

R26 NO POP

R49
10k

R50
10k

D3.3V

D3.3V

D3.3V/RESET

TED[31..0]

TEA[22..3]

TSDWE#
TSDCAS#

TED0
TED1
TED2
TED3
TED4
TED5
TED6
TED7

TEA3
TEA4
TEA5
TEA6
TEA7
TEA8
TEA9
TEA10
TEA11
TEA12
TEA13
TEA14
TEA15
TEA16
TEA17
TEA18
TEA19
TEA20
TEA21

TEA[22..3]

TED[31..0]

GP13_A19

GP15_A21
GP14_A20

TCE1#
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DALLAS, TEXAS 75243

F&V BIT BREAKOUT

C75
0.1uF

C74
0.1uF

C76
0.1uF

C77
0.1uF

C78
0.1uF

CLK/I01

I12

I23

I34

I45

I56

I67

I78

I89

I910

I1011

GND12 I11 13I/O0 14I/O1 15I/O2 16I/O3 17I/O4 18I/O5 19I/O6 20I/O7 21I/O8 22I/O9 23VCC 24
U6

PALCE22V10H-10PC/5

SCLK
Y0
Y1
Y2
Y3
Y4
Y5
Y6
Y7

D5V

TP
1

TP19
TP

TP
1

TP20
TP

TP
1

TP21
TP

TP
1

TP22
TP

Vcc 7

Vcc 18Vcc31 Vcc42

1A147

1A246

1A344

1A443

1A541

1A640

1A738

1A837

1B1 2

1B2 3

1B3 5

1B4 6

1B5 8

1B6 9

1B7 11

1B8 12

2A136

2A235

2A333

2A432

2A530

2A629

2A727

2A826

2B1 13

2B2 14

2B3 16

2B4 17

2B5 19

2B6 20

2B7 22

2B8 23

1OE48

1DIR1

2OE25

2DIR24

GND4

GND10

GND15

GND21

GND 28

GND 34

GND 39

GND 45

U5

SN74LVT16245BDGGR

SCK4

CH4_OUT[7..0]

CH4_OUT0
CH4_OUT1
CH4_OUT2
CH4_OUT3
CH4_OUT4
CH4_OUT5
CH4_OUT6
CH4_OUT7

CH4_OUT[7..0]

D5V

#OE     DIR     OPERATION
L           L          A <--- B
L           H          A ---> B
H           X          ISOLATION

3.3V_SUPPLY

3.3V_SUPPLY

3.3V_SUPPLY
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C 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

DAUGHTERCARD INTERFACE

CH1_OUT0
CH1_OUT1
CH1_OUT2
CH1_OUT3
CH1_OUT4
CH1_OUT5
CH1_OUT6
CH1_OUT7

CH2_OUT0
CH2_OUT1
CH2_OUT2
CH2_OUT3
CH2_OUT4
CH2_OUT5
CH2_OUT6
CH2_OUT7

CH3_OUT0
CH3_OUT1
CH3_OUT2
CH3_OUT3
CH3_OUT4
CH3_OUT5
CH3_OUT6
CH3_OUT7

CH4_OUT0
CH4_OUT1
CH4_OUT2
CH4_OUT3
CH4_OUT4
CH4_OUT5
CH4_OUT6
CH4_OUT7

HS1
VS1
FID1

AV1
VB1
SCK1
SCKS1

CH1_OUT[7..0]

SCKS1
SCK1
VB1
AV1
HS1
VS1
FID1

CH1_OUT[7..0]

CH2_OUT[7..0] CH2_OUT[7..0]

CH3_OUT[7..0] CH3_OUT[7..0]

CH4_OUT[7..0] CH4_OUT[7..0]

HS2
VS2
FID2

AV2
VB2
SCK2
SCKS2SCKS2

SCK2
VB2
AV2
HS2
VS2
FID2

HS3
VS3
FID3

AV3
VB3
SCK3
SCKS3SCKS3

SCK3
VB3
AV3
HS3
VS3
FID3

HS4
VS4
FID4

AV4
VB4
SCK4
SCKS4SCKS4

SCK4
VB4
AV4
HS4
VS4
FID4

1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
25 26
27 28
29 30
31 32

H3

HEADER 16X2

1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
25 26
27 28
29 30
31 32

H4

HEADER 16X2

1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
25 26
27 28
29 30
31 32

H5

HEADER 16X2

1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
25 26
27 28
29 30
31 32

H2

HEADER 16X2

/RESET

D5V

SDASCL
SDA

SCL

1 2
3 4
5 6
7 8
9 10
11 12

H1

HEADER 6X2
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C 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

TVP5154

1
3

2 JP9
I2C ADR

I2CSEL1

1
3

2 JP11
/PDN

PDN

INPUT V DIVIDER NETWORK

I2C ADDRESS SELECTION

FOR 0-0.75V INPUT RANGE

   
2-3   Base Addr 0xB8 - Default

POWERDOWN
1-2   Normal Operation - Default
2-3  Powerdown

R56
10k

R54
10k

IOVDD IOVDD

RN16
RPACK8-33

RN15

RPACK8-33

REMEMBER 75ohm TERMINATION

R57
10k

C88
0.1uF

C89
0.1uF

DVDD

IOVDD

AI1A2

AI1B3

PLL_VDD4

PLL_GND5

REFM26

REFP27

CH2OUT7 86CH2OUT6 87CH2OUT5 88CH2OUT4 89CH2OUT3 90CH2OUT2 91CH2OUT1 92CH2OUT0 93

C
H

1O
U

T7
10

5
C

H
1O

U
T6

10
6

C
H

1O
U

T5
10

7
C

H
1O

U
T4

10
8

C
H

1O
U

T3
10

9
C

H
1O

U
T2

11
0

C
H

1O
U

T1
11

1
C

H
1O

U
T0

11
2

AI1GND1

AVDD8

AGND9

AI2GND10

AI2A11

AI2B12

PLL_VDD13

PLL_GND14

AVDD15

AGND16

REFM317

REFP318

AVDD19

AGND20

AI3GND21

AI3A22

AI3B23

PLL_VDD24

PLL_GND25

REFM426

REFP427

AVDD28

AGND29

AI4GND30

AI4A31

AI4B32

C
H

4O
U

T7
48

C
H

4O
U

T6
49

C
H

4O
U

T5
50

C
H

4O
U

T4
51

C
H

4O
U

T3
52

C
H

4O
U

T2
53

C
H

4O
U

T1
54

C
H

4O
U

T0
55

PL
L_

V
D

D
33

PL
L_

G
N

D
34

A
G

N
D

35

TM
S

36

FI
D

4/
G

LC
O

4
37

V
SY

N
C

4/
PA

LI
4

38

H
SY

N
C

4
39

A
V

ID
4

40

IN
T4

/G
PC

L4
/V

B
LK

4
41

C
LK

4
42

SC
LK

4
43

IO
G

N
D

44

IO
V

D
D

45

D
V

D
D

46

D
G

N
D

47

FI
D

3/
G

LC
O

3
56

V
SY

N
C

3/
PA

LI
3

57

H
SY

N
C

3
58

A
V

ID
3

59

IN
T4

/G
PC

L4
/V

B
LK

4
60

C
LK

3
61

SC
LK

3
62

IO
G

N
D

63

IO
V

D
D

64

CH3OUT7 67CH3OUT6 68CH3OUT5 69CH3OUT4 70CH3OUT3 71CH3OUT2 72CH3OUT1 73CH3OUT0 74

DVDD 65DGND 66

FID2/GLCO2 75VSYNC2/PALI2 76HSYNC2 77AVID2 78IOGND 79IOVDD 80DVDD 81DGND 82INT2/GPCL2/VBLK2 83               CLK2 84                 SCLK2 85

FID1/GLCO1 94VSYNC1/PALI1 95IOGND 96IO
D

V
D

D
97

D
V

D
D

98
D

G
N

D
99

H
SY

N
C

1
10

0
A

V
ID

1
10

1
IN

T1
/G

PC
L1

/V
B

LK
1

10
2

   
   

   
   

   
C

LK
1

10
3

   
   

   
   

   
  S

C
LK

1
10

4

IO
G

N
D

11
3

IO
V

D
D

11
4

D
V

D
D

11
5

D
G

N
D

11
6

   
 I2

C
A

1
11

7
   

 I2
C

A
0

11
8

SD
A

11
9

SC
L

12
0

R
ES

ET
B

12
1

PD
N

12
2

X
O

U
T

12
3

X
IN

/O
SC

12
4

R
EF

M
1

12
5

R
EF

P1
12

6
A

V
D

D
12

7
A

G
N

D
12

8

U1

TVP5154PNP

SCLK3

GPCL2/VBLK2

AVID2
HSYNC2
VSYNC2/PALI2
FID2/GLCO2

SCLK1
SCLKS1

CH1_D0
CH1_D1
CH1_D2
CH1_D3
CH1_D4
CH1_D5
CH1_D6
CH1_D7

CH2_D0
CH2_D1
CH2_D2
CH2_D3
CH2_D4
CH2_D5
CH2_D6
CH2_D7

CH3_D0
CH3_D1
CH3_D2
CH3_D3
CH3_D4
CH3_D5
CH3_D6
CH3_D7

CH4_D0
CH4_D1
CH4_D2
CH4_D3
CH4_D4
CH4_D5
CH4_D6
CH4_D7

GPCL1/VBLK1
AVID1
HSYNC1
VSYNC1/PALI1
FID1/GLCO1

SCLKS3

GPCL3/VBLK3
AVID3
HSYNC3
VSYNC3/PALI3
FID3/GLCO3

SCLKS4
SCLK4
GPCL4/VBLK4
AVID4
HSYNC4
VSYNC4/PALI4
FID4/GLCO4

C100 0.1uF

C101 0.1uF

C102 0.1uF

C103 0.1uF

C104 0.1uF

C105 0.1uF

C177
33pF

R102
100k

Y4
14.31818MHz

C176
33pF

X
2

X
1/

O
SC

1

2
 

3
 

4
 

5

P1
SMA_PCB_MT_MOD

R101
50

R92
0

BNC1
BNC_RA

R108
37.4

CH1_AR10437.4

C179

1uF

C178
1uF

C180
1uF

R
EF

M
1

R
EF

P1

CH2_PLL_VDD

CH3_AVDD

REFM2
REFP2

REFM4
REFP4

REFM3
REFP3

C98 0.1uF

C99 0.1uF

R
EF

P1
R

EF
M

1
X

1/
O

SC
X

2
PD

N
/R

ES
ET

SC
L

SD
A

I2
C

SE
L1

I2
C

SE
L2

DVDD

IOVDD

C182

1uF

C181
1uF

C183
1uF

R
EF

M
2

R
EF

P2

C185

1uF

C184
1uF

C186
1uF

R
EF

M
3

R
EF

P3

C188

1uF

C187
1uF

C189
1uF

R
EF

M
4

R
EF

P4

1
3

2 JP10
I2C ADR

I2CSEL2

R55
10k

IOVDD

R58
10k

CH1_A

CH1_B

CH2_A

CH2_B

CH3_A

CH3_B

CH4_A

CH4_B

1A_IN 1A_OUT

1 2

3 4

JP1

1A_IN 1A_OUT

BNC5
BNC_RA

R116
37.4

CH1_BR11237.4

1B_IN 1B_OUT

1 2

3 4

JP5

1B_IN 1B_OUT

BNC2
BNC_RA

R109
37.4

CH2_AR10537.4

2A_IN 2A_OUT

1 2

3 4

JP2

2A_IN 2A_OUT

BNC6
BNC_RA

R117
37.4

CH2_BR11337.4

2B_IN 2B_OUT

1 2

3 4

JP6

2B_IN 2B_OUT

BNC3
BNC_RA

R110
37.4

CH3_AR10637.4

3A_IN 3A_OUT

1 2

3 4

JP3

3A_IN 3A_OUT

BNC7
BNC_RA

R118
37.4

CH3_BR11437.4

3B_IN 3B_OUT

1 2

3 4

JP7

3B_IN 3B_OUT

BNC4
BNC_RA

R111
37.4

CH4_AR10737.4

4A_IN 4A_OUT

1 2

3 4

JP4

4A_IN 4A_OUT

BNC8
BNC_RA

R119
37.4

CH4_BR11537.4

4B_IN 4B_OUT

1 2

3 4

JP8

4B_IN 4B_OUT

SCLK2
SCLKS2

CH1_D0
CH1_D1
CH1_D2
CH1_D3
CH1_D4
CH1_D5
CH1_D6
CH1_D7

SCLK1
SCLKS1

GPCL1/VBLK1
AVID1
HSYNC1
VSYNC1/PALI1
FID1/GLCO1

CH2_D0
CH2_D1
CH2_D2
CH2_D3
CH2_D4
CH2_D5
CH2_D6
CH2_D7

GPCL2/VBLK2
AVID2
HSYNC2
VSYNC2/PALI2
FID2/GLCO2

SCLK2
SCLKS2

CH3_D0
CH3_D1
CH3_D2
CH3_D3
CH3_D4
CH3_D5
CH3_D6
CH3_D7

SCLK3
SCLKS3

GPCL3/VBLK3
AVID3
HSYNC3
VSYNC3/PALI3
FID3/GLCO3

SCLKS4
SCLK4
GPCL4/VBLK4
AVID4
HSYNC4
VSYNC4/PALI4
FID4/GLCO4

CH4_D0
CH4_D1
CH4_D2
CH4_D3
CH4_D4
CH4_D5
CH4_D6
CH4_D7

RN18
RPACK8-33

RN17

RPACK8-33

RN19
RPACK8-33

RN20

RPACK8-33

RN22
RPACK8-33

RN21

RPACK8-33

CH1_OUT0
CH1_OUT1
CH1_OUT2
CH1_OUT3
CH1_OUT4
CH1_OUT5
CH1_OUT6
CH1_OUT7

CH2_OUT0
CH2_OUT1
CH2_OUT2
CH2_OUT3
CH2_OUT4
CH2_OUT5
CH2_OUT6
CH2_OUT7

CH3_OUT0
CH3_OUT1
CH3_OUT2
CH3_OUT3
CH3_OUT4
CH3_OUT5
CH3_OUT6
CH3_OUT7

CH4_OUT0
CH4_OUT1
CH4_OUT2
CH4_OUT3
CH4_OUT4
CH4_OUT5
CH4_OUT6
CH4_OUT7

HS1
VS1
FID1

AV1
VB1
SCK1
SCKS1

HS2
VS2
FID2

AV2
VB2
SCK2
SCKS2

HS3
VS3
FID3

AV3
VB3
SCK3
SCKS3

HS4
VS4
FID4

AV4
VB4
SCK4
SCKS4

CH1_OUT[7..0]

CH2_OUT[7..0]

CH3_OUT[7..0]

CH4_OUT[7..0]

SCKS1
SCK1
VB1
AV1
HS1
VS1
FID1

SCKS2
SCK2
VB2
AV2
HS2
VS2
FID2

SCKS3
SCK3
VB3
AV3
HS3
VS3
FID3

SCKS4
SCK4
VB4
AV4
HS4
VS4
FID4

/RESET

SCL
SDA SDA

SCL

/RESET

TMS

R120
100

R59
10k

IOVDD

CH2_AVDD

CH4_AVDD

CH1_AVDD

CH3_PLL_VDD

CH4_PLL_VDD CH1_PLL_VDD

AVDD_REF

CH2_PLL_VDD

CH4_AVDDCH2_AVDD AVDD_REFCH1_AVDD

CH3_PLL_VDD CH4_PLL_VDDCH1_PLL_VDD

CH3_AVDD

C79
0.1uF

C81
0.1uF

C83
0.1uF

C85
0.1uF

C86
0.1uF

C80
0.1uF

C82
0.1uF

C84
0.1uF

C87
0.1uF

C90
0.1uF

C92
0.1uF

C94
0.1uF

C91
0.1uF

C93
0.1uF

C95
0.1uF

C97
0.1uF

C96
0.1uF

R93
0

CH1_OUT[7..0]

CH2_OUT[7..0]

CH3_OUT[7..0]

CH4_OUT[7..0]

TM
S

Download from Www.Somanuals.com. All Manuals Search And Download.



1 2 3 4 5 6

A

B

C

D

654321

D

C

B

A

Scale Sheet

Size FCSM No. DWG No. Rev

11 of 17
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TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

ANTI-ALIASING FILTERS

L10 2.2uH

L5 2.2uH

C222
330pF

C224
330pF

C2078.2pF

C212
330pF

C203 8.2pF

C213
330pF

L11 2.2uH

C223
330pF

C225
330pF

C209 8.2pF

L6 2.2uH

L4 2.2uH

C214
330pF

C215
330pF

C204 8.2pF

C210
330pF

C202 8.2pF

C211
330pF

L7 2.2uH

C216
330pF

C217
330pF

C206 8.2pF

L8 2.2uH

C218
330pF

C205 8.2pF

C220
330pF

L9 2.2uH

C219
330pF

C221
330pF

C208 8.2pF

1A_IN 1A_OUT 2A_IN 2A_OUT

3A_IN 3A_OUT 4A_IN 4A_OUT

1B_IN 1B_OUT 2B_IN 2B_OUT

3B_IN 3B_OUT 4B_IN 4B_OUT

NOTE: FILTERS DESIGNED FOR CVBS INPUTS (ADC SAMPLING RATE = 27MHz)
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TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

I2C

11 10

U2E

SN74AHC05DR

R85
2.2k

R86
2.2k

SDA

C106

0.1uF

R87
2.2k

R88
2.2k

R82
2.2k R83

2.2k
R84
2.2k

SCL

R95

0
SDA

R94

0

D3.3V

8

7

6

5

4

3

2
14
1

15

16

17

18

19

20

13

12

11

10

9
21

22

23

24

25

26
27

P2

DB25F_182-25F-ND

DB11

DB9

DB17

DB15

1 2

14
7

U2A

SN74AHC05DR

34

U2B

SN74AHC05DR

56

U2C

SN74AHC05DR

98

U2D

SN74AHC05DR

13 12

U2F

SN74AHC05DR
D3.3V

TP
1

TP24
TP

TP
1

TP23
TP

SCL
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TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

SDRAM

TED[63..0]

TSDCAS#
TSDRAS#
TCE0#

TBE0#

TEA[22..3]

TSDWE#

VDD1

D02

VDDQ3

D14

D25

VSSQ6

D37

D48

VDDQ9

D510

D611

VSSQ12

D713

NC14

VDD15

DQM016

/WE17

/CAS18

/RAS19

/CS20

A1121

BA022

BA123

A10/AP24

A025

A126

A227

DQM228

VDD29

NC30

D1631

VSSQ32

D1733

D1834

VDDQ35

D1936

D2037

VSSQ38

D2139

D2240

VDDQ41

D2342

VDD43 VSS 44D24 45VSSQ 46D25 47D26 48VDDQ 49D27 50D28 51VSSQ 52D29 53D30 54VDDQ 55D31 56NC 57VSS 58DQM3 59A3 60A4 61A5 62A6 63A7 64A8 65A9 66CKE 67CLK 68NC 69NC 70DQM1 71VSS 72NC 73D8 74VDDQ 75D9 76D10 77VSSQ 78D11 79D12 80VDDQ 81D13 82D14 83VSSQ 84D15 85VSS 86
U7

MT48LC4M32B2TG-6

TBE1#TBE0#
TSDWE#
TSDCAS#
TSDRAS#
TCE0#

TECLKOUT1

D3.3V

C107
0.1uF

C109
0.1uF

C111
0.1uF

C113
0.1uF

C115
0.1uF

C117
0.1uF

D3.3V

C119
0.1uF

C121
0.1uF

C123
0.1uF

C125
0.1uF

C127
0.1uF

C129
0.1uF

TEA[22..3]

TED[63..0]

TEA3
TEA4
TEA5

C108
0.1uF

C110
0.1uF

C112
0.1uF

C114
0.1uF

C116
0.1uF

C118
0.1uF

D3.3V

C120
0.1uF

C122
0.1uF

C124
0.1uF

C126
0.1uF

C128
0.1uF

C130
0.1uF

VDD1

D02

VDDQ3

D14

D25

VSSQ6

D37

D48

VDDQ9

D510

D611

VSSQ12

D713

NC14

VDD15

DQM016

/WE17

/CAS18

/RAS19

/CS20

A1121

BA022

BA123

A10/AP24

A025

A126

A227

DQM228

VDD29

NC30

D1631

VSSQ32

D1733

D1834

VDDQ35

D1936

D2037

VSSQ38

D2139

D2240

VDDQ41

D2342

VDD43 VSS 44D24 45VSSQ 46D25 47D26 48VDDQ 49D27 50D28 51VSSQ 52D29 53D30 54VDDQ 55D31 56NC 57VSS 58DQM3 59A3 60A4 61A5 62A6 63A7 64A8 65A9 66CKE 67CLK 68NC 69NC 70DQM1 71VSS 72NC 73D8 74VDDQ 75D9 76D10 77VSSQ 78D11 79D12 80VDDQ 81D13 82D14 83VSSQ 84D15 85VSS 86
U8

MT48LC4M32B2TG-6

TBE5#TBE4#
TSDWE#
TSDCAS#
TSDRAS#
TCE0#

TECLKOUT1

D3.3V

TBE2# TBE3#TBE2#
TBE1#
TBE3#
TBE4#
TBE5#
TBE6#
TBE7#

TSDCKETSDCKE

TSDCKE

TECLKOUT1

TBE7#TBE6#
TBE1#
TBE3#
TBE4#
TBE5#
TBE6#
TBE7#

TSDCKE

TECLKOUT1

TEA6
TEA7
TEA8
TEA9
TEA10
TEA11
TEA12

TEA13

TEA14
TEA15
TEA16

TEA6
TEA7
TEA8
TEA9
TEA10
TEA11
TEA12

TEA3
TEA4
TEA5

TEA13

TEA14
TEA15
TEA16

TED0

TED1
TED2

TED3
TED4

TED5
TED6

TED7

TED32

TED33
TED34

TED35
TED36

TED37
TED38

TED39

TED8

TED9
TED10

TED11
TED12

TED13
TED14

TED15

TED16

TED17
TED18

TED19
TED20

TED21
TED22

TED23 TED24

TED25
TED26

TED27
TED28

TED29
TED30

TED31

TED40

TED41
TED42

TED43
TED44

TED45
TED46

TED47

TED48

TED49
TED50

TED51
TED52

TED53
TED54

TED55 TED56

TED57
TED58

TED59
TED60

TED61
TED62

TED63
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C 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

JTAG

1

2
4

5
3

U10

SN74LVC1G32DCKR

R4
33

R5
33

1

2
4

5
3

U9

SN74LVC1G32DCKR

R121 100 1%

1
3
5
7
9

2
4

8
10

11 12
13 14

H6

HEADER 7x2, Emulation

C132
0.1uF

GND A1

GND A2

GND A3

GND A4

GND A5

GND A6

GND A7

TYPE0 A8

GND A9

GND A10

GND A11

GND A12

GND A13

GND A14

GND A15

GND D1

GND D2

GND D3

GND D4

GND D5

GND D6

GND D7

TYPE1 D8

GND D9

GND D10

GND D11

GND D12

GND D13

GND D14

GND D15

EMU0B14 EMU1C14 EMU2B13 EMU3C13

TCLKB12

EMU4C12 EMU5B11 EMU6C11 EMU7B10 EMU8C10 EMU9B9 EMU10C9

TDOB7

EMU11C7 EMU12B6 EMU13C6 EMU14B5 EMU15C5

TDIB4

EMU16C4 EMU17B3

TRSTnC3 TMSB2

EMU18C2

ID0B1 ID1B15 ID2C1 ID3C15

TVDB8

TCKRTNC8

P3

Samtec SOLC-115-02-S-Q-A

C226

18pF

R38 1k
D3.3V

D3.3V

D3.3V

D3.3V

DSP_TDO

DSP_TDI
DSP_TMS

DSP_TCLK

DSP_TRST#

ROUTE TRACES AS ONE GROUP.  MATCH SIGNAL LENGTH.

LOCATE R-PACK NEAR DSP

XDS_TMS
XDS_TDI

XDS_TDO
XDS_TCKRET
XDS_TCK
XDS_EMU0

XDS_TRST#

XDS_EMU1

XDS_TDO
XDS_TDI
XDS_TMS
XDS_TRST#

XDS_TRST#

XDS_TDI
XDS_TMS

XDS_EMU0
XDS_EMU1

XDS_TCK

XDS_TCK
XDS_TCKRET

XDS_TCKRET

RN24RPACK8-39

RN23RPACK8-39

C131
0.1uF

DSP_EMU1

DSP_EMU4

DSP_EMU0

DSP_EMU6

DSP_EMU9

DSP_EMU5

DSP_EMU11

DSP_EMU3

DSP_EMU8
DSP_EMU7

DSP_EMU10

DSP_EMU2

DSP_EMU[11..0] DSP_EMU[11..0]
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D 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

POWER

R122
330

POWER ON LED (+5V)

F1 FUSE

2
3
1

P4
PJ-002BH

D1
ZENER

5V, 3.0A DC INPUT

SS26

D5V

D5V

A
2

K
1

LED1
GRN_LED

1
2
3

H7

HEADER 3

+ C227
47uF

C228
22uF

CONTROL1

/RESIN2

CT3

GND4 /RESET 5RESET 6SENSE 7VDD 8
U11

TLC7733IPWR 

C1330.1uF

C190
1uF

R103

100k

S1
PB

RESET ON POWER UP

D3.3V

/RESET/RESET

L12

1
2

H8

HEADER 2

1
2

H9

HEADER 2

1
2

H11

HEADER 2

1
2

H12

HEADER 2

1
2

H17

HEADER 2 C251
22uF

FB12

FERRITE

C253
22uF

C200

1uF

C164

0.1uF

C162

0.1uF

1
2

H18

HEADER 2 C252
22uF

FB13

FERRITE

C254
22uF

C201

1uF

C165

0.1uF

C163

0.1uF

12

J1
JUMPER

12

J10
JUMPER

12

J11
JUMPER

1

2J5

JUMPER

1

2J4

JUMPER

1

2J2

JUMPER

D5V

D3.3V

TP
1

TP27
TP

TP
1

TP26
TP

TP
1

TP28
TP

3.3V_SUPPLY

1.8V_SUPPLY

1.8V_SUPPLY

DVDD

IOVDD

CH2_PLL_VDD

CH4_AVDD

CH2_AVDD

AVDD_REF

CH1_AVDD

CH3_PLL_VDD

CH4_PLL_VDD

CH1_PLL_VDD

CH3_AVDD

3.3V_SUPPLY

1.8V_SUPPLY

C233
22uF

FB2

FERRITE

C235
22uF

C191

1uF

C138

0.1uF

C134

0.1uF

C234
22uF

FB3

FERRITE

C236
22uF

C192

1uF

C139

0.1uF

C135

0.1uF

C239
22uF

FB5

FERRITE

C242
22uF

C194

1uF

C150

0.1uF

C147

0.1uF

C240
22uF

FB6

FERRITE

C243
22uF

C195

1uF

C151

0.1uF

C148

0.1uF

1
2

H13

HEADER 2

1

2J6

JUMPER

C241
22uF

FB7

FERRITE

C244
22uF

C196

1uF

C152

0.1uF

C149

0.1uF

1
2

H10

HEADER 2

1
2

H14

HEADER 2

1
2

H15

HEADER 2

1
2

H16

HEADER 2

12

J3
JUMPER

1

2J9

JUMPER

1

2J8

JUMPER

1

2J7

JUMPER

1.8V_SUPPLY

C237
22uF

FB4

FERRITE

C238
22uF

C193

1uF

C143

0.1uF

C140

0.1uF

C245
22uF

FB8

FERRITE

C248
22uF

C197

1uF

C156

0.1uF

C153

0.1uF

C246
22uF

FB9

FERRITE

C249
22uF

C198

1uF

C157

0.1uF

C154

0.1uF

C247
22uF

FB10

FERRITE

C250
22uF

C199

1uF

C158

0.1uF

C155

0.1uF

C268
1000pF

AGND 1

VSENSE 2

COMP 3

PWRGD 4

BOOT 5

PH1 6

PH2 7

PH3 8

PH4 9

PH5 10PGND111 PGND212 PGND313

VIN114 VIN215 VIN316

VBIAS17 SS/ENA18 SYNC19 RT20 POWERPAD21
U13

TPS54310PWP

C159
0.1uF

L18 2.7uH
C262

0.047uF

C273
560pF

AGND 1

VSENSE 2

COMP 3

PWRGD 4

BOOT 5

PH1 6

PH2 7

PH3 8

PH4 9

PH5 10PGND111 PGND212 PGND313

VIN114 VIN215 VIN316

VBIAS17 SS/ENA18 SYNC19 RT20 POWERPAD21
U14

TPS54310PWP

+
C258

10uF LESR

C146
0.1uF

C144
0.1uF

C265
100uF

R128
17.4k 1%

C269
1000pF

C274
0.01uF

L16

BLM41P750SPT
+

C259

10uF LESR

C161

0.1uF

C272

NO POP

C261

0.047uF
L17 2.7uH

D13

MURS120T3

R135
1.65k 1%

C267
3300pF

R133
107 1%

R131
10k 1%

R129
3.74k 1%

C263
8200pF

R127
2k 1%

C260
470pF

C266
3300pF

R132
107 1%

R13010k 1%

C145

0.1uF

R126

71.5k 1%

C160

0.1uF

R134
71.5k 1%

R60
10k

C264
100uF

C256

0.039uF

C257

0.039uF

+
C271

100 uF

+ C270
100 uF

D15

MURS120T3

D14

MURS120T3

L15

BLM41P750SPT

D17

MURS120T3

D16

MURS120T3

DSP_CVDD

D3.3V

D3.3V

3.3 sq in AGND, min thermal pad
Connect at pin 1

Sets Voltage

3.3V @1.5Amp Max

1.4V @1.5Amp Max

POWER ESTIMATES BASED ON SPRU190
1.4V@600MHz
3.3V@600MHz

1.09 W
0.52 W

0.778A
0.157A ( no emif clk)

MEASURED CURRENT ON C6416TEB, ~0.7A@5V

EACH REGULATOR CAN SUPPLY UP TO 3A OF�CURRENT.  HOWEVER COMPONENT VALUES HAVE�BEEN SELECTED FOR 1.5A OPERATION.

VALUES CALCULATED WITH SWIFT DESIGN TOOL 2.0.

EMI SUPPRESION.  LOCATE NEAR EACH REGULATOR.

FOLLOW TPS54310 EVM LAYOUT

1.4V -> 17.4K 1%
1.2V -> 28.0K 1%
1.1V -> 42.2K 1%

OPTIONAL CROSS COUPLE

D5V

DSP_CVDD

3.3 sq in AGND, min thermal pad
Connect at pin 1

FB14

FERRITE

FB16

FERRITE

FB18

FERRITE

FB15

FERRITE

FB17

FERRITE

FB19

FERRITE

FB11

FERRITE

FB1

FERRITE

C231
22uFR124249k

R125249k

R123
249k

VOUT1 IS 3.3V 1A
VOUT2 IS 1.8V 2A

C232
22uF

C142
0.1uF

C141
0.1uF

L13

L14

GND1

VIN1A2

VIN1B3

/MR5

/EN16

/EN27

/RESET8

GND9

VIN2A10

VIN2B11

GND12 VOUT2B 14VOUT2A 15VSENSE2/FB2 16

PG2 18PG1 19

VSENSE1/FB1 21VOUT1B 22VOUT1A 23

PP
25

GND 24

NC4

GND 13

NC 17

NC 20

U12

TPS70451PWP
C137
0.1uF

C230
22uF

C136
0.1uF

C229
22uF

D5V

R28
NO POP

R97
0

R27
NO POP

R96

0

+ C255
47uF

TP
1

TP25
TP

TP
1

TP29
TP

TP
1

TP30
TP

TP
1

TP31
TP

TP
1

TP32
TP

TP
1

TP33
TP

TP
1

TP34
TP

TP
1

TP35
TP

TP
1

TP36
TP

TP
1

TP37
TP

TP
1

TP38
TP

TP
1

TP39
TP

TP
1

TP40
TP

6 VIAS FROM PAD TO PLANE OR DIRECT TIE.

Download from Www.Somanuals.com. All Manuals Search And Download.



1 2 3 4 5 6

A

B

C

D

654321

D

C

B

A

Scale Sheet

Size FCSM No. DWG No. Rev

16 of 17

C 1

TEXAS INSTRUMENTS, INC.
12500 TI BLVD
DALLAS, TEXAS 75243

CONNECTOR

FFOE/DIG_V1 FFRE/DIG_H2 FFRSTWIN/~SCLK3 FFWE/DVALID4 FFIE/CCVALID5 VGAV/SYNC_T6 FSY/HC/HSYA/~BLNK7 FFRSTW/CBFLAG8 FPDAT/VSYA/M29 CLK5/M110 GND11 PHI_D012 PHI_D113 PHI_D214 PHI_D315 PHI_D416 PHI_D517 PHI_D618 PHI_D719 PHI_A020 PHI_A121 PHI_CS22 PHI_DS/RD23 SDA/PHI_RWW24 SCL/PHI_ACK25 GND26 GND27 GND28 5V29 5V30

D_VS31 D_HS32 D_PREF33 D_RDY34 D_SCLK35 VACTIVE36 SOGOUT37 ITRDY38 GND39 GPCL40 INTREQ41 GPIO042 GPIO143 GPIO244 GPIO345 GND46 GPIO447 GPIO548 GPIO649 GPIO750 GND51 AMCLK52 ASCLK53 ALRCLK54 AMXCLK55 GND56 GND57 GND58 5V59 5V60

D976 GND77 RCr078 RCr179 RCr280 RCr381 RCr482 RCr583 RCr684 RCr785 RCr886 RCr987 GND88 GND89 5V90

SCLK91 PCLK92 VSYNC93 GLCO94 FID95 GND96 GY097 GY198 GY299 GY3100 GY4101 GY5102 GY6103 GY7104 GY8105 GY9106 GND107 BCb0108 BCb1109 BCb2110 BCb3111 BCb4112 BCb5113 BCb6114 BCb7115 BCb8116 BCb9117 GND118 GND119 5V120

PREF61 AVID62 HSYNC63 PALI64 RESET65 GND66 D067 D168 D269 D370 D471 D572 D673 D774 D875

P5

SAMTEC_TMMS_120PIN_M_RA

SDA
SCL

D5VD5V D5V D5V

ENC_HS ENC_VS

ENC_FID

ENC_SCLK

/RESET

ENC_Y[7..0] ENC_Y[7..0]

ENC_C[7..0] ENC_C[7..0]

ENC_Y0
ENC_Y1
ENC_Y2
ENC_Y3
ENC_Y4
ENC_Y5
ENC_Y6
ENC_Y7

ENC_C0
ENC_C1
ENC_C2
ENC_C3
ENC_C4
ENC_C5
ENC_C6
ENC_C7

R99 0
R100 0

R98 0
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications,
enhancements, improvements, and other changes to its products and services at any time and to discontinue
any product or service without notice. Customers should obtain the latest relevant information before placing
orders and should verify that such information is current and complete. All products are sold subject to TI’s terms
and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in
accordance with TI’s standard warranty. Testing and other quality control techniques are used to the extent TI
deems necessary to support this warranty. Except where mandated by government requirements, testing of all
parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for
their products and applications using TI components. To minimize the risks associated with customer products
and applications, customers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right,
copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process
in which TI products or services are used. Information published by TI regarding third-party products or services
does not constitute a license from TI to use such products or services or a warranty or endorsement thereof.
Use of such information may require a license from a third party under the patents or other intellectual property
of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of information in TI data books or data sheets is permissible only if reproduction is without
alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction
of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for
such altered documentation.

Resale of TI products or services with statements different from or beyond the parameters  stated by TI for that
product or service voids all express and any implied warranties for the associated TI product or service and
is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Following are URLs where you can obtain information on other Texas Instruments products and application
solutions:

Products Applications

Amplifiers amplifier.ti.com Audio www.ti.com/audio

Data Converters dataconverter.ti.com Automotive www.ti.com/automotive

DSP dsp.ti.com Broadband www.ti.com/broadband

Interface interface.ti.com Digital Control www.ti.com/digitalcontrol

Logic logic.ti.com Military www.ti.com/military

Power Mgmt power.ti.com Optical Networking www.ti.com/opticalnetwork

Microcontrollers microcontroller.ti.com Security www.ti.com/security

Low Power Wireless www.ti.com/lpw Telephony www.ti.com/telephony

Video & Imaging www.ti.com/video

Wireless www.ti.com/wireless

Mailing Address: Texas Instruments

Post Office Box 655303 Dallas, Texas 75265

Copyright  2006, Texas Instruments Incorporated
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