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TVP5158 Evaluation Module

1 Description

The TVP5158EVM evaluation module is a printed circuit board designed for evaluation of the TVP5158
Four-Channel PAL/NTSC Video Decoder. The TMS320DM6467 DVEVM (digital video evaluation module)
can be used with the TVP5158EVM as a back-end video processor. This user guide outlines the
necessary hardware and software setup required to provide full evaluation of the TVP5158.

1.1 Functional Overview

TVP5158EVM is powered by a single 5-V universal supply. The TVP5158EVM allows the user to have up
to four composite video inputs and up to four audio inputs. Analog YPbPr component video output is
supported for non-interleaved video modes. Digital video is output to the DaVinci HD EVM in a single or
dual ITU-R BT.656 configuration or in ITU-R BT.601 (16-Bit) configuration for evaluation of line-interleaved
modes.

The TVP5158EVM uses one PC USB port to provide I2C communication with the TVP5158, THS8200
Video/Graphics Triple DAC and the TLV320DAC32 Stereo Audio DAC devices on the TVP5158EVM. The
Video Control Center (VCC) application software is provided for control and evaluation of the
TVP5158EVM. A VT100 terminal program is required to connect to the DaVinci HD EVM via UART to
send Linux shell commands to control the DSP.

1.2 Notational Conventions

This document uses the following conventions.

The TMS320DM6467 Digital Video Evaluation Module is usually referred to as the DaVinci HD EVM.

The TMS320DM6467 Digital Media System-on-Chip is usually referred to as the DM6467.
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2 Board Level Description

Figure 1 shows the various features available on the TVP5158EVM.

Figure 1. TVP5158 EVM Block Diagram

2.1 Analog Video/Audio Inputs

The TVP5158EVM makes use of all the available inputs on the TVP5158 decoder, including four CVBS
video inputs and four analog audio inputs. Connector J1 has four analog video (CVBS) inputs (yellow RCA
jacks) and four analog audio inputs (white RCA jacks).

2.2 Analog Video/Audio Outputs

The TVP5158EVM has a THS8200 Video/PC Graphics Triple DAC and a TLV320DAC32 audio DAC on
the board so that the user can evaluate video and audio performance using a single EVM setup. The
THS8200 Video/Graphics Triple DAC takes the video output from DVO port A of TVP5158 and outputs
analog YPbPr video signals to component output connector J4. The TLV320DAC32 Stereo Audio DAC
takes digital audio output from TVP5158 and outputs analog audio to the head phone jack J5.
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2.3 Digital Video/Audio Outputs to DaVinci HD EVM

The TVP5158EVM has two dedicated connectors which match the digital video/audio input connectors on
the DaVinci HD EVM. Connector J9 includes a 16-bit video data bus (buffered data from DVO_A and
DVO_B of TVP5158), OCLK_P, OCLK_N, I2C and interrupts. The connector J10 includes BCLK, LRCLK
and SD_R/SD_M outputs from TVP5158. Samtec HQCD cables are required to connect TVP5158EVM
digital video and audio signals to the DaVinci HD EVM.

2.4 Digital Video/Audio Cascade Output/Input

The TVP5158EVM has two connectors for video/audio cascade mode test. The connector J2 is for
video/audio cascade output, which includes buffered data from the DVO_A and DVO_B video output ports
and audio cascade output from TVP5158. The connector J3 is for video/audio cascade input, which
includes video input data to the DVO_C and DVO_D video ports and audio cascade input from a lower
cascaded stage TVP5158 device.

2.5 I2C Configuration Options

The TVP5158EVM uses one PC USB port for I2C communication. The I2C bus master can be changed
based on jumper settings. Control is via the PCB USB interface (VCC application controls TVP5158), via
the DaVinci EVM (DSP driver software controls TVP5158) or via the cascade input/output connectors J3
or J2.

2.6 Test Points and Jumpers

Various test points are available on the TVP5158EVM for the user. This includes the various power
supplies as well as a few GND test points. The user can also use J2/J3 for primary test-point headers to
access video/audio data, video/audio clocks, I2C and GND.

There are several jumpers available on the TVP5158EVM that configure I2C address select, I2C control
configuration, clock source selection and I2S source select. Each jumper is set by default in its preferred
state for the TVP5158EVM. Next to each jumper on the TVP5158EVM is the silkscreen that describes the
various jumper configurations. If the I2C address is changed on the TVP5158EVM while the
TVP5158EVM is powered up, then that device will not recognize the new I2C address. The reset button
on the TVP5158EVM must be pressed and the VCC application must be exited, restarted, and
re-configured for the new I2C address. Table 1 shows the TVP5158EVM jumper settings.

Table 1. TVP5158EVM Jumper Descriptions

Jumper Description of Function DefaultDesignator

TVP5158 I2C address selection (I2C_A0)
W0 1-21-2: Low

2-3: High

TVP5158 I2C address selection (I2C_A1)
W1 1-21-2: Low

2-3: High

TVP5158 I2C address selection (I2C_A2)
W2 1-21-2: Low

2-3: High

I2C SDA source selection

1-2: USB controls I2CW3 1-2
2-3: DaVinciHD controls I2C
OFF: Control by another EVM for cascade mode.

I2C SCL source selection

1-2: USB controls I2CW4 1-2
2-3: DaVinciHD controls I2C
OFF: Control by another EVM for cascade mode.

8 TVP5158 Evaluation Module SLEU108–November 2009
Submit Documentation Feedback

Copyright © 2009, Texas Instruments IncorporatedDownload from Www.Somanuals.com. All Manuals Search And Download.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLEU108


www.ti.com System Level Description

Table 1. TVP5158EVM Jumper Descriptions (continued)

Jumper Description of Function DefaultDesignator

Clock source selection
W5 1-21-2: Crystal

2-3: Clock from another EVM for cascade mode

I2C EEPROM
W6 ON

ON: Use EEPROM (MUST ALWAYS BE ON)

W7 I2C SCL connection for audio DAC ON

W8 I2C SDA connection for audio DAC ON

I2S input selection for audio DAC
W9 2-31-2: TVP5158 mixing output to audio DAC (SD_M)

2-3: TVP5158 record output to audio DAC (SD_R)

3 System Level Description

The system block diagram illustrated in Figure 2 provides an example of how the TVP5158EVM may be
used for evaluation. Typically, the analog video/audio input is provided by a video source such as a
pattern generator or a DVD player running a test DVD. The TVP5158EVM is configured with the 5-V
supply and the USB cable provided.

The TVP5158EVM analog video output is standard definition component video (YPbPr). These outputs
are then fed into a high-end or studio-quality NTSC/PAL monitor.

The user can also connect the TVP5158EVM to a DaVinci HD EVM and then output combined video from
the DaVinci HD EVM to a 1080i HD monitor.

Figure 2. TVP5158EVM System Level Block Diagram
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4 Required Hardware and Equipment

The required hardware and equipment are as follows:

• Windows-based PC with Windows XP or later
• Video sources (security camera, pattern generator, DVD player, etc.)
• Display monitor that supports

– 1080i component YPbPr video (50 and 60 Hz)
– 480i and 576i component YPbPr video

• Audio amplifier/speakers or headphones
• TVP5158EVM (provided)

– Cables to provide up to four composite video and up to four audio line inputs
– Component Video (YPbPr) cable for output
– USB cable (provided)
– Universal 5-V power supply (100 to 240 VAC in, 5 VDC/3.0 A out) (provided)

• DaVinci HD EVM

– Two Samtec HQCD cables
– Component video (YPbPr) cable for output
– RS-232 null MODEM cable
– Universal 5-V power supply (100 to 250 VAC in, 5 VDC/5.0 A out)

5 Hardware Setup

The following sections describe the hardware setup for evaluation of the TVP5158.

5.1 Setup for TVP5158EVM Stand-Alone Configuration

For evaluation of video quality, comb filter, noise reduction, auto-contrast and other features, the
TVP5158EVM can be setup in a stand-alone configuration. Analog video and audio sources are input to
TVP5158. TVP5158 outputs digital video as ITU-R BT.656 or ITU-R BT.601 non-interleaved video to the
THS8200 PC Graphics/Video Triple DAC. Component Video YPbPr from the THS8200 is output in 480i or
576i format to a video monitor. To setup the stand-alone configuration, make the following connections:

1. Analog video sources to TVP5158EVM composite video inputs (see Figure 3)
2. Analog audio sources to TVP5158EVM audio line inputs (see Figure 3)
3. Analog component YPbPr video out from TVP5158EVM to video monitor
4. Stereo audio headphone output from TVP5158EVM to audio amplifier/speakers or headphones
5. USB cable from PC to TVP5158EVM. A green LED should be lit indicating that the EVM is ready for

communication on the USB.
6. 5-V power supply to the dc jack on the TVP5158EVM
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Figure 3. Location of TVP5158EVM Video/Audio Inputs

Table 2. Jumper Settings for Stand-Alone Configuration

Jumper Function Setting CommentDesignator

TVP5158 I2C addressW2, W1, W0 1-2, 1-2, 1-2 Slave address 0xB0 (1011 LLL0)selection

W3, W4 I2C master selection 1-2, 1-2 PC USB port controls TVP5158 I2C

W7, W8 I2C connection to audio DAC ON, ON Connected

W9 I2S selection to audio DAC 2-3 or 1-2 Monitor record I2S output or mixer I2S output from TVP5158

5.2 Setup for TVP5158EVM with DaVinci HD EVM

The TMS320DM6467 DVEVM (digital video evaluation module) can be used as the audio/video back-end
processor for evaluation of TVP5158. This EVM is available separately from Texas Instruments and is
referred to as the DaVinci HD EVM in this document.

This configuration allows evaluation of all line-interleaved video output formats with up to four channels in
D1, Half-D1 or CIF resolution. Eight-channel line-interleaved video is also possible if two TVP5158EVM
boards are cascaded together.

Sample video and audio driver code and a demo application are provided to run on the TMS320DM6467
on the Linux O/S.

To setup the TVP5158EVM with DaVinci HD EVM configuration, make the following connections:

1. Analog video sources to TVP5158EVM composite video inputs (see Figure 3)
2. Analog audio sources to TVP5158EVM audio line inputs (see Figure 3)
3. Analog component YPbPr video out from DaVinci HD EVM to monitor
4. USB cable from PC to TVP5158EVM. A green LED should be lit indicating that the EVM is ready for

communication on the USB.

NOTE: If the VCC GUI Software for TVP5158 is not used, it is not necessary to connect the
TVP5158EVM to a PC USB port.

5. RS-232 null MODEM cable from PC to DaVinci HD EVM
6. 5-V power supply to the dc jack on the TVP5158EVM
7. 5-V power supply to the dc jack on the DaVinci HD EVM
8. Ethernet cable from LAN to DaVinci HD EVM
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5.2.1 Additional Setup when DSP Processes Video Only

In this configuration, digital video goes to the DaVinci HD EVM. Digital I2S audio goes to the
TLV320DAC32 Audio DAC on the TVP5158EVM. Stereo audio output can then be taken from the
TVP5158EVM headphone jack. Make the following additional connections:

1. Samtec HQCD ribbon cable from TVP5158EVM DaVinci Video connector to the DaVinci HD EVM
DC_P2 Video Expansion connector.

2. TVP5158EVM headphone jack to audio amplifier/speakers or headphones

5.2.2 Additional Setup When DSP Processes Video and Audio

CAUTION

A modification to both the TVP5158EVM and the DaVinci HD EVM must be
made if I2S digital audio is to be processed by the DM6467 DSP (see
Section 5.2.2.1).

In this configuration, digital video and digital audio go to the DaVinci HD EVM. For the digital audio
connection, a hardware modification is required as described in Section 5.2.2.1. The stereo audio is then
output from the DaVinci HD EVM headphone jack. After making the hardware modification, make the
following additional connections:

1. Samtec HQCD ribbon cable from TVP5158EVM DaVinci Video connector to the DaVinci HD EVM
DC_P2 Video Expansion connector

2. Samtec HQCD ribbon cable from TVP5158EVM DaVinci Audio connector to DaVinci HD EVM DC_P3
I/O Expansion connector

3. DaVinci HD EVM headphone jack to audio amplifier/speakers or headphones

5.2.2.1 Hardware Modification for I2S Audio to DM6467 DSP

Three 0-Ω resistors must be removed from the TVP5158EVM and three 0-Ω resistors must be removed
from the DaVinci HD EVM according to Table 3.

Table 3. Hardware Modifcation for I2S Audio to DM6467

Remove From TVP5158EVM Remove From DaVinci HD EVM

R42 SD_M R13 MCASP0_ACLKR

R98 MCASP0_EN R17 MCASP0_AFSR

R99 AUDIO_CLK_EN R31 MCASP0_AXR1

NOTE: After this modification has been made, the SD_M I2S digital audio output from TVP5158 will
no longer be available. The SD_R output must be used and W9 must be jumpered 2-3. If
headphone output from the TVP5158EVM is to be tested using the audio mixer (SD_M I2S
output), 0-ohm resistor R42 must be reinstalled and W9 must be jumpered 1-2.

5.2.3 Jumper Settings with DaVinci HD EVM

When the DaVinci HD EVM is used, the video and/or audio driver software can be set to control the entire
system, or can be set to skip I2C programming of the TVP5158. In the latter case, the PC USB interface
and the Video Control Center application software are used to initialize and experiment with TVP5158
register settings through a graphical user interface.
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5.2.3.1 DaVinci HD EVM as TVP5158 I2C Master

Table 4 describes the jumper settings to set the DaVinci HD EVM as I2C master for the TVP5158. In this
case, the Linux application and driver software control the entire system. Audio can be output from the
TVP5158EVM or from the DaVinci HD EVM. See Section 5.2.1 and Section 5.2.2 for audio configurations.

Table 4. Jumper Settings for DaVinci HD EVM as TVP5158 I2C Master

Jumper Function Setting CommentDesignator

TVP5158 I2C AddressW2, W1, W0 1-2, 1-2, 1-2 Slave address 0xB0 (1011 LLL0)selection

W3, W4 I2C master selection 2-3, 2-3 DaVinci HD EVM controls TVP5158 I2C

W7, W8 I2C connection to audio DAC ON, ON Connected

W9 I2S selection to audio DAC 2-3 or 1-2 Monitor record I2S output or mixer I2S output from TVP5158

5.2.3.2 PC USB as TVP5158 I2C Master with DaVinci HD EVM

Table 5 describes the jumper settings to set the PC USB interface as I2C master for the TVP5158. In this
case, the Video Control Center application software can be used to experiment with TVP5158 register
settings through a graphical user interface.

NOTE: This system configuration has known I2C issues that sometimes occur when PC USB and
DaVinci HD EVM I2C buses are used independently.

Table 5. Jumper Settings for PC USB Interface as TVP5158 I2C Master

Jumper Function Setting CommentDesignator

TVP5158 I2C addressW2, W1, W0 1-2, 1-2, 1-2 Slave address 0xB0 (1011 LLL0)selection

W3, W4 I2C master selection 1-2, 1-2 PC USB port controls TVP5158 I2C

W7, W8 I2C connection to audio DAC ON, ON Connected

W9 I2S selection to audio DAC 2-3 or 1-2 Monitor record I2S output or mixer I2S output from TVP5158

5.2.3.3 Jumper Settings for Audio/Video Cascade Configuration

CAUTION

If two or more TVP5158EVM boards are cascaded together, care must be
taken that the leads on the J2 and J3 connectors are in alignment, because the
connectors are not keyed.

Table 6 describes the jumper settings for a second stage TVP5158EVM connected for video/audio
cascade operation. In this case, the I2C slave address must be set be set differently than the first EVM.
The I2C Master jumpers must be removed to allow the first stage EVM to control I2C (either from USB or
from DaVinci HD EVM). USB should be connected to the first stage EVM if used. The Audio DAC I2C
must be disconnected on the second stage, since they are both at the same I2C slave address.
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Table 6. Jumper Settings for a Cascaded TVP5158EVM

Jumper Function Setting CommentDesignator

W2, W1, W0 TVP5158 I2C address selection 1-2, 1-2, 2-3 Slave address 0xB2 (1011 LLH0)

W3, W4 I2C master selection OFF, OFF Stage 1 TVP5158EVM controls TVP5158 I2C

W7, W8 I2C connection to audio DAC OFF, OFF Disconnected

W9 I2S selection to audio DAC 2-3 Not used

6 Software Installation

If the TVP5158EVM Software has previously been installed on the PC, it is necessary to uninstall the
previous version. To uninstall:

1. Click Start > Control Panel > Add or Remove Programs.
2. Wait for the list to populate.
3. Scroll down and click on "TVP5158EVM Software" to highlight it.
4. Click the remove button.
5. When prompted with Are you sure you want to remove TVP5158EVM Software from your computer?,

click Yes.

The TVP5158EVM software installation program is contained in a ZIP archive file containing the following
two files:

Setup.exe
TVP5158EVM_Software.msi

Unzip these two files to a temporary directory and run setup.exe. The dialog box in Figure 4 appears.
Click Next on the dialog boxes shown in Figure 4, Figure 5, and Figure 6. When the installation is finished,
the dialog box shown in Figure 7 appears. Click Close to complete the installation.

Documentation and a shortcut to the VCC application can now be found in the Windows start menu at:
Start > All Programs > TVP5158EVM > TVP5158EVM Software
Start > All Programs > TVP5158EVM > TVP5158EVM User Guide

Figure 4. TVP5158EVM Software Setup Wizard
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Figure 5. Select Installation Folder

Figure 6. Confirm Installation
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Figure 7. Installation Complete
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7 TVP5158EVM Evaluation Procedures

7.1 Stand-Alone Operation - Non-Interleaved Digital Video Output Modes

The following is the procedure for evaluation of TVP5158 for non-interleaved modes. The digital video
output from TVP5158 is converted to analog component YPbPr video using a THS8200 Video/PC
Graphics Triple DAC:

1. Double-click the TVP5158EVM Software icon on the Windows desktop to start the VCC application.
2. The VCC Configuration dialog box appears (see Figure 8). Click OK to continue.
3. The Cascaded Devices dialog box appears (see Figure 9). Click OK to continue. If a message appears

indicating that the USB device was not found (see Figure 10), disconnect the USB cable, wait three
seconds and reconnect the USB cable.

4. After 3 to 5 seconds, the Real-Time Polling dialog box appears (see Figure 11). Click OK to continue.
5. The VCC main window appears (see Figure 12).
6. Set video source(s) to the NTSC video standard (for this example).
7. Click the Tools > System Initialization menu item. The System Initialization dialog box (see Figure 13)

appears. Click once on the following table entry:
TVP5158 + THS8200, NTSC, Non-Interleaved, 1-Ch D1, Quad BT.656 @ 27 MHz
Click the PROGRAM button. The TVP5158 is now programmed for the NTSC standard using the
above video output format. The output formatter is bypassed.

8. To select a video input:

(a) In the VCC main window, select the video decoder for the video input to be displayed. This will
select which source is used to detect the video standard for updating THS8200 register settings.

(b) In System Initialization table, click once on one of the following table entries to the select the video
channel to be displayed and click the Program button.
Select Ch-1 Video Input
Select Ch-2 Video Input
Select Ch-3 Video Input
Select Ch-4 Video Input

9. Video from the selected video input should now be seen on the monitor and audio channels 1 and 2
should be heard from the left and right speakers respectively.

Figure 8. VCC Configuration
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Figure 9. Specifying Cascaded Devices

Figure 10. USB Device Not Found Error Message

Figure 11. Real-Time Polling Enable
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Figure 12. VCC Main Window - Set for Communication to All Decoders

Figure 13. System Initialization for Analog Component YPbPr Video Output

7.2 Evaluation Using the DaVinci HD EVM

7.2.1 Setting DM6467 ARM and DDR2 Memory Clock Rates

For maximum performance, in a system using DM6467 and TVP5158(s) in the line-interleaved video
modes, the DM6467 clock frequencies should be set as specified in Table 7.

Table 7. Recommended DM6467 Clock Frequencies

ARM Clock 675 MHz

DDR2 Memory Clock 324 MHz (1)

(1) DaVinci HD EVM assembly revision F or later is required.
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Since the DaVinci HD EVM is not packaged with the TVP5158, it is usually necessary to program its
NAND flash memory to the recommended clock frequencies, as described by the following procedure:

1. Unzip the UBL_DM646x_NAND_675_324.zip archive file onto the PC’s local hard drive.
Suggested location is C:\UBL

2. Connect a null MODEM 9-pin serial cable from the DaVinci HD EVM UART connector to the PC COM1
serial port.

3. Close any open program that is using the COM1 serial port.
4. Turn OFF the DaVinci HD EVM power switch.
5. Set SW3 Boot Mode Configuration positions 1-3 to OFF and position 4 to ON to select UART0 Flash

Boot. SW3 is located beneath the Samtec HQCD digital video ribbon cable. In the OFF position, the
switch is moved toward the PCI connector.

6. In the Windows Start menu, click Run, type cmd, and click OK to open a command window.
7. Execute these commands in the command window:

cd \ubl
sfh_DM646x.exe -nandflash UBL_DM646x_NAND_675_324.bin u-boot.bin

8. After the Waiting for the DM646x... message appears in the terminal window, turn ON the DaVinci HD
EVM power switch.

9. After flash programming has completed, turn OFF the DaVinci HD EVM power switch. Set the SW3
Boot Mode Configuration positions 1-3 to ON and position 4 to OFF to select NAND Flash boot mode.

7.2.2 Evaluation Procedure for Line-Interleaved Video Output Modes

The following are the instructions for evaluation of TVP5158 for line-interleaved modes. The digital video
output from TVP5158 is captured using a DM6467 DaVinci HD EVM and is demultiplexed and displayed
on a 1080i HD monitor.

7.2.2.1 DaVinci HD EVM Boot
1. Start the VT100 terminal application of your choice. For example, HyperTerminal can be started in

Windows XP using these steps:

(a) Click Start > All Programs > Accessories > Communications > HyperTerminal.
Set "Connect using" to:

COM1 (or other available serial port)
Set "Port Settings" to:

Bits per second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None

2. Turn ON the DaVinci HD EVM power switch. It may be necessary to halt the boot process (by striking
a key at the terminal) to modify boot parameters (especially the first time). For details of the boot
methods see separate documentation that is provided with the DaVinci HD EVM: TMS320DM6467
DVEVM Getting Started Guide (SPRUF88).

NOTE: See the mcvip_tvp5158\README.TXT file for instructions on running or building target
image and application. This is found in the zip file containing the DaVinci HD video/audio
driver source code.
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7.2.2.2 Setup DaVinci HD Video / Audio Drivers

Once the DaVinci HD EVM boot has completed, the login: prompt appears at the terminal. Copy and paste
the Linux commands below to set up the video capture and and audio driver software. In place of
<program_directory>, insert the directory path where the driver files are stored.
root
cd <program_directory>
insmod cmemk.ko phys_start=0x87800000 phys_end=0x8ba00000 pools=1x1000
./mapdmaq-hd
insmod drv.ko
mknod /dev/dev_i2c c 251 0
mknod /dev/dev_dma c 250 0

7.2.2.3 Start VCC Application (Optional – Provides GUI Interface for TVP5158)
1. Double-click the TVP5158EVM Software icon on the Windows desktop to start the VCC application.
2. The VCC Configuration dialog box appears (see Figure 8). Set THS8200 device family to NOT USED.

Click OK to continue.
3. The Cascaded Devices dialog box appears (see Figure 9). Click OK to continue. If a message appears

indicating that the USB device was not found (see Figure 10), disconnect the USB cable, wait three
seconds, and reconnect the USB cable.

NOTE: If a second TVP5158EVM is used for cascade operation select "2 Devices Cascaded" and
I2C slave addresses 0xB0 and 0xB2.

4. The VCC main window appears (see Figure 12).
5. Click the Tools > System Initialization menu item. The System Initialization dialog box appears (see

Figure 13).
6. Click the Browse… button. The Open dialog box appears (see Figure 14). Double-click the file

TVP5158EVM_DaVinci_HD_Setup.CMD

Figure 14. Browse to Command File

The dataset descriptions table should now appear (see Figure 15).
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Figure 15. System Initialization for Line-Interleaved Modes
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7.2.2.4 mcvip_test Demo Application

The syntax and main menu of the mcvip_test (multi-channel video interface port) demo application is
shown in Figure 16.

Figure 16. mcvip_test Demo Application Menu

7.2.2.5 Procedure for Initializing Individual Video Formats

The procedure for initializing the system for each individual video output format is as follows:

1. Start the mcvip_test application (do not enter the menu option yet).
Example: ./mcvip_test.out NTSC VCC <Cascade Mode Option> <Audio Mode Option>

2. Program TVP5158 for the video output format (only if using VCC GUI Software).
In the VCC System Initialization window, click on the video output format (same format as chosen in
step 3) and click the PROGRAM button.

3. Select the video capture format for the DaVinci HD EVM:
In terminal window, type video format menu option (00-1b) and then <Enter>.
The video output should now be displayed on the HD video monitor using 1080i format.

4. At Linux terminal, type 0 <return> to stop the video capture.
5. Audio should be heard from the left and right speakers respectively if audio mode option selected.

Repeat steps 1 through 4 for each line-interleaved video output format.
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7.3 Evaluation of Pixel-Interleaved Digital Video Output Modes

The TVP5158EVM can be programmed for pixel-interleaved modes as described below. The DM6467
DaVinci HD EVM does not support pixel interleave modes, so a different back-end processor is required
for this evaluation.

1. In the VCC System Initialization dialog box, click the Browse button. The Open dialog box shown in
Figure 14 appears. Double-click the following file:
TVP5158EVM_Pixel_Interleave_Setup.CMD

2. The dataset descriptions table should now appear as shown in Figure 17. Click once on the following
table entry:
Multi-Standard, Pixel-Interleave, 2-Ch D1, 8-bit @ 54MHz (OCLK_P, OCLK_N @ 27MHz, Opposite
Phase)
Click the PROGRAM button. The TVP5158 is now programmed to automatically detect the video
standard received at the input and output video in the above pixel-interleaved format.

Figure 17. System Initialization for Pixel Interleave Modes
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8 VCC Software in Depth

8.1 VCC Main Window

The VCC main window contains the menu bar whose contents are summarized in Table 8.

Table 8. VCC Main Menu Summary

Menu Contents

File Exit

Edit Register Map – Edit I2C registers directly

TVP5158

THS8200

Generic I2C – Edit I2C registers for any slave address

Property Sheets – GUI controls for the I2C register map

TVP5158

THS8200

Tools System Initialization – Initializes system using .CMD files

Real-time Polling – Enables update of THS8200 when a video standard change occurs

USB/LPT/I2C Options – Set 100 or 400 kHz I2C

Window Allows selection of the active window

Help Displays program version

8.2 Register Map Editor

The register map editor (see Figure 18) allows the display and editing of the entire used register space of
the TVP5158 within a simple scrolling text box. To open this, click on the following menu item:

Edit > Register Map > TVP5158

Table 9 describes how to use each of the controls in the register map editor.

NOTE: To save registers to a file, check the Histogram Enable checkbox and click Read All. Click Show to view
the saved file.

Figure 18. TVP5158 Register Map Editor
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Table 9. VCC Register Map Editor Controls

Control Definition

Register Window Scrolling text box that displays the address and data for the I2C registers that are defined for the device.

This contains the I2C subaddress that will be accessed using the Write and Read buttons. Clicking on a
row selects an address, which then appears in the address edit box.

NOTE: After clicking on a row, the Data Edit box contains the data that was in the register window. The
Address Edit Box device has not yet been read.

The address up/down arrows are used to jump to the next/previous subaddress that is defined for the
device. If an address is not defined for the device, then it can still be accessed by typing the subaddress
in the Address Edit box.

This contains the data which will be written to or was read from the I2C subaddress.
Data Edit Box

The data up/down arrows increment/decrement the data value by 1.

Writes the byte in the Data Edit box to the address in the Address Edit box.
Write Button

The I2C register is written to whether or not the data is different from the last time the register was read.

Read Button Reads the data from the address in the Address Edit box into the Data Edit box and the register window.

Read All Button Reads all defined readable registers from the device and updates the register window.

Hex Button Converts all values in the register window and address and data edit boxes to hexadecimal.

Dec Button Converts all values in the register window and address and data edit boxes to decimal.

Closes the dialog.
Close Button NOTE: Multiple edit register map windows can be open at the same time (one for each device). Use the

Window menu to navigate.

Causes subsequent write, read or read all operations to be performed N times. N is entered as aLoop Count decimal number from 1 to 999.

8.3 Property Sheets

The property sheets represent the register data in a user-friendly format. The data is organized by
function, with each function having its own page and being selectable via tabs at the top.

To open this for the TVP5158, click on the following menu item:
Edit > Property Sheets > TVP5158

When the property sheet function is started or whenever you tab to a different page, all readable registers
in the device are read from hardware to initialize the dialog pages. Values on the page are changed by
manipulating the various dialog controls as described in Table 11.

Table 10. Property Sheet Controls

Type of Control Function/How to Set a Value When is Hardware Updated?

Read-Only Edit Box Read status information N/A

Check Box Toggle a single bit After Apply

Drop-Down List Select from a text list After Apply

Edit Box Type a number After Apply

Up/Down Arrows: ImmediatelyEdit Box with Up/Down Arrows Use up/down arrows or type a number Type a number: After Apply

Slider Slide a lever Immediately

Pushbutton Initiate an action Immediately
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Table 11. Property Sheet Button Controls

Button Definition

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
OK written is different from the value last read from that address.

Closes the dialog.

Causes all changes made to the property page since the last Apply to be discarded. Changes made to dialog
controls with 'immediate hardware update' are not discarded, because they have already been changed in
hardware.Cancel
Does not write to hardware.
Closes the dialog.

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
Apply written is different from the value last read from that address.

Does not close the dialog.

8.3.1 Property Sheet Refresh

The property sheets were designed so that the data displayed is always current. Certain actions cause the
entire register map to be read from the device and to update the property sheets. This happens when:

• Property sheets are initially opened.
• When tabbing from one page to another.
• When Read All is clicked.
• When making the Property Sheets window the active window (by clicking on it).
• When making a Register Map Editor window the active window (by clicking on it).

8.4 Video Decoder Select and Write Enables

The VCC main window contains controls for accessing the four video decoders within the TVP5158. The
buttons under “Selected Video Decoder Core” are mutually exclusive. Four sets of the various editing tools
(Register Map Edit and Property Sheets) exist in memory, but only the data for the selected video decoder
can be seen. Any or all of the write enable buttons can be enabled. These control which of the video
decoders will accept I2C writes.

8.4.1 Broadcast Write Access

This is the default configuration as shown in Figure 19. All four decoders are enabled for I2C writes. All
I2C writes done using the Edit Register Map, Property Sheets, or System Initialization tools will affect all
video decoders.

8.4.2 Single Video Decoder Write Access

This configuration is used to program unique settings for one video decoder without effecting the others.
The “Set write enable for selected decoder only” check box should be checked as shown in Figure 20.
This provides a shortcut, so that as each decoder is selected using the decoder buttons, the same
decoder is also enabled for writes (and the other three are disabled for writes).

8.4.3 Arbitrary Video Decoder Write Access

This configuration is used to program the write enabled video decoder(s) in any combination. The “Set
write enable for selected decoder only” check box should be unchecked.

NOTE: The command files used by the System Initialization tool can override the write enable
button settings. They are generally setup for writing to all decoders independent of the
current write enable buttons setting.
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8.4.4 Editing Tools vs Video Decoder Write Enables

The behavior of the System Initialization, Edit Register Map and Property Sheets tools regarding the
decoder write enables is described in Table 12.

Figure 19. VCC Main Window – Configured for Broadcast Write Access (default)

Figure 20. VCC Main Window – Configured for Single Video Decoder Write Access

Table 12. Editing Tools vs Video Decoder Write Enables

Editing Tool Reads From Writes To Writes What

Command File N/A Write Enabled decoders I2C register values
(can be overridden in cmd file)

Edit Register Map Selected Decoder Write Enabled decoders 1 byte – same data to all

Edit Property Sheets Selected Decoder Write Enabled decoders Bit fields that changed on the selected
decoder

8.5 Example TVP5158 Property Pages

Example property pages are shown in Figure 21 through Figure 24.

Some of the controls for the Output Formatter (OFM) page only exist for video decoder 1. Figure 21
shows the OFM page when Decoder 1 is the selected decoder. Figure 22 shows the OFM page when
Decoder 4 is the selected decoder (some of the OFM controls are not visible). They would also not be
visible for Decoder 2 and Decoder 3. To change the Port A selection, for example, Decoder 1 must be the
selected decoder.

The Audio property page only exists for video decoder 1. To access the Audio controls Decoder 1 must be
the selected decoder.
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Figure 21. TVP5158 Output Formatter Property Page With Decoder 1 Selected
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Figure 22. TVP5158 Output Formatter Property Page With Decoder 4 Selected
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Figure 23. TVP5158 Noise Reduction and Auto Contrast Property Page
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Figure 24. TVP5158 Audio Property Page (Seen Only When Decoder 1 is Selected)
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Figure 25 shows how TDM I2S audio data can be configured. Jumper W9 can be used to select the SD_R
(default) or SD_M I2S output to the audio DAC.

Figure 25. TDM I2S Audio Data Configuration
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9 Troubleshooting

This section discusses ways to troubleshoot the TVP5158EVM.

9.1 Troubleshooting Guide

If you are experiencing problems with the TVP5158EVM hardware or the VCC software, see Table 13
through Table 16 for available solutions.

Table 13. Troubleshooting Setup and General Issues

Symptom Cause Solution

TVP5158EVM Software Previous version was Use "Add or Remove Programs" in Windows Control Panel to remove
Installer reports that installed previous version of TVP5158EVM Software. Run SETUP.EXE again.
previous version must
be uninstalled

On connecting USB EVM was not Disconnect USB cable between PC and EVM. Wait 3 seconds. Reconnect the
cable, green "connected recognized on the USB. USB cable. Green "connected LED" near USB connector should light.
LED" does not light.

On connecting USB Jumper W6 has been Install jumper W6 near USB connector. Disconnect USB cable between PC
cable, New Hardware removed. and EVM. Wait 3 seconds. Reconnect the USB cable. Green "connected
Wizard appears LED" should light.

VCC application has USB polling rate is too Conect EVM directly to a laptop/desktop USB port instead going through a
slow response time. slow. docking station. Property Pages can not be refreshed using Read All buttons

at more than about a 1-Hz rate.

Nothing seems to Clicking Read All button Property Pages can not be refreshed using Read All buttons at more than
happen when I click too frequently. about a 1-Hz rate.
Read All repeatedly.

Table 14. Troubleshooting with THS8200 and CompositeVideo Output

Symptom Cause Solution

USB: Device Not Found EVM was not Disconnect USB cable. Wait 3 seconds. Reconnect USB cable. Green
error message recognized on the USB. "connected LED" should light. Click continue

USB: I2C Error Code 1 5V power not present Connect 5V power supply to EVM. Click Continue.
error message. An I2C EVM hardware reset Normal occurrence. An I2C error will occur if the hardware reset button is
acknowledge error has button has been pressed while real-time polling or property page auto-update is active. Click
occurred. See reported pressed. Continue.
I2C slave address and

I2C slave address Check that jumpers W2, W1 and W0 are connected across pins 1-2 (L, L, L)sub-address.
jumper setting and to specify slave address 0xB0 (Set jumper W0 across pins 2-3 (L, L, H) to
program setting do not specify slave address 0xB2 for a cascaded 2nd TVP5158EVM.) Exit VCC
match. application. Restart VCC and select the correct I2C slave address.

I2C bus master Check that jumpers W3 and W4 are connected across pins 1-2 to select USB
jumpered incorrectly. as I2C master.

No video output Wrong video input is Click on System Initialization in the Tools menu. Browse to
selected. TVP5158EVM_YPbPr_Output_Setup.CMD. Click on the dataset named

"Select Ch-X Video Input". (X is the channel to be displayed.) Click the
program button.

TVP5158 is not locked Click on Property Sheets -> TVP5158 in the Edit menu (see Figure 26). Lock
to video signal. status LEDs should both be green. In main window, click buttons

Decoder1,...,Decoder4 to see the lock status of each decoder (see Figure 3).
for numbering of video inputs.

THS8200 is not Click on Property Sheets -> THS8200 in the Edit menu. Pixel count/line count
receiving BT.656 data status should be 858/525 for NTSC or 864/625 for PAL (see Figure 27).
correctly.

THS8200 programmed Click on Property Sheets -> THS8200 in the Edit menu. Click DTG tab. Frame
for wrong standard. Size should be set to 525 if source is NTSC or 625 if source is PAL. If not,

click Real-time polling button in the Tools menu.

Horizontal instability in THS8200 Video Triple On TVP5158 Output Formatter property page, check the Line-Locked Output
displayed image DAC requires a Clock check box. Set the Port A Channel Selection drop-down box to select

line-locked clock. the video input for display. Line-Locked Output Clock is required when using
non-interleaved mode and THS8200.

No audio Wrong digital audio Set jumper W9 across pins 2-3 to hear the record output (SD_R) or across
output selected. 1-2 to hear the mixer output (SD_M).
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Table 15. Troubleshooting with DM6467 DaVinci HD EVM

Symptom Cause Solution

No serial communication Wrong serial port Set terminal program to 115200 baud, 8 bit data, no parity, 1 stop bit. Check
settings that COM port is available in the Windows Device Manager and is not being

used by another program.

Wrong cable type Use a null MODEM 9-pin serial cable. Pins 2 and 3 at one end should be
wired to pins 3 and 2 at the other end.

Boot up process fails No wired network Connect Ethernet LAN cable to DaVinci HD EVM
connection

No FTP server available Boot up arguments must specify the IP address of the computer that contains
the image file to be loaded. An FTP server program must be runnning on that
computer.

No Linux host available A PC running the Linux O/S or a PC running the Windows O/S with a virtual
Linux O/S must be accessible on the LAN and provide a shared file system
for the boot process.

Table 16. Troubleshooting I2C Connections and Cascaded EVMs

Symptom Cause Solution

When PC USB (VCC application) is I2C master for TVP5158

USB: I2C Error Code 1 I2C bus master Check that jumpers W3 and W4 are connected across pins 1-2 to select USB
error message. jumpered incorrectly. as I2C master.

When DSP video/audio driver is I2C master for TVP5158

I2C error messages I2C bus master Check that jumpers W3 and W4 are connected across pins 2-3 to select
from demo application. jumpered incorrectly. DaVinci HD EVM as I2C master.

When cascading two TVP5158EVMs together

I2C error messages I2C bus master The Stage 2 TVP5158EVM feeds cascaded video and audio data through
from demo application. jumpered incorrectly. connector J2 to connector J3 of the Stage 1 TVP5158EVM.

On the Stage 2 board, check that jumpers W2, W1, and W0 are connected
across pins 1-2, 1-2 and 2-3 (L, L, H) respectively, to specify slave address
0xB2.
On the Stage 2 board, check that jumpers W3 and W4 are both removed to
allow I2C to be mastered by the stage 1 board.
Also on the Stage 2 board, remove W7 and W8 to remove the second Audio
DAC from the I2C bus.
The Stage 1 TVP5158EVM can have I2C controlled by USB or the DaVinci
HD EVM.
Any changes to the above setup require that VCC be exited and restarted so
that the correct I2C slave address(es) can be selected.
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Figure 26. TVP5158 Video Format Property Page
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Figure 27. THS8200 Input Controls / Status Property Page
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10 TVP5158 EVM Schematics

This section contains the TVP5158EVM schematics.

Figure 28. Schematics (1 of 8)
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Figure 29. Schematics (2 of 8)
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Figure 30. Schematics (3 of 8)
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Figure 33. Schematics (6 of 8)
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