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Preface
The Preface discusses the topics and illustrates standards that are used throughout this guide.
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Preface
Who Should Use This Document

10
Who Should Use This Document
This User Guide is intended to be used by any person who will install and work with the 
ZebraNet PrintServer II.

How This Document Is Organized
The ZebraNet PrintServer II User and Reference Guide consists of these chapters:

Title Content Description

Introduction This chapter provides a high-level overview of the 
ZebraNet PrintServer II (PSII), installation 
instructions, standard network configurations, and 
how to work with PSII. 

Installation This chapter provides information on how to install 
PSII (external and internal) and the ZebraNet Utilities.

Getting Started This chapter provides you with information on how to 
work with the most frequently used PSII features. 

Printing Configurations This chapter provides information and instructions on 
configuring your printer for remote BSD-style LPD 
printing on the UNIX operating system.

NetWare Print Configuration This chapter provides you with instructions on how to 
configure Novell’s NetWare for printing to PSII.

Using Printing Protocols This chapter provides information and steps to set up 
your PSII to support Internet Printing Protocol (IPP).

PrintServer II This appendix provides you with details on the most 
commonly used PSII features.

ZebraLink
(for ZebraLink-enabled printers)

This appendix provides you with detailed information 
that allows you to use the enhanced functionality of 
your ZebraLink-enabled printer with the PSII.

ZebraNet Utilities This appendix provides you with details on ZebraNet 
Utilities, the software suite of printer administration 
tools that complements and enhances both ZebraLink 
and the ZebraNet family of connectivity products.

Hardware Troubleshooting This section provides you with solutions to known 
issues.

Frequently Asked Questions This section is a compiled group of frequently asked 
questions (FAQs) about PSII.

Glossary This section is a glossary of terms that are specific to 
the PSII.
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11About This DocumentPreface
Contacts
Contacts
Technical Support via the Internet is available 24 hours per day, 365 days per year.

Web Site: www.zebra.com 
E-mail Back Technical Library:  

E-mail address: emb@zebra.com  
Subject line: Emaillist  

Self Service Knowledge Base: www.zebra.com/knowledgebase 
Online Case Registration: www.zebra.com/techrequest   

Which Department 
Do You Need? The Americas Europe, Africa, 

Middle East, India Asia Pacific

Regional Headquarters Zebra Technologies International, 
LLC 
333 Corporate Woods Parkway 
Vernon Hills, IL 60061-3109 
U.S.A.
T: +1 847 793 2600 
Toll-free +1 800 423 0422 
F: +1 847 913 8766

Zebra Technologies Europe 
Limited 
Dukes Meadow 
Millboard Road 
Bourne End 
Buckinghamshire, SL8 5XF 
United Kingdom
T: +44 (0) 1628 556000 
F: +44 (0) 1628 556001

Zebra Technologies Asia  
Pacific Pte. Ltd. 
120 Robinson Road 
#06-01 Parakou Building 
Singapore 068913
T: + 65 6858 0722 
F:  +65 6885 0838

Technical Support
For questions on the 
operation of Zebra 
equipment and software, 
please call your distributor. 
For additional assistance, 
contact us.
Please have your model and 
serial numbers available.

T: +1 877 ASK ZEBRA (275 9327) 
F: +1 847 913 2578
Hardware: ts1@zebra.com  
Software: ts3@zebra.com 
Kiosk printers: 
T: +1 866 322 5202 
E: kiosksupport@zebra.com

T: +44 (0) 1628 556039 
F: +44 (0)  1628 556003
E:  Tseurope@zebra.com 

T: +65 6858 0722 
F: +65 6885 0838
E: China: tschina@zebra.com 
All other areas: 
tsasiapacific@zebra.com

Repair Service 
Department
For back-to-base service and 
repair.

T: +1 877 ASK ZEBRA (275 9327) 
F: +1 847 821 1797
E: repair@zebra.com 
To request a repair in the U.S., 
go to www.zebra.com/repair.  

T: +44 (0) 1772 693069 
F: +44 (0) 1772 693046 
New requests: ukrma@zebra.com  
Status updates: 
repairupdate@zebra.com 

T: +65 6858 0722 
F: +65 6885 0838
E: China: tschina@zebra.com 
All other areas: 
tsasiapacific@zebra.com

Technical Training 
Department
For Zebra product training 
courses.

T: +1 847 793 6868 
T: +1 847 793 6864 
F: +1 847 913 2578
E: ttamerica@zebra.com 

T: +44 (0) 1628 556000 
F: +44 (0) 1628 556001
E: Eurtraining@zebra.com 

T: + 65 6858 0722 
F: +65 6885 0838
E: China: tschina@zebra.com 
All other areas: 
tsasiapacific@zebra.com

Inquiry Department
For product literature and 
distributor and dealer 
information.

T: +1 877 ASK ZEBRA (275 9327)
E: inquiry4@zebra.com 

T: +44 (0) 1628 556037 
F: +44 (0) 1628 556005
E: mseurope@zebra.com 

E: China: GCmarketing@zebra.com 
All other areas: 
APACChannelmarketing@zebra.com

Customer Service 
Department (US)
Internal Sales 
Department (UK)
For printers, parts, media, 
and ribbon, please call your 
distributor or contact us.

T: +1 877 ASK ZEBRA (275 9327)
E: clientcare@zebra.com 

T: +44 (0) 1628 556032 
F: +44 (0) 1628 556001
E: cseurope@zebra.com 

T: +65 6858 0722  
F: +65 6885 0836 
E: China: order-csr@zebra.com 
All other areas: 
csasiapacific@zebra.com 

Key: T: Telephone
F: Facsimile
E: E-mail
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Document Conventions
The following conventions are used throughout this document to convey certain information: 

About this Chapter Sections  These sections list and describe each main section of the 
chapter, including the initial page numbers of those sections. These sections primarily serve as 
hyperlink components for the Adobe Acrobat .pdf version of this guide.

Alternate Color  (online only) Cross-references contain hot links to other sections in this 
guide. If you are viewing this guide online in .pdf format, you can click the cross-reference 
(royal blue text) to jump directly to its location. 

Command Line Examples  All command line examples appear in Courier font. For 
example, you would type the following to get to the Post-Install scripts in the bin directory: 
 
Ztools

Files and Directories  All file names and directories appear in Courier font. For 
example, the Zebra<version number>.tar file and the /root directory.

Caution, Important, Note, Tools, and Example  These topics are defined in the 
following example:

Caution • Advises you that failure to take or avoid a specified action could result in loss of 
data. 

Caution • Warns you of a potential electric shock situation.

Caution • Advises you that failure to take or avoid a specified action could result in 
personal injury. 

Important • Provides information that is essential to the completion of a task. 

Note • Indicates neutral or positive information that emphasizes or supplements important 
points of the main text. 

Tools • Identifies the tools you need to accomplish a task. 

Example • Provides an example, often a scenario, to better clarify a section of text. 
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Illustration Instructions  Used when an illustration contains either information about a 
dialog box or step(s) to accomplish in a dialog box. 

One illustration instruction identifies a section of the dialog box and the other shows steps to 
follow.

1 Set Permanent text-box.
2 a. In the Set Permanent text-box, type in the print 

server’s IP address.
b. When you are finished, click OK.

1

2
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Related Documents
In addition to the ZebraNet PrintServer User Guide, the following documents might be helpful 
references while using PSII:

• ZPL II® Programming Guide For Firmware Version x.14 and later

• ZPL II® Programming Guide For x.10 through x.13 Firmware

• EPL2 Programmer’s Manual

• EPL1 Line Mode Manual

Note • Most of these documents are available on our Web site.
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1
Introduction
This chapter provides a high-level overview of the PrintServer II (PSII), installation types, 
standard network configurations, and how to work with PSII. 
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Overview
The PrintServer II (PSII) is an optional factory- or field-installed interface device that supports 
network connection of the Zebra printer. PSII also provides a browser-type user interface that 
supports both the configuration of print server settings and the generation of unsolicited printer 
status messages to email-equipped devices.

ZebraLink-enabled printers offer an additional set of web pages that allow the user to set 
printer specific settings, as well as configure additional unsolicited alerts to be sent via email 
or SNMP. 

If your printer also has ZebraNet Utilities, you have even more functionality. For details, see 
ZebraNet Utilities on page 17.

Illustration

This illustration shows the flow of all the components that work with PSII. The table that 
follows identifies the components and how they enhance each respective device:

 

Important • You can download the most recent version of ZebraNet Utilities from our Web 
site: www.zebra.com.

Printer with PSII only

ZebraLink-enabled printer, with PSII

ZebraNet Utilities

1

2

3

PAUSEPAUSE
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Components Description

1 Printer with PSII only PSII gives your printer these features:
• allows the remote monitoring and configuration capability of the 

PSII using a browser. 
• allows you to send unsolicited printer status messages via email-

enabled devices.

2 ZebraLink-enabled 
printer with PSII

A ZebraLink-enabled printer with PSII gives you all the above-mentioned 
features (WebView and Alert).

Note • PSII can be either field- or factory-installed for additional 
features. For details, see Installation Types on page 21.

3 ZebraNet Utilities ZebraNet® Utilities is a suite of software programs that work with PSII and 
enhance the features of ZebraLink resident within ZPL-based printers. The 
features include:
• ZebraNet Alert lets you configure multiple event alerts per device with 

different alerts going to different people. You are notified of alerts from 
either visual or audio cues. You can also generate advanced alert 
reports.

• ZebraNet Connect IP lets you, with Windows, enable simple printer 
selection of an IP addressable printer.

• ZebraNet View allows you to locate printers automatically. ZebraNet 
View searches on parameters such as IP address, subnet, printer model, 
printer status, and many other user-defined characteristics. It also offers 
powerful device management capabilities.

• ZebraNet View Java Applet is a Java-based version of the popular 
ZebraNet View. It gives you ZebraNet View capabilities in a non-
Windows environment.
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Requirements
This section lists the minimum requirements for PSII, which include operating systems, 
browser support, and hardware.

Operating Systems

These are the platforms supported by ZebraNet Utilities:

• Windows™ NT®, 95, 98, 2000, Me

• Novell® versions 3 and 4 Netware®

• UNIX®

• Linux

Browser Support

The ZebraNet View Java Applet is supported by any Java-enabled browser:

• Internet Explorer 4.0+

• Netscape Navigator 4.08+

• Any browser that is HTML 1.1 compliant
45537L-005 ZebraNet PrintServer II User Guide 04/21/2009
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Hardware

These are the minimum hardware requirements:

Printers External Internal
Field Upgrade

Internal
Factory

Xi Series (XiII and XiIII) • • •

Xi4 •

R140 • • •

PAX Series (excluding PAX4) • • •

Z Series® •

Stripe® Series •

Z4Mplus™ • • •

Z6Mplus™ • • •

105SL • • •

105 Se/160S •

2746 •

2746e • •

2684 •

DA402, T402 •

2844 (EPL) • •

2844-Z (ZPL) • •

Ht-146 • •

2824 • •

ZM400™ •

ZM600™ •
04/21/2009 ZebraNet PrintServer II User Guide 45537L-005

Download from Www.Somanuals.com. All Manuals Search And Download.



Introduction
Compatibility

20
Compatibility
This section identifies the various components that are compatible with PSII.

ZebraNet Wireless Card Socket Option (WCSO)  PSII is fully compatible with 
WCSO.

Software  HP JetAdmin, HP Web JetAdmin™, and HP OpenView™ all work with PSII. 
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Installation Types
PSII can be factory- or field-installed, as follows:

Factory  Factory-installations are for new Zebra printers that are built with the internal PSII 
option.

Field  Field-installations are for Zebra printers already in the field that do not have the PSII 
device installed. The PSII option can be installed on existing printers, as follows:

• External PSII — attaches to the printer parallel port

• Internal PSII — for the appropriate Zebra printers, this option connects directly to the 
main logic board

Important • This installation must be performed by a qualified service technician.
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PSII Specifications
Network Connection  10BASE-T UTP RJ45 connection. Auto senses IEEE- 802.3, 
Ethernet II, IEEE- 802.2, and IEEE 802.2/SNAP frame formats 

Printer Connection  Bi-directional, IEEE- 1284 Centronics parallel port 

User Interface  Activity indicator: bi-color display of operational status; test button: 
diagnostic test and configuration printing 

Size (external ZebraNet PrintServer II)  Length: 3.6" / 91.4 mm, Width: 2.5" / 63.5 mm, 
Height: 0.8"/ 20.3 mm

Weight (external ZebraNet PrintServer II)  .5 oz. / 71 g. 

Power  Maximum 250mA at 5.25VDC; power provided by the printer (Centronics pin 18, 
5VDC at 200mA)

Environment   Operating Temperature: 0° to 104°F (0° to 40°C); Storage Temperature: –4° 
to 140°F (–20° to 60°C); Operating Humidity: 25 to 85% non-condensing

Agency Approvals   FCC Class B, Canadian ICES-003 “Class B”, EN55022 Class B, 
EN55024, AS/NZS3548
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2
Installation
This chapter provides information on how to install PSII (external and internal) and the 
ZebraNet Utilities.
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External PSII
This section provides you with an illustration of the external PSII and the steps required for its 
installation.

This illustration shows an external PSII with the important components identified.

Figure 1 • External PSII 

To install an external PS II, complete these steps: 

1. Turn off (O) the printer. 

2. See Figure 2. From the back of the printer, insert the PSII device into the parallel port.
Figure 2 shows the location and an enlarged view of the parallel port.

1 Parallel connector
2 Test button
3 Status indicator
4 Ethernet connector

Note • When necessary, refer back to this illustration during the installation steps.

1

4 2

3
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Figure 2 • Parallel Port
 

3. Secure the wire locks.

4. On the back of the PSII, insert a live 10BASE-T cable into the Ethernet connector.

5. Turn on the printer. 
A red status indicator blinks during the Power On Self Test (POST) and changes to green 
when the initialization is finished.
The Test button is a small hole on the PSII device. To press it, you need to insert 
something small into the hole, like a paperclip.

6. Press the Test button located on the bottom of the PSII. This prints out a PSII 
configuration label.

This table shows you how to determine the minimum label width needed to print a PSII 
configuration label for printers with firmware version 7 or lower:

1 Parallel connector

Important • Label length, DPI and your firmware version:
• For all printers, the minimum label length is 4 in. (10.16 cm). 
• For printers with firmware version 7.01 and higher, regardless of the dpi, a  

2-inch (5 cm) label prints 
• For printers with firmware version 7 and lower, see the table that follows. 

DPI Inches

600 1.25

300 2.50

200 3.69

150 5.0

1
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This is an example of a PSII configuration label. The numbers identify the settings you need to 
know. The table following the illustration provides a description of each number.

Figure 3 • PSII Configuration Label
  

 

1 This shows the IP address, subnet mask, and default gateway 
of the PSII device. If the IP address is set at 0.0.0.0, you need 
the serial number (in number 3) to set the IP address.

2 This shows all the Novell settings. 
3 This shows the serial number, hardware address (MAC 

address), and firmware version of the PSII device.

1

2

3
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Internal PSII
This section provides you with an illustration of the internal PSII and installation steps. 

1. Which printer model do you have?

XiII, XiIII, R140, 105SL, and PAX Series

Figure 4 shows you the internal PSII that can be installed into XiII, XiIII, 105SL, and PAX 
series printers. The important components are identified.

Figure 4 • Internal PSII

If you have a(n)… Then…

XiII, XiIII, R140, 
105SL, or PAX series 
printer

See XiII, XiIII, R140, 105SL, and PAX Series on page 27.

Z4Mplus or Z6Mplus 
printer

See Z4Mplus/Z6Mplus on page 31.

1 Test button
2 Status indicator
3 Ethernet connector
4 Ribbon cable connector

4
1

2

3
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To install an internal PSII into a XiII, XiIII, R140, 105SL, and PAX Series printer, 
complete these steps:

 

1.

2.

3. From the back of the printer, remove the two screws and the blank cover plate positioned 
next to the main RS-232 and parallel interface connectors.

4. Which printer model do you have?

Caution • A qualified service technician must perform this installation.

Tools • You need these tools to complete this procedure:

Phillips Screwdriver Set 3/32 in. Allen Wrench

Caution • Observe proper electrostatic safety precautions when handling 
static-sensitive components such as circuit boards and printheads.

Connect yourself to an antistatic device.

Caution • Turn off (O) the printer and disconnect it from the power source before 
performing the following procedure.

Turn off (O) the printer and disconnect the AC power cord and all data cables.

If you have 
a(n)… Then…

XiII, XiIII series, 
R140, or a 105SL

a. See Figure 5.
b. To remove the side panel, remove the screws and remove the 

left side panel. 
PAX a. See Figure 6.

b. To remove the side panel, access the electronics by removing 
the mounting screws from the printer’s PCB access panel and 
sliding the panel out.
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Figure 5 • Internal PSII
for the XiII, XiIII Series, R140, and 105SL

Figure 6 • Internal PSII
for the PAX

1 Ferrite Bead
2 Data Cable Connector
3 Ribbon Cable

1 Ferrite bead
2 Ribbon cable
3 Status indicator
4 Test button

2

3

1

1

3

4

3

12 2 1
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5. Insert the ribbon cable and PSII through the mounting slot.

6. Fold the cable and the ferrite bead back over the mounting bracket, and connect the ribbon 
cable connector into the keyed Interface Data Cable Connector (J4) on the main logic 
board. 

7. Secure the PSII interface board in place with the cover plate screws that you removed in 
step 3 of this procedure.

8. Confirm that all small cable connectors are tight.

9. Which printer model do you have?

10. This kit includes a label printed with the Ethernet MAC hardware address for the PSII. 
Remove the backing from the label and affix it to the back of the printer.

11.

12. Consult your System Administrator before configuring the PSII for your network! To 
establish the network connection, refer to the section applicable to your network type.

Note • The parallel port on the back of the printer is not operational when the internal PSII 
is installed. The hardware of the PSII mounting bracket covers the parallel port.

If you have 
a(n)… Then…

 XiII, XiIII series, 
R140, or a 105SL

a. See Figure 5.
b. Reinstall the left-side panel.
c. Replace the screws that you removed in step 3 of this 

procedure. 
PAX a. See Figure 6.

b. Reinstall the PCB access panel and gently slide the panel into 
the back of the print engine.

c. Replace the screws that you removed in step 3 of this 
procedure.

Caution • Reconnect the printer to the power source and turn on (l).

Reconnect the AC power cord and all data cables and turn on (l) the printer.
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Z4Mplus/Z6Mplus

Figure 7 shows you the internal PSII that can be installed into Z4Mplus and Z6Mplus printers. 
The components you need to be familiar with are identified below.

Figure 7 • Internal PSII for the Z4Mplus/Z6Mplus

1 Ferrite bead
2 Parallel port socket
3 Ribbon cable
4 Red status indicator
5 Green status indicator
6 Ethernet connector
7 Test button

Caution • A qualified service technician must perform this installation.

7

6

5

234

1
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To install an internal PSII into a Z4Mplus printer, complete these steps:   
 

1.

2.

3. See Figure 8. Lift the media door and locate the screw in the middle of the hinge along the 
top of the printer frame. 

4. Remove the screw and the lock washer.

Figure 8 • Z4Mplus Media Door and Compartment

5. Close the media door. 

Tools • You need these tools to complete this procedure:

Flat-blade Screwdriver Set 7 mm Nutdriver

Caution • Observe proper electrostatic safety precautions when handling 
static-sensitive components such as circuit boards and printheads.

Connect yourself to an antistatic device.

Caution • Turn off (O) the printer and disconnect it from the power source before 
performing the following procedure.

Turn off (O) the printer and disconnect the AC power cord and all data cables.

1 Media door
2 Lock washer
3 Screw
4 Electronics cover

3

4

1

2
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6. See Figure 9. To remove the electronics cover, push in and pull up.

Figure 9 • Z4Mplus Electronics Cover

7. From the back of the printer, use a flat-blade screwdriver to remove the screws and the 
cover plate.
This opens the mounting slot on the back of the printer.

8. See Figure 10. To disconnect the PSII, unplug the cable connector from the I/O board.
You will have the I/O board separate from the PSII board (and the cable connected to it). 

1 Cover plate screws (2)
2 Printer back
3 Cover plate

2

3

1
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Figure 10 • Internal PSII for Z4Mplus

1 Cable connector
2 Cable
3 Cable tie
4 PSII Board
5 Parallel port socket
6 Standoffs (3)
7 Back cover
8 I/O Board

1 

8

7

5

2 3

4

6
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9. See Figure 11. Insert the short ends of each standoff into the holes on the main logic board 
until you hear a click.

Figure 11 • Z4Mplus Main Logic Board and Standoffs

10. See Figure 10 and Figure 11. From the electronics enclosure, plug the parallel port socket 
of the PSII board into the parallel port connector on the main logic board.

11. Align the holes in the PSII board with the standoffs and snap into place.
Be sure the PSII is seated securely.

12. Does your printer have a PCMCIA card installed?

1 Parallel port connector on the main logic 
board

2 Standoffs (3)

If… Then…

No a. With the PSII board connected to the main logic board, feed the connector 
through the mounting slot in the back of the printer.

b. Continue with step 13.
Yes a. With the PSII board connected to the main logic board, feed the connector 

over the PCMCIA card, then through the mounting slot in the back of the 
printer. 

b. Continue with step 13.

2

1
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13. See Figure 12. Place the I/O board inside the plate, and plug the cable into the connector 
on the I/O board.

Figure 12 • Z4Mplus I/O Board and Plate

.

14. Using the screws removed in step 7, screw the plate onto the back of the printer.

15. Reinstall the electronics cover.

16.

If the green status indicator is solid (not blinking), the PSII has power.

17. Consult your System Administrator before configuring the PSII for your network. To 
establish the network connection, refer to the section applicable to your network type.

1 Plate
2 I/O Board
3 I/O Board connector

Note • The parallel port on the back of the printer cannot be used when the internal PSII is 
installed. The hardware of the PSII mounting bracket covers the parallel port.

2

3
1

Caution • Reconnect the printer to the power source and turn on (l).

Reconnect the AC power cord and all data cables and turn on (l) the printer.
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ZebraNet Utilities
The ZebraNet Utilities is a software suite consisting of tools to assist you with the 
configuration of the PSII device, which gives you the flexibility to make changes to settings, 
track errors, and more.

If you want to be certain you have the most recent version of the ZebraNet Utilities, you can 
visit our Web site and download the most recent version.

For more details, see Overview on page 16 or ZebraNet Utilities on page 115. 

To install the ZebraNet Utilities, complete these steps:

The steps that follow reflect the steps and dialogs for a typical installation. If you plan to 
conduct a custom installation, the dialogs you see will differ from those in this procedure.   

1. Insert the CD-ROM into the drive.

2. Click Next>.
This dialog box lets you select the utilities that you want to install.

Note • Contact your System Administrator before installing this software. You must have 
Administrator rights on your network to install most of these utilities.

Important • Is AutoPlay enabled on your computer?
• Yes. Your computer automatically launches the installation.
• No. You need to navigate to the Software>ZebraNet Util>setup.exe on the CD-ROM 

and manually launch the installation.

Each of these 
options has 

drop-down menus 
from which to 

choose.
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3. In the ZebraNet Utilities dialog, select the features you want to install and click Next>. 
This dialog box gives you the chance to reset your installation settings.

Important • If you installed ZebraNet View Java Applet, you must complete the 
installation steps for ZebraNet View Java Applet on page 40.
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4. In the ZebraNet Utilities dialog, you have the option to review and make any changes to 
your installation settings. When you are satisfied with your installation settings, click 
Install. 
When the installation is complete, this dialog opens.

5. Click Finish.

Important • When the installation is complete, you need to restart your system for the 
changes to take effect.
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ZebraNet View Java Applet
If you selected ZebraNet View Java Applet when you installed the ZebraNet Utilities, you 
need to complete a few installation steps to work with this utility.

To install ZebraNet View Java Applet, complete these steps: 

1. From the task bar, select Programs>ZebraNet Utilities>ZebraNet View Java Applet 1.0.
This Security Warning dialog opens.
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2. To begin the installation, click Yes.
The Select Java Plugin Installation dialog opens.

3. Make the selections that apply to your environment, and click Install.
The Software License Agreement opens.

4. Read the License Agreement. 

5. To continue with the installation, click Yes. 
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6. When the installation is complete, click OK. 
The Java page opens.

7. You have these options:

• To work with this utility, see ZebraNet View Java Applet on page 126.

• To close the utility, click the X.
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3
Getting Started
This chapter provides you with information and procedures for working with the most 
frequently used PSII features.
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Before You Begin 
PSII offers many features, but how you access and work with them is dependent on your 
environment. Before you begin, you need to get information from the PSII configuration label. 

To print a PSII configuration label, complete these steps:   

1. Turn on (l) the printer and let it complete its power-up cycle.

2. Let the PSII complete its POST cycle. 

3. When the above steps are complete, press Test and hold it in for a few seconds before you 
release it. 

• On the Z4Mplus and Z6Mplus, the Test button for the internal PSII device is a small 
button on the back of the printer located under the RJ-45 connector. For more details, 
see Figure 7 on page 31.

• On any other printer, the Test button on the PSII device is a small hole. For more 
details, see Figure 4 on page 27.

A PSII configuration label prints. Your configuration label looks similar to Figure 13 
on page 45.

Important • Make sure the printer is turned off (O).
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Figure 13 • Configuration Label

4. From the configuration label, you need to get these numbers:
For details on getting these numbers, see page 26. 

• ADDRESS (IP address) 

• SUBNET MASK 

• DEFAULT GATEWAY 

• SERIAL NUMBER 

• HARDWARE ADDRESS (MAC address)     

5. On the configuration label that prints out for your PSII device, circle the above-mentioned 
settings. You can now proceed to Assigning an IP Address on page 46.
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Assigning an IP Address 
Before you can begin working with PSII, you must get or assign an IP address for the PSII 
device.

With Dynamic Host Configuration Protocol (DHCP) 

If your network uses DHCP, your PSII device is assigned a temporary IP address. This is 
important to know, because you have the option to make the temporary IP address the 
permanent IP address.

Without DHCP 

If your network does not use a dynamic IP addressing system (such as DHCP), you need to set 
a permanent IP address of the PSII device. 

ZebraNet View

ZebraNet View is the Windows-based print server management and configuration utility that 
came with your PSII. 

Important • Throughout the procedure in this chapter, there are some features that require 
the default User ID and/or default password. If you are prompted, these are the defaults:

• User ID: admin
• Password: 1234

Note • Check with your Network Administrator to see whether your network uses DHCP.

Important • The remaining sections are dependent on the successful installation of ZebraNet 
Utilities, which you should have completed on page 37.
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f 
To assign an IP address using ZebraNet View, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens:

2. Compare the H/W Address or Serial Number on the PSII configuration label with 
the H/W Address column on the screen to find the PSII you are working with. 

3. When you locate your PSII, select it. 

4. From the menu bar, select PrintServer>Configuration.

5. If your PSII does not have an IP address, complete these steps:

• Find your PSII and right-click.

• In the small dialog that opens, enter an IP Address, click OK.

• The ZebraNet View dialog opens. 

Important • On the illustration that follows, take note of the H/W address column and 
Serial # column. Compare what you see in ZebraNet View with the configuration label 
you printed out.

Important • If the PSII does not have an IP address, it shows in the main screen with an IP o
0.0.0.0. If, after 2 minutes, you do not assign an IP Address, the PSII defaults to IP Address 
192.168.254.254 or 198.102.102.254 (this depends on your firmware version).
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To set the subnet, complete these steps: 

1. From the ZebraNet View menu bar, select PrintServer>Configuration.

2. Click the TCP/IP tab.

3. From the Print Server Configuration>TCP/IP tab, in the Subnet Mask text-box, type in 
your subnet mask.

4. Confirm it is accurate, and click OK.

The Print Server Configuration dialog opens:

5. To set a permanent IP address, enable the Set Permanent radio button.

6. In the Set Permanent text-box, type a new IP address and click OK.

To set the default gateway, complete these steps: 
These steps are Optional.

1. From the ZebraNet View menu bar, select PrintServer>Configuration.

2. Click the TCP/IP tab.

3. From the Print Server Configuration>TCP/IP tab, in the Default GateWay text-box, type 
in your default gateway.

4. Confirm it is accurate, and click OK.
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In a Non-Windows Environment 

These steps can be used with all printers. However, the liquid crystal display (LCD) 
instructions are for printers with an LCD. 

To assign an IP address from the printer LCD, complete these steps:

1. Turn on the printer and allow 2 minutes for all systems to complete the self test. If you do 
not have a network cable in the port, the PSII prints the configuration label when it is 
ready.

2. On the printer front panel, press SETUP/EXIT.

3. On the printer front panel, press PREVIOUS twice until you reach the network settings 
menu item. 

4. You can edit any of the following network settings in order to communicate with any PSII 
in your network environment.

• ip resolution (dynamic, permanent) The printer menu item IP RESOLUTION 
must be set to PERMANENT if attempting to assign the IP address from the front 
panel.

• default gateway (default setting of 000.000.000.000) 

• subnet mask (default setting 255.0.0.0) 

• ip address (if initial default setting is 0.0.0.0, after 2 minutes this defaults to 
198.102.102.254 or 192.168.254.254 — depends on firmware version) 

• ip protocol (gleaning only, rarp bootp, dhcp, dhcp and bootp, all) 

Assigning an IP Address via a Telnet Session 

If your environment is not Windows-based, this section is for you. However, this method can 
be used in a Windows environment, too.

The methods used for assigning an IP address with a Telnet session are Static Route and 
Gleaning.

Before you can Telnet to the PSII and configure it, you must first assign the PSII a temporary 
IP address. 

Important • Your PSII must have firmware 6.3 and higher and your Zebra printer must have 
firmware x.10 or higher with an LCD. 

Important • To change any of these settings, you need to use the default password: 1234.

Important • This applies to any TCP/IP capable workstation/ host networked with the Zebra 
printer. Both the workstation/host and the PSII must be on the same network segment.
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Static Route: To use this method, complete these steps: 

1. Turn on the printer and wait for 2 minutes to allow for the device self test. 
During this time, the PSII performs an address broadcast. If no address is assigned to the 
unit (via DHCP or Bootp), it uses a default address. The default address used varies with 
the version of firmware the PSII is using. Print the PSII configuration label to confirm the 
address; for details see page 44.

2. You can use the route add command to place the default IP address into the 
workstation's network routing table.

3. At the workstation/host command prompt (in Windows, go the DOS prompt), type:
route add **** "IP address of the workstation" 0

4. Telnet to the PSII by typing:
"Telnet xxx.xxx.xxx.xxx" 
The password is 1234. 

5. When finished, you can alter the appropriate settings. When complete, do a reset and 
allow the PSII self test to complete before proceeding with any communications activity. 

Gleaning: To use this method, complete these steps: 

A method by which the PSII uses the IP address of the first ping packet that is sent to its 
Hardware address. 

1. Add an entry to the ARP table that assigns an IP address to an Ethernet (Hardware) 
address. 
The syntax for this command is: arp -s "temporary ipaddress of print 
server" "MAC Address (print server hardware address)" arp -s 
<temporary ip address> <MAC Address>

2. Power cycle the printer. 

3. As the printer reboots, begin a continuous ping to the address assigned previously. 

Example • In the next step, **** is the IP address on the PSII configuration label.

Note • The zero (0) placed at the end of the "route add" command is optional on some 
systems.

Note • Gleaning works only on local subnets at routers. It does not pass Address Resolution 
Protocol (ARP) broadcasts.

Example • You would type: arp -s 10.3.50.59 00-40-68-1D-B9-86
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4. When the PSII begins to respond, stop the ping activity.
 In Windows, Ctrl + C halts the pinging.

5. Telnet to the PSII and assign the appropriate IP address, subnet mask, and gateway if 
applicable. 

6. Once this is complete, reset the PSII. 
For details on resetting the PSII, see Reset on page 97.

Note • Most UNIX systems use a continuous ping. 

To use a continuous ping from a Windows host, you must issue the command: ping -t 
"ipaddress". 
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Setting Alerts 
It is important to understand the relationship between the PSII and the printer when you are 
establishing alerts. Here are the relationships you need to be aware of:

• Non-ZebraLink-enabled printers — can send alerts on only a specific set of printer 
errors that are reported in the IEEE 1284 protocol.

• ZebraLink-enabled printers — ZebraLink allows for the printer to send alerts not in 
the IEEE 1284 protocol.

ZebraNet View   

In this section are step-by-steps instructions on how to set up an alert using ZebraNet View. 
For information on setting up alerts using ZebraLink, see ZebraLink on page 54.

To set alerts (traps) using ZebraNet View, complete these steps:

1. In the ZebraNet View dialog, from the menu bar select Print Server>Configuration.

2. Click the SNMP Traps tab.
The Printer Traps check boxes are the alerts you can set from ZebraNet View.

3. Enable the alerts (printer traps) you want to set here and click OK.
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4. To monitor the alerts you established, from the task bar select Start>ZebraNet 
Utilities>ZebraNet Alert.
The ZebraNet Alert dialog opens:

In this dialog you can view the log of errors and monitor the activity of your printer(s).
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ZebraLink 

In this section are step-by-step instructions on how to set up an alert using ZebraLink. For 
information on setting up alerts using ZebraNet View, see ZebraNet View on page 58. 

To view Alert Setup using ZebraLink, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, and press Enter.

3. From the Printer Home Page, click Alert Setup.
The Alert Messaging System dialog opens:

To add an alert, you need the default user ID and password.

4. To add an alert, click Add Alert Message.

Important • If you do not have a ZebraLink-enabled printer, these steps will not work. 
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5. Select accordingly.

6. You can use ZebraNet Alert to monitor alerts set through a ZebraLink-enabled printer.

From this Web page you can add alert messages to notify you when a printer is out of paper, 
needs a ribbon, and so on.

Establishing Email Alert Messaging 

ZebraNet Alert supports email notification of printer errors sent directly to any valid email 
address. You can have multiple email addresses set up for routing different error messages, or 
split notifications between email and other network management tools. 

To begin receiving email notification of errors, complete these steps:

1. From the browser view, in the Address text-box type in the printer’s IP address. 
The Printer Home Page opens.

2. From the Printer Home Page, click Alert Setup.
The Alert Setup page shows a list of message notifications and their respective 
destinations (if no notifications are listed). 
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3. To set up email notification, go to the Alert Setup page and click Add Alert Message.
The Add Alert Message page opens:

4. Specify the condition to send over email, such as HEAD ELEMENT BAD or PAPER 
OUT.

5. Set destination to Email.

6. Enter a valid email address for the messages to be sent to. 

7. Click Add Alert Message. 

8. To receive email alert you must give PSII the IP address of your mail server that is 
running SMTP.

9. To save current settings, click Save Printer Setting. 

Important • The printer accepts only the last configuration made.

Example • admin@yourcompany.net (The Port field can be ignored for email 
setup.)

Important • A password is required. If you forget to enter the password, the alerts you just 
set are deleted.
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10. Enter the password and click Save Current Configuration.

11. You can continue to add more settings or, if finished:

• From the Printer Home Page, select PrintServer Settings>Network Communications 
Setup. 

• Click SMTP Email Alerts.

• Specify your SMTP server address. 
When these steps are done, you can begin receiving email notification messages.

To monitor alerts, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.
The Active Log dialog opens, displaying a list of all the logged alerts:   

 

Note • The SMTP Server address might be referred to as Mail Server address.
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2. From this dialog, you can track the printer(s) activity and status. 

3. From the menu bar, you can explore all the other features, such as Reports.

Checking Printer Configuration Settings
This section provides steps on how to check PSII’s configuration settings using ZebraNet 
View and a browser.

ZebraNet View 

To check configuration settings, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
The ZebraNet View dialog opens: 
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2. From the menu bar, select Print Server>Configuration.
The Print Server Configuration dialog opens: 

This dialog offers multiple tabs to choose from. Each tab contains various configuration 
settings that you can change.
For details on the configurations, see page 116.
04/21/2009 ZebraNet PrintServer II User Guide 45537L-005

Download from Www.Somanuals.com. All Manuals Search And Download.



Getting Started
Checking Printer Configuration Settings

60
Browser

This section provides steps on how to check PSII’s configuration settings using its Web pages.

To access the PSII settings, complete these steps: 

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, then press Enter.
Your browser page looks similar to this:

Note • Your printer firmware determines how this page looks. This page is from a printer 
with firmware x.10 and above.
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3. From the Printer Home Page, click Print Server Settings.
The default User ID and password are required.

The Print Server Configuration Page opens:

Important • The illustration of the Print Server Settings page is based on a ZPL printer. If 
you have an EPL printer, the menu options on the Print Server page are slightly different.

Note • Your printer firmware determines how this page looks. This page is from a printer 
with firmware x.10 and below.
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To access the PSII settings, complete these steps: 

1. From the Print Server page, click Print Server.
The Print Server Configuration page opens:

2. For details on the configuration choices, see Checking Printer Configuration Settings 
on page 58.
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Setting Up a ZebraNet Connect IP 
ZebraNet Connect IP allows you to send jobs to PrintServers that use Dynamic IP addresses 
(DHCP). It also notifies you of printer errors, such as paper out or head open. When print jobs 
are printed through ZebraNet Connect IP, they are sent directly to PSII and are not routed 
through a network server, resulting in a reduction of network traffic. 

If you have printing problems while using the ZebraNet Connect IP printing port, you may 
check the status of the port or change its settings through the printer Properties dialog.

• For Windows 95/98, select Port Settings under the Details tab.

• For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.

Windows NT 4.0/Windows 2000 

If you are using the Windows NT 4.0 or Windows 2000 operating system, use the following 
procedure to set up a printer port for the PSII.

1. From the task bar, select Start>Settings>Printers.

2. Select the Windows printer to use when printing with the PSII.

3. From the menu bar, select File>Properties.

4. To add a ZebraNet Connect IP port, in the Ports tab select Add Port.

5. From the list of Available Printer Ports, select ZebraNet Connect Monitor as the type of 
port to add, and click New Port.

You enter into the Add ZebraNet Connect Port screen, where there is a list of all PSII 
devices available on the local subnet.

• The TCP/IP monitor searches only the local subnet.

• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

Note • The DHCP feature of ZebraNet Connect IP can rediscover a PSII on the local subnet, 
even when its IP address might be changing (e.g., when using DHCP for IP address 
resolution). The PSII is relocated by its port name as configured through ZebraNet View (the 
default name is Serial Number-Port Number). This feature is enabled on the local subnet 
only. A non-local PSII device is not rediscovered if the IP address changes.

Note • If ZebraNet Connect IP monitor is not listed, verify that the ZebraNet Connect IP 
software has been properly installed. To do this, you need to reinstall the software and 
choose Modify.
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6. If the port you want to add is listed in the Ports Available on Local Subnet window, select 
the port name. If the port you want to use is not listed, you can: 

• Select Cancel and repeat step 5 to rediscover the print servers. 

• In ZebraNet Connect for IPX/SPX, click Search and enter the PrintServer’s Network 
Number and Hardware Address.

• In ZebraNet Connect, click the Locate Non-local Device button and enter the static 
TCP/IP Address used for the PSII.

7. Click Add.

8. To close the Printer Ports dialog, click Cancel.

9. To save the configuration, click OK.

Now you can use ZebraNet Connect. Whenever you print to the Windows printer configured 
with ZebraNet Connect, your print job will go directly to the ZebraNet PSII port.

Windows 95/98/Me 

To set up a PSII port using Windows 95/Windows 98/Me, complete these steps:

1. From the task bar, select Start>Settings>Printers.

2. Select the Windows printer that you want to print with ZebraNet Connect IP.

3. From the file menu, select File>Properties.

4. To add a ZebraNet Connect IP port, in the Details tab select Add Port.

5. From the Add Port dialog, select Other, then select the ZebraNet Connect Monitor as the 
type of port to add. 

6. Click OK.

The Add ZebraNet Connect Port screen opens. There is a list of all PSII devices discovered on 
the network.

• The TCP/IP monitor searches only the local subnet.

• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

Note • The ZebraNet Connect for TCP/IP DHCP discovery feature relocates a PSII device 
on the local subnet by its port name, even if the IP address changes. This feature is enabled 
on the local subnet only. A non-local PSII device is not rediscovered if the IP address 
changes.

Note • Under Windows 95, you have to set up the printer for a local port first, then open 
Properties from the File menu and continue with the configurations.

Note • If ZebraNet Connect IP is not listed, verify that the software has been properly 
installed.
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7. If the port you want to add is listed in the Ports Available on Local Subnet window, select 
the port name. If the port you want to use is not listed, you can:

• Select Cancel and repeat step 5 to rediscover the PSII devices. 

• In ZebraNet Connect IP for IPX/SPX, click Search and enter the PSII’s network 
number and hardware address.

• In ZebraNet Connect IP, click the Locate Non-local Device button and enter the static 
TCP/IP address used for the PSII.

8. Click Add.

9. To save the configuration, click OK.

Now you can use ZebraNet Connect IP. Whenever you print to the Windows printer 
configured with ZebraNet Connect IP, your print job will go directly to the PSII port.

IPX (NetWare) 

ZebraNet Connect for IPX/SPX is a utility that allows simple, direct, IPX/SPX printing from 
your computer to a printer attached to a ZebraNet PSII. Print jobs printed through the 
ZebraNet Connect utility are sent directly to the PSII and do not require a NetWare server, 
resulting in a reduction of network traffic.

If you have printing problems while using the PSII Connect printing port, you can check the 
status of the port or change its settings under the printer Properties window.

• For Windows 95/98, select Port Settings under the Details tab.

• For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.
Notify on Printer Error — This feature checks the printer status prior to printing the job. 
If a printer error is detected (e.g., printer off-line), the error description is given.
Notify When Printed — This feature provides an alert when your job is active on the 
printer. This is useful if the printer is unusually busy.
Description — An optional field in which you can list any useful information about the 
printer port, such as location.
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Enabling Protocols
You can enable protocols with WebView or ZebraNet View. This section provides you with 
directions for accessing and enabling protocols using both WebView and ZebraNet View.

WebView 

This section contains directions for accessing protocols using WebView. The browser 
illustrations were captured from a ZebraLink-enabled printer.

To enable protocols using WebView, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, then press Enter.
Your browser page looks similar to this: 

3. From the Printer Home Page, click Print Server Settings.
The default User ID and password are required.
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4. From the Print Server page, click Print Server.
The Print Server Configuration page opens: 
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5. From the Print Server Configuration page, click Enabled Protocols.
The Protocol Configuration page opens:

6. Select the protocols you want to enable, then click Submit Changes.
You get a confirmation to reset the unit for changes to take place.
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ZebraNet View     

This section contains directions for accessing protocols using ZebraNet View.

To enable protocols using WebView, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
The ZebraNet View dialog opens:

2. From the menu bar, select Print Server>Configuration.

3. Click the Protocols tab.
The Protocols tab opens:
04/21/2009 ZebraNet PrintServer II User Guide 45537L-005

Download from Www.Somanuals.com. All Manuals Search And Download.



Getting Started
Defaulting the PSII

70
4. Select the protocols you want to enable, then click OK.
A confirmation message opens. 

5. To accept changes, click OK.

Defaulting the PSII
This section provides you with instructions for defaulting the PSII to factory settings using 
WebView, ZebraNet View, and the Test button.

WebView    

To default the PSII to factory settings using WebView, complete these steps:

1. From the ZebraNet PrintServer view, click Factory Print Server Settings.
The Restore to Factory Defaults page opens:

2. Enable the check box of the settings you want to reset, and click Submit Changes.
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ZebraNet View    

To default PSII to factory settings using ZebraNet View, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
The ZebraNet View dialog opens:

2. From the menu bar, select Print Server>Reset. 
The Reset Print Server dialog opens: 

3. Select the settings you want to reset, then click Restore.

Important • With the reset command on its way to the PSII, the HTTP connection is 
unavailable while the PSII re-initializes. You need to wait a few seconds before trying to 
reestablish a connection.
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Test Button   

To default the PSII to factory settings using the Test button, complete these 
steps:

1. The printer is turned off (O).
The Test button is a small hole on the bottom of the external PSII device. To press the 
Test button, you need to insert something small into the hole, like a paperclip.

2. With the printer turned off, press and hold the Test button on the PSII device and turn on 
the printer.

3. The status indicator tells you when PSII has been reset to factory defaults, as follows:

• If an active network cable is connected to the PSII, the status indicator turns solid 
green. When this happens, you can release the Test button.

• If there is not an active network cable connected to the PSII, the status indicator 
flashes green. When this happens, you can release the Test button.

• For more details on status indicators, see Status Indicator on page 130.
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4
Printing Configurations
This chapter provides information and instructions on configuring your printer.
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BSD (Berkeley Software Distribution)-Style Print Queue
BSD is a version of the UNIX OS that distributes software that includes TCP/IP.

Configuring the Print Queue

For remote BSD-style LPD printing, add the PSII as a remote printer in the /etc/printcap 
database to each host printing to the PSII. You can add printcap options as needed. If you are 
unfamiliar with these options, consult the printer documentation. 

The entry looks similar to this:
local_print_queue_name|[printer_model_and_manufacturer]:\

:lp=:mx#0:rm=ZebraNet_name:\

:rp=remote_print_queue_name:\

:sd=path_to_spool_directory:lf=just log_file_name

local_print_queue_name — This defines the name of the printcap entry. It is used by 
the LPR/LPD utilities to specify which printcap entry is being referenced. Additional printcap 
entries can be added as needed for different queue types. Each entry must have a unique 
local_print_queue_name and a different spool directory to work properly. When you are ready 
to print, use the local_print_queue_name that matches the data type of the file to be printed.

ZebraNet_name — This is the name (alias) of the ZebraNet PSII. This must be the same 
name as entered in the /etc/ hosts file or your NIS or DNS system. An IP address may also 
be used here.

remote_print_queue_name — This entry determines the ZebraNet port where the print 
job will be printed and optionally specifies ASCII printing that must end for LF1.

path_to_spool_directory — This is the path to a directory where the print jobs will 
be spooled for this queue. You must create a unique spool directory for each printcap entry.

log_file_name — This is the path to a file where error information from the LPD will be 
logged. 

Important • You must be logged in as root.

Example • Your printcap entries might look similar to this:
Ascii_files|form.feed.Queue_on_Port_1:\

:lp=:mx#0:rm=pserver1:rp=MYQUEUELF1:\

:sd=/usr/spool/myqueuelf1:\

:lf=/usr/spool/myqueuelf1/queue.log

Important • Each printcap entry must have a different spool directory to work properly.
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System V Queue Installation

Configuring Operating System V Queue for ZebraNet Printing

This section describes the configuration of the printing system on the UNIX operating system. 
For clarity and brevity, the following specific names are used to represent general devices or 
concepts. 

lj4 — The local queue name on the UNIX system to which you want PSII print jobs directed.

ZEBRAPRINTER — The host name or IP address of the remote system that is the PSII device. 
For example, to Telnet to the PSII and invoke the PSII configuration utility, you would enter: 

Telnet ZEBRAPRINTER

A host name is not required for the PSII — the IP address can be used. 

yourqueuename — This is the name of the queue on the ZebraNet and must end with LF1.

Prerequisites   

Before you proceed, the following prerequisites must be met: 

• The name ZEBRAPRINTER and the IP address assigned to the PSII are in the /etc/hosts 
file on the UNIX system.

• The LPD must be running on the UNIX system.

UNIX Configuration

To configure the UNIX machine so users can spool print jobs to the PCL print 
queue on the ZebraNet named ZEBRAPRINTER, complete these steps: 

1. Log in to the UNIX machine as root. 

2. Type:
lpsystem -t bsd ZEBRAPRINTER

3. Type:
lpadmin -p lj4 -s ZEBRAPRINTER!yourqueuename - I any

4. Type:
accept lj4

5. Type:
enable lj4

6. Try printing by typing the command:
lp -d lj4 [filename]
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5
NetWare Print Configuration
This chapter provides you with instructions for configuring Novell’s NetWare for printing to 
PSII.
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Printing in PServer Mode
You must have Zebra’s snap-in for Novell installed to complete these steps.

To configure in Novell’s NetWare for printing to the PSII, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

2. Create a ZebraNet object by completing the following steps:

• From Novell’s NetWare Administrator, select the container in which you want the 
object created. 

• From the menu bar, select Object>Create.
If the Create option is gray, you do not have sufficient rights, or you selected a leaf object. 

• Find Zebra Print Server, select it, and click OK.
If the class of the object you want to create is not listed, you cannot create it in the 
container you selected.

• Define filter and sort devices for displaying a list of PSII devices to choose from, and 
click OK.

• Type in a name for the new PSII object, and click Create.
Wait for the print server to reset.

• (optional) To rename one of the PSII devices, select the one you want to rename, and 
click Create.

3. In the Directory Tree, find your object, and double-click.

4. Select Assignments>Assign>New.

5. Next to the Context text-box, click the Directory Tree icon, then double-click the browse 
arrow.

6. Find the Contexts container you want, and double-click.
It auto-fills into the Context text-box.

7. Enter the printer name you want, and click Create.

8. Next to the Print Queues section, click New.

9. Next to the Context text-box, click the Directory Tree, and double-click the Browse arrow.

10. Select the Context you want.
It auto-fills the text-box.

Important • Some important items to keep in mind before you proceed with these steps:

• You must have PSII installed before you proceed with these steps. 

• Snap-in for Novell only works with Windows 9X operating systems. 

Example • To create an object that is subordinate to sales, choose SALES.
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11. In the Print Queue Name text-box, type in the name you want.

12. Next to the Print Queue Volume text-box, click the Directory Tree icon.

13. Double-click the Volume you want, and click Create.
Your Print Queue Name is listed with the name of your Context as the extension.

14. Click OK, and then click OK again.
Wait for the print server to reset.

15. To refresh your Directory Tree, double-click on your context twice.
You now see the Object, Printer Name, and Print Queue that you created.

To attach a generic text driver to print to the PSII configured in NetWare, 
complete these steps:   

1. On Add Printer double-click, and click Next.

2. Select Network Printer, and click Next.

3. Click Browse and click on the context.
You can see the queue and printer that you created.

4. Select the queue, and click OK.
The Network path (queue name) auto-fills.

5. Click Next.

6. Select Generic for Manufacturer of printer, and click Next.

7. Select Keep Existing Driver, and click Next.

8. Enter the printer name you want and click Next.

9. Select No for printing a Test Page, and click Finish.

10. From the Printers dialog, double-click on your new printer and set it as the default printer.

11. Open a text editor, create ZPL (Zebra Programming Language) file, and print.
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6
Using Printing Protocols
In this chapter you are given steps to set up your PSII to support Internet Printing Protocol 
(IPP). Also, an exercise is provided to experiment with File Transfer Protocol (FTP) support.
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IPP 

IPP is an application-level protocol used for distributed printing over the Internet. Using IPP 
from any standard IPP client, you can transfer jobs to a printer that is connected to your 
ZebraNet PSII device and the Internet. 

To set up your PSII to support IPP, complete these steps:

1. Open a browser.

2. Enter the PSII IPP URL as follows:
http://xxx.xxx.xxx.xxx:631/ipp/port1

xxx.xxx.xxx.xxx = the IP address of the PrintServer II 
device

:631 = a fixed value

/ipp = a fixed string designating IPP

/port1 = a fixed value

Important • You must have IPP support on your system.

Important • IPP support is not available on all PSII printers. To be certain you are running 
the latest version of firmware, visit our Web site: www.zebra.com

Example • Your address might look like this:

http:198.60.248.120:631/ipp/port1

Note • Because IPP does not have an official standard, usage depends entirely on the 
quality of the IPP client and server.
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FTP 
Embedded within the PSII is an FTP server application that processes file transfers from a host 
computer to the printer.

If the printer is on a network, label formats can be generated and data can be transferred 
without setting up a print queue.

To send information to the printer in a Windows environment, try this 
alternative exercise: 

1. In a text editor, generate the following ZPL II code:
^XA

^FO100,100

^CF0,55^FDZebra Technologies^FS

^XZ

2. Save the file and name it test.txt.

3. Open the MS-DOS Command Prompt and type:
ftp <IP of PrintServer II>

This opens a session with the FTP server. 

4. Type your user name and press Enter.

5. Type:
put test.txt

This transfers test.txt to the printer, and the printer generates a label.

6. To terminate the FTP session, type:
quit

Example • If the IP address of your PSII device is 12.3.4.123, you would type:

ftp 12.3.4.123.

Note • The default user name is blank.
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PrintServer II
This appendix provides you with details on the PSII features that were not covered in the 
chapter Getting Started on page 43.
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PSII Features
This section covers features available for the PSII only, not the printer’s features. Some of the 
features you access in this section prompt you to enter the default user ID and password, as 
follows:     

• User ID: admin

• Password: 1234 

The options on the Print Server page vary. ZPL and EPL printers print server settings vary 
slightly.

Status and Configuration

The steps that follow are based on the navigation of a ZPL printer using firmware X.10 or 
higher.

To access the print server settings, complete these steps:

1. Open a Web browser.

Note • The difference between ZPL and EPL is this:
• ZPL — If you have a ZPL printer, you are initially prompted to the Printer Home 

page, and from there, you select Print Server Settings.
• EPL — If you have an EPL printer, you are immediately prompted to the Print Server 

page. 

Important • You can upgrade your firmware by visiting our Web site: 

http://www.zebra.com
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2. In the Address text-box, type your printer’s IP address, and press Enter.
The Printer Home Page opens:
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3. From the Printer Home Page, click Print Server Settings.

The PrintServer page opens:

Important • The illustration of the Printer Server Settings page is based on a ZPL printer. 
If you have an EPL printer, the menu options on the Print Server page are slightly 
different.
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4. From the PrintServer page, click Print Server.
The Print Server Configuration page opens:
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5. In the Print Server Configuration page, you have a menu to choose from. The table that 
follows identifies what each menu option page looks like:

Enabled Protocols
Modifies the protocols to be used. NetWare, HP 
JetAdmin, or both.
Enabling HP JetAdmin Support allows status 
from the Zebra device to display in Hewlett-
Packard’s HP JetAdmin utility.

Netware
Preferred Tree — Enter the tree that the printer is 
in.
Print Server Name — Enter the name of the 
printer.
Disable NetWare SAP — Enables or disables the 
broadcast SAP (Service Advertising Protocol) 
messages. Typically, SAP is enabled. If SAPs are 
disabled, the print server does not appear in the 
bindery and is not discovered by ZebraNet View. 
Disabling SAPs reduces network traffic, 
however, SAPs should be disabled, only on 
networks using NDPS exclusively or NetWare 5 
over the IP protocol.
NetWare Frame Format — You can select how 
the frames for the data packets are assembled. 
The default is Automatic Sensing.
For details, see Help. 
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TCP/IP Configuration
You can change the TCP/IP Configuration of the 
PSII.
For details, see Help.

TCP/IP Logical Printing Ports
Logical printers allow you to set up multiple pre- 
and post-processing configurations for each 
output port. Each logical port configuration can 
do the following:
• Add user-configured strings before and after 

the print data.
• Remove unwanted characters from the 

beginning of the print data.
• Four logical printer configurations are 

supported for each output port on the printer. 
The configurations can be assigned to any 
port, and all of these configurations can be 
assigned to a single output port.
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System (SNMP)
This feature gives you the ability to manage 
multiple devices on a network, be it printers, 
computers, or other network-attached devices.
On this page you can define the SNMP system 
name, system location (PSII description), and 
other SNMP settings for your PSII.

IPX Alerts (Traps)
Internetwork Packet Exchange (IPX) is 
Netware’s network-layer protocol that handles 
networking addressing, routing, and packets. 
This feature has you enter the IPX Network 
Address and IPX Node Address to which traps 
will be sent.
• To broadcast traps to all addresses on all 

networks, enter FFFFFFFF in the IPX 
Network address field and FFFFFFFFFFFF 
in the IPX Node Address field. 

• To broadcast traps to all addresses on a 
specific local network, enter the network 
number in the IPX Network Address field 
and then FFFFFFFFFFFF in the IPX Node 
Address field.

• To disable traps, set all destination addresses 
to 0.
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SMTP Email Alert Configuration
This feature allows you to enter data regarding 
System Information on the network that is being 
used. Typically, a Network Administrator would 
use this.
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Web Admin
This page allows you to configure the Admin 
name and password. Links to upgrades and 
support information can also be altered. 

POP3 Email Printing
This feature helps you set up the print server to 
receive email messages containing formats that 
can be printed. The POP3 settings must be set to 
retrieve emails from the email server. 

Warning • Setting the POP3 polling 
interval (seconds) below 30 can cause 
communication problems with the POP3 
server.
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Print Server Status

From the Print Server page, in the Print Server Status section you can access PSII’s 
configuration sheet and port status.

To open PSII’s configuration sheet, complete this step:

1. From the PrintServer page, click View Configuration Sheet.
This page opens:
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 To view the port status, complete this step: 

1. From the Print Server page, click View Port Status.
The port status page opens:

Important • The default user ID and password is required to access this page.
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Reset

From the Print Server page, in the Reset section you can reset PSII’s configuration settings to 
what they were before you made the most recent changes.

To reset the PSII, complete these steps:

1. From the Print Server page, click Reset Print Server.
The Reset Device page opens:

2. To reset PSII, click Yes.
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Restore

From the Print Server page, in the Restore section you can restore PSII’s to the default factory 
settings:

To restore PSII to the default factory settings, complete these steps:

1. From the Print Server page, click Factory Print Server Settings.
The Restore To Factory Defaults page opens:

2. Make the selections you want, and click Submit Changes.
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ZebraLink 
The appendix provides you with detailed information that allows you to use the enhanced 
functionality of your ZebraLink-enabled printer with the PSII.
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WebView
WebView gives the System Administrator or user who needs complete, easy, one-step control 
over the printing environment exactly what is needed. It provides real-time configuration, 
control, and monitoring capabilities with the convenient graphic interface of a Web browser. 

The Web pages returned by Zebra printers are not static. They contain real-time information 
about the printer’s present state of operation, including on-line status, error conditions, and all 
printing parameters. 

Home Page

The Home Page is the first Web page that opens. It is a page with a menu of hyperlinks. Each 
hyperlink allows you to make modifications to the printer, PSII, and network settings; the 
other changeable settings through the Home Page include:

• Network Status, Error, and Warning reports

• ZebraNet PSII configuration

• Printer settings

• Directories of objects stored in Flash memory and RAM devices

• Objects, stored fonts, images, programs, and ZPL II formats

• Zebra Technologies support and home pages

Note • To access the printer’s Web page, you need the IP address. For instructions on getting 
the IP address, see Assigning an IP Address on page 46.
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To open the WebView of your printer, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, and press Enter.
The Printer Home Page opens:
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View Printer Configuration 

The View Printer Configuration menu option provides accurate, up-to-the-minute information 
on the printer’s current state. An administrator can conveniently find any information on the 
Virtual Configuration Label and also check on the status of printer ports.

To see the View Printer Configuration menu option, complete these steps:

1. From the Printer Home Page, click View Printer Configuration.
The WebView displays the configuration settings:

2. To update the printer information from this view:

• For Netscape, select Reload and the printer sends current information to the Web 
browser.

• For IE, click Refresh and the printer sends current information to the Web browser.
45537L-005 ZebraNet PrintServer II User Guide 04/21/2009

Download from Www.Somanuals.com. All Manuals Search And Download.



103ZebraLink
WebView
3. When you are finished reviewing:

• To return to the Home page, click the Home link.

• To print the label, scroll to the bottom of this page and click Print Label. 

View and Modify Printer Settings

This section provides you with steps for accessing and modifying printer settings with a 
ZebraLink-enabled printer. It also provides illustrations of the various pages you can access.

To view the View and Modify Printer Settings, complete these steps:

1. From the Printer Home Page, click View and Modify Printer Settings.
The View and Modify Printer Settings page opens:

Important • To apply changes made in this section, you need to use the default user ID and 
password:

User ID: admin 

Password: 1234
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2. In the View and Modify Printer Settings page, you have a menu to choose from. The 
section that follows identifies what each menu option page looks like:

General Setup

Serial Communications Setup
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Network Communications 
Setup

Print Listings on Label
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Media Setup

Calibration
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ZPL Control

Advanced Setup
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Directory Listing 

The directory page provides a listing of all file system devices (B:, E:, R:, Z:). The size, name, 
and location of each stored object appears.

Buttons are available to perform file management operations on the objects. The file 
management operations include:

• Delete object — Not available for objects in read-only memory (Z:).

• Copy object to a new name and/or device — Not available for objects in read-only 
memory (Z:).

To view the Directory Listing, complete these steps:

1. From the Printer Home Page, click Directory Listing.
This page opens:

2. There are several links to select in this view. 

3. To create a script, click Create New Script.
45537L-005 ZebraNet PrintServer II User Guide 04/21/2009

Download from Www.Somanuals.com. All Manuals Search And Download.



109ZebraLink
WebView
Alert Setup

To configure the printer’s interaction with ZebraNet Alert to be completely functional, SNMP 
settings must be established in these areas:

• The printer, via the WebView interface.

• The Alert Printer Management Utility for logging SNMP traps.

The ZebraLink messaging system provides for more than SNMP notification. Alert can be 
routed to various destinations:

• TCP

• UDP

• email

• serial port

• parallel port destinations

To view Alert Setup, complete these steps:

1. From the Printer Home Page, click Alert Setup.
The Alert Messaging System page opens:

2. To add an alert, click Add Alert Message.

3. Select accordingly.
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Establishing Email Alert Messaging

ZebraNet Alert supports email notification of printer errors sent directly to any valid email 
address. You can have multiple email addresses set up for routing different error messages, or 
split notifications between email and other network management tools. 

To begin receiving email notification of errors, complete these steps:

1. From the browser, in the address text-box type in the printer’s address. 
The printer’s home page opens.

2.  From the Printer Home Page, click Alert Setup.
The Alert Setup page shows a list of message notifications and their respective 
destinations. 

3. From the Alert Setup page, email notification can be set up. Click  
Add Alert Message.
The Add Alert Message page opens:

.

Important • The printer accepts only the last configuration made.
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4. Specify the condition to send over email, such as HEAD ELEMENT BAD or PAPER 
OUT.

5. Enter a valid email address for the messages to be sent.

6. Click Add Alert Message. Here you can continue to add more settings or, if finished, save 
the current settings.

7. From the Printer Home Page, select PrintServer Settings>Network Communications 
Setup. 

8. Click SMTP Email Alerts.

9. Specify your SMTP server address. 
When these steps are done, you can begin receiving email notification messages.

Example • admin@yourcompany.net (The Port field can be ignored for email 
setup.)

Important • You must type in a password. If you forget to enter the default password, the 
alerts you just set are deleted.
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Printer Controls

This page offers control over basic printer functions. 

Other functions are also accessible from this page. These include:

• Feed — causes printer to feed one label.

• Cancel One Format — cancels the currently printing format.

• Cancel All Formats — cancels all formats.

• Reset Printer — causes printer to perform its standard reset without cycling 
power. 

To view Printer Controls, complete these steps:

1. From the Printer Home Page, click Printer Controls.
This Printer Controls page opens:

Important • In this view, you must have administrative rights to make changes to the 
printer controls. 
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Print Server Settings

This section provides you with instructions for viewing the current printer settings.

To view the print server menu, complete these steps:
• From the Printer Home Page, click Print Server Settings.

 The PrintServer page opens:   

For more details on PSII, see PrintServer II on page 85.
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ZebraNet Utilities 
The appendix provides you with details on ZebraNet Utilities, the software suite of printer 
administration tools that complements and enhances both ZebraLink and the ZebraNet family 
of connectivity products. 
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ZebraNet View
ZebraNet View allows you to locate printers automatically. It can search on parameters such as 
IP address, subnet, printer model, printer status, and many other user-defined characteristics. It 
also offers powerful device management capabilities.

To open ZebraNet View Utilities, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
The ZebraNet View dialog opens:

2. Select your printer.
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3. From the menu bar, select PrintServer>Configuration.

The Print Server Configuration dialog opens:

There are multiple tabs that you can access to make changes to current settings. 
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To set alerts in ZebraNet View, complete these steps:

1. From the Print Server Configuration dialog, click the SNMP Traps tab.
The SNMP Traps tab shows the alerts you can set.

2. To monitor the set alerts (printer traps), see ZebraNet Alert on page 119.

The check 
boxes in 
Printer Traps 
are the 
alerts.
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ZebraNet Alert 
ZebraNet Alert gives you the ability to manage your Zebra printers by immediately notifying 
System Administrators of printer error or warning conditions. Using Web- based configuration 
tools, selected errors or warning conditions can be routed to a variety of services such as email 
messages, wireless pagers, or the ZebraNet Alert.

The following tables show the conditions that can trigger alerts:

PSII Alerts

These conditions can trigger PSII alerts:

• On-line (condition clear)

• Off-line

• Paper out

• Printer error

ZebraLink Alerts

These conditions can trigger ZebraLink Alerts:

• Media out

• Ribbon out

• Printhead over-temp warning

• Printhead under-temp warning

• Head open

• Power supply over-temp

• Ribbon warning (in direct-thermal mode)

• Rewind full

• Cut error

• Printer paused

• PQ job completed

• Label taken

• Head element out

• Power on
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ZebraNet Alert Destinations 

Unsolicited Alert messages can be directed to the following destinations:

• Email (PSII-specific)

• Serial (ZebraLink-specific)

• Parallel (ZebraLink-specific)

• TCP (PSII-specific)

• UDP (ZebraLink-specific)

• SNMP (PSII-specific)

ZebraNet Alert Using SNMP 

You can send notifications over SNMP only, for use with ZebraNet Alert or a similar network 
management utility. 

To configure the PSII to send alerts across a TCP/IP Network to ZebraNet Alert, 
complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

2. Select the printer you want.

• If a DHCP server is present, the PSII will already have an IP address.

• If no DHCP server is present, you might need to assign the printer an IP address.

3. To assign your printer an IP address, from the menu bar, select Print 
Server>Configuration.

4. For PrintServer SNMP Traps, select the SNMP Traps tab.

5. Enter the trap destination and options.
This tells the PSII what TCP/IP address to send the alerts to, and under what 
circumstances to send error and log reports. Entering 255.255.255.255 broadcasts the 
message to every host on the network with an SNMP program running.

Important • If you did not install ZebraNet Alert during the ZebraNet Utilities installation, 
see ZebraNet Utilities on page 37.
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6. For ZebraNet Alert to get and display the messages, you need to open ZebraNet Alert. To 
do this, follow these steps:

• From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.

• In the ZebraNet Alert dialog, from menu bar, select View>Filter Settings. 

• From the View Filter - Devices tab, choose your settings accordingly.

• The View Filter - Events tab allows you to select individual events you want the 
program to be aware of.

Sending Email to Your Zebra Printer

To easily transfer instructions and data to your printer from a remote location, PSII allows you 
to send email to the printer. This is set up under the link POP3 Email Printing. You need to 
provide the address of the network POP3 server, a user name, and a password.

With this option, you can create a text-based email containing ZPL II code and transfer it to 
the printer.

By using the proper ZPL II commands, files can be saved, loaded, printed, copied, and deleted, 
just as if the data were transferred from a serial or parallel port.

Important • The SNMP trap settings must be established to communicate with PSII if 
messages are sent to the ZebraNet Alert.

Note • If you select No device filtering, messages from every printer are caught; Device 
Address allows you to specify which IP address data will come from.

Important • Now PSII’s SNMP Alert messages can be set up in WebView. From the 
printer’s home page, activate the link to Alert Setup. You can add messages that are sent 
to the ZebraNet Alert for Windows by choosing SNMP as a destination.

Note • Email attachments sent to the printer are not supported.
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To access POP3, complete these steps: 

1. From the Printer Home page, click Print Server Settings.
The PrintServer page opens:
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2. From the PrintServer page, click Print Server.
The Print Server Configuration page opens:
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3. From the Print Server Configuration page, click POP3 E-mail Printing.
The POP3 Printing Configuration page opens:

4. Make the necessary changes, and click Submit Changes.

ZebraNet Alert monitors status and activity of all Zebra printers on the network. It alerts the 
administrator when there is an error condition, which reduces printer downtime and increases 
application efficiency.
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Open Alert

To open ZebraNet Alert, complete these steps:

1. From the task bar, select Start>ZebraNet Utilities>ZebraNet Alert.

2. In the ZebraNet Alert dialog, from the menu bar select Report>. The report menu option 
has multiple report selections.

3. Select the type of report you want to generate.

This is an example of the Event Summary report. Notice it generates a .log file:

ZebraNet Connect 
For details, see Setting Up a ZebraNet Connect IP on page 63.
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ZebraNet View Java Applet 
ZebraNet View Java Applet is a Java-based version of ZebraNet View. This can run on any 
enabled platform that can run a Java virtual machine, such as Windows, UNIX, Linux, and 
many others. 

To access ZebraNet View Java Applet, complete these steps: 

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View Java Applet 
1.0.
This view opens:

Important • To use this, you must have installed it with ZebraNet Utilities and then installed 
this application. For installation instructions for ZebraNet Utilities, see ZebraNet View Java 
Applet on page 40.
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2. In the Search Method drop-down list box, select the search method you want.

3. Click Begin Search.
It searches your network for all networked Zebra printers, discovers them, and lists them.

4. When you select a device from the list that is discovered, the selected device’s Home Page 
displays in the lower portion of the view (it replaces the ZebraNet View Web 
Configuration Utility content).
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Hardware Troubleshooting
This provides you with solutions to known issues.
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Troubleshooting the PSII

Resetting to Factory Defaults 

To reset the PSII configuration parameters to the factory defaults, press the Test button and 
hold it in while turning the printer power on. Keep the test button pressed until the Status 
Indicator light turns green, then release the test button. After approximately 20 seconds, a 
configuration label prints automatically.

Status Indicator   

A bi-color Status Indicator displays the operational status of the PSII. The following 
conditions might occur:

• During normal operation, the LED is solid green for more than 30 seconds. This indicates 
all the hardware is functioning properly and it has detected the presence of the network. It 
does not mean the PSII has an IP address or is attached to a printer queue.

• If the LED is rapidly flashing green (9 times/sec), the PSII has not detected the presence of 
a network cable. To solve the problem:

• Turn the printer power off. Remove the network cable from the PSII. Plug the 
network cable back in until you hear a positive click. Check the other end of the cable 
in the same manner. Turn the printer power on. If the PSII still does not detect a cable, 
continue.

• Verify that the network cable is 10BASE-T and has an RJ-45 connector. 

• Connect the PSII to a network drop that is a known good network connection. If the 
PSII is still unable to detect the network cable, contact Technical Support for 
assistance.

• If the LED is slowly flashing green (1 time/sec), the PSII is trying to print a job. If the job 
does not print, check the following:

• Verify that the printer has media and ribbon (if in thermal transfer mode). If the 
printer is showing any errors, it is unlikely that the PSII can send data to the printer. 
The LED continues to blink until the printer malfunction is resolved or until the 
printer is turned off.

• Flashing red indicates the Power On Self Test (POST) is in progress.

• If the LED is solid red for more than 30 seconds, the PSII has failed the POST. If the 
failure is not severe, the PSII attempts to print a configuration label on the printer. A failed 
POST can be caused by any of the following:

• The printer attached to the PSII device is malfunctioning. Turn the printer power off, 
wait 10 seconds, then turn the printer back on. 

• If the PSII still fails the POST, continue below. The PSII has a hardware problem that 
can be fixed only by replacing or returning the unit. Contact Technical Support for 
repair or replacement information.

Important • Cables with a rating higher than CAT-5 have not been tested.
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• If the LED is alternately flashing red and green for longer than 2 minutes, the PSII is in 
firmware-download mode. This means it is waiting for new firmware data to be sent 
before it continues normal functioning. Perform the following:

• If the PSII was purposely put into firmware-download mode, finish the download 
with the proper update utility. Contact the Zebra Web site at        
http://www.zebra.com to download this utility.

• Contact Technical Support for help recovering this unit.

ZebraNet View Utility Discovery or Configuration Problems

If you are having problems using the ZebraNet View utility to discover or configure the unit, 
check the following:

• Verify there is not a router between the workstation running ZebraNet View and the PSII. 
Because the PSII does not have an IP address, TCP/IP communication cannot be started 
across a router. Run ZebraNet View on the same subnet as the PSII. This is not a limitation 
when using ZebraNet View for HP JetAdmin in IPX/SPX Discovery Mode.

• Verify the PSII has a solid green light. If the LED shows a rapidly flashing green light, 
check the network cable that is attached.

Unable to Print 
• If you are having problems printing, verify that there is communication between the PSII 

and the printer. Check the following:

• Print a configuration label by pressing the test button on the PSII. If a configuration 
label does not print, verify the printer has media and ribbon (if used) and is not 
paused. 

• If problems persist, contact Technical Support.

Unable to Configure Device 

To assign an IP address to a ZebraNet PSII using ZebraNet View, you must be on the same 
subnet. If ZebraNet View has Multicast enabled, you might be able to view the ZebraNet PSII 
on another subnet, but you will not be able to configure the device.

HP JetAdmin or HP Web JetAdmin    

The ZebraNet PSII might be set up and managed using HP JetAdmin or HP Web JetAdmin 
products.
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E
Frequently Asked Questions
This is a group of frequently asked questions (FAQs) about PSII.
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FAQs
This table provides frequently asked questions (FAQs) on PSII:

Question Answer

Are there any differences in 
functionality between a ZebraNet 
PSII with an EPL-based printer and 
with a ZebraLink-enabled ZPL 
printer?

Yes.
• In a ZebraLink environment, with either a Web 

browser or with the ZebraNet View Utilities, 
there are a variety of Web pages that display a 
wealth of status information regarding both the 
ZebraLink printer and its ZebraNet PSII. 
However, when used with an EPL printer, such 
as the LP/TLP 2844, the Web pages for printer 
status are not available at this time, only the 
Web pages showing status of the PSII are 
displayed. The PSII can be easily configured. 
However, printer configuration information 
regarding the EPL printer is not available via 
the ZebraNet Utilities. 

• Error conditions: Using ZebraNet Alert, an EPL 
printer can be configured to use different IP 
addresses to report the following Alert status 
conditions: on-line, off-line, paper out.

• For EPL: only two destinations can be 
configured to report error messages (online, 
offline, and paper out) using SMTP email alert – 
serial and parallel port destinations are not 
supported.

Can the internal ZebraNet PSII 
option work on a computer network 
that is running both TCP/IP and IPX 
protocols simultaneously?

Yes. 
The ZebraNet PSII runs all of its available 
protocols simultaneously. This means that the 
ZebraNet PSII can run on mixed networks such as a 
network using Microsoft, UNIX, and Novell 
NetWare operating systems.

Will the ZebraNet PSII allow 
connectivity to anything other than a 
PC network?

Yes. 
The ZebraNet PSII allows connectivity to systems 
such as IBM’s AS400, provided that it is 
configured using TCP/IP. Other network protocols 
can be used with third-party adapters that are 
converted to 10BASE-T.

Will the ZebraNet PSII option work 
on a 100BASE-T per second network?

No. 
The ZebraNet PSII option is a 10BASE-T print 
server. This means that the data cannot travel any 
faster than 10 megabits per second. The ZebraNet 
PSII can be deployed on a network that is utilizing 
10/100 hubs, but the ZebraNet PSII operates at only 
10 megabits per second. 
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What if a print job makes it to the 
queue, but never leaves the queue? 
The label does not print. 

These are the things to check:
• Confirm that the printer is turned on and 

receiving power. 
• Confirm that the network cable is plugged in 

and that you can ping the printer.   
If the above bullets do not change the outcome, it is 
likely that there was a misconfiguration while 
creating the queue. The queue must be recreated 
verifying the following:

• Confirm that you use the print server’s valid 
IP address. 

• If you are using a UNIX or AS/400 host, 
there is an option for the remote queue 
name. There is only one valid response to 
use: PORTLF1.

• If Windows does not have LPR installed, the 
above required option should be left blank.

• See the documentation for other operating 
system specific queue creation.   

What are the minimum requirements 
to network a printer?

• Cat-5 network cable with 10BASE-T 
connectors

• PSII
• Hub or Switch
• If a hub or switch is NOT used, you need a 

cross-over cable.
• Workstation running a TCP stack with print 

services installed

What do the activity lights on the PSII 
mean?

• Fast blinking (9 times/second) — no link status
• Slow blinking (1 time/second) — no IP address, 

or the unit is sending data to the parallel port
• Blinking red — unit is still in POST
• red-green-red-green — unit is in Netware 

firmware update mode
• red-red-green-green — unit is in IP firmware 

update mode
• Solid red — unit has failed POST. Remove 

network cable and restart printer

What is the default User ID and 
password for the print server?

• The User ID is admin and the password is 1234.

Question Answer
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What ports are open on PSII and 
related software?

TCP Ports:
• 21 FTP
• 23 Telnet
• 80 HTTP Server
• 515 Printer port
• 631 IPP port
• 9100 Raw socket connection
UDP Ports:
• 161 SNMP broadcast from PSII
• 162 SNMP trap on ZebraNet Alert
• 4201 discovery destination on PSII
• (dynamic) SNMP get request from ZebraNet 

View
• (dynamic) discovery broadcast from ZebraNet 

view
• (dynamic) discovery broadcast from ZebraNet 

view Java

What are my network connectivity 
options based on when using a PSII? 

It depends on your environment, but the print 
server accepts print jobs in any of the following 
ways:
• FTP — ZPL/EPL files can be sent to the printer 

via a FTP client as standard ASCII files
• HTTP — (ZebraLink-enabled printers only) 

Using the script option of the print server’s 
homepage, you can type ZPL into a specified 
location of the Web browser and send it to the 
printer 

• IPP — Using third-party IPP clients, print jobs 
can be sent via the internet

• LPR/LPD — Sometimes referred to as queue 
based printing. LPR/LPD is the standard in 
network printing. Most TCP/IP operating 
systems are compatible with this option

• Raw socket connection — You can connect to 
the printer directly via the network, bypassing 
everything in-between. This option is 
commonly used to integrate ZPL/EPL into 
existing programs, such as VB scripts

• POP3 — With proper configuration, you can 
place ZPL/EPL files into the body of an email, 
and it will print. The print server periodically 
checks this email box at the specified intervals 
and prints the body of the message. 
IMPORTANT: attachments and subject line are 
not supported

Question Answer
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10BASE-T   A type of Ethernet that uses unshielded twisted pair cable.

arp   The standard TCP/IP method for determining the actual network address of a device 
based on its IP address. 

ASCII   A standard for the binary representation of characters. 

BOOTP  BOOTP (Bootstrap Protocol) is a protocol that lets a network client configure 
automatically. It can automatically configure any of the following information: IP address, 
gateway, subnet, system name, name server, and more. It automatically assigns the necessary 
settings from a pool of pre-determined addresses for a certain duration of time. BOOTP is the 
basis for a more advanced network manager protocol, the DHCP (Dynamic Host 
Configuration Protocol). 

broadcast  In a network, a situation when all destinations on the network receive a given 
packet. 

client   A workstation or PC in a client/server environment. 

community  For SNMP, a relationship between an agent and a set of SNMP managers that 
defines security characteristics. The community concept is a local one, defined at the agent. 
Each community is given a unique community name. 

DHCP (Dynamic Host Configuration Protocol)   DHCP is an alternative to another 
network IP management protocol, Bootstrap Protocol (BOOTP). Like BOOTP, DHCP can 
configure an IP address, gateway, subnet, system name, and name server. When speaking 
about the PSII, BOOTP, and DHCP configure the same options.

delete bytes  This number is used to remove characters from the beginning of every job sent 
to the logical printer. The value for delete bytes can range from 0 to 255. 
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dynamic  A dynamic configuration, as the name implies, means that it changes. BOOTP and 
DHCP offer time-based leases for the configurations they assign. Their changes depend on the 
time-based lease, and how often the printer itself is offline and online again. A dynamic 
configuration includes BOOTP or DHCP. 

EPL  Eltron Programming Language.

Ethernet  A widely used local area network system based on the IEEE 802.3 standard. 

firmware  Software routines that are stored in ROM (Read Only Memory). This is typically 
part of a device, such as a printer or PSII. 

FTP  File Transfer Protocol, a TCP/IP-related protocol for transferring files between devices 
on a network. 

Flash memory  A type of memory that allows read-and-write operations, but permanently 
stores data when the power is turned off. Useful for storing firmware because it can be easily 
updated by downloading new code. 

gateway  A device that converts one higher-level network protocol to a different higher level 
protocol. 

gleaning  A temporary, local configuration option. Gleaning lets you add the address of the 
device you want to configure to your local workstation’s arp table. This configuration is not 
permanent and is valid only from the workstation from which you entered the arp information. 
After the information is entered into the workstation’s arp table, the user follows up with a 
Telnet session to enter the information permanently. This configuration option is used mostly 
by non-Windows workstations that cannot run the ZebraNet View configuration utility. 

IP  Internet Protocol, one of the main protocols of the TCP/IP protocol suite. 

IP address  A network address used by the TCP/IP protocol.

IPP  Internet Printing Protocol. Allows you to associate a printer with a URL address that is 
used for printing over the Internet.

IPX   Internetwork Packet Exchange, one of the NetWare protocols.

JetAdmin  A Hewlett-Packard printer management program available for NetWare and 
TCP/IP. 

logical  Refers to conceptual rather than physical. For example, a computer might have a 
single physical connection to the network (an Ethernet adapter card), but could have logical 
connections to several other devices on the network. 

MAC Address  Media Access Control. Ethernet address that corresponds to the assigned IP 
address. 

name server  A workstation on a TCP/IP network that provides a list of all workstations on 
the network. 

NetWare  A network operating system developed by Novell. 
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node  A device connected to a network, such as a computer or print server.

parallel port   A port on a device that sends information in groups of bits over multiple 
wires, one wire for each bit in a group. 

ping  A TCP/IP command that determines whether a device is accessible on the network. 

POP3  Post Office Protocol, the protocol used to retrieve email from the server. 

port  A physical connector, such as the parallel port, or a logical connection to a device.

post string  A string that is sent at the end of every job going to the logical printer. 
Maximum 64 characters long.

pre string  A string that is sent at the beginning of each job that goes to the logical printer. 
Max 64 characters long. 

print server  A device in a network that changes a network protocol into a printer protocol. 

protocol  A method of sending and receiving data between two or more workstations on a 
network, and insuring that the data is received without errors. 

rarp  Reverse Arp, a standard TCP/IP method of determining a device’s IP address based on 
its Ethernet address. 

raw TCP port  A type of TCP port in which data is passed unmodified to the receiving node. 

RJ45  A type of modular jack connector similar to a telephone connector with up to eight 
wires. Used for 10BASE-T Ethernet connections and for serial port connections. 

serial port  On a printer or print server, a port that transfers data one bit at a time. Serial ports 
usually have either a 25-pin, 9-pin "D", or RJ45 connector. 

server  A device on a local area network that provides services to client computers on the 
network. 

SMTP  Simple Mail Transfer Protocol, a protocol used to send email messages over the 
Internet. 

SNMP  Simple Network Management Protocol, a protocol for monitoring and controlling 
devices on a network. 

spooling  In printing applications, spooling is the transfer of data to a temporary storage area 
on disk (the print queue) prior to printing. Spooling allows many jobs to be queued to a single 
printer. 

static  Refers to a static IP address. All information is provided by the network administrator. 

subnet mask  A TCP/IP method of dividing a network into several smaller subnetworks. 

TCP/IP  Transmission Control Protocol/Internet Protocol, the de facto standard for Internet 
communications that is widely used on local area networks.
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TCP Port  A method of accessing a TCP/IP service, where a device with a single IP address 
can have multiple TCP ports. 

Telnet  A TCP/IP protocol that allows two devices to communicate over a LAN. 

trap  An unsolicited message sent by an SNMP agent to an SNMP management station. It 
notifies the management station of some unusual event. 

UNIX  A general-purpose computer operating system used on many different kinds of 
computers.

WCSO  Wireless Card Socket Option. Zebra’s wireless Ethernet option. 

Windows 95 and Windows 98  Microsoft’s PC operating systems that feature built-in 
peer-to-peer networking. 

Windows NT  Microsoft’s multitasking operating system that can be used either as a client 
or as a server. 

Windows 2000  Microsoft’s multitasking operating system that replaces Windows NT; can 
be used as either as a client or as a server. 

ZebraNet PrintServer II  An Ethernet connectivity solution. 

ZebraLink  Allows you to connect and control your bar code printers anywhere and anytime. 

ZPL II  Zebra Programming Language II is a powerful label-definition and printer-control 
language. 
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