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Warranty Information

ZebraNet® PrintServer II

Zebra Technologies Corporation warrants the ZebraNet PrintServer II against defects 
in material or workmanship for a period of three years from either (i) the date of 
shipment to you by Zebra Technologies Corporation, or (ii) the date of any resale by 
you to an end user, whichever is later. Proof of shipment date may be required to 
validate the warranty period. This warranty does not cover normal wear and tear, and 
shall be null and void if the equipment is modified, improperly installed or used, 
damaged by accident or neglect, or improperly installed or replaced by the user. To 
qualify for this warranty, the ZebraNet PrintServer II must be returned to the factory or 
other authorized service center.

ZEBRA TECHNOLOGIES CORPORATION’S SOLE OBLIGATION UNDER THIS 
WARRANTY SHALL BE TO FURNISH PARTS AND LABOR FOR THE REPAIR 
OR REPLACEMENT OF PRODUCTS FOUND TO BE DEFECTIVE IN 
MATERIAL OR WORKMANSHIP DURING THE WARRANTY PERIOD, OR 
ZEBRA MAY, AT ITS DISCRETION, ISSUE A CREDIT FOR ANY SUCH 
DEFECTIVE PRODUCTS IN SUCH AMOUNT AS IT DEEMS REASONABLE.

As a condition of this warranty, the user must: (a) obtain a Zebra Return Materials 
Authorization (RMA) which will include an RMA number that must be prominently 
displayed on the outside of the shipping container (returns without an RMA number 
will be rejected by Zebra and immediately returned to you, freight collect); (b) ship the 
Product being returned freight prepaid, to the authorized service location; and (c) 
PrintServer II User and Reference Guide iii

Download from Www.Somanuals.com. All Manuals Search And Download.



Warranty Information
include with the Product a written description of the claimed defect. Products returned 
should be packaged in the original packing and shipping container or comparable 
container. In the event the Product is not so packaged or if shipping damage is evident, 
it will not be accepted for service under warranty. Surface transportation charges for 
the return of the Product to the customer shall be paid by Zebra Technologies 
Corporation within the 48 contiguous states and the District of Columbia. The 
customer shall pay shipping costs, customs clearance, and other related charges 
outside the designated area. If Zebra Technologies Corporation determines that the 
Product returned to it for warranty service or replacement is not defective as herein 
defined, the customer shall pay all costs of handling and transportation.

Warranty Exclusions and Conditions

The above warranty is in lieu of all other warranties, expressed or implied, oral or 
written, statutory or otherwise, including any implied warranty of merchantability or 
fitness for a particular purpose. Zebra Technologies Corporation shall not be 
responsible for the specific application to which any Products are applied, including 
but not limited to compatibility with other equipment. All statements, technical 
information and recommendations relating to Zebra Products are based upon tests 
believed to be reliable but do not constitute a guarantee or warranty.

ZEBRA TECHNOLOGIES CORPORATION SHALL NOT, UNDER ANY 
CIRCUM- STANCES WHATSOEVER, BE LIABLE TO THE BUYER OR ANY 
OTHER PARTY FOR LOST PROFITS, DIMINUTION OF GOOD WILL, OR ANY 
OTHER SPECIAL OR CONSEQUENTIAL DAMAGES WHATSOEVER WITH 
RESPECT TO ANY CLAIM HEREUNDER. IN ADDITION, ZEBRA 
TECHNOLOGIES CORPORATION’S LIABILITY FOR WARRANTY CLAIMS 
SHALL NOT, IN ANY EVENT, EXCEED THE INVOICE PRICE OF THE 
PRODUCT CLAIMED DEFECTIVE, NOR SHALL ZEBRA TECHNOLOGIES 
CORPORATION BE LIABLE FOR DELAYS IN REPLACEMENT OR REPAIR OF 
PRODUCTS.

No salesperson, representative or agent of Zebra Technologies Corporation is 
authorized to make any guarantee, warranty, or representation in addition to the 
foregoing warranty.

NO WAIVER, ALTERATION, ADDITION, OR MODIFICATION OF THE 
FOREGOING WARRANTY SHALL BE VALID UNLESS MADE IN WRITING 
AND SIGNED BY AN EXECUTIVE OFFICER OF ZEBRA TECHNOLOGIES 
CORPORATION.
iv  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



Warranty Information
Software License Agreement

Software and documentation provided by Zebra Technologies Corporation are 
protected by the United States copyright law and international treaty, and therefore 
you must treat them like a book, with the exception that you may make copies of the 
software to protect yourself against loss of the original.

Your right to use the software and documentation as described below is non-exclusive 
and non-transferable. Zebra Technologies Corporation retains ownership of the 
software and documentation and all other rights, title, and interest. The software and 
documentation may be used by any number of people and may be freely moved from 
one computer to another as long as there is no possibility of their being used by more 
than one person on more than one computer at the same time.

Machine readable files representing graphics or fonts which you have created 
independently may be converted to ZPL format files using the software and such files 
may be used, copied onto diskettes or font cards, given away, or sold without paying 
license fees to Zebra Technologies Corporation. Pictorial or graphic images and any 
machine readable files representing them, may be protected by United States copyright 
law and international treaty provisions which prohibits you from transcribing or 
scanning such images or using, copying, or converting such files without permission 
of the copyright owner. You may not use this software in violation of U.S. copyright 
law or international treaty. By using this software, you agree to be bound by these 
terms.

Zebra Technologies Corporation warrants the software diskettes to be free of defects in 
material and workmanship for a period of 60 days from the date of purchase. In the 
event of notification within the warranty period of defects in material and 
workmanship, Zebra Technologies Corporation will replace the defective diskette or 
documentation. Zebra specifically disclaims all other warranties, expressed or implied, 
including but not limited to implied warranties of merchantability and fitness for a 
particular purpose. IN NO EVENT WILL ZEBRA TECHNOLOGIES BE LIABLE 
FOR LOST PROFITS, LOST DATA, OR ANY OTHER INCIDENTAL OR 
CONSEQUENTIAL DAMAGES CAUSED BY ABUSE OR MISAPPLICATION OF 
THE SOFTWARE OR BY ITS USE IN VIOLATION OF THE U.S. COPYRIGHT 
LAW OR INTERNATIONAL TREATY.

This product document refers to hardware and software products by their trade names. 
ZebraNet™ is a trademark of Zebra Technologies Corporation. The PrintServer II is a 
product of Zebra Technologies Corporation. All other designations are trademarks or 
registered trademarks of their respective companies.
PrintServer II User and Reference Guide v
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I have determined that the Zebra print server or product identified as the

ZebraNet PrintServer II

manufactured by:

Zebra Technologies Corporation
333 Corporate Woods Parkway

Vernon Hills, Illinois 60061-3109 U.S.A.

have been shown to comply with the applicable technical standards of the FCC

for Home, Office, Commercial, and Industrial use

if no unauthorized change is made in the equipment,
and if the equipment is properly maintained and operated.
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Preface

The Preface discusses the topics and illustrates standards that are used throughout this 
guide.

These are the main topics:

• Contacts on page 2
• About this Document on page 3
• Document Conventions on page 5
• Related Documents on page 7
PrintServer II User and Reference Guide 1
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Contacts
Contacts

You can contact Zebra Technologies Corporation, USA at any of the following: 

Visit us at:   http://www.zebra.com

Our Mailing Address:   
Zebra Technologies Corporation
333 Corporate Woods Parkway
Vernon Hills, Illinois 60061.3109 U.S.A
Telephone +1 847.634.6700
Facsimile +1 847.913.8766

Zebra Technologies Europe Limited
Zebra House
The Valley Centre, Gordon Road
High Wycombe
Buckinghamshire HP13 6EQ, UK
Telephone +44 (0)1494 472872
Facsimile +44 (0) 1494 450103

Support

You can contact Zebra support with any questions or problems with your ZebraNet 
PrintServer (PSII):

Support email:  http://support.zebra.com 

Phone number:  847.913.2259
2  PrintServer II User and Reference Guide
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About this Document
About this Document

The ZebraNet PrintServer II Guide consists of these chapters:

Title Content Description

Introduction This chapter provides a high-level overview of 
the ZebraNet PrintServer II (PSII), installation 
instructions, standard network configurations 
and how to work with PSII. 

Installation This chapter provides information on how to 
install PSII (external and internal) and the 
ZebraNet Utilities.

Getting Started This chapter provides you with information 
and procedures to work with the most 
frequently used PSII features. 

NetWare Print Configuration This chapter provides you with instructions on 
how to configure Novell’s NetWare for printing 
to PSII.

Printing Configurations This chapter provides information and 
instructions on configuring your printer.

Using Printing Protocols Provides information and steps to setup your 
PSII to support IPP (Internet Printing 
Protocol).

PrintServer II This appendix provides you with details on the 
most commonly used features of PSII.

ZebraLink The appendix provides you with detailed 
information that allows you to use the 
enhanced functionality of your ZebraLink 
enabled printer with the PSII.

ZebraNet® Utilities The appendix provides you with details on 
ZebraNet® Utilities, the software suite of 
printer administration tools that complements 
and enhances both ZebraLink and the ZebraNet 
family of connectivity products.

Hardware Troubleshooting This provides you with solutions to known 
issues.
PrintServer II User and Reference Guide 3
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About this Document
Frequently Asked Questions  This is a group of frequently asked questions 
(FAQs) about PSII.

Glossary This provides a glossary of terms that are 
specific to the PSII.
4  PrintServer II User and Reference Guide
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Document Conventions
Document Conventions

The following conventions are used throughout this document to convey certain 
information: 

About this Chapter Sections  This section lists and describes each main section 
of the chapter, including the initial page number of that section. These sections 
primarily serve as hyperlink components for the Adobe Acrobat .pdf version of this 
guide.

Alternate Color  (online only) Cross-references contain hot links to other sections in 
this guide. If you are viewing this guide online in .pdf format, you can click the 
cross-reference (royal blue text) to jump directly to its location. 

Command Line Examples  All command line examples appear in Courier font. 
For example, you would type the following to get to the Post-Install scripts in the bin 
directory:

Ztools

Files and Directories  All file names and directories appear in Courier New font. 
For example, the Zebra<version number>.tar file and the /root directory.

Warning, Caution, Important, Note and Example  These topics are defined in 
the following example:         

 ! Warning • Advises you that failure to take or avoid a specific action could result in 
physical harm to you or the hardware.

Caution • Advises you that failure to take or avoid a specified action could result in 
loss of data.

Important • Provides information that is essential to the completion of a task.

Note •  Indicates neutral or positive information that emphasizes or supplements 
important points of the main text.
PrintServer II User and Reference Guide 5
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Document Conventions
Illustration Callout Instruction  Illustration callout instructions are used when an 
illustration contains either information about a dialog box or step(s) to accomplish in a 
dialog box.

This illustration callout instruction identifies a section of the dialog box and the other 
callout shows steps to follow:

Example • Provides an example, often a scenario, to better clarify a section of text.

When you are 
finished, click OK.

In the Set 
Permanent 
text-box, 
type in the 
print 
server’s IP 
address
6  PrintServer II User and Reference Guide
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Related Documents
Related Documents

In addition to the ZebraNet PrintServer User and Reference Guide, the following 
documents might be helpful references while using PSII:

• Wireless Card Socket Option (WCSO)Install and Users Guide
• The ZebraLink Solution Application White-paper
• ZBI Guide

• ZPL II® Programming Guide Volume One: Command Reference for X.10

• ZPL II® Programming Guide Volume Two: The X.10 Environment
• EPL2 Programmer’s Manual
• Line Mode Programmer’s Manual

Note • Most of these documents are available on our web site.
PrintServer II User and Reference Guide 7

Download from Www.Somanuals.com. All Manuals Search And Download.



Preface
Related Documents
8  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



CHAPTER 1

Introduction

This chapter provides a high-level overview of the ZebraNet PrintServer II (PSII), 
installation instructions, standard network configurations and how to work with PSII. 

These are the main topics:

• Overview on page 10
• Requirements on page 13
• Compatibility on page 15
• Installation Types on page 16
• PSII Specifications on page 17

 

PrintServer II User and Reference Guide 9
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Overview
Overview

The PSII is an optional factory or field-installed device that connects the network and 
your Zebra printer. If your printer has ZebraLink, PSII can provide you with a browser 
user interface for printer and print server settings. If your printer also has ZebraNet 
Utilities, you have even more functionality.

Illustration

This illustration shows the flow of all the components that work with PSII. A table 
follows that identifies the components and how they enhance each respective device:

1

2

Printer with PSII only

ZebraLink enabled printer, with 
PSII

ZebraNet Utilities

3
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Overview
 

Components Description

Printer with PSII only PSII gives your printer these features:
• enables the remote monitoring and configuration 

capability of the PSII using a Web- browser. 
• enables the printer to send unsolicited status mes-

sages via email-enabled devices.

ZebraLink enabled 
printer with PSII

A ZebraLink enabled printer with PSII gives you all 
the above mentioned features (WebView and Alert), 
plus these features: 
• ZBI ™ (Zebra BASIC Interpreter)—programming 

language that works with ZPL II to control and 
interpret incoming text and data. This provides you 
with the ability to create stand-alone applications 
using a printer and peripheral devices, such as a 
scale or a scanner, without needing a PC host. Inter-
net-aware ZBI can then transmit data captured by 
these devices over your LAN, WAN, or wireless 
network by using a Wireless Card Socket (WCS) 
option via email or TCP/ IP messaging. 
NOTE • PSII can be either field or factory installed 
for additional features. For details, see Installation 
Types on page 16.

ZebraNet Utilities ZebraNet® Utilities is a suite of software programs for 
your computer that works with PSII and enhances the 
features of ZebraLink™ resident within ZPL-based 
printers. The features include:

• ZebraNet Alert lets you configure multiple event 
alerts per device with different alerts going to differ-
ent people. You are notified of alerts from either 
visual or audio cues. You can also generate 
advanced alert reports.

• ZebraNet Connect lets you, with Windows, enable 
simple printer selection of an IP addressable printer.

1

2

3
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• ZebraNet View allows you to automatically locate 
printers. ZebraNet View can search on parameters 
such as IP address, subnet, printer model, printer 
status, and many other user-defined characteristics. 
It also offers powerful device management capabili-
ties.

• ZebraNet View Java Applet is a Java-based version 
of the popular ZebraNet View. It lets you enable any 
operating system that has a Java enabled browser to 
take advantage of the powerful discovery feature.

Components Description
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Requirements

This section lists the minimum requirements for PrintServer II, which include: 
software, browser support, and hardware.

Software

These are the platforms supported by ZebraNet Utilities:

The ZebraNet View Java Applet is supported by any Java enabled browser:

Browser Support

Hardware

These are the minimum hardware requirements:

Windows™ NT®, 95, 98, 2000, Me

Novell® Netware®

UNIX®

Linux

Internet Explorer 4.0+

Netscape Navigator 4.08+

Any browser that is HTML 1.1 
compliant

Printers External Internal
Field Upgrade

Internal
Factory

Xi Series (XiII and XiIII) • • •
R140 • • •
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* - future releases

PAX Series • • •
Z Series •
Stripe Series •
105SL • • •
105 Se/160S •
2746 • •*

2684 •
DA402, T402 •
2844 (EPL) • •
2844 (ZPL) • •*

Ht-146 • •*

2824 • •*

Printers External Internal
Field Upgrade

Internal
Factory
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Compatibility

This section identifies the various components that are compatible with PSII.

ZebraNet Wireless Card Socket Option (WCSO)  The ZebraNet PrintServer II 
is fully compatible WCSO.

Software  HP JetAdmin, HP Web JetAdmin™, and HP OpenView™ all work with 
PSII. 
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Installation Types

PSII can be factory or field installed, as follows:

Factory  Factory installations are for new Zebra printers that are built with the 
internal PSII option.

Field  Field installations are for Zebra printers already in the field. The PSII option 
can be installed on existing printers, as follows:

• External PSII—attaches to the printer parallel port
• Internal PSII—for the appropriate Zebra printers, this option connects directly 

to the main logic board
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PSII Specifications

Network Connection  10BASE-T UTP RJ45 connection. Auto senses IEEE- 802.3, 
Ethernet II, IEEE- 802.2, and IEEE 802.2/SNAP frame formats 

Printer Connection  Bi-directional, IEEE- 1284 Centronics parallel port 

User Interface  Activity indicator: bi-color display of operational status; Test 
button: diagnostic test and configuration printing 

Size (external ZebraNet PrintServer II)  Length: 3.6” / 91.4mm, Width: 2.5” / 
63.5mm, Height: 0.8” / 20.3mm

Weight (external ZebraNet PrintServer II)  .5oz / 71g 

Power  Maximum 250mA at 5.25VDC; Power provided by the printer (Centronics 
pin 18, 5VDC at 200mA)

Environment   Operating Temperature: 0° to 104°F (0° to 40°C); Storage 
Temperature: -4° to 140°F (-20° to 60°C); Operating Humidity: 25 to 85% non-
condensing

Agency Approvals   IEC950; Canadian DOC; FCC Class B; C. I. S. P. R. 22-B; 
EN50082-1: 1997; and AS/NZS3548

Warranty  Three years
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CHAPTER 2

Installation

This chapter provides information on how to install PSII (external and internal) and 
the ZebraNet Utilities.

These are the main topics:

• External PSII on page 20
• Internal PSII on page 23
• ZebraNet Utilities on page 27
• ZebraNet View Java Applet on page 31
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External PSII
External PSII

This section provides you with an illustration of the external PSII and steps on how to 
install an external print server.

Illustration

This illustration provides you with a visual of an external PSII. The callouts identify 
the important components:

To install an external PS II, complete these steps:

1. Power down the printer. 
2. On the back of the printer, insert the PSII device into the parallel port.

Note • Refer back to this illustration during the installation steps, when necessary.
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External PSII
This illustration calls out the location of the parallel port and provides a blown up 
illustration of the parallel port:

3. Secure the wire locks.
4. On the back of the PSII, insert a live 10BASE-T cable into the Ethernet connector.
5. Power on the printer. 

An red status indicator blinks during the POST (Power On Self Test) and changes 
to green when stabilized.

6. Press the test button located on the side of the PSII. This prints out a configuration 
label of PSII:

Note • To determine the minimum label width needed to print a PSII configuration 
label, refer the following list of printhead resolutions:

• 600 dpi (1.25 inch)
• 300 dpi (2.50 inch)
• 200 dpi (3.69 inch)
• 150 dpi (5.0 inch)
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This is an example of a PSII configuration label. The callouts identify settings you 
need to know. A table follows, and provides a description of each callout. 

Callout Description

This shows the IP address, subnet mask, and 
default gateway of the PSII device. IF the IP 
address is set at 0.0.0.0, you will need the serial 
number (in callout 3) to set the IP address.

This shows all the Novell settings. 

This shows the serial number, hardware 
address (MAC address), and firmware version 
of the PSII device.

1

2

3

1

1

2

3
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Internal PSII

This section provides you with an illustration of an internal PSII and steps on how to 
install it in the Zebra XiII, XiIII, 105SL, and PAX-Series printers. 

Illustration

This illustration provides you with a visual of an internal PSII. The callouts identify 
the important components:

Important • It is recommended that this installation be performed by a qualified 
service technician. The service technician must follow the step-by-step procedure 
provided in these instructions.

Note • Refer back to this illustration during the installation steps, when necessary.
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To prepare for the installation, be sure you have these tools 
available:

• #1 Phillips screwdriver
• 3/32” Allen wrench

To install an internal PSII, complete these steps:

1. Turn the printer power off and disconnect the AC power cord.
2. At the rear of the printer, remove the two screws and the blank cover plate or an 

existing optional interface board positioned next to the main RS-232 and parallel 
interface connectors.

3. To remove the side panel:
• XiII-, XiIII-Series, and 105SL, remove the mounting screws and remove the left 

side panel.
 

• PAX-Series, to access the electronics, remove the mounting screws from the 
printer’s PCB access panel and slide the panel out.

Caution • Wear an anti-static wrist strap and attach it to the printer chassis when 
performing installations. Printer electronics are susceptible to static discharge.
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.

4. Through the mounting slot, insert the ribbon cable and PSII.
5. Fold the cable and the ferrite bead back over the mounting bracket, and connect the 

ribbon cable connector into the keyed Interface Data Cable Connector (J4) on the 
main logic board. 

Confirm that the connector is properly seated and that pin 1 of the Interface Data 
Cable Connector is connected to pin 1of J4. 

6. Secure the PSII interface board in place with the cover plate screws that you 
removed early in this step sequence.

7. Confirm that all small cable connectors are tight.
8. Reinstall the PAX-Series PCB access panel or the left side-panel of the XiII and 

XiIII-Series printers that you removed earlier in this step sequence.
9. This kit includes a label printed with the Ethernet MAC hardware address for the 

PSII. Remove the backing from the label and affix it to the back of the printer.
10.Reconnect the AC power cord and turn the printer power on.

Note • The parallel port on the back of the printer is not operational when the 
internal PSII is installed. The hardware of the PSII mounting bracket covers the 
parallel port.
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11. Consult your System Administrator before configuring the PSII for your network! 
To establish the network connection, refer to the section applicable to your 
network type.
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ZebraNet Utilities

The ZebraNet Utilities is a software suite that consists of various tools that assists you 
with configuring the print server, which allows you the flexibility to make changes to 
settings, track errors, and more.

For more details on these utilities, see Overview on page 10.

To install the ZebraNet Utilities, complete these steps:

1. Insert the CD-ROM into the drive.
2. Click Next>.

This illustration shows the dialog box that lets you select the utilities that you want 
to install:

Note • You must have Administrator rights on your network to install most of these 
utilities. Contact your System Administrator before installing this software.

Important • Is AutoPlay enabled on your computer?
• Yes. Your computer automatically launches the installation.
• No. You need to navigate to the Software>ZebraNet Util>setup.exe
on the CD-ROM and manually launch the installation.

Note • Another option is to visit our web site to download the ZebraNet Utilities.
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ZebraNet Utilities
3. In the ZebraNet Utilities dialog, select the features you want to install and click 
Next>. 

Important • If you installed ZebraNet View Java Applet, you must complete the 
installation steps for ZebraNet View Java Applet on page 31.

Each of these 
have drop-
down menus 
to choose 
from
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ZebraNet Utilities
This illustration gives you the chance to reset your installation settings:

4. In the ZebraNet Utilities dialog you have the option to review and make any 
changes to your installation settings. When you are satisfied with your installation 
settings, click Install. 
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ZebraNet Utilities
This dialog appears when the installation is complete:

5. Click Finish.

Important • When the installation is complete, you need to restart your system for 
the changes to take place.
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ZebraNet View Java Applet

If you selected ZebraNet View Java Applet when you were installing the ZebraNet 
Utilities, you need to complete a few installation steps to work with this utility.

To install ZebraNet View Java Applet, complete these steps:

1. From the task bar, select Programs>ZebraNet Utilities>ZebraNet View Java Applet 
1.0.

This Security Warning dialog opens:

2. To begin the install, click Yes.
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The Select Java Plugin Installation dialog opens:

3. Make the selections that apply to your environment, and click Install.
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ZebraNet View Java Applet
The Software License Agreement opens.

4. Read the License Agreement. To continue with the install, click Yes. 
5. When the installation is complete, click OK. 
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The Java view opens:
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CHAPTER 3

Getting Started

This chapter provides you with information and procedures to work with the most 
frequently used PSII features. PSII offers many features, but how you access and work 
with them is dependent on your environment.

These are the main topics:

• Before you begin on page 36
• Assigning an IP Address on page 38
• Setting Alerts on page 44
• Checking PSII Configuration Settings on page 51
• Setting up a ZebraNet Connect IP on page 56
• Enabling Protocols on page 60
• Defaulting the PSII on page 64
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Before you begin
Before you begin

Before you begin, you need to get information from the PSII configuration label. 

To print a PSII configuration label, complete these steps:

1. Turn on the printer and let it complete it's power up cycle.
2. Let the PSII complete it's POST cycle. 
3. When the first few steps are done, on the PSII push in the Test button and hold it 

in for a few seconds, then release it. 

Important • Be sure that the printer is powered down.
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Before you begin
A PSII config label prints. Your configuration label will look similar to this 
example:

4. From the configuration label, you need to get these numbers:
• ADDRESS (IP address)
• SUBNET MASK
• DEFAULT GATEWAY 
• SERIAL NUMBER
• HARDWARE ADDRESS (MAC address)

5. On the configuration label that prints out for your PSII device, circle the above 
mentioned settings. You can now proceed to the Assigning an IP Address on page 
38.
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Assigning an IP Address

Before you can begin working with PSII, you must get or assign an IP address for the 
PSII device.

Assigning an IP address with DHCP

If your network uses DHCP, the necessary configuration information be set on the PSII 
when the unit initially connects to the network and is turned on. Check with your 
Network Administrator to see if your network uses DHCP. 

Assigning an IP address without DHCP

If your network does not use a dynamic IP addressing system (such as DHCP) you 
need to set the IP address of the PSII. 

ZebraNet View

ZebraNet View is the Windows based print server management and configuration 
utility that came with your PSII. 

To assign an IP address using ZebraNet View, complete these 
steps:

Important • Throughout the step sequence in this chapter, there are some features 
that require the default User ID and/or default password. If you are prompted, these 
are the defaults:

• User ID: admin
• Password: 1234

Important • The remaining sections are dependent on the successful installation of 
ZebraNet Utilities which you should have completed on page 27. 
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1. From the task bar select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog appears:

2. Compare the H/W Address on the PSII configuration label to the H/W Address 
column on the screen to find the PSII you are working with. 

3. When you located your PSII, select it. 
4. From the menu bar, select PrintServer>Configuration.

5. IF your PSII does not have an IP address, complete these steps:
• Find your PSII and right-click it.
• In the small dialog that opens, enter an IP Address, click OK.
• The Print Server Configuration dialog opens. 
• Set the Subnet Mask (required). Set the Default Gateway (optional). 
• Click OK.

Important • On the illustration that follows, take note of the H/W address column 
and Serial # column. Compare what you see in ZebraNet View with the 
configuration label you printed out.

Important • If the PSII does not have an IP address, it shows in the main screen 
with an IP of 0.0.0.0. If, after 2 minutes, you do not assign an IP Address, the PSII 
defaults to IP Address 192.168.254.254 or 198.102.102.254 (this depends on your 
firmware version).
PrintServer II User and Reference Guide 39

Download from Www.Somanuals.com. All Manuals Search And Download.



Getting Started
Assigning an IP Address
The Print Server Configuration dialog appears:

6. Type a new IP address in the text-box illustrated above.
7. Enable the Set Permanent radio button.

To set the subnet, complete these steps:

8. From the ZebraNet View menu bar, select PrintServer>Configuration.
9. Click the TCP/IP tab.
10.From the Print Server Configuation>TCP/IP tab, in the Subnet Mask text-box, 

type in your subnet mask.
11. Confirm it is accurate, and click OK.

To set the default gateway, complete these steps:

These steps are Optional.

1. From the ZebraNet View menu bar, select PrintServer>Configuration.
2. Click the TCP/IP tab.
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3. From the Print Server Configuation>TCP/IP tab, in the Default GateWay text-box, 
type in your default gateway.

4. Confirm it is accurate, and click OK.

Setting the IP address in a non-Windows environment

These steps can be used with all printers. However, the LCD instructions are for XiIII 
units. 

To assigning an IP address from the printer LCD Display, 
complete these steps:

1. Power on the printer and allow two minutes for all systems to complete self test. If 
you do not have a network cable in the port, the print server prints configuration 
label when it is ready.

2. On the printer front panel, press SETUP/EXIT.
3. On the printer front panel, press PREVIOUS twice until you reach the network 

settings menu items. 
4. You can edit any of the following network setting in order to communicate with 

PSII in your network environment.

• default gateway (default setting of 000.000.000.000) 
• subnet mask (default setting 255.0.0.0) 
• ip address (if initial default setting is 0.0.0.0, after two minutes this defaults to 

198.102.102.254 or 192.168.254.254 - depends on firmware version) 
• ip protocol (gleaning only, rarp bootp, dhcp, dhcp and bootp, all) 
• ip resolution (dynamic, permanent) The printer menu item IP RESOLUTION 

must be set to PERMANENT if attempting to assign the IP Address from the 
front panel

Important • Your PSII must have firmware 6.3 and higher and your Zebra printer 
must have firmware x.10 or higher with an LCD. 

Important • To change any of these settings, you need to use the default password: 
1234.
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Assigning an IP address via a telnet session

If your environment is not Windows-based, this section is for you. However, this 
method can be used in a Windows environment too.

The methods used are: Static Route and Gleaning. 

Before you can telnet to the print server and configure the device you must first assign 
the print server a temporary IP address. 

Static Route: To use this method, complete these steps:

1. Power on the printer and wait for two minutes to allow for device selftest. 

During this time the PSII performs an address broadcast. If no address is assigned 
to the unit (via DHCP or Bootp), it uses a default address. The default address used 
varies with the version of firmware the PSII is using. Print the PSII configuration 
label to confirm the address.

2. You can use the route add command to place the default IP address into the 
workstation's network routing table.  

3. At the workstation/host command prompt (in Windows, go the DOS prompt) type:

route add **** "IP address of the workstation" 0 

4. Telnet to the PSII by typing:

"telnet xxx.xxx.xxx.xxx" 

The password is 1234 

5. When finished, you can alter the appropriate settings. When complete do a reset 
and allow completing of the PSII selftest before proceeding with any 
communications activity. 

Important • This applies to any TCP/IP capable work station/ host networked with 
the Zebra printer. Both the work station/host and the printer server must be on the 
same network segment.

Example • In the next step, **** is the IP address on the PSII configuration label.

Note • The zero (0) placed at the end of the "route add" command is optional on 
some systems. 
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Gleaning: To use this method, complete these steps:

A method where the print server uses the IP Address of the first ping packet that is sent 
to its Hardware Address. 

1. Add an entry to the ARP table that assigns an IP address to an Ethernet (Hardware) 
address. 

The syntax for this command is: arp -s " temporary ipaddress of 
print server" "MAC Address (print server hardware 
address) " 

2. Power cycle the printer. 
3. As the printer reboots, begin a continuous ping to the address assigned previously. 

4. When the PSII begins to respond, stop the ping activity.

 In Windows, Ctrl + C, halts the pinging.

5. Telnet to the PSII and assign the appropriate IP address, subnet mask and gateway 
if applicable. 

6. Once this is complete, reset the PSII. 

Example • You would type: arp -s 10.3.50.59 00-40-68-1D-B9-86

Note • Most UNIX systems use a continuous ping. 

To use a continuous ping from a Windows host you must issue the 
command: ping -t "ipaddress". 
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Setting Alerts

It is important to understand the relationship between the PSII and the printer when 
you are establishing Alerts. Here are the relationships you need to be aware of:

• Non-ZebraLink enabled printers—can send Alerts on only a specific set of 
printer conditions.

• ZebraLink enabled printers—can access a wider variety of Alerts. 

ZebraNetView

To set alerts (traps) using ZebraNet View, complete these 
steps:

1. In the ZebraNet View dialog, from the menu bar select Print Server>Configuration.
2. Click the SNMP Traps tab.

The Printer Traps check boxes are the Alerts you can set from ZebraNet View.
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3. Enable the alters (printer traps) you want to set here and click OK.
4. To monitor the alerts you established, from the task bar select Start>ZebraNet 

Utilities>ZebraNet Alert.

The ZebraNet Alert dialog opens:

ZebraLink

To view Alert Setup, complete these steps:

1. From the Printer Home Page, click Alert Setup.
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This view opens:

2. To add an alert, click Add Alert Message.
3. Select accordingly.
4. You can use ZebraNet Alert to monitor alerts set through a ZebraLink enabled 

printer.

From this web page you can add alert messages to notify you when a printer is out of 
paper, needs a ribbon, and so on.

Establishing Email Alert Messaging

ZebraNet Alert supports email notification of printer errors sent directly to any valid 
email address. You can have multiple email addresses set up for routing different error 
messages, or split notifications between email and other network management tools. 

To begin receiving email notification of errors, complete these 
steps:
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1. From the browser, in the address text-box type in the printer’s address. 

The Printer Home Page opens.

2.  From the Printer Home Page, click Alert Setup.

The Alert Setup page shows a list of message notifications and their respective 
destinations (if no notifications are listed). 

3. From the Alert Setup page, email notification can be set up. Click Add Alert 
Message.
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Setting Alerts
The Add Alert Message page opens:

.

4. Specify the condition to send over email. For example, HEAD ELEMENT BAD 
or PAPER OUT.

5. Enter a valid email address for the messages to be sent. 

Important • The printer only accepts the last configuration made.

Example • printers@helpdesk.com or admin@yourcompany.net (the 
Port field can be ignored for email setup).

 ! Warning • A password is required. If you forget to enter the password, the alerts 
you just set are deleted.
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6. Click Add ALERT Message. Here you can continue to add more settings or, if 
finished, save the current settings.

7. From the Printer Home Page, select PrintServer Settings>Network 
Communications Setup. 

8. Click SMTP Email Alerts.
9. Specify your SMTP server address. 

When these steps are done, you can begin receiving email notification messages.

To monitor PSII alerts, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.
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The Active Log dialog opens, displaying a list of all the logged alerts:    

2. From this dialog you can track the activity of printer statuses. 
3. From menu bar, you can explore all the other features, such as Reports.
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Checking PSII Configuration Settings

This section provides steps on how to check PSII’s configuration settings using 
ZebraNet View.

ZebraNet View

To check configuration settings, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens: 

2. From the menu bar, select Print Server>Configuration.
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The Print Server Configuration dialog opens: 

3. From this dialog you have multiple tabs to choose from. Each tab contains various 
configuration settings that you can change.

For details on the configurations, see page 116.

Checking PSII Configuration

This section provides steps on how to check PSII’s configuration settings using its web 
pages.

To access the print server settings, complete these steps:

1. Open a web browser.
2. In the Address text-box, type your printer’s IP address, then press Enter.
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Your browser view looks similar to this:

3. From the Printer Home Page, click Print Server Settings.

The default User ID and password are required.

Important • The illustration of the Printer Server Settings page is based on a ZPL 
printer. If you have a EPL printer, the menu options on the Print Server page are 
slightly different.
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The Print Server Configuration Page opens:

To access the print server settings, complete these steps:

1. From the Print Server page, click Print Server.
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The Print Server Configuration page opens:

2. For details on the configuration choices, see To check configuration settings, 
complete these steps: on page 51.
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Setting up a ZebraNet Connect IP

ZebraNet Connect allows you to send jobs to PrintServers that use Dynamic IP 
addresses (DHCP). It also notifies you of printer errors, such as paper out or head 
open. When print jobs are printed through ZebraNet Connect, they are sent directly to 
PSII and are not routed through a network server, resulting in a reduction of network 
traffic. 

If you have printing problems while using the PSII Connect printing port, you may 
check the status of the port or change its settings through the printer Properties dialog.

• For Windows 95/98, select Port Settings under the Details tab.
• For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.

Windows NT 4.0/Windows 2000

If you are using the Windows NT 4.0 or Windows 2000 operating system, use the 
following procedure to set up a printer port for the PSII.

1. From the task bar, select Start>Settings>Printers.
2. Select the Windows printer to use when printing with the PSII.
3. From the menu bar, select File>Properties.
4. To add a PSII Connect port, in the Ports tab select Add Port.
5. From the list of Available Printer Ports, select ZebraNet Connect Monitor as the 

type of port to add, and click New Port.

You enter into the Add ZebraNet Connect Port screen where there is a list of all 
PSII devices available on the local subnet.

Note • The DHCP feature of ZebraNet Connect can re-discover a PrintServer on the 
local subnet, even when its IP address might be changing (e.g. when using DHCP 
for IP address resolution). The PrintServer is relocated by its port name as 
configured through ZebraNet View (the default name is Serial Number-Port 
Number). This feature is enabled on the local subnet only. A non-local PSII device is 
not re-discovered if the IP address changes.

Note • If PSII Connect is not listed, verify the ZebraNet Connect software has been 
properly installed.
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• The TCP/IP monitor only searches the local subnet.
• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

6. If the port you want to add is listed in the Ports Available on Local Subnet window, 
select the port name. If the port you want to use is not listed, you can: 

• Select Cancel and repeat step 5 to rediscover the print servers. 
• In ZebraNet Connect for IPX/SPX, click Search and enter the PrintServer’s 

Network Number and Hardware Address.

In ZebraNet Connect, click the Locate Non-local Device button and enter the static 
TCP/IP Address used for the PSII.

7. Click Add.
8. To close the Printer Ports dialog, click Cancel.
9. To save the configuration, click OK.

Now you can use ZebraNet Connect. Whenever you print to the Windows printer 
configured with ZebraNet Connect, your print job will go directly to the ZebraNet PSII 
port.

Windows 95/98

To setup a PSII port using Windows 95 or Windows 98, 
complete these steps:

1. From the task bar, select Start>Settings>Printers.
2. Select the Windows printer that you want to print with PSII Connect.

3. From the file menu, select File>Properties.
4. To add an PSII Connect port, in the Details tab select Add Port.

Note • The ZebraNet Connect for TCP/IP DHCP discovery feature relocates a PSII 
device on the local subnet by its port name, even if the IP address changes. This 
feature is enabled on the local subnet only. A non-local PSII device is not re-
discovered if the IP address changes.

Note • Under Windows 95, you have to set up the printer for a local port first, then 
open Properties from the File menu and continue with the configurations.
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5. From the Add Port dialog, select Other, then select the ZebraNet Connect Monitor 
as the type of port to add. 

6. Click OK.

The Add ZebraNet Connect Port screen appears. There is a list of all PSII devices 
discovered on the network.

• The TCP/IP monitor searches only the local subnet.
• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

7. If the port you want to add is listed in the Ports Available on Local Subnet window, 
select the port name. If the port you want to use is not listed, you can:

• Select Cancel and repeat step 5 to rediscover the PSII devices. 
• In PSII Connect for IPX/SPX, click Search and enter the PSII’s network 

number and hardware address.
• In PSII Connect, click the Locate Non-local Device button and enter the static 

TCP/IP address used for the PSII.
8. Click Add.
9. To save the configuration, click OK.

Now you can use PSII Connect. Whenever you print to the Windows printer 
configured with PSII Connect, your print job will go directly to the PSII port.

IPX (NetWare)

ZebraNet Connect for IPX/SPX is a utility that allows simple, direct, IPX/SPX 
printing from your computer to a printer attached to a ZebraNet PSII. Print jobs printed 
through the ZebraNet Connect utility are sent directly to the PSII and do not require a 
NetWare server, resulting in a reduction of network traffic.

If you have printing problems while using the PSII Connect printing port, you can 
check the status of the port or change its settings under the printer Properties window.

• For Windows 95/98, select Port Settings under the Details tab.
• For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.

Note • If PSII Connect is not listed, verify the software has been properly installed.
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Notify on Printer Error—This feature checks the printer status prior to printing 
the job. If a printer error is detected (e.g. printer off-line), the error description is 
given.

Notify When Printed—This feature provides an alert when your job is active on 
the printer. This is useful if the printer is unusually busy.

Description—An optional field where you can list any useful information about 
the printer port, such as location.
PrintServer II User and Reference Guide 59

Download from Www.Somanuals.com. All Manuals Search And Download.



Getting Started
Enabling Protocols
Enabling Protocols

You can enable protocols using ZebraNet View or the browser view.

WebView

To enable protocols using WebView, complete these steps:

1. Open a web browser.
2. In the Address text-box, type your printer’s IP address, then press Enter.

Your browser view looks similar to this:

3. From the Printer Home Page, click Print Server Settings.

The default User ID and password are required

4. From the Print Server page, click Print Server.
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The Print Server Configuration page opens:

5. From the Print Server Configuration page, click Enabled Protocols.
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The Protocol Configuration page opens:

6. Select the protocols you want to enable, click Submit Changes.

You get a confirmation to reset the unit for changes to take place.

ZebraNet View

To enable protocols using WebView, complete these steps:

1. From the task bar select Start>Programs>ZebraNet Utilities>ZebraNet View.
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The ZebraNet View dialog appears:

2. From the ZebraNet View menu bar, select Print Server>Configuration.
3. Click the Protocols tab.

The Protocols tab opens:

4. Select the protocols you want to enable, click OK.
5. A confirmation appears. To accept changes, click OK.
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Defaulting the PSII

This section provides you with instructions to default PSII to factory settings. 

ZebraNet View

To default PSII to factory settings using ZebraNet View, 
complete these steps:

1. From the task bar select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog appears:

2. From the menu bar, select Print Server>Reset. 

The Reset Print Server dialog opens.
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3. Select the settings you want to reset, Click Restore.

WebView

To default the PSII to factory settings, complete these steps:

1. From the ZebraNet PrintServer view, click Factory Print Server Settings.

The Restore to Factory Defaults view opens:
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2. Enable the check box of the settings you want to reset, and click Submit 
Changes.

Test Button

To default the PSII to factory settings, complete these steps:

1. The print is turned off.
2. With the printer turned off, press and hold the Test button on the PSII device and 

power up the printer.
3. The status indicator tells you when PSII has been reset to factory defaults, as 

follows:
• If an active network cable is connected to the PSII, the status indicator turns 

solid green. When this happens, you can release the Test button.
• If there is not an active network cable connected to the PSII, the status 

indicator flashes green. When this happens, you can release the Test button.

Important • With the reset command on its way to the PSII, the HTTP connection 
is unavailable while the PSII re initializes. You need to wait a few seconds before 
trying to reestablish a connection.
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CHAPTER 4

NetWare Print Configuration

This chapter provides you with instructions on how to configure Novell’s NetWare for 
printing to PSII.

This is the main topic:

• Printing in PServer Mode on page 68
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Printing in PServer Mode

To configure in Novell’s NetWare for printing to the PSII, 
complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
2. Create a ZebraNet object by doing the following steps:

• From Novell’s NetWare Administrator, select the container that you want the 
object created in. See example:

• From the menu bar, select Object>Create.

If the Create option is grayed, you do not have sufficient rights, or you 
selected a leaf object. 

• From the Class of New Object list box, choose ZebraNet PrintServer II. If the 
class of the object you want to create is not listed, you cannot create it in the 
container you selected.

• Click OK.
• Define filter and sort criteria for displaying a list of ZebraNet devices to 

choose from.
• Click OK.
• Enter a name for the new ZebraNet object.
• If you want to rename on the PrintServer II devices, select the one you want to 

rename, and click Create.
3. Find your object in the Directory Tree, and double-click to open.
4. From the Assignments page, select Assign.
5. Select New, and click the Directory Tree icon.
6. From the Browse Context dialog, double-click the browse arrow.
7. Find the Context container you want, and double-click it.

It auto-fills into the context field.

Important • You must have PSII installed before you proceed with these steps.

Example •  To create an object that is subordinate to sales, choose SALES.
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8. Enter the printer name you want, and click OK.
9. Next to the Print Que dialog, click New and click on the directory tree.
10.Repeat steps 6 and 7.
11. Type in the print que name that you want, and click on the Directory Tree icon.
12. In the Volume dialog, double-click on the volume you want, and click Create.

The Print Que is listed with the name of your context as an extension.

13.Click OK, and then click OK again.

Wait for the print server to reset.

14.To refresh your Directory Tree, double-click on your context twice.

You now see the Object, Printer Name, and Print Que that you created.

To attach a generic text driver to print to the PSII configured in 
NetWare, complete these steps:

1. On Add Printer double-click, and click Next.
2. Select Network Printer, and click Next.
3. Click Browse and click on the context.

You can see the que and printer that you created.

4. Select the Que, and click OK.

The Network path (que name), auto-fills.

5. Click Next.
6. Select Generic for Manufacturer of printer, and click Next.
7. Select Keep Existing Driver, and click Next.
8. Enter the printer name you want and click Next.
9. Select No for printing a Test Page, and click Finish.
10.From the Printers dialog, double-click on your new printer and set it as the default 

printer.
11. Open Notepad, create ZPL (Zebra Programming Language) file and print.
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CHAPTER 5

Printing Configurations

This chapter provides information and instructions on configuring your printer.

These are the main topics:

• BSD-Style Print Queue on page 72
• System V Queue Installation on page 74
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BSD-Style Print Queue

Configuring the Print Queue

For remote BSD-style LPD printing, add the PSII as a remote printer in the /etc/
printcap database to each host printing to the PSII. You can add printcap options as 
needed. If you are unfamiliar with these options, consult the printcap documentation. 

The entry looks similar to this:

local_print_queue_name|[printer_model_and_manufacturer]
:\

:lp=:mx#0:rm=ZebraNet_name:\

:rp=remote_print_queue_name:\

:sd=path_to_spool_directory:lf=just log_file_name

local_print_queue_name—This defines the name of the printcap entry. It is 
used by the LPR/LPD utilities to specify which printcap entry is being referenced. 
Additional printcap entries can be added as needed for different queue types. Each 
entry must have a unique local_print_queue_name and a different spool directory to 
work properly. When you are ready to print, use the local_print_queue_name that 
matches the data type of the file to be printed.

ZebraNet_name—This is the name (alias) of the ZebraNet PSII. This must be the 
same name as entered in the /etc/hosts file or your NIS or DNS system. An IP address 
may also be used here.

remote_print_queue_name—This entry determines the ZebraNet port where 
the print job will be printed and optionally specifies ASCII printing.

path_to_spool_directory—This is the path to a directory where the print jobs 
will be spooled for this queue. You must create a unique spool directory for each 
printcap entry.

Important • You must be logged in as root.
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log_file_name—This is the path to a file where error information from the LPD 
will be logged.:

Example • Your printcap entries might look similar to this:

Ascii_files|form.feed.Queue_on_Port_2:\

:lp=:mx#0:rm=pserver1:rp=MYQUEUEFF2:\

:sd=/usr/spool/myqueueff2:\

:lf=/usr/spool/myqueueff2/queue.log

Important • Each printcap entry must have a different spool directory to work 
properly.
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System V Queue Installation

Configuring System V for ZebraNet Printing

This section describes the configuration of the printing system on the UNIX operating 
system. For clarity and brevity, the following specific names are used to represent 
general devices or concepts. 

lj4—The local queue name on the UNIX system that PSII print jobs are directed to.

ZEBRAPRINTER—The host name of the remote system that is the PSII device. For 
example, to Telnet to the PSII and invoke the PSII configuration utility, you would 
enter: 

Telnet ZEBRAPRINTER

A host name is not required for the PSII – the IP address can be used. 

yourqueuename—This is the name of the queue on the ZebraNet and must end 
with 1, 2, 3, or 4, depending on the port selected to service the print jobs. If FF, LF or 
NF are the last two letters of the queue name, the job is converted accordingly.

Prerequisites

Before you proceed, the following prerequisites must be met: 

• The name ZEBRAPRINTER and the IP address assigned to the PSII are in the /etc/
hosts file on the UNIX system.

•  The LPD must be running on the UNIX system.

UNIX Configuration

To configure the UNIX machine so users can spool print jobs to 
the PCL print queue on the ZebraNet named ZEBRAPRINTER, 
complete these steps: 

1. Login to the UNIX machine as root. 
2. Type lpsystem -t bsd ZEBRAPRINTER.
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3. Type lpadmin -p lj4 -s ZEBRAPRINTER!yourqueuename - I 
any.

4. Type accept lj4.
5. Type enable lj4.
6. Try printing by entering the command lp -d lj4 [filename].
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CHAPTER 6

Using Printing Protocols

In this chapter you are given steps to setup your PSII to support IPP (Internet Printing 
Protocol). Also, an exercise is provided to experiment with FTP (File Transfer 
Protocol) support.

These are the main topics in this chapter:

• Internet Printing Protocol (IPP) on page 78
• File Transfer Protocol (FTP) on page 79
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Internet Printing Protocol (IPP)

IPP is an application-level protocol that is used for distributed printing over the 
Internet. Using IPP from any standard IPP client, you can transfer jobs to a printer that 
is connected to your ZebraNet PSII device and the Internet. 

To setup your PSII to support IPP, complete these steps:

1. Open a browser.
2. Enter the PSII IPP URL as follows:

http://xxx.xxx.xxx.xxx:631/ipp/port1

xxx.xxx.xxx.xxx = the IP address of the PrintServer II 
device

:631 = a fixed value

/ipp = a fixed string designating IPP

/port1 = a fixed value

Important • You must have IPP support on your system.

Important • IPP support is not available on all PSII printers. To be certain you are 
running the latest version of firmware, visit our web site.

Example • Your address might look like this:

http:198.60.248.120:631/ipp/port1

Note • Since IPP does not have an official standard, usage depends entirely on the 
quality of the IPP client and server.
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File Transfer Protocol (FTP)

Embedded within the PSII is an FTP server application that processes file transfers 
from a host computer to the printer.

If the printer is on a network, label formats can be generated and data can be 
transferred without setting up a print queue.

To send information to the printer in a Windows environment, 
try this alternative exercise:

1. In a text editor, generate the following ZPL II code:

^XA

^FO100,100

^CF0,55^FDZebra Technologies^FS

^XZ

2. Save the file and name it test.txt.
3. Open the MS-DOS Command Prompt and type:

ftp <IP of PrintServer II>

This opens a session with the FTP server. 

4. Type your user name and press Enter.
5. Type:

put test.txt

This transfers test.txt to the printer, and the printer generates a label.

6. To terminate the FTP session, type:

quit

Example • The IP address of your PSII device is 12.3.4.123, you would type:

ftp 12.3.4.123
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APPENDIX  A

PrintServer II

This appendix provides you with details on the PrintServer features that were not 
covered in the Getting Started Chapter.

The main topics include:

• Status and Configuration on page 82
• From the Print Server page, click Print Server. on page 84
• Print Server Status on page 91
• Reset on page 93
• Restore on page 94
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Print Server II

This section covers features available for the PSII only, not the printer’s features.Some 
of the features you access in this section will prompt you to enter the default user ID 
and password, as follows:

• User ID: admin
• Password: 1234 

The options on the Print Server page varies. ZPL and EPL printers Print Server 
settings vary slightly.

Status and Configuration

The steps that follow are based on the navigation of a ZPL printer using firmware X.10 
or higher.

To access the print server settings, complete these steps:

1. Open a web browser.
2. In the Address text-box, type your printer’s IP address, press Enter.

Note • The difference between ZPL and EPL is this:
• ZPL—If you have a ZPL printer, you are initially prompted to the 

Printer Home page, and from there, you select Print Server Settings.
• EPL—If you have a EPL printer, you are immediately prompted to the 

Print Server page. 
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Your browser view looks similar to this:

3. From the Printer Home Page, click Print Server Settings.

Important • The illustration of the Printer Server Settings page is based on a ZPL 
printer. If you have an EPL printer, the menu options on the Print Server page is 
slightly different.
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The Print Server Configuration Page opens:

4. From the Print Server page, click Print Server.
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The Print Server Configuration page opens:

5. In the Print Server Configuration page, you have a menu to choose from. The table 
that follows, identifies what each menu option page looks like:
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Enabled Protocols
Modifies the protocols to be utilized. 
NetWare, HP JetAdmin, or both.
Enabling HP JetAdmin Support allows 
status from the Zebra device to display in 
Hewlett-Packard's HP JetAdmin utility

Netware
Preferred Tree—Enter the tree that the 
printer is in.
Print Server Name—Enter the name of the 
printer.
Disable NetWare SAP—Enables or 
disables the broadcast SAP (Service 
Advertising Protocol) messages. Typically, 
SAP is enabled. If SAPs are disabled, the 
print server does not appear in the bindery 
and is not discovered by ZebraNet View. 
Disabling SAPs reduce network traffic, 
however, SAPs should only be disabled on 
networks using NDPS exclusively or 
NetWare 5 over the IP protocol.
NetWare Frame Format—You can select 
how the frames for the data packets are 
assembled. The default is Automatic 
Sensing.
For details, see Help. 
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TCP/IP Configuration
You can change the TCP/IP Configuration 
of the PSII.
For details, see the help file.
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TCP/IP Logical Printing Ports
Logical printers allow you to set up 
multiple pre- and post-processing 
configurations for each output port. Each 
logical port configuration can do the 
following:
• Add user-configured strings before and 
after the print data.
• Remove unwanted characters from the 
beginning of the print data.
• Four logical printer configurations are 
supported for each output port on the 
printer. The configurations can be assigned 
to any port, and all of these configurations 
can be assigned to a single output port.

System (SNMP)
This feature gives you the ability to 
manage multiple devices on a network, be 
it printers, computers or other network 
attached devices.
On this page you can define the SNMP 
system name, system location (PS 
description), and other SNMP settings for 
your print server.
88  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



PrintServer II
Print Server II
IPX Alerts (Traps)
IPX (Internetwork Packet Exchange) is 
Netware’s network-layer protocol that 
handles networking addressing, routing, 
and packets. 
This feature has you enter the IPX Network 
Address and IPX Node Address that traps 
will be sent to.
To broadcast traps to all addresses on all 
networks, enter FFFFFFFF in the IPX 
Network address field and 
FFFFFFFFFFFF in the IPX Node Address 
field. 
To broadcast traps to all addresses on a 
specific local network, enter the network 
number in the IPX Network Address field 
and then FFFFFFFFFFFF in the IPX Node 
Address field.
To disable traps, set all destination 
addresses to 0.

SMTP Email Alert Configuration
This feature allows you to enter data 
regarding System Information on the 
network that is being used. Typically, a 
Network Administrator would use this.
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Web Admin
This page allows you to configure the 
Admin name and password. Links to 
upgrades and support information can also 
be altered. 

POP3 Email Printing
This features helps you set up the print 
server to receive email messages that can 
contain formats that can be printed. The 
POP3 settings need to be set to retrieve 
emails from the email server. 
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Print Server Status

From the Print Server page, in the Print Server Status section, you can access PSII’s 
configuration sheet and port status.

To open PSII’s configuration sheet, complete this steps:

• From the Print Server page, click View Configuration Sheet:
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The configuration sheet page opens, displaying all the current settings:

 To View the port status, complete this steps

1. From the Print Server page, click View Port Status.

Important • The default user ID and password is required to access this page.
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The port status page opens:

Reset

From the Print Server page, in the Reset section, you can reset PSII’s configuration 
settings to what they were before you made the most recent changes.

To reset the PSII’s, complete these steps:

1. From the Print Server page, click Reset Print Server.
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This page opens:

2. To reset PSII, click Yes.

Restore

From the Print Server page, in the Restore section, you can restore PSII’s to the 
default factory settings:

To restore PSII to the default factory settings, complete these 
steps:

1. From the Print Server page, click Factory Print Server Settings.
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The Restore to Factory Defaults page opens:

2. Make the selections you want, and click Submit Changes.
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APPENDIX  B

ZebraLink

The appendix provides you with detailed information that allows you to use the 
enhanced functionality of your ZebraLink enabled printer with the PSII.

These are the main topics:

• WebView on page 98
• Alert Setup on page 108
• ZBI on page 114
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WebView

WebView gives the System Administrator or user who needs complete, easy, one-step 
control over the printing environment. It provides real- time configuration, control, 
and monitoring capabilities with the convenient graphic interface of a Web browser. 

The Web pages returned by Zebra printers are not static. They contain real-time 
information about the printer’s present state of operation, including on-line status, 
error conditions, and all printing parameters. 

Home Page

The Home Page is the first web page that opens. It is a page with a menu of hyperlinks. 
Each hyperlink gives you access to make modifications to the printer, PSII, and 
network settings; the other changeable settings through the Home Page include:

• Network Status, Error, and Warning reports
• ZebraNet PSII configuration
• Printer settings
• Directories of objects stored in Flash memory and RAM devices
• Objects, stored fonts, images, programs, and ZPL II formats
• Zebra Technologies support and home pages

To open the webview of your printer, complete these steps:

1. Open a web browser.
2. In the Address text-box, type your printer’s IP address, and press Enter.

Note • To access the printer’s web page you need the IP address. For instructions on 
getting the IP address, see Assigning an IP Address on page 38.
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WebView
This view opens:

View Printer Configuration

The View Printer Configuration menu option provides accurate, up-to-the- minute 
information on the printer’s current state. An administrator can conveniently find any 
information on the Virtual Configuration Label and also check on the status of printer 
ports.

To view the View Printer Configuration menu option, complete 
these steps:

1. From the Printer Home Page, click View Printer Configuration.
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The webview displays the configuration settings:

2. To update the printer information from this view:
• For Netscape, select Reload and the printer sends current information to the 

Web browser.
• For IE, click Refresh and the printer sends current information to the Web 

browser.
3. When you are finished reviewing, you can:

• To return to the Home page, click the Home link.
• To print the label, scroll to the bottom of this view and click Print Label. 
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WebView
View and Modify Printer Settings

To view the View and Modify Printer Settings, complete these 
steps:

1. From the Printer Home Page, click View and Modify Printer Settings.

Important • To apply changes made in this section, you need to default user ID and 
password:

User ID: admin 
Password: 1234
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WebView
This view opens:

2. In the View and Modify Printer Settings page, you have a menu to choose from. 
The table that follows identifies what each menu option page looks like:
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WebView
General Setup

Serial Communications
Setup
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Network Communications
Setup

Print Listings on Label
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Media Setup

Calibration
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WebView
ZPL Control

Advanced Setup
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Directory Listing

The directory page provides a listing of all file system devices (B:, E:, R:, Z:). The 
size, name, and location of each stored object appears.

Buttons are available to perform file management operations on the objects. The file 
management operations include:

• Delete object—Not available for objects in read-only memory (Z:).
• Copy object to a new name and/or device—Not available for objects that have 

the “protected” attribute set.
• Run a ZBI™ program—Only available if the object is a stored ZBI program. 

For details, see ZBI on page 114.

To view the Directory Listing, complete these steps:

1. From the Printer Home Page, click Directory Listing.
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This view opens:

2. There are several links to select in this view. 
3. To create a script, click Create New Script.

Alert Setup

To configure the printer’s interaction with ZebraNet Alert to be completely functional, 
SNMP settings must be established in these areas:

• The printer, via the WebView interface (below is an example of the Web page used 
to route Alert messaging).

• The Alert Printer Management Utility for logging SNMP traps.
108  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



ZebraLink
WebView
The ZebraLink messaging system provides for more than SNMP notification. Alert 
can be routed to various destinations, as follows:

• TCP
• UDP
• email
• serial port
• parallel port destinations

To view Alert Setup, complete these steps:

1. From the Printer Home Page, click Alert Setup.

This view opens:

2. To add an alert, click Add Alert Message.
3. Select accordingly.
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Establishing Email Alert Messaging

ZebraNet Alert supports email notification of printer errors sent directly to any valid 
email address. You can have multiple email addresses set up for routing different error 
messages, or split notifications between email and other network management tools. 

To begin receiving email notification of errors, complete these 
steps:

1. From the browser, in the address text-box type in the printer’s address. 

The printer’s home page opens.

2.  From the Printer Home Page, click Alert Setup.

The Alert Setup page shows a list of message notifications and their respective 
destinations (if no notifications are listed). 

3. From the Alert Setup page, email notification can be set up. Click Add Alert 
Message.
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The Add Alert Message page opens:

.

4. Specify the condition to send over email. For example, HEAD ELEMENT BAD 
or PAPER OUT.

5. Enter a valid email address for the messages to be sent. 

Important • The printer only accepts the last configuration made.

Example • printers@helpdesk.com or admin@yourcompany.net (the 
Port field can be ignored for email setup).
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6. Click Add ALERT Message. Here you can continue to add more settings or, if 
finished, save the current settings.

7. From the Printer Home Page, select PrintServer Settings>Network 
Communications Setup. 

8. Click SMTP Email Alerts.
9. Specify your SMTP server address. 

When these steps are done, you can begin receiving email notification messages.

Printer Controls

This page offers control over basic printer functions. 

Other functions are also accessible from this page. These include:

• Feed - causes printer to feed one label
• Cancel One Format - cancels the currently printing format
• Cancel All Formats - cancels all formats.
• Reset Printer - causes printer to perform it's standard reset without cycling 

power. 

To view Printer Controls, complete these steps:

1. From the Printer Home Page, click Printer Controls.

 ! Warning • You must type in a password. If you forget to enter the password, the 
alerts you just set are deleted.
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This view opens:

Print Server Settings

To view the print server menu, complete these steps:

• From the Printer Home Page, click Print Server Settings.

Important • In this view, you must have administrative rights to make changes to 
the printer controls. 
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WebView
 The PrintServer view opens.

For more information on the PrintServer settings, XREF TO PRINT SERVER AP

ZBI

ZBI allows you to maximize printing options through custom programs written for 
your specific needs. ZBI programs can be viewed, modified and run from the 
Directory Listing Page. Directory Listing on page 107.
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APPENDIX  C

ZebraNet® Utilities

The appendix provides you with details on ZebraNet® Utilities, the software suite of 
printer administration tools that complements and enhances both ZebraLinkTM and the 
ZebraNet® family of connectivity products. 

These are the main topics:

• ZebraNet View on page 116
• ZebraNet Alert on page 119
• ZebraNet Connect on page 127
• ZebraNet View Java Applet on page 128
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ZebraNet View
ZebraNet View

ZebraNet View allows you to automatically locate printers. It can search on 
parameters such as IP address, subnet, printer model, printer status, and many other 
user defined characteristics. It also offers powerful device management capabilities.

To open ZebraNet View Utilities, complete these steps:

1. From the task bar select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog appears:

2. Select your printer.

From the menu bar, select PrintServer>Configuration.
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The Print Server Configuration dialog appears:

There are multiple tabs that you can access to make changes to current settings. 

To set alerts in ZebraNet View, complete these steps:

3. From the Print Server Configuration dialog, click the SNMP Traps tab.
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The SNMP Traps tab shows the alerts you can set.

4. To monitor the set alerts (printer traps), see ZebraNet Alert on page 119.

The check 
boxes in 
Printer Traps 
are the alerts
118  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



ZebraNet® Utilities
ZebraNet Alert
ZebraNet Alert

ZebraNet Alert gives you the ability to manage your Zebra printers by immediately 
notifying System Administrators of printer error or warning conditions. Using Web- 
based configuration tools, selected errors or warning conditions can be routed to a 
variety of services such as email messages, wireless pagers, or the ZebraNet Alert.

The following tables show the conditions that can trigger alerts:

PSII Alerts

ZebraLink Alerts

• On-line (condition clear)

• Off-line

• Paper out

• Printer error

• Media out

• Ribbon out

• Printhead over-temp warning

• Printhead under-temp warning

• Head open

• Power supply over-temp

• Ribbon warning (in direct-thermal mode)

• Rewind full

• Cut error

• Printer paused

• PQ job completed
PrintServer II User and Reference Guide 119

Download from Www.Somanuals.com. All Manuals Search And Download.



ZebraNet® Utilities
ZebraNet Alert
ZebraNet Alert Destinations

Unsolicited ALERT messages can be directed to the following destinations:

• Email (PSII specific)
• Serial (ZebraLink specific)
• Parallel (ZebraLink specific)
• TCP (PSII specific)
• UDP (ZebraLink specific)
• SNMP (PSII specific)

ZebraNet Alert Using SNMP

You can send notifications over SNMP only, for use with ZebraNet Alert or a similar 
network management utility. 

To configure the PSII to send alerts across a TCP/IP Network 
to ZebraNet Alert, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
2.  Select the printer you want.

• If a DHCP server is present, the PSII will already have an IP address.

• Label taken

• Head element out

• ZBI (Zebra BASIC Interpreter) runtime 
error

• ZBI (Zebra BASIC Interpreter) forced 
error

• Power on

Important • If you did not install ZebraNet Alert during the ZebraNet Utilities 
installation, see ZebraNet Utilities on page 27.
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ZebraNet Alert
• If no DHCP server is present, you might need to assign the printer an IP 
address.

3. To assign your printer an IP address, from the menu bar, select Print 
Server>Configuration.

4. For PrintServer SNMP Traps, select the SNMP Traps tab.
5. Enter the trap destination and options.

This tells the PSII what TCP/IP address to send the alerts to, and under what 
circumstances to send error and log reports. Entering 255.255.255.255 broadcasts 
the message to every host on the network with a SNMP program running.

6. For ZebraNet Alert to go get and display the messages, you need to open ZebraNet 
Alert. To do this, follow these steps:

• From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.

• In the ZebraNet Alert dialog, from menu bar, select View>Filter Settings. 
• From the View Filter - Devices tab, choose your settings accordingly. 

• The View Filter - Events tab, allows you to select individual events you want the 
program to be aware of.

 Sending Email to Your Zebra Printer

To easily transfer instructions and data to your printer from a remote location, PSII 
allows you to send email to the printer. This is set up under the link POP3 email 
Printing. You need to provide the address of the network POP3 server, a user name, 
and a password.

Important • The SNMP trap settings must be established to communicate with PSII 
if messages are sent to the ZebraNet Alert

Note • If you select No device filtering messages from every printer are caught; 
Device Address allows you to specify which IP address data will come from.

Important • Now PSII’s SNMP Alert messages can be set up in WebView. From 
the printer’s home page, activate the link to Alert Setup. You can add messages that 
are sent to the ZebraNet Alert for Windows by choosing SNMP as a destination.
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With this option, you can create a text-based email containing ZPL II code and transfer 
it to the printer.

By using the proper ZPL II commands, files can be saved, loaded, printed, copied, and 
deleted, just as if the data were transferred from a serial or parallel port.

To access POP3, complete these steps:

1. From the Printer Home page, click Print Server Settings.

This page opens:

Note • Email attachments sent to the printer are not supported.
122  PrintServer II User and Reference Guide

Download from Www.Somanuals.com. All Manuals Search And Download.



ZebraNet® Utilities
ZebraNet Alert
2. From the PrintServer page, click Print Server.
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The Print Server Configuration page opens:

3. From the Print Server Configuration page, click POP3 E-mail Printing.
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The POP3 Printing Configuration page opens:

4. Make the necessary changes, and click Submit Changes.

ZebraNet Alert monitors status and activity of all Zebra printers on the network. It 
alerts the administrator when there is an error condition, which reduces printer 
downtime and increases application efficiency.

Open Alert

To open ZebraNet Alert, complete these steps:

1. From the task bar, select Start>ZebraNet Utilities>ZebraNet Alert.
2. In the ZebraNet Alert dialog, from the menu bar select Report>. The report menu 

option has multiple report selections, select the kind of report you want to 
generate.
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3. Select the type of report you want to generate.

This is an example of the Event Summary report. Notice it generates a .log file.
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ZebraNet Connect 

For details, see Setting up a ZebraNet Connect IP on page 56.
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ZebraNet View Java Applet

ZebraNet View Java Applet is a Java based version of ZebraNet® View. This can run 
on any enable platform that can run a java virtual machine, such as Windows, UNIX, 
Linux and many others 

To access ZebraNet View Java Applet, complete these steps:

1. From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View Java 
Applet 1.0.

Important • To use this, you must have installed it with ZebaNet Utilities and then 
installed this application. For installation instructions for ZebraNet Utilities see 
ZebraNet View Java Applet on page 31.
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This view opens:

2. In the Search Method drop-down list box, select the search method you want.
3. Click Begin Search.

It searches your network for all networked Zebra printers, discovers them, and lists 
them.

4. When you select a device from the list that is discovered, the selected devices 
Home Page displays in the lower porition of the view (it replaces where the 
ZebraNet View Web Configuration Utility content).
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Hardware Troubleshooting

This provides you with solutions to known issues.
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Troubleshooting the PSII

Resetting to Factory Defaults

To reset the PSII configuration parameters to the factory defaults, press the test button 
and hold it in while turning the printer power on. Keep the test button pressed until the 
Status Indicator light turns green, then release the test button. After approximately 20 
seconds, a configuration label prints automatically.

Status Indicator

A bi-color Status Indicator displays the operational status of the PSII. The following 
conditions might occur:

• During normal operation, the LED is solid green for more than 30 seconds. This 
indicates all the hardware is functioning properly and it has detected the presence 
of the network. It does not mean the PSII has an IP address or is attached to a 
printer queue.

• If the LED is rapidly flashing green (9 times/sec), the PSII has not detected the 
presence of a network cable. To solve the problem:

• Turn the printer power off. Remove the network cable from the PSII. Plug the 
network cable back in until you hear a positive click. Check the other end of 
the cable in the same manner. Turn the printer power on. If the PSII still does 
not detect a cable, continue.

• Verify that the network cable is 10BASE-T and has an RJ-45 connector. The 
cable must have a CAT-3 or higher rating.

• Connect the PSII to a network drop that is a known good network connection. 
If the PSII is still unable to detect the network cable, contact Technical 
Support for assistance.

• If the LED is slowly flashing green (1 time/sec), the PSII is trying to print a job. If 
the job does not print, check the following:

• Verify that the printer has media and ribbon (if in thermal transfer mode). If 
the printer is showing any errors, it is unlikely that the PSII can send data to 
the printer. The LED continues to blink until the printer malfunction is 
resolved or until the printer is turned off.

• Flashing red indicates the Power On Self Test (POST) is in progress.
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• If the LED is solid red for more than 30 seconds, the PSII has failed the POST. If 
the failure is not severe, the PSII attempts to print a configuration label on the 
printer. A failed POST can be caused by any of the following:

• The printer attached to the PSII device is malfunctioning. Turn the printer 
power off, wait 10 seconds, then turn the printer back on. 

• If the PSII still fails the POST, continue below. The PSII has a hardware 
problem that can only be fixed by replacing or returning the unit. Contact 
Technical Support for repair or replacement information.

• If the LED is alternately flashing red and green for longer than two minutes, the 
PSII is in firmware-download mode. This means it is waiting for new firmware 
data to be sent before it continues normal functioning. Perform the following:

• If the PSII was purposely put into firmware-download mode, finish the 
download with the proper update utility. Contact the Zebra web site at http://
www.zebra.com to download this utility.

• Contact Technical Support for help recovering this unit.

ZebraNet View Utility Discovery or Configuration Problems

If you are having problems using the ZebraNet View utility to discover or configure 
the unit, check the following:

• Verify there is not a router between the workstation running ZebraNet View and 
the PSII. Since the PSII does not have an IP address, TCP/IP communication can 
not be started across a router. Run ZebraNet View on the same subnet as the PSII. 
This is not a limitation when using ZebraNet View for HP JetAdmin in IPX/SPX 
Discovery Mode.

• Verify the PSII has a solid green light. If the LED shows a rapidly flashing green 
light, check the network cable that is attached.

Unable to Print

• If you are having problems printing, verify that there is communication between 
the PSII and the printer, check the following:

• Print a configuration label by pressing the test button on the PSII. If a 
configuration label does not print, verify the printer has media and ribbon (if 
used) and is not paused. 

• If problems persist, contact Technical Support.
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Unable to Configure Device

To assign an IP address to a ZebraNet PSII using ZebraNet View, you must be on the 
same subnet. If ZebraNet View has Multicast enabled, you might be able to view the 
ZebraNet PSII on another subnet, but you will not be able to configure the device.

HP JetAdmin or HP Web JetAdmin

The ZebraNet PSII might be setup and managed using HP JetAdmin or HP Web 
JetAdmin products.
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Frequently Asked Questions

This is a group of frequently asked questions (FAQs) about PSII.
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FAQs

This table provides frequently asked questions (FAQs) on PSII:

Question Answer

Are there any differences in 
functionality between a ZebraNet 
PSII with an EPL based printer 
and with a ZebraLink enabled 
ZPL printer?

Yes.
• In a ZebraLink environment, with either a 
web browser or with the ZebraNet View Util-
ities, there are a variety of web pages which 
display a wealth of status information regard-
ing both the ZebraLink printer and its Zebra-
Net PSII. However, when used with an EPL 
printer, such as the LP/TLP 2844, the web 
pages for printer status are not available at 
this time, only the web page showing status 
of the PSII are displayed. The PSII can be 
easily configured. However, printer configu-
ration information regarding the EPL printer 
is not available via the ZebraNet Utilities. 
• Error conditions: Using ZebraNet Alert, an 
EPL printer can be configured to use multiple 
different IP addresses to report the following 
Alert status conditions: on-line, off-line, 
paper out.
• For EPL: only two destinations can be con-
figured to report error messages (online, 
offline, and paper out) using SMTP email 
alert – serial and parallel port destinations are 
not supported.

Can the internal ZebraNet PSII 
option work on a computer 
network that is running both 
TCP/IP and IPX protocols 
simultaneously?

Yes. 
The ZebraNet PSII runs all of its available 
protocols simultaneously. This means that the 
ZebraNet PSII can run on mixed networks 
such as a network using Microsoft, UNIX, 
and Novell NetWare operating systems.
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Will the ZebraNet PSII allow 
connectivity to anything other 
than a PC network?

Yes. 
The ZebraNet PSII allows connectivity to 
systems such as IBM’s AS400, provided that 
it is configured using TCP/IP. Other network 
protocols can be used with third party 
adapters that are converted to 10BASE-T.

Will the ZebraNet PSII option 
work on a 10BASE-T per second 
network?

No. 
The ZebraNet PSII option is a 10BASE-T 
print server. This means that the data cannot 
travel any faster than 10 megabits per second. 
The ZebraNet PSII can be deployed on a 
network that is utilizing 10/100 hubs, but the 
ZebraNet PSII operates only at 10 megabits 
per second. 

What if a print job makes it to 
the queue, but never leaves the 
queue? The label does not print. 

These are the things to check:
• Confirm that the printer is turned on and 
receiving power. 
• Confirm that the network cable is plugged 
in and that you can ping the printer.   

If the above bullets do not change the 
outcome, it is likely that there was a 
misconfiguration while creating the queue. 
The queue must be recreated verifying the 
following:

• Confirm that you use the print servers valid 
IP address. 
• If you are using a UNIX or AS/400 host, 
there is an option for the remote queue name. 
There is only one valid response to use: 
PORTLF1.
• If Windows does not have LPR installed 
the above required option should be left 
blank.
• See the documentation for other operating 
system specific queue creation.   

Question Answer
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Frequently Asked Questions
FAQs
What are the minimum 
requirements to network a 
printer?

• Cat-5 network cable with 10 base-T con-
nectors
• PSII
• Hub or Switch
• If a hub or switch is NOT used, you need a 
cross-over cable.
• Workstation running a TCP stack with print 
services installed

What do the activity lights on the 
PSII mean?

• Fast blinking (9 times/second) - no link 
status
• Slow blinking (1 time/second) - no IP 
address, or the unit is sending data to the par-
allel port
• Blinking red - unit is still in POST
• red-green-red-green - unit is in Netware 
firmware update mode
• red-red-green-green - unit is in IP firm-
ware update mode
• Solid red - unit has failed POST. Remove 
network cable and restart printer

What is the default User ID and 
password for the print server

• The User ID is admin and the password is 
1234.

Question Answer
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Frequently Asked Questions
FAQs
What ports are open on PSII and 
related software?

TCP Ports:
• 21 FTP
• 23 Telnet
• 80 HTTP Server
• 515 Printer port
• 631 IPP port
• 9100 Raw socket connection
UDP Ports:
• 161 SNMP broadcast from PSII

• 162 SNMP trap on ZebraNet Alert
• 4201 discovery destination on PSII

• (dynamic) SNMP get request from Zebra-
Net View
• (dynamic) discovery broadcast from Zebra-
Net view
• (dynamic) discovery broadcast from Zebra-
Net view Java

Question Answer
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Frequently Asked Questions
FAQs
What are my network 
connectivity options based on 
when using a PSII? 

It depends on your environment, but the print 
server accepts print jobs in any of the 
following ways:
• FTP-ZPL/EPL files can be sent to the 
printer via a FTP client as a standard ASCII 
file
• HTTP-(ZebraLink enabled printers only) 
Using the script option of the print servers 
homepage, you can type ZPL into a specified 
location of the web browser and send it to the 
printer 
• IPP-Using third party IPP clients, print jobs 
can be sent via the internet
• LPR/LPD-Sometimes referred to as queue 
based printing. LPR/LPD is the standard in 
network printing. Most TCP/IP operating 
systems are compatible with this option
• Raw socket connection-You can connect to 
the printer directly via the network, bypass-
ing everything in-between. This option is 
commonly used to integrate ZPL/EPL into 
existing programs, such as VB scripts
• POP3-With proper configuration, you can 
place ZPL/EPL files, into the body of an 
email, and it will print. The print server peri-
odically checks this email box at the specified 
intervals and prints the body of the message. 
IMPORTANT: attachments and subject line 
are not supported

Question Answer
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Glossary

This provides a glossary of terms that are specific to the PSII.

 

PrintServer II User and Reference Guide 141

Download from Www.Somanuals.com. All Manuals Search And Download.



Glossary
Terms
Terms

10BASE-T   A type of Ethernet that uses unshielded twisted pair cable.

arp   The standard TCP/IP method for determining the actual network address of a 
device based on it’s IP address. 

ASCII   A standard for the binary representation of characters.

BOOTP  BOOTP (Bootstrap Protocol) is a protocol that lets a network client 
automatically configured. It can automatically configure any of the following 
information: IP address, gateway, subnet, system name, name server, and more. It 
automatically assigns the necessary settings from a pool of pre-determined addresses 
for a certain duration of time. BOOTP is the basis for a more advanced network 
manager protocol, the DHCP (Dynamic Host Configuration Protocol). 

broadcast  In a network, a situation when all destinations on the network receive a 
given packet.

client   a workstation or PC in a client/server environment.

community  For SNMP, a relationship between an agent and a set of SNMP 
managers that defines security characteristics. The community concept is a local one, 
defined at the agent. Each community is given a unique community name.

DHCP (Dynamic Host Configuration Protocol)   DHCP is an alternative to 
another network IP management protocol, Bootstrap Protocol (BOOTP). Like 
BOOTP, DHCP can configure an IP address, gateway, subnet, system name and name 
server. When speaking about the PSII, BOOTP and DHCP configure the same options.

delete bytes  This number is used to remove characters from the beginning of every 
job sent to the logical printer. The value for delete bytes can range from 0 to 255.

dynamic  A dynamic configuration, as the name implies, means that it changes. 
BOOTP and DHCP offer time based leases for the configurations they assign. Their 
changes depend on the time based lease, and how often the printer itself is offline and 
online again. A dynamic configuration includes BOOTP or DHCP.

EPL  Eltron Programming Language.
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Terms
Ethernet  a widely used local area network system based upon the IEEE 802.3 
standard. 

firmware  software routines that are stored in ROM (Read Only Memory). This is 
typically part of a device, such as a printer or PSII.

FTP  File Transfer Protocol, a TCP/IP-related protocol for transferring files between 
devices on a network.

Flash memory  A type of memory which allows read and write operations, but 
permanently stores data when the power is turned off. Useful for storing firmware, 
because it can be easily updated by downloading new code.

gateway  A device that converts one higher-level network protocol to a different 
higher level protocol.

gleaning  A temporary, local configuration option. Gleaning lets you add the address 
of the device you want to configure to your local workstations arp table. This 
configuration is not permanent and is only valid from the workstation that you entered 
the arp information to. After the information is entered into the workstations arp table, 
the user follows up with a telnet session to enter the information permanently. This 
configuration option is used mostly by non-Windows workstations, that cannot run the 
ZebraNet View configuration utility. 

IP  Internet Protocol, one of the main protocols of the TCP/IP protocol suite.

IP address  A network address used by the TCP/IP protocol.

IPP  Internet Printing Protocol. Allows you to associate a printer with a URL address 
that is used for printing over the Internet.

IPX   Internetwork Packet Exchange, one of the NetWare protocols.

JetAdmin  A Hewlett-Packard printer management program available for NetWare 
and TCP/IP.

logical  Refers to conceptual rather than physical. For example, a computer might 
have a single physical connection to the network (an Ethernet adapter card), but could 
have logical connections to several other devices on the network.

MAC Address  Media Access Control. Ethernet address that corresponds to the 
assigned IP address.
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name server  A workstation on a TCP/IP network that provides a list of all 
workstations on the network.

NetWare  A network operating system developed by Novell.

node  a device connected to a network, such as a computer or print server.

parallel port   a port on a device that sends information in groups of bits over 
multiple wires, one wire for each bit in a group.

ping  a TCP/IP command that determines whether a device is accessible on the 
network. 

POP3  Post Office Protocol, the protocol used to retrieve email from the server. 

port  A physical connector, such as the parallel port, or a logical connection to a 
device.

post string  A string that is sent at the end of every job going to the logical printer. 
Maximum 64 characters long.

pre string  A string that is sent at the beginning of each job that goes to the logical 
printer. Max 64 characters long.

print server  a device in a network that changes a network protocol into a printer 
protocol.

protocol  a method of sending and receiving data between two or more workstations 
on a network, and insuring that the data is received without errors.

rarp  Reverse Arp, a standard TCP/IP method of determining a devices IP address 
based on its Ethernet address.

raw TCP port  A type of TCP port in which data is passed unmodified to the 
receiving node.

RJ45  A type of modular jack connector similar to a telephone connector with up to 8 
wires. Used for 10baseT Ethernet connections and for serial port connections.

serial port  On a printer or print server, a port that transfers data one bit at a time. 
Serial ports usually have either a 25-pin, 9-pin "D", or RJ45 connector.
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server  A device on a local area network that provides services to client computers on 
the network. 

SMTP  Simple Mail Transfer Protocol, a protocol used to send email messages over 
the Internet.

SNMP  Simple Network Management Protocol, a protocol for monitoring and 
controlling devices on a network.

spooling  In printing applications, spooling is the transfer of data to a temporary 
storage area on disk (the print queue) prior to printing. Spooling allows many jobs to 
be queued to a single printer.

static  In reference to a static IP address. All information is provided by the network 
administrator.

subnet mask  A TCP/IP method of dividing a network into several smaller 
subnetworks.

TCP/IP  Transmission Control Protocol/Internet Protocol, the de facto standard for 
Internet communications that is widely used on local area networks.

TCP Port  A method of accessing a TCP/IP service, where a device with a single IP 
address can have multiple TCP ports.

TELNET  A TCP/IP protocol that allows two devices to communicate over a LAN.

trap  An unsolicited message sent by an SNMP agent to an SNMP management 
station. It notifies the management station of some unusual event.

UNIX  A general-purpose computer operating system used on many different kinds of 
computers.

WCSO  Wireless Card Socket Option. Zebra’s wireless Ethernet option.

Windows 95 and Windows 98  Microsoft's PC operating systems that feature 
built-in peer-to-peer networking. 

Windows NT  Microsoft's multitasking operating system that can be used either as a 
client or as a server. 
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Windows 2000  Microsoft's multitasking operating system that replaces Windows 
NT; can be used as either as a client or as a server.

ZebraNet PrintServer II  an Ethernet connectivity solution.

ZebraLink  allows you to connect and control your bar code printers anywhere and 
anytime. 

ZPL II  Zebra Programming Language II is a powerful label-definition and printer-
control language.
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