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About This Guide

About this Guide
About this Guide

This guide provides information to help you use the following management tools to manage 
the HP StorageWorks 2/8q Fibre Channel Switch (2/8q FC Switch):

■ Switch Manager

■ Command Line Interface (CLI)

“About This Guide” topics include:

■ Overview, page 14

■ Conventions, page 15

■ Getting help, page 17
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Overview
This section covers the following topics:

■ Intended audience

■ Related documentation

Intended audience
This book is intended for use by the system administrator responsible for the MSA1000 
storage system.

Related documentation
The following MSA1000 SAN and 2/8q FC Switch documents are on the MSA1000 Small 
Business SAN and HA Documentation CD:

■ HP StorageWorks Modular Smart Array 1000 Small Business SAN Kit Installation 
Instructions (also printed) 

■ HP StorageWorks 2/8q Fibre Channel Switch Installation Guide 

■ HP StorageWorks 2/8q Fibre Channel Switch Simple Network Management Protocol 
Reference Guide 

■ HP StorageWorks 2/8q Fibre Channel Switch Event Messages Reference Guide 

The following MSA1000-specific documents are on the MSA1000 documentation CD:

■ HP StorageWorks MSA1000 Configuration Overview 

■ HP StorageWorks MSA1000 Installation Guide

■ HP StorageWorks Modular Smart Array 1000 Maintenance and Service Guide

■ HP StorageWorks Modular Smart Array 1000/1500 cs Command Line Interface User 
Guide 

■ HP StorageWorks Modular Smart Array 1000 Controller Reference Guide 

■ HP Array Configuration Utility User Guide
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Conventions
Conventions consist of the following:

■ Document conventions

■ Text symbols

■ Equipment symbols

Document conventions
This document follows the conventions in Table 1.

Text symbols
The following symbols may be found in the text of this guide. They have the following 
meanings:

WARNING:  Text set off in this manner indicates that failure to follow directions in the 
warning could result in bodily harm or death.

Caution:  Text set off in this manner indicates that failure to follow directions could result in 
damage to equipment or data.

Note:  Text set off in this manner presents commentary, sidelights, or interesting points of 
information.

Table 1:  Document conventions

Element Convention
Cross-reference links Blue text: Figure 1
Menu items, buttons, keys, tabs, and 
user input in a graphical interface. (Use 
plain text for all other GUI elements.)

Bold

Text emphasis and document titles (not 
CD titles) in body text

Italics

Command-line user input, commands, 
code, device instances, file and 
directory names, and system responses 
(output and messages)

Monospace font

Command-line and code variables Monospace, italic font

Web site addresses Blue underlined sans serif font text 
(http://www.hp.com)
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Equipment symbols
The following equipment symbols may be found on hardware for which this guide pertains. 
They have the following meanings:

Any enclosed surface or area of the equipment marked with these symbols indicates 
the presence of electrical shock hazards. Enclosed area contains no operator 
serviceable parts. 

WARNING: To reduce the risk of personal injury from electrical shock hazards, do 
not open this enclosure.

Any RJ-45 receptacle marked with these symbols indicates a network interface 
connection.

WARNING: To reduce the risk of electrical shock, fire, or damage to the equipment, 
do not plug telephone or telecommunications connectors into this receptacle.

Any surface or area of the equipment marked with these symbols indicates the 
presence of a hot surface or hot component. Contact with this surface could result in 
injury. 

WARNING: To reduce the risk of personal injury from a hot component, allow the 
surface to cool before touching.

Power supplies or systems marked with these symbols indicate the presence of 
multiple sources of power. 

WARNING: To reduce the risk of personal injury from electrical shock, 
remove all power cords to completely disconnect power from the power 
supplies and systems.

Any product or assembly marked with these symbols indicates that the component 
exceeds the recommended weight for one individual to handle safely.

WARNING: To reduce the risk of personal injury or damage to the equipment, 
observe local occupational health and safety requirements and guidelines for 
manually handling material.
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Getting help
If you still have a question after reading this guide, contact an HP Authorized Service Provider 
or access the following HP web site: http://www.hp.com.

Note:  HP call centers use product and serial numbers to validate warranty entitlement. Most HP 
products can provide product number, serial number and firmware revision electronically through 
the use of supplied management or diagnostic utilities, eliminating the need to physically inspect or 
remove products from installed enclosures. You may be directed by HP to run these utilities to 
gather required entitlement information.

HP installation and configuration assistance
A moderate level of SAN-related knowledge is required to successfully install this product. If 
you are not familiar with installing and configuring storage array systems in a SAN, HP can 
install it for you. 

For more information, access the following HP web site: 
http://www.hp.com/hps/storage/ns_implementation.html.
Depending on your needs, different levels of assistance are available.

For example, the HP Installation and Startup for HP StorageWorks Disk Arrays Service 
Package includes:

■ Physical installation of the MSA

■ Virtual disk design and configuration of the MSA

■ Service planning

■ Service deployment

■ Installation Verification Testing (IVT)

■ Customer orientation 
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HP technical support
Telephone numbers for worldwide technical support are listed on the following HP web site: 
http://www.hp.com/support/. From this web site, select the country of origin.

Note:  For continuous quality improvement, calls may be recorded or monitored.

Be sure to have the following information available before calling:

■ Technical support registration number (if applicable)

■ Product serial numbers

■ Product model names and numbers

■ Applicable error messages

■ Operating system type and revision level

■ Detailed, specific questions

HP storage web site
The latest information on this product, as well as the latest drivers, are available on the 
following HP web site: http://www.hp.com/country/us/eng/prodserv/storage.html. From this 
web site, select the appropriate product or solution.

HP authorized reseller
For the name of your nearest HP Authorized Reseller:

■ In the United States, call 1-800-345-1518

■ In Canada, call 1-800-263-5868

■ Elsewhere, see the HP web site for locations and telephone numbers: http://www.hp.com.
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1Switch Manager

This chapter describes how to use the Switch Manager application and its menus, including:

■ Getting started, page 20

■ Managing fabrics, page 35

■ Managing switches, page 58

■ Managing ports, page 80

■ Graphing port performance, page 91

■ Interpreting Switch Manager messages, page 97
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Getting started
■ Installing Switch Manager, page 20

■ Starting Switch Manager, page 21

■ Exiting Switch Manager, page 22

■ Removing Switch Manager, page 23

■ Changing the encryption key for the default fabric view file, page 23

■ Saving and opening fabric view files, page 23

■ Setting Switch Manager preferences, page 24

■ Using online help, page 25

■ Viewing software version and copyright information, page 25

■ Using the Switch Manager user interface, page 25

■ Using the topology display, page 31

■ Using the faceplate display, page 33

Installing Switch Manager
Switch Manager is installed during the initial set up and installation of the MSA1000 Small 
Business SAN. If Switch Manager is not installed on your system, first verify that your 
workstation or server meets the following minimum system requirements. (Table 2)

Installing Switch Manager on Windows systems
1. Close all programs currently running, and then insert the Small Business SAN Software 

CD into the server or management workstation CD-ROM drive.

The CD automatically starts, and displays the HP Small Business SAN Wizard.

2. In the Welcome window, click Next, and then follow the onscreen instructions.

Note:  Switch Manager is installed and placed in the following system folder:
C:\Program Files\HP\HP_StorageWorks_Switch_Manager.

Table 2:  Management system requirements

Item Minimum Requirements
Operating system Windows® 2000/2003 32-bit operating systems

Linux® Red Hat 32-bit operating systems
Memory 256 MB
Disk space 150 MB, per installation
Processor 300 MHz
Hardware CD-ROM drive, RS-232 serial port, RJ-45 Ethernet port
Internet browser Windows: Microsoft® Internet Explorer®

Linux: Netscape Navigator 6.2 or later, or Mozilla 1.0.2 or 
later with Personal Security Manager
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Installing Switch Manager on Linux systems
1. Close all programs currently running, and then insert the Small Business SAN Software 

CD into the server or management workstation CD-ROM drive. 

The CD auto-mounts, and executes an installation script.

If the CD does not auto-mount, mount the CD and execute the HP Small Business Linux 
Wizard script from the /linux directory. (install_smb.sh)

2. Follow the onscreen instructions to complete the installation.

Starting Switch Manager
For Windows systems, do one of the following:

■ Double-click the Switch Manager shortcut icon

■ Select Start > Switch Manager

■ Enter the following at the command line: 
<install_directory>Switch_Manager.exe

For Linux systems, because the installation script creates a symbolic link between 
/opt/HP/HP_StorageWorks_Switch_Manager/Switch_Manager and 
/usr/sbin/Switch_Manager, enter the following at the command line:

# Switch_Manager

The application opens with the Initial Start Dialog—Switch Manager dialog box (Figure 1). If 
you prefer not to see this dialog box, check the Don’t show this dialog again option. This has 
the same effect as disabling the Display Initial Startup Dialog preference. See “Setting Switch 
Manager preferences” on page 24 for more information.

Figure 1:  Initial Startup Dialog—Switch Manager dialog box

The following options are available from this initial dialog box:

■ Open Configuration Wizard—Opens the wizard to configure a switch, add a new 
switch, replace/restore a switch, or recover or edit an IP configuration of an existing 
switch. See “Configuration wizard” on page 69.

■ Open existing fabric (requires ip address, login, and password—Opens the Add a New 
Fabric dialog box, which prompts you for a fabric name, IP address, account name, and 
password. See “Adding a fabric” on page 36.
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■ Open existing fabric view file—Opens the Open View dialog box which prompts you to 
specify a fabric view file that you saved earlier. See “Opening a fabric view file” on 
page 37.

■ Start application without specifying a fabric—Opens the Switch Manager window.

Exiting Switch Manager
To exit a Switch Manager application session:

1. Select File > Exit.

If you have not yet defined an encryption key, the Save Default Fabric View File dialog 
box (Figure 2) is displayed and prompts you to save the current fabric view as the default 
fabric view file. 

Figure 2:  Save Default Fabric View File dialog box

2. Enter the encryption key information in the Default Fabric View File Encryption Key 
box.

3. Re-enter the encryption key in the Re-enter Encryption Key to Confirm box.

4. Click OK to save the current set of fabrics to the default fabric view file in the working 
directory.

The encryption key is used to encrypt the sensitive data in the default fabric view file. See 
“Changing the encryption key for the default fabric view file” on page 23 for more 
information. 

If an encryption key has been defined and the View File Auto Save and Load preferences 
setting to is set to Enable, the current fabric view is automatically saved to your default fabric 
view file upon exiting future Switch Manager sessions. 

To prevent Switch Manager from prompting you to save the default fabric view file between 
Switch Manager sessions, set the View File Auto Save and Load preferences setting to Enable 
(default). See “Setting Switch Manager preferences” on page 24 for more information. 

In your next Switch Manager session, the Load Default Fabric View File dialog box (Figure 3) 
prompts you to load the default fabric view file and to specify its encryption key, if there is 
one. If you do not want to load the default fabric view file, click Continue Without Loading 
to open the Switch Manager with no fabric displayed.

Figure 3:  Load Default Fabric View File dialog box
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Removing Switch Manager

Removing Switch Manager from Windows 
To remove Switch Manager from Windows:

1. Browse for and change to the installation directory:

The default directory is C:\Program Files\HP\HP_StorageWorks_Switch_Manager.

2. Double-click the uninstall program file or shortcut/link, and then follow the onscreen 
instructions to remove Switch Manager.

Removing Switch Manager from Linux
To remove Switch Manager from Linux:

1. Browse for and change to the installation directory. 

The default directory is /opt/HP/HP_StorageWorks_Switch_Manager.

2. Enter the following command:

# Uninstall_HP_StorageWorks_Switch_Manager

Changing the encryption key for the default fabric view file 
To change the encryption key for the Switch Manager default fabric view file:

1. Select File > Save Default Fabric View File. 

2. Enter an encryption key in the Default Fabric File Encryption Key box.

3. Re-enter the same encryption key in the confirmation box.

4. Click OK to save the current set of fabrics to the default fabric view file in the working 
directory.

Saving and opening fabric view files
A fabric view file is one or more fabrics saved to a file. In addition to the Switch Manager 
default fabric view file, you can save and open your own fabric view files. 

To save a set of fabrics to a file:

1. Select File > Save View As. The Save View dialog box is displayed.

2. Enter a name for the fabric file or click Browse to select an existing file.

Files are saved in the working directory.

3. Enter a password in the File Password box.

When opening this fabric file, a password is required. If the File Password box is left 
blank, no password is required when attempting to open this fabric file.

4. Click OK.

To open a fabric view file:

1. Select File > Open View File. The Open View dialog box is displayed.

2. Enter a name for the fabric file or click Browse to select an existing file. 

3. Enter a password in the File Password box.

4. Click OK.
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Setting Switch Manager preferences
Using the preferences settings to:

■ Change the location of the working directory in which to save files.

■ Change the location of the browser used to view the online help.

■ Choose the fabric discovery interval. The fabric discovery interval is how often the Switch 
Manager application receives information from the fabric. Choose 30 (default), 45, or 60 
seconds. The smaller the interval, the more often the application talks to the switch and 
thus the greater impact to performance.

■ Enable (default) or disable the view file auto save and load feature. See “Exiting Switch 
Manager” on page 22 for more information on the default fabric view file.

■ Enable (default) or disable the use of the Initial Start Dialog—Switch Manager dialog box 
at the beginning of a Switch Manager session. See “Starting Switch Manager” on page 21 
for information about the Initial Start Dialog—Switch Manager dialog box. After a default 
fabric view file is created, this setting has no effect. 

■ Enable (default) or disable the Event Browser. See the “Event Browser” on page 41. If the 
Event Browser is enabled using the Preferences dialog box, the next time Switch Manager 
is started, all events from the switch alarm log is displayed. If the Event Browser is 
disabled when Switch Manager is started and later enabled, only those events from the 
time the Event Browser was enabled and forward are displayed. 

■ Choose the default port view when opening the faceplate display. You can set the 
faceplate to reflect the current port type (default), port speed, port operational state, or port 
transceiver media. Regardless of the default port view you choose, you can change the 
port view in the faceplate display by opening the View menu and then selecting a different 
port view option. See “Port status” on page 80 for more information.

To set preferences for your Switch Manager sessions:

1. Select File > Preferences. The Preferences dialog box is displayed (Figure 4).

Figure 4:  Preferences dialog box

2. Enter or browse for paths to the working directory and browser.

3. Select the preferences you want in the Application-wide Options area.

4. Click OK.
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Using online help
Online help is available for the Switch Manager application and its functions. 

You can do one of the following to open the online help file: 

■ Select Help > Help Topics.

■ Click Help on the tool bar.

■ Click Help in a dialog box to display context-sensitive help for all Switch Manager dialog 
boxes.

Viewing software version and copyright information
To view Switch Manager software version and copyright information:

1. Select Help > About.

2. Click OK when you are finished.

Using the Switch Manager user interface
The Switch Manager application uses two basic displays to manage the fabric and individual 
switches; the topology display (Figure 5) and the faceplate display (Figure 6). The topology 
display shows all switches that are able to communicate. The faceplate display shows the front 
of a single switch and its ports.

Figure 5:  Switch Manager Topology window

1 Menu bars
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5 Data window and tabs
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Figure 6:  Switch Manager Faceplate window

Menu bars
In addition to the menu bar, both the topology and faceplate displays have context sensitive 
menus that pop up when you right-click in the graphic window. The menus and the options 
offered in them vary depending on the display. For example, the Port menu and many of the 
Switch menu selections are available only in the faceplate display. 

See Figure 7 and Figure 8 for example menu bar options for the topology and faceplate 
displays.

See “Opening the topology display menus” on page 33 and “Opening the Faceplate menu” on 
page 34 for information about accessing these displays.
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5 Data window and tabs
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Topology display menu bar options and shortcut keys

Figure 7:  Topology display menu bar options

Table 3:  Topology display shortcut keys

Shortcut Selection Shortcut Selection
Ctrl+O
Alt+F, O

File>Open View File Alt+S, E Switch>Export Name Server

Alt+F, A File>Save View As Alt+S, P Switch>Switch Properties 
(active only when one switch 
is selected)

Alt+F, D File>Save Default Fabric 
View File

Alt+S, N Switch>Network properties 
(active only when one switch 
is selected)

Alt+F, R File>Preferences Alt+W, C Wizards>Configuration 
Wizard

Alt+F, X File>Exit Alt+V, R
F5

View>Refresh

Alt+B, A Fabric>Add Fabric Alt+V, L View>Layout Topology
Alt+B, R Fabric>Remove Fabric Alt+V, A View>Toggle Auto Layout
Alt+B, D Fabric>Rediscover Fabric Alt+V, M View>Remember Layout
Alt+B, T Fabric>Start Fabric View Alt+H, H Help>Help Topics
Alt+B, E Fabric>Show Event Browser Alt+H, A Help>About
Alt+S, D Switch>Delete
Shortcut key combinations are not case-sensitive.
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Faceplate display menu bar options and shortcut keys

Figure 8:  Faceplate display menu bar options

Table 4:  Faceplate display shortcut keys

Shortcut Selection Shortcut Selection
Ctrl+O
Alt+F, O

File>Open View File Alt+S, E 
+R 
+A

Switch>Reset Switch|
Reset
Hard Reset

Alt+F, A File>Save View As Alt+S, S Switch> Restore Factory 
Defaults

Alt+F, D File>Save Default Fabric 
View File

Alt+S, W Switch>Download Support 
File

Alt+F, R File>Preferences Alt+P, R Port>Port Properties
Alt+F, X File>Exit Alt+P, N Port>Port Symbolic Name
Alt+B, A Fabric>Add Fabric Alt+P, T Port>Reset Port
Alt+B, R Fabric>Remove Fabric Alt+P, L Port>Port Loopback Test
Alt+B, E Fabric>Show Event Browser Alt+Z, E Zoning>Edit Zoning
Alt+S, A Switch>Archive Alt+Z, C Zoning>Edit Zoning Config
Alt+S, R Switch>Restore Alt+Z, A Zoning>Activate Zone Set
Alt+S, U Switch>User Accounts Alt+Z, D Zoning>Deactivate Zone Set
Alt+S, D Switch>Set Date/Time Alt+Z, R Zoning>Restore Default 

Zoning
Alt+S, O Switch>Switch Properties Alt+W, C Wizards>Configuration 

Wizard
Alt+S, N Switch>Network Properties Alt+W, E Wizards>Ext Credit Wizard
Alt+S, G Switch>Toggle Beacon Alt+V, R

F5
View>Refresh

Alt+S, C Switch>Port Threshold 
Alarm Configuration

Alt+H, H Help>Help Topics

Alt+S, L Switch>Load Firmware Alt+H, A Help>About
Shortcut key combinations are not case-sensitive.
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Tool bar
The tool bar consists of a row of graphical buttons that are used to access Switch Manager 
functions (Table 5). Tool bar buttons are an alternative method to using the menu bar. The tool 
bar can be relocated in the display by clicking and dragging the handle at the left edge of the 
tool bar.

Fabric tree
The fabric tree lists the managed fabrics and their switches (Figure 9). The window width can 
be adjusted by clicking and dragging the moveable window border. An entry handle located to 
the left of an entry in the tree indicates that the entry can be expanded or collapsed. Click this 
handle or double-click the entry to expand or collapse a fabric tree entry. A fabric entry 
expands to show its member switches.

Table 5:  Tool bar buttons

Button Description

Add Fabric—Adds a new fabric to the fabric view.

Open View File—Opens an existing fabric view file.

Save View As—Saves the current fabric view to a file.

Refresh—Updates the topology or faceplate display with the current 
information.

Event Browser—Opens the event browser.

Help Topics—Opens the online help file.

Edit Zoning—Opens the Edit Zoning dialog box (available only in the 
faceplate display).
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Figure 9:  Fabric tree

Each fabric tree entry has a small icon next to it that uses color to indicate operational status.

■ A green icon indicates normal operation.

■ A yellow icon indicates that a switch is operational, but may require attention to maintain 
maximum performance.

■ A red icon indicates a potential failure or non-operational state (if switch is offline).

■ A blue icon indicates that a switch is unknown, unreachable, or unmanageable.

If the status of the fabric is not normal, the fabric icon in the fabric tree indicates the reason for 
the abnormal status. The same message is provided when you rest the mouse over the fabric 
icon in the fabric tree.

The fabric tree provides access to the topology and faceplate displays for any fabric or switch.

■ To open the topology display from the fabric tree, click a fabric entry.

■ To open the faceplate display from the fabric tree, click a switch entry.

Graphic window
The graphic window (Figure 6), presents graphic information about fabrics and switches such 
as the fabric topology and the switch faceplate. The window height can be adjusted by clicking 
and dragging the window border that it shares with the data window. This only works when 
displaying a fabric. 

1 Fabric entry
2 Entry handle

3 Switch entries

1
2 3
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Data window and tabs
The data window presents a table of data and statistics associated with the selected tab. 
(Figure 6.) Use the scroll bar to browse through the data. The window length can be adjusted 
by clicking and dragging the border that it shares with the graphic window.

Adjust the column width by moving the pointer over the column heading border shared by two 
columns until a right/left arrow graphic is displayed. Click and drag the arrow to the desired 
width.

The data window tabs present options for the type of information to display in the data 
window. These options vary depending on the display.

Working status indicator
The working status indicator, located in the lower right corner of the Switch Manager window 
(Figure 6), shows when the management workstation is exchanging information with the 
fabric. As conditions change, the fabric forwards this information to the management system 
where it is reflected in the various displays.

Using the topology display
The topology display (Figure 10) receives information from the selected fabric and displays its 
topology. Switches appear in the graphic window and use color to indicate status. Consider the 
following topology display features:

■ Switch status

■ Topology data windows

■ Working with switches and links

Figure 10:  Topology display
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Switch status

Switch icon shape and color provide information about the switch and its operational state. 
Lines represent links between switches. The topology display uses green to indicate normal 
operation, yellow to indicate operational with errors, red to indicate a potential failure or 
non-operational state, and blue to indicate unknown, unreachable, or unmanageable. See 
“Fabric status” on page 40 for more information about topology display icons.

Topology data windows

The topology display provides the following data windows, which correspond to the data 
window tabs at the bottom of the display:

■ Name Server—Displays all devices logged with the name server and their addresses 
within the current fabric configuration. See “Name Server data window” on page 63 for 
more information.

■ Active Zoneset—Displays the active zone set for the fabric including zones and their 
member ports. See “Active Zoneset data window” on page 44 for more information about 
this data window. See “Zoning a fabric” on page 45 for information about zone sets and 
zones.

■ Switch—Displays current network and switch configuration data for the selected 
switches. See “Switch data window” on page 63 for more information.

■ Link—Displays information about the inter-switch links. See “Link data window” on 
page 64 to for more information.

Working with switches and links

Switch and link icons are selectable and moveable, and serve as access points for other 
displays and menus. You select switches and links to display information about them, modify 
their configuration, or delete them from the display. Context-sensitive menus are displayed 
when right-clicking on a switch or link icon, or in the background of the topology display 
graphic window.

Selecting switches

Selected switch icons are highlighted in light blue. Select switches in the following ways:

■ To select a switch, click the icon.

■ To select multiple switches, hold down Ctrl and select.

■ To select all switches, right-click anywhere in the graphic window background. Select 
Select All Switches from the menu.

■ To cancel a selection, hold down Ctrl and select the item again. To cancel all selections, 
click in the graphic window background.

Arranging switches in the display

You can arrange switch icons in the topology display:

■ To move an individual switch icon, click and drag the icon to another location in the 
graphic window. Links stretch or contract to remain connected.

■ To arrange all switch icons in the topology display automatically, select View > Layout 
Topology.

By default, the Toggle Auto Layout box in the View menu is checked, which causes Switch 
Manager to arrange the icons when Layout Topology is selected.
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You can save a custom arrangement, or layout, and restore that layout during a Switch 
Manager session. Begin by arranging the icons, and then select View > Remember Layout. 
To restore the saved layout, select View > Toggle Auto Layout box, and then select Layout 
Topology.

Opening the topology display menus

The faceplate display shows the front of a single switch and its ports. To open the faceplate 
display when viewing the topology display, click the switch entry/icon in the fabric tree, or 
double-click the switch graphic.

The topology display also offers a Fabric, Switch, and Link menu:

■ To open the Fabric menu, right-click the graphic window background. The Fabric menu 
presents selections to refresh the fabric, select all switches, select all links, or layout 
topology.

■ To open the Switch menu, right-click the switch icon in the graphic window. The Switch 
menu presents selections to refresh the switch, delete the switch from the display, open the 
Switch Properties dialog box, and open the Network Properties dialog box.

■ To open the Link menu, right-click the link. The Link menu presents a selection to delete 
the link from the display.

Using the faceplate display
The faceplate display (Figure 11) displays the switch name and operational state, and port 
status. 

Figure 11:  Faceplate display

Port views and status

Port color and text provide information about the port and its operational state. Green indicates 
active; gray indicates inactive. The faceplate display provides views of port status 
corresponding to the View menu options in the faceplate display. See “Port status” on page 80 
for more information about these displays.

Displayed port information includes the port type, state, speed, and media.
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Context-sensitive menus are displayed when you right-click on the faceplate image or on a 
port icon in the faceplate display.

Faceplate data windows

The faceplate display provides the following data windows, which correspond to the data 
window tabs at the bottom of the display:

■ Name Server—Displays all devices connected to the switch that are logged with the name 
server.

■ Switch—Displays current switch configuration data.

■ Port Statistics—Displays performance data for the selected ports.

■ Port Information—Displays information for the selected ports.

■ Configured Zonesets—Displays all zone sets, zones, and zone membership in the zoning 
database.

Working with ports

Ports are selectable and serve as access points for other displays and menus. Select ports to 
display information about them in the data window or to modify them. Context-sensitive 
menus are displayed when right-clicking the faceplate image or on a port icon in the faceplate 
display. 

Selecting ports

You can select ports in the following ways. Selected ports are outlined in white.

■ To select a port, click the port in the faceplate display.

■ To select a range of consecutive ports, select a port, and then press and hold Shift and 
select another port. The application selects both end ports and all ports in between in port 
number sequence.

■ To select several non-consecutive ports, hold Ctrl while selecting.

■ To select all ports, right-click on the faceplate image. and then select Select All Ports 
from the menu.

■ To cancel a selection, press and hold Ctrl and select it again.

Opening the Faceplate menu

To open the Faceplate menu, right-click on the faceplate image to present the following tasks:

■ Refresh the switch

■ Select all ports

■ Manage switch properties

■ Manage network properties

■ Extended credits wizard

■ Manage port properties 

■ Change the port symbolic name

■ Run the port loopback tests

If no ports are selected, the port-related tasks is unavailable in the menu. Right-click a port to 
open the Port menu. Hold down the Shift or Ctrl to select more than one port. If multiple 
ports are selected, right-click on one of the selected ports.
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Managing fabrics
This section describes the following tasks that manage fabrics:

■ Managing fabric security, page 35

■ Managing the fabric database, page 36

■ Displaying fabric information, page 40

■ Zoning a fabric, page 45

Managing fabric security
The components of Fibre Channel fabric security are:

■ User account security

■ Fabric services

Note:  HP does not support Inter-Switch Links (ISLs), also known as E-Ports, between two or more 
switches. There should be no fiber cables joining two or more switches together. This is not a 
supported configuration. If they are connected, remove the link. The features relating to the use of 
ISLs—specifically Interop AutoSave, Interop Mode, Inband Management, and Legacy 
Addressing—are left in this User Guide for completeness, but are not supported by HP.

User account security
User account security is the process by which your user account and password are 
authenticated with the list of valid user accounts and passwords. The switch validates your 
account and password when you attempt to add a fabric using Switch Manager or log into a 
switch through Telnet. The system administrator defines accounts, passwords, and authority 
levels that are stored on the switch. See “Displaying switch information” on page 62 for more 
information. 

The Admin account possesses Admin authority which grants full access to all tasks of the 
Switch Manager menu system. The switch validates your user account and Switch Manager 
grants access to its menus according to your authority level. If you do not have Admin 
authority, you are limited to monitoring tasks. 

Note:  If a user is logged into a switch using Switch Manager or CLI, and an administrator changes 
user access rights or passwords, existing logins are not affected by the new settings. Login access 
and privileges are only checked for a new login request.
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Fabric services
Fabric services security includes SNMP and In-band management. 

Simple Network Management Protocol (SNMP) is the protocol governing network 
management and monitoring of network devices. SNMP security consists of a read community 
string and a write community string, which are basically the passwords that control read and 
write access to the switch. The read community string (“public”) and write community string 
(“private”) are set at the factory defaults and should be changed if SNMP is enabled using the 
Network Properties dialog box. If SNMP is enabled (default) and the read and write 
community strings have not been changed from their defaults, you risk unwanted access to the 
switch. See “Enabling SNMP configuration” on page 36 for more information. SNMP is 
enabled by default. 

In-band management is the ability to manage switches across inter-switch links using Switch 
Manager, SNMP, management server. The switch comes from the factory with in-band 
management enabled. If you disable in-band management on a particular switch, you can no 
longer communicate with that switch by means other than a direct Ethernet or serial 
connection. See “Enabling In-band Management” on page 36 for more information. In-band 
management in not supported at this time.

Enabling SNMP configuration

1. Open the faceplate display, and then select Switch > Network Properties. The Network 
Properties dialog box is displayed. 

2. Select SNMP Enabled in the SNMP Configuration area. 

3. Click OK.

Enabling In-band Management

1. Open the faceplate display, and then select Switch > Switch Properties. The Switch 
Properties dialog box is displayed. 

2. Select In-band Management Enable. 

3. Click OK.

Managing the fabric database
A fabric database contains the set of fabrics that you have added during a Switch Manager 
session. Initially, if you do not open an existing fabric or fabric view file, the Switch Manager 
application opens with an empty fabric database.

Adding a fabric
To add a fabric to the database:

1. Select Fabric > Add Fabric. The Add a New Fabric dialog box is displayed (Figure 12).
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Figure 12:  Add a New Fabric dialog box

2. Enter a fabric name (optional) and the IP address of the switch through which to manage 
the fabric.

3. Enter an account name and password. The factory login name and password are: admin, 
password. The password is for the switch and is stored in the switch firmware. 

— See “User account security” on page 35 for information about user authentication.

— See “Managing user accounts” on page 58 or the “User command” on page 171 for 
information about creating user accounts.

4. Click Add Fabric.

Note:  A switch supports a combined maximum of 19 logins or sessions as follows:
■ Four logins or sessions for internal applications such as management server and SNMP
■ Nine high priority Telnet sessions
■ Six logins or sessions for Switch Manager inband and out-of-band logins, and Telnet logins. 

Additional logins are refused.

Removing a fabric
To delete a fabric file from the database:

1. Select a fabric in the fabric tree.

2. Select Fabric > Remove Fabric.

Opening a fabric view file
A fabric view file is one or more fabrics saved to a file. 

1. Select File > Open View File, or click Open. If the fabric you are currently viewing has 
changed, you are prompted to save the changes to the fabric view file with the Save View 
dialog box before opening a different view file. 

2. Enter the name of the file to open, and enter a file password, if a password was entered 
when this fabric view file was saved. 

3. Click OK. 
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Saving a fabric view file
1. Select File > Save View As. The Save View dialog box is displayed.

2. Enter a new file name.

3. Enter a file password, if necessary. 

4. Click OK.

Rediscovering a fabric
After making changes to or deleting switches from a fabric view, it may be helpful to again 
view the actual fabric configuration. The rediscover fabric option clears out the current fabric 
information being displayed, and rediscovers all switch information. The rediscover function 
is more comprehensive than the refresh function.

To rediscover a fabric, select Fabric > Rediscover Fabric. 

Adding a new switch to a fabric
If there are no special conditions to be configured for the new switch, simply plug in the 
switch and the switch becomes functional with the default fabric configuration. Default fabric 
configuration settings:

■ Fabric zoning is sent to the switch from the fabric.

■ All ports are GL_Ports.

■ The default IP address 10.0.0.1 is assigned to the switch without a gateway or boot 
protocol configured (RARP, BOOTP, and DHCP).

If you are adding a new switch to a fabric and do not want to accept the default fabric 
configuration, do the following:

1. If the switch is not new, reset the switch to the factory configuration before adding the 
switch to the fabric by selecting Switch > Restore Factory Defaults. 

2. If you want to manage the switch through the Ethernet port, you must first configure the IP 
address using the Network Properties dialog box or the Config Wizard.

3. Configure any special switch settings. 

Consider configuring the Default Visibility setting to None in the Zoning Config dialog 
box to prevent devices from finding other devices on all switches in the fabric until the 
new switch is configured. To open the Zoning Config dialog box, select Zoning > Edit 
Zoning Config.

4. Configure the port types for the new switch using the Port Properties dialog box.

The ports can be G_Port, GL_Port, F_Port, FL_Port, or Donor.

5. Connect the devices to the switch.

6. Make any necessary zoning changes using the Edit Zoning dialog box.

To open the Edit Zoning dialog box, select Zoning > Edit Zoning. If you changed the 
Default Visibility setting in the Zoning Config dialog box from All to None, change that 
setting back to All. To open the Zoning Config dialog box, select Zoning > Edit Zoning 
Config.
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Replacing a failed switch
The archive/restore works for all switches. However, the Restore menu item is not available 
for the in-band switches. You can only restore a switch out-of-band (the fabric management 
switch). There are certain parameters that are not archived, and these are not restored by 
Switch Manager. See “Archiving a switch configuration” on page 75 and “Restoring a switch 
configuration” on page 75 for information about archive and restore. Use the following 
procedure to replace a failed switch for which an archive is available. 

1. At the failed switch:

a. Turn off the power and disconnect the AC cords.

b. Note port locations and remove the interconnection cables and SFPs.

c. Remove the failed switch.

2. At the replacement switch:

a. Mount the switch in the location where the failed switch was removed.

b. Install the SFPs using the same ports as were used on the failed switch.

Caution:  Do not reconnect the target devices and initiator devices at this time. Doing so 
could invalidate the fabric zoning configuration.

c. Attach the AC cords and power up the switch.

3. Select the failed switch in the topology display, and then select Switch > Delete.

4. Restore the configuration from the failed switch to the replacement switch:

a. Open a new fabric through the replacement switch.

b. Open the faceplate display for the replacement switch, and then select Switch > 
Restore. The Restore dialog box is displayed.

c. Enter the archive file for the failed switch or browse for the file.

d. Click Restore.

5. Select Switch > Reset Switch.

This resets the replacement switch to activate the configuration formerly possessed by the 
failed switch including the domain ID and the zoning database. 

6. Reconnect the target devices, and initiator devices to the replacement switch using the 
same ports as were used on the failed switch.

Deleting switches and links
The Switch Manager application does not automatically delete switches or links that have 
failed or have been physically removed from the Fibre Channel network. In these cases, you 
can delete switches and links to bring the display up to date. If you delete a switch or a link 
that is still active, the Switch Manager application automatically restores itself. The display 
can also be refreshed. 

Deleting a switch

To delete a switch:

1. Select one or more switches in the topology display, and then select Switch > Delete.
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Deleting a link

To delete a link:

1. Select one or more links in the topology display, and then select Switch > Delete.

Displaying fabric information
The topology display is the primary tool for monitoring a fabric. The graphic window of the 
topology display provides status information for switches and the Ethernet connection to the 
management workstation.

The data window tabs show name server, switch, and active zone set information. The Active 
Zoneset tab shows the zone definitions for the active zone set. See “Name Server data 
window” on page 63 and “Switch data window” on page 63 for information about the Name 
Server and Switch data windows.

Fabric status
The fabric updates the topology and faceplate displays by forwarding changes in status to the 
management workstation as they occur. You can allow the fabric to update the display status, 
or you can refresh the display at any time. 

To refresh the topology display, do one of the following:

■ Click Refresh.

■ Select View > Refresh.

■ Press F5.

■ Right-click anywhere in the background of the topology display, and then click Refresh 
Fabric from the menu.

The topology display uses switch and status icons to provide status information about switches 
and the Ethernet connection. The switch status icons, displayed on the left side of a switch, 
vary in shape and color. Switches controlled by an Ethernet Internet Protocol have a colored 
Ethernet icon displayed on the right side of the switch. A green Ethernet icon indicates normal 
operation, yellow indicates a condition that may require attention to maintain maximum 
performance, and red indicates a potential failure. Table 6 shows the different switch icons and 
their meanings.

Download from Www.Somanuals.com. All Manuals Search And Download.



Switch Manager

41HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Event Browser
The Event Browser displays a list of events generated by the switches in the fabric and the 
Switch Manager application. Events are generated by the Switch Manager application and are 
not saved on the switch, but can be saved to a file during the Switch Manager session. Entries 
in the Event Browser are formatted by severity, time stamp, source, type, and description. The 
maximum number of entries allowed is 1500. Once the maximum is reached, the event list 
wraps and the oldest events are discarded and replaced with the new events. Event entries from 
the switch, use the switch time stamp, while event entries generated by the application have a 
workstation time stamp. You can filter, sort, and export the contents of the Event Browser to a 
file. The Event Browser begins recording when enabled and Switch Manager is running. 

If the Event Browser is enabled using the Preferences dialog box, the next time Switch 
Manager is started all events from the switch log are displayed. If the Event Browser is 
disabled when Switch Manager is started and later enabled, only those events from the time 
the Event Browser was enabled and forward are displayed. 

Displaying the Event Browser

Perform the following to display the Event Browser:

1. Select Fabric > Show Event Browser or click Events on the tool bar. The Events 
Browser is displayed (Figure 13).

If the Show Event Browser selection or the Events button is grayed-out, you must first 
enable the Events Browser preference. See “Setting Switch Manager preferences” on 
page 24.

Severity is indicated in the severity column, using icons as described in Table 7.

Table 6:  Topology display switch and status icons

Switch Icon Description
2/8q FC Switch
■ Normal operation (green)
■ Warning—Operational with errors (yellow)
■ Critical—Potential failure (red)
■ Unknown—Communication status unknown, unreachable, 

or unmanageable (blue)

Fabric Management Switch:
■ Ethernet connection normal (green)
■ Ethernet connection warning (yellow)
■ Ethernet connection critical (red)

Switch is not manageable with this version of Switch 
Manager. Use the management application that was shipped 
with this switch.
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Figure 13:  Event Browser

Note:  
■ Events that are generated by the application are not saved on the switch. They are permanently 

discarded when you close a Switch Manager session, but you can save these events to a file on 
the workstation before closing Switch Manager and can read it later with a text editor or 
browser.

■ Events that are generated by the switch are stored on the switch, and retrieved when the 
application is restarted. Some alarms are configurable. See “Configuring port threshold 
alarms” on page 66.

1 Severity column 2 Column sorting buttons

Table 7:  Event severity levels

Severity Icon Description
Alarm—An Alarm is any event that is a “serviceable event.” This means that 
attention by the user or field service is required. Alarms are events that get 
posted asynchronously to the screen. Alarms cannot be turned off. If the alarm 
denotes that a system error has occurred, the customer or field representative 
will be directed to provide a “show support” capture of the switch.
Critical Event—An event generated by the Switch Manager application and 
indicates a potential failure. Critical log messages are events that warrant 
notice by the user. By default, these log messages are posted to the screen. 
Critical log messages do not have alarm status because they require no 
immediate attention from a user or service representative.
Warning Event—An event generated by the Switch Manager application that 
indicates errors or other conditions that may require attention to maintain 
maximum performance. Warning messages are not posted to the screen unless 
the log is configured to do so. Warning messages are not disruptive and 
therefore do not meet the criteria of Critical. The user need not be informed 
asynchronously.

No icon
Informative—An unclassified event generated by the Switch Manager 
application that provides supporting information.

1

2
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Filtering the Event Browser

Filtering the Event Browser enables you to display only those events that are of interest based 
on the event severity, timestamp, source, type, and description. To filter the Event Browser, 
select Filter > Filter Entries. This opens the Filter Events dialog box (Figure 14). The Event 
Browser displays those events that meet all of the criteria in the Filter Events dialog box. If the 
filtering criteria is cleared or changed, all the events that were previously hidden that satisfy 
the new criteria are shown.

You can filter the event browser in the following ways:

■ Severity—Check one or more of the corresponding check boxes to display alarm events, 
critical events, warning events, or informative events.

■ Date/Time—Check one or both of the From: and To: check boxes. Enter the bounding 
timestamps (MM/dd/yy hh:mm:ss aa) to display only those events that fall within those 
times. (“aa” indicates AM or PM.) The current year (yy) can be entered as either 2 or 4 
digits. For example, 12/12/03 will be interpreted December 12, 2003.

■ Text—Check one or more of the corresponding check boxes and enter a text string (case 
sensitive) for event source, type, and description. The Event Browser displays only those 
events that satisfy all of the search specifications for the Source, Type, and Description 
text. 

Figure 14:  Filter Events dialog box

Sorting the Event Browser

Sorting the Event Browser enables you to display the events in alphanumeric order based on 
the event severity, timestamp, source, type, or description. Initially, the Event Browser is 
sorted in ascending order by timestamp. 

To sort the Event Browser, click the Severity, Timestamp, Source, Type, or Description 
column buttons. You can also open the Sort menu and then select By Severity, By 
Timestamp, By Source, By Type, or By Description. Successive sort operations of the same 
type alternate between ascending and descending order.
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Saving the Event Browser to a file

To save the Event Browser to a file:

Note:  Filtered events are not saved.

1. Filter and sort the Event Browser to obtain the desired display.

2. Select File > Save As.

3. Select a folder and enter a file name in which to save the event log, and then click Save.

The file can be saved in XML, CSV, or text format. XML files can be opened with an 
internet browser or text editor. CSV files can be opened with Microsoft Excel or most 
spreadsheet applications. 

Active Zoneset data window
The Active Zoneset data window displays the zone membership for the active zone set that 
resides on the fabric management switch. 

To open the Active Zoneset data window, click the Active Zoneset tab below the data window 
in the topology display. See “Configured Zonesets data windows” on page 65 for information 
about the zone set definitions on a particular switch. See “Zoning a fabric” on page 45 for 
more information about zone sets and zones.

The Active Zoneset data window (Figure 15) uses display conventions for expanding and 
contracting entries that are similar to the fabric tree. An entry handle located to the left of an 
entry in the tree indicates that the entry can be expanded. Click this handle or double-click the 
following entries:

■ A zone set entry expands to show its member zones.

■ A zone entry expands to show its member port/devices.

■ WWN and FC devices that are zoned, but no longer part of the fabric, are grayed-out.

Figure 15:  Active Zoneset data window
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Zoning a fabric
Zoning enables you to divide the ports and devices of the fabric into zones for more efficient 
and secure communication among functionally grouped nodes. This subsection addresses the 
following topics:

■ Zoning concepts, page 45

■ Using the Zoning Config dialog box, page 48

■ Restoring default zoning, page 48

■ Merging fabrics and zoning, page 49

■ Using the Edit Zoning dialog box, page 49

■ Managing zone sets, page 52

■ Managing zones, page 54

■ Managing aliases, page 56

■ Saving the Zoning Database to a File, page 57

Zoning concepts
The following zoning concepts provide some context for the zoning tasks described in this 
section:

■ Zones

■ Aliases

■ Zone sets

■ Zoning database

■ Zoning configuration

Zones

A zone is a named group of ports or devices that can communicate with each other. Devices 
within a zone can only communicate with other devices in the same zone. A device may 
participate in more than one zone. 

Membership in a zone can be defined by switch domain ID and port number, device Fibre 
Channel address, or device World Wide Name (WWN).

■ WWN entries define zone membership by the World Wide Name of the attached device. 
With this membership method, you can move WWN member devices to different switch 
ports in different zones without having to edit the member entry as you would with a 
domain ID/port number member. Furthermore, unlike FCID members, WWN zone 
members are not affected by changes in the fabric that could change the Fibre Channel 
address of an attached device.

■ FCID entries define zone membership by the Fibre Channel address of the attached 
device. With this membership method you can replace a device on the same port without 
having to edit the member entry as you would with a WWN member.

■ Domain ID/Port number entries define zone membership by switch domain ID and port 
number. All devices attached to the specified port become members of the zone. The 
specified port must be an F_Port or an FL_Port.
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Two types of zones are supported. The following zone types define increasingly restrictive 
levels of communication. 

■ Soft zones

■ Hard zones (ACL zoning)

Soft Zones

Soft zoning divides the fabric for purposes of controlling discovery. Devices within the same 
soft zone automatically discover and communicate freely with all other members of the same 
zone. The soft zone boundary is not secure; traffic across soft zones can occur if addressed 
correctly. Soft zone boundaries yield to ACL zone boundaries. Soft zones can overlap; that is, 
a device can participate in more than one soft zone. Zone membership can be defined by Fibre 
Channel address, domain ID and port number, World Wide Name, or a combination. Soft 
zoning supports all port types.

Hard Zoning (ACL Zoning)

Access Control List (ACL) zoning divides the fabric for purposes of controlling discovery and 
inbound traffic. ACL zoning is a type of hard zoning that is hardware enforced. This type of 
zoning is useful for controlling access to certain devices without totally isolating them from 
the fabric. Devices can communicate with each other and transmit outside the ACL zone, but 
cannot receive inbound traffic from outside the zone. The ACL zone boundary is secure 
against inbound traffic. ACL zones can overlap; that is, a port can be a member of more than 
one ACL zone. ACL zone boundaries supersede soft zone boundaries. Membership can be 
defined only by domain ID and port number. ACL zoning supports all port types. 

Aliases

To make it easier to add a group of ports or devices to one or more zones, you can create an 
alias. An alias is a named set of ports or devices that are grouped together for convenience. 
Unlike zones, aliases impose no communication restrictions between its members. You can 
add an alias to one or more zones. However, you cannot add a zone to an alias, nor can an alias 
be a member of another alias.

Zone sets

A zone set is a named group of zones. A zone can be a member of more than one zone set. All 
zones that are not members of a zone set belong to the orphan zone set. The orphan zone set is 
saved on the switch. Each switch in the fabric maintains its own zoning database containing 
one or more zone sets. This zoning database resides in non-volatile or permanent memory and 
is therefore retained after a reset. See “Configured Zonesets data windows” on page 65 for 
information about displaying the zoning database.

To apply zoning to a fabric, choose a zone set and activate it. When you activate a zone set, the 
switch distributes that zone set and its zones, excluding aliases, to every switch in the fabric. 
This zone set is known as the active zone set. See “Active Zoneset data window” on page 44 
for information about displaying the active zone set.

Zoning database

Each switch has its own zoning database. The zoning database is made up of all aliases, zones, 
and zone sets that have been created on the switch or received from other switches. The switch 
maintains two copies of the inactive zoning database: one copy is maintained in temporary 
memory for editing purposes; the second copy is maintained in permanent memory. Zoning 
database edits are made on an individual switch basis and are not propagated to other switches 
in the fabric when saved. 

Download from Www.Somanuals.com. All Manuals Search And Download.



Switch Manager

47HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

The zoning limits for a fabric are as follows:

■ MaxZoneSets is 256—The maximum number of zone sets that can be configured on the 
switch. This is enforced during the configuration of zoning and during a zoning database 
merge from the fabric.

■ MaxZones is 256—The maximum number of zones that can be configured on the switch. 
This is enforced during the configuration of zoning and during a zoning database merge 
from the fabric.

■ MaxAliases is 256—The maximum number of aliases that can be configured on the 
switch. This is enforced during the configuration of zoning and during a zoning database 
merge from the fabric.

■ MaxTotalMembers is 2000—The maximum number of total zone and alias members that 
can be configured on the switch. This is enforced during the configuration of zoning and 
during a zoning database merge from the fabric. Aliases are considered zone members 
since they can be added to a zone just like a normal zone member.

■ MaxZonesInZoneSets is 1000—The maximum number of zone linkages to zone sets that 
can be configured on the switch. This is enforced during the configuration of zoning and 
during a zoning database merge from the fabric. Every time a zone is added to a zoneset 
this constitutes a linkage. 

■ MaxMembersPerZone is 2000—The maximum number of zone members that can be 
added to any zone on the switch. This is enforced during the configuration of zoning and 
during a zoning database merge from the fabric. Aliases are considered zone members 
when added to a zone.

■ MaxMembersPerAlias is 2000—The maximum number of zone members that can be 
added to any alias on the switch. This is enforced during the configuration of zoning and 
during a zoning database merge from the fabric.

Zoning configuration

You can set the Interop Auto Save and Default Visibility zoning configuration parameters 
using Switch Manager. The Interop Auto Save parameter determines whether changes to the 
active zone set that a switch receives from another switch in the fabric is saved to permanent 
memory on that switch. Interop Auto Save is not supported at this time. The Default Visibility 
parameter permits or prohibits communication among ports/devices when there is no active 
zone set. See “Using the Zoning Config dialog box” on page 48 for information about zoning 
configuration using Switch Manager. 
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Using the Zoning Config dialog box
Use the Zoning Config dialog box to change the Interop Auto Save and Default Visibility 
configuration parameters. In the faceplate display, select Zoning > Edit Zoning Config to 
open the Zoning Config dialog box (Figure 16). After making changes, click OK to put the 
new values into effect.

Figure 16:  Zoning Config dialog box

Interop Auto Save parameter

The Interop Auto Save parameter determines whether changes to the active zone set that a 
switch receives from other switches in the fabric is saved to the zoning database on that 
switch. Changes are saved when an updated zone set is activated. Zoning changes are always 
saved to temporary memory. However, if Interop Auto Save is enabled, the switch firmware 
saves changes to the active zone set in temporary memory and to the zoning database. If 
Interop Auto Save is disabled, changes to the active zone set are stored only in temporary 
memory, which is cleared when the switch is reset. Interop Auto Save is not supported at this 
time.

Note:  Disabling the Interop Auto Save parameter can be useful to prevent the propagation of 
zoning information when experimenting with different zoning schemes. However, leaving the 
Interop Auto Save parameter disabled can disrupt device configurations should a switch have to be 
reset. For this reason, the Interop Auto Save parameter should be enabled in a production 
environment. Interop Auto Save is not supported at this time.

Default Visibility parameter

Default visibility determines the level of communication that is permitted among ports/devices 
when there is no active zone set. The default visibility parameter can be set differently on each 
switch. When default visibility is enabled (ALL) on a switch, all ports/devices on the switch 
can communicate with all ports/devices on switches that also have default visibility enabled. 
When Default Visibility is disabled (NONE), none of the ports/devices on that switch can 
communicate with any other port/device in the fabric.

Restoring default zoning
Restoring the default zoning clears the switch of all zoning definitions.

Caution:  This command deactivates the active zone set.

1. In the faceplate display, select Zoning > Restore Default Zoning.

2. Click OK to restore default zoning and save changes to the zoning database.
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Merging fabrics and zoning

Note:  HP does not support merging fabrics.

Zone merge failure

A zone merge fails if the two active zone sets have member zones with identical names that 
differ in membership or type. For example, consider Fabric A and Fabric B, each with a soft 
zone named “ZN1” in its active zone set. Fabric A “ZN1” contains a member specified by 
Domain ID 1 and Port 1; Fabric B “ZN1” contains a member specified by Domain ID 1 and 
Port 2. In this case, the merge fails because the two zones have the same name, but different 
membership. 

Zone Merge failure recovery

When a zone merge failure occurs, the conflict that caused the failure must be resolved. You 
can correct a failure due to a zone conflict by deactivating one of the active zone sets or by 
editing the conflicting zones so that their membership is the same. You can deactivate the 
active zone set on one fabric if the active zone set on the other fabric accurately defines your 
zoning needs. If not, you must edit the zone memberships, and reactivate the zone sets. After 
correcting the zone membership, reset the isolated ports to allow the fabrics to join.

Note:  If you deactivate the active zone set in one fabric and the Interop Auto Save parameter is 
enabled, the active zone set from the second fabric propagates to the first fabric and replace all 
zones with matching names in the configured zone sets. Interop Auto Save is not supported at this 
time.
If the zone sets to merge have the same Zone A that only differ in the type of zone (soft vs. hard), 
the zone sets merge. If this is a 2 switch fabric, Switch 1 states that Zone A is soft and Switch 2 
states that Zone A is ACL. 

See “Managing zones” on page 54 for information about adding and removing zone members. 
See “Resetting a port” on page 89 for information about resetting a port.

Using the Edit Zoning dialog box
To edit the zoning database for a particular switch, select Zoning > Edit Zoning. The Edit 
Zoning dialog box is displayed (Figure 17). Changes can only be made to inactive zone sets, 
which are stored in flash (non-volatile) memory and retained after resetting a switch.

To apply zoning to a fabric, choose a zone set and activate it. When you activate a zone set, the 
switch distributes that zone set and its zones, excluding aliases, to every switch in the fabric. 
This zone set is known as the active zone set. 

You can not edit an active zone set on a switch. You must configure an inactive zone set to 
your needs and then activate that updated zone set to apply the changes to the fabric. When 
you activate a zone set, the switch distributes that zone set to the temporary zoning database on 
every switch in the fabric. In addition to the merged active zone set, each switch maintains its 
own original zone set in its zoning database. Only one zone set can be active at one time. 
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Figure 17:  Edit Zoning dialog box

Note:  If the Interop Mode parameter is enabled on the Switch Properties dialog box, every time the 
active zone set changes, the switch copies it into an inactive zone set stored on the switch. You can 
edit this copy of the active zone set stored on the switch, and activate the updated copy to apply the 
changes to the active zone set. The edited copy then becomes the active zone set. 

As illustrated in Figure 17, the Edit Zoning dialog box has a Zone Sets tree and a Port/Device 
(or members) tree. Both trees use display conventions similar to the fabric tree for expanding 
and contracting zone sets, zones, and ports. An expanded port shows the port Fibre Channel 
address; an expanded address shows the port World Wide Name. Select items as follows:

■ Click a zone, zone set, or port icon.

■ Right-click to select a zone set or zone, and then open the corresponding menu.

■ Hold down Shift while clicking several consecutive icons.

■ Hold down Ctrl while clicking several non-consecutive icons. Using tool bar buttons, 
menus, or a drag-and-drop method, you can create and manage zone sets and zones in the 
zoning database. Table 8 describes the zoning tool bar operations.

After defining zoning changes, click OK to implement those changes and exit the Edit Zoning 
dialog box. Click Apply to save changes without closing the Edit Zoning dialog box. Before 
zoning changes are implemented, Switch Manager checks for and reports zoning conflicts:

■ Empty zone sets

■ Empty zones

■ Empty aliases

■ ACL zones with non-domain ID/port number membership

1 Zone sets tree 2 Port/Device tree

2

1
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Table 8:  Edit Zoning dialog box tool bar buttons and icons

Tool bar button / icon Description

Create Zone Set—Create a new zone set

Create Zone—Create a new zone

Create Alias—Create another name for a set of objects

Insert Member—Add the selected zone to a zone set, or add 
the selected port/device to a zone

Remove Member—Delete the selected zone from a zone set, 
or delete the selected port/device from a zone

Switch port—Not logged in

Switch port—Logged in

NL_Port (loop) device—Logged into fabric

NL_Port (loop) device—Not logged into fabric

N_Port device—Logged into a fabric

N_Port device—Not logged into a fabric
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Managing zone sets
Zoning a fabric involves creating a zone set, creating zones as zone set members, and then 
adding devices as zone members. The zoning database supports multiple zone sets to serve the 
different security and access needs of your storage area network, but only one zone set can be 
active at one time. Managing zone sets consists of the following tasks:

■ Creating a zone set

■ Activating and deactivating a zone set

■ Copying a zone to a zone set

■ Removing a zone from a zone set or from all zone sets

■ Removing a zone set

■ Removing all zoning definitions

Note:  Changes that you make to the zoning database are limited to the managed switch and do 
not propagate to the rest of the fabric. To distribute changes to configured zone sets fabric wide, 
you must edit the zoning databases on the individual switches.

Creating a zone set

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select Edit > Create Zone Set. The Create Zone Set dialog box is displayed.

3. Enter a name for the zone set, and then click OK. The new zone set name is displayed in 
the Zone Sets dialog box. A zone set name must begin with a letter and be no longer than 
64 characters. Valid characters are 0-9, A-Z, a-z, _, -, ^, and $.

4. To create new zones in a zone set, do one of the following:

— Right-click a zone set and then select Create A Zone from the menu. In the Create a 
Zone dialog box, enter a name for the new zone, and then click OK. The new zone 
name is displayed in the Zone Sets dialog box.

— Copy an existing zone by dragging a zone into the new zone set. See “Copying a zone 
to a zone set” on page 53.

5. Click Apply to save changes to the zoning database.

Activating and deactivating a zone set

You must activate a zone set to apply its zoning definitions to the fabric. Only one zone set can 
be active at one time. When you activate a zone set, the switch distributes that zone set to the 
temporary zoning database on every switch in the fabric. 

The purpose of the deactivate function is to suspend all fabric zoning, which results in free 
communication fabric wide or no communication depending on the default visibility setting. 
See “Default Visibility parameter” on page 48 for more information. It is not necessary to 
deactivate the active zone set before activating a new one. 

■ To activate a zone set, select Zoning > Activate Zone Set. The Activate Zone Set dialog 
box is displayed. Select a zone set from the Select Zone Set menu, and then click 
Activate.

■ To deactivate the active zone set, select Zoning > Deactivate Zone Set. Acknowledge the 
warning about traffic disruption, and then click Yes to confirm that you want to deactivate 
the active zone set.
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Copying a zone to a zone set

To copy an existing zone and its membership from one zone set to another, Do the following:

1. Select the zone and drag it to the chosen zone set.

2. Click Apply to save changes to the zoning database.

Removing a zone from a zone set or from all zone sets

You can remove a zone from a zone set or from all zone sets in the database.

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone(s) to be removed from the Zone Sets tree.

3. Select Edit > Remove to remove the zone from the zone set, or select Remove from All 
Zones to remove the zone from all zone sets.

4. Click Apply to save changes to the zoning database.

Alternatively, you may use shortcut menus to remove a zone from a zone set or from all zone 
sets in the database.

Removing a zone set

Removing a zone set from the database affects the member zones in the following ways:

■ Member zones that are members of other zone sets are not affected.

■ Member zones that are not members of other zone sets become members of the orphan 
zone set. The orphan zone set is saved on the switch.

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone set to be removed in the Zone Sets tree.

3. Select Edit > Remove to remove the zone set.

4. Click Apply to save changes to the zoning database.

Alternatively, you may use shortcut menus to remove a zone set from the database.

Removing all zoning definitions

To clear all zone and zone set definitions from the zoning database, choose one of the 
following:

■ Select Edit > Clear Zoning, and then click Yes in the Removes All dialog box to confirm 
that you want to delete all zones and zone sets. 

■ Right-click the Zone Sets heading at the top of the Zone Sets tree, and then select Clear 
Zoning from the menu. Click Yes to confirm that you want to delete all zone sets and 
zones.
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Managing zones
Managing zones involves the following:

■ Creating a zone in a zone set

■ Adding zone members

■ Creating a member

■ Renaming a zone or a zone set

■ Removing a zone member

■ Removing a zone from a zone set

■ Removing a zone from all zone sets

■ Changing zone types

Note:  Changes that you make to the zoning database are limited to the managed switch and do 
not propagate to the rest of the fabric. To distribute changes to configured zone sets fabric wide, 
you must edit the zoning databases on the individual switches.

Creating a zone in a zone set

When a zone is created, its zone type is soft. To change the zone type to a hard zone, refer to 
“Changing zone types” on page 56 for more information. See “Zones” on page 45 for 
information on zone types (soft and hard).

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select a zone set.

3. Select Edit > Create a Zone. The Create a Zone dialog box is displayed.

4. Enter a name for the new zone.

5. Click OK.

The new zone name is displayed in the Zone Sets dialog box. A zone name must begin 
with a letter and be no longer than 64 characters. Valid characters are 0-9, A-Z, a-z, _, ^, $, 
and -.

Note:  If you enter the name of a zone that already exists in the database, the Switch Manager asks 
if you would like to add that zone and its membership to the zone set.

6. To add switch ports or attached devices to the zone, do one of the following:

— In the zone set tree, select the zone set. In the graphic window, select the port to add to 
the zone. Select Edit > Add Members. 

— Select a port by port number, Fibre Channel address, or World Wide Name in the 
Port/Device tree, and drag it into the zone.

— Select a port by port number, Fibre Channel address, or World Wide Name in the 
Port/Device tree. Right-click the zone and then select Add Zone Members.

7. Click Apply to save changes to the zoning database.
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Adding zone members

Adding a zone member to a zone affects every zone set in which that zone is a member. To add 
member ports/devices to a zone, do one of the following:

■ Select a port by port number, Fibre Channel address, or World Wide Name in the 
Port/Device tree, and drag it into the zone. To select and drag multiple ports/devices, press 
and hold Ctrl while dragging.

■ Select one or more ports by port number, Fibre Channel address, or World Wide Name in 
the Port/Device tree. Right-click the zone and then select Add Zone Members from the 
menu.

■ Select Edit > Create Members. Choose the WWN, Domain/Port, or First Port Address 
option and enter the port hex value.

Click Apply to save changes to the zoning database.

Note:  Domain ID conflicts can result in automatic reassignment of switch domain IDs. These 
reassignments are not reflected in zones that use domain ID/port number pair to define their 
membership. Be sure to reconfigure zones that are affected by a domain ID change.

Creating a member

The Create a Member dialog box allows you to add a member to a zone or alias that can not be 
added using the drag/drop method. 

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone or alias in the left pane in which to add a member.

3. Select Edit > Create Members. The Create a Member dialog box is displayed.

4. Click WWN, Domain Port, or FC Address.

5. Enter the hexadecimal value for the new zone member. Enter 16 digits for a WWN 
member, 4 digits for a Domain Port member (DDPP), or 6 digits for an FC Address 
member (DDPPAA - D=Domain ID, P=PortNumber, A=ALPA).

6. Click OK.

Renaming a zone or a zone set

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone/zone set to be renamed in the Zone Sets tree.

3. Select Edit > Rename. The Rename Zone/Rename Zone Set dialog box is displayed.

4. Enter a new name for the zone/zone set.

5. Click OK.

Removing a zone member

Removing a zone member affects every zone and zone set in which that zone is a member.

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone member to be removed.

3. Select Edit > Remove.

4. Click OK.
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Removing a zone from a zone set

Zones that are no longer members of any zone set are moved to the orphan zone set. The 
orphan zone set is saved on the switch. 

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone to be removed in the Edit Zoning dialog box.

The selected zone is removed from that zone set only.

3. Select Edit > Remove.

4. Click OK.

Removing a zone from all zone sets

Zones that are no longer members of any zone set are moved to the orphan zone set. The 
orphan zone set is saved on the switch. To remove a zone from all zone sets including the 
orphan zone set:

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the zone to be removed in the Edit Zoning dialog box.

3. Select Edit > Remove Zone from All Sets.

4. Click OK.

Changing zone types

1. Select the switch with the zone type to change in the faceplate display.

2. Select Zoning. The Edit Zoning dialog box is displayed (Figure 17).

3. Select the zone to change in the Zone Sets tree.

4. Select Edit > Set Zone Type. The Set Zone Type dialog box is displayed.

5. Select Soft or ACL from the Zone Type drop-down list. 

— Soft zoning is the least restrictive type of zoning.

— ACL zoning is hard zoning and is enforced by hardware and defines access to a given 
port.

Managing aliases
An alias is a collection of objects that can be zoned together. An alias is not a zone, and can 
not have a zone or another alias as a member. Managing aliases includes:

■ Creating an alias

■ Adding a member to an alias

■ Removing an alias from all zones

Note:  Changes that you make to the zoning database are limited to the managed switch and do 
not propagate to the rest of the fabric. To distribute changes to configured zone sets fabric wide, 
you must edit the zoning databases on the individual switches. You do not see aliases in the active 
zone set.
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Creating an alias

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select Edit > Create Alias. The Create Alias dialog box is displayed.

3. Enter a name for the alias, and then click OK.

The alias name is displayed in the Zone Sets dialog box. An alias name must begin with a 
letter and be no longer than 64 characters. Valid characters are 0-9, A-Z, a-z, _, $, ^, and -.

4. Click OK.

Adding a member to an alias

You can add a member to an alias in the following ways:

■ Drag-and-drop method.

■ Select the alias in the left pane and the member in the right pane to add to that alias, and 
then click Insert.

■ Select the alias in the left pane and the member in the right pane to add to that alias, and 
then select Edit > Add Members.

To add a member to an alias using the drag-and-drop method:

1. On the member to be added, click and hold down the mouse button.

2. Drag the selected member from the right pane to the alias in the left pane.

To add a member to an alias using the menu options:

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select an alias in the left pane.

3. Select the member to add to the selected alias in the right pane.

4. Choose one of the following: 

— Select Edit > Add Members.

— Click Insert.

5. Click OK.

Removing an alias from all zones

To remove an alias from all zones:

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select the alias to be removed in the Zone Sets tree.

3. Select Edit > Remove Alias from All Zones. The Remove dialog box is displayed.

4. Click Yes.

Saving the Zoning Database to a File
You can save the zoning database to an XML file. You can later reload this zoning database on 
the same switch or another switch. 

1. Select Zoning > Edit Zoning. The Edit Zoning dialog box is displayed (Figure 17).

2. Select File > Save As. The Save dialog box is displayed.

3. Enter a file name for the database file. 

4. Click Save. 
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Managing switches
This section describes the following tasks that manage switches in the fabric.

■ Managing user accounts, page 58

■ Displaying switch information, page 62

■ Configuring port threshold alarms, page 66

■ Exporting name server information to a file, page 67

■ Paging a switch, page 67

■ Setting the date/time and NTP client, page 68

■ Resetting a switch, page 68

■ Configuring a switch, page 68

■ Archiving a switch configuration, page 75

■ Restoring a switch configuration, page 75

■ Restoring the factory default configuration, page 77

■ Downloading a support file, page 78

■ Installing firmware, page 78

■ Displaying hardware status, page 79

Managing user accounts
Only the Admin account can manage user accounts with the User Account Administration 
dialog box. However, any user can modify their own password. Select Switch > User 
Accounts. The User Account Administration dialog box is displayed. A user account includes 
an account name or login, password, authority level, and expiration date.

Switches come from the factory with the following user accounts:

The Admin account can create, remove, or modify user accounts, and change account 
passwords. The Admin account can also view and modify the switch and its configuration with 
Switch Manager. The Admin account can not be removed. Users without Admin authority are 
limited to viewing switch status and configuration. 

The Images account can not be removed, and is required for exchanging files with the switch 
using FTP. 

Managing user accounts includes:

■ Creating user accounts

■ Removing a user account

■ Changing a user account password

■ Modifying a user account

Table 9:  Factory Supplied User Accounts

Account name Password Admin authority Expiration
admin admin true never expires
images images false never expires
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Creating user accounts
A switch can have a maximum of 15 user accounts.

1. Select Switch > User Accounts. The User Account Administration dialog box is 
displayed (Figure 18). 

Figure 18:  User Account Administration dialog box – Add Account

2. Click the Add Account tab at the bottom of the dialog box. The Add Account tab is 
displayed.

3. Enter an account name in the New Account Login box. Account names are limited to 15 
characters.

4. Click the Admin Authority Enabled check box to grant admin authority to the account 
name. 

5. Enter a password in the New Password box and enter it again in the Verify Password 
box. A password must have a minimum of 4 characters and no more than 20.

6. Select an option from the Account Expiration Date area.

7. Click Add Account.

Removing a user account
1. Select Switch > User Accounts. The User Account Administration dialog box is 

displayed (Figure 18). 

2. Click the Remove Account tab at the bottom of the dialog box. The Remove Account tab 
is displayed (Figure 19).

3. Select the account (login) name from the list of accounts at the top of the dialog box, and 
then click Remove Account. 
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Figure 19:  User Account Administration dialog box – Remove Account

Changing a user account password
1. Select Switch > User Accounts. The User Account Administration dialog box is 

displayed.

2. Click the Change Password tab at the bottom of the dialog box. The Change Password 
tab is displayed (Figure 20).

3. Select the account (login) name from the list of accounts at the top of the dialog box,

4. Enter the password in the Old Password, New Password, and Verify Password boxes.

5. Click Change Password.

Any user can change their password for their account, but only the Admin account name 
can change the password for another user’s account. If the administrator does not know 
the user’s original password, the administrator must remove the account, and then add the 
account again. 
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Figure 20:  User Account Administration dialog box – Change Password

Modifying a user account
1. Select Switch > User Accounts. The User Account Administration dialog box is 

displayed.

2. Click the Modify Account tab at the bottom of the dialog box. The Modify Account tab is 
displayed (Figure 21). 

Figure 21:  User Account Administration dialog box—Modify Account

3. Select the account (login) name from the list of accounts at the top of the dialog box. 
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4. Click the Admin Authority Enabled check box to grant admin authority to the account 
name. 

5. Select an option from the Account Expiration Date area.

6. Click Modify Account.

7. Click Close. 

Displaying switch information
The following faceplate display and data windows provide information about the name server, 
the device and HBA, switch specifications and addresses, configuration parameters, 
performance statistics, port information and configured zone sets information.

■ Name Server data window, page 63

■ Switch data window, page 63

■ Link data window, page 64

■ Port Statistics data window, page 64

■ Port Information data window, page 65

■ Configured Zonesets data windows, page 65

Figure 22:  Faceplate display—Switch data window

The fabric updates the topology and faceplate displays by forwarding changes in status to the 
management system as they occur. You can allow the fabric to update the switch status, or you 
can refresh the display at any time. 

To refresh switch status in the display, do one of the following:

■ Click Refresh.

■ Select View > Refresh.

■ Press F5.

■ Right-click a switch in the topology display, and then select Refresh Switch.

■ Right-click in the graphic window of the faceplate display, and then select Refresh 
Switch.
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Name Server data window
The Name Server data window displays information about the devices that are logged into the 
fabric. Click the Name Server tab below the data window to display name server information 
for all devices that are logged into the selected fabric. To narrow the display to devices that are 
logged into specific switches, select one or more switches in the fabric tree or the topology 
display. See Table 10 for a description of the entries in the Name Server data window and 
refer to “Exporting name server information to a file” on page 67 for more information. 

Switch data window
The Switch data window displays current network and switch information for the selected 
switches. See “Configuring a switch” on page 68 for more information about the Switch data 
window. To open the Switch data window, select one or more switches in the topology 
display, or open the faceplate display, and then click the Switch tab below the data window. 
Table 11 describes the Switch data window entries. 

Table 10:  Name Server data window entries

Entry Description
Target/Initiator Device type: target or initiator
Switch Switch name
Port Switch port address
Address Fibre Channel address
Type Node type
WWNN World Wide Node Name
WWPN World Wide Port Name
Vendor Host Bus Adapter/Device vendor
FC-4 types Device Fibre Channel protocol types
Active zones The active zone to which the device belongs

Table 11:  Switch data window entries

Entry Description
First port address Switch Fibre Channel address
World Wide Name Switch World Wide Name
Serial number Number assigned to each switch chassis

(required for license keys)
Reason for status Additional status information
User name Account name
Login level Authority level 
Super user Super user privileges enabled/disabled
User authentication enabled Enforcement of account names and authority
Vendor Switch manufacturer
Firmware version Active firmware version
Inactive firmware version This does not apply to this switch
Pending firmware version Firmware version that is activated at the next 

reset
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Link data window
The Link data window displays information about all switch links in the fabric or selected 
links. This information includes the switch name, the port number at the end of each link, and 
the link status. 

To open the Link data window, click the Link tab below the data window in the topology 
display.

Port Statistics data window
The Port Statistics data window displays port performance data for the selected ports. 

To open the Port Statistics data window, click the Port Stats tab below the data window in the 
faceplate display. See Table 23 for a description of the Port Statistics data window entries.

The Statistics menu is available on the Port Statistics data window, and provides different 
ways to view detailed port information. Click the down arrow to open the menu. Open the 
menu, and then select Absolute to view the total count of statistics since the last switch reset. 
Select Rate to view the number of statistics counted per second over the polling period. Select 
Baseline to view the total count of statistics since the last time the baseline was set. Click 
Clear Baseline to set the current baseline.

PROM/Boot version PROM boot version
MAC address Media Access Control address
IP address Internet Protocol address
Subnet mask Mask that determines the IP address subnet
Gateway Gateway address
SNMP enabled SNMP enabled/disabled
Negotiated domain ID The domain ID currently being used by the 

fabric
Configured domain ID The domain ID defined by the network 

administrator
Domain ID lock Domain ID lock status

(prevents (true) or permits (false) dynamic 
domain ID reassignment)

Number of ports Number of ports activated on the switch
Switch type Switch model
Operational state Switch operational state: online, offline, 

diagnostic
Administrative state Current switch administrative state
Configured admin state Switch administrative state that is stored in the 

switch configuration
R_A_TOV Resource allocation timeout value
E_D_TOV Error detect timeout value

Table 11:  Switch data window entries (Continued)

Entry Description
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Port Information data window
The Port Information data window displays port detail information for the selected ports. To 
open the Port Statistics data window, click the Port Info tab below the data window in the 
faceplate display. Refer to Table 24 for a description of the Port Information data window 
entries.

Configured Zonesets data windows
The Configured Zonesets data window displays all zone sets, zones, aliases, and zone 
membership in the zoning database (Figure 23). 

To open the Configured Zonesets data window, click the Configured Zonesets tab below the 
data window in the faceplate display. To view the active zonesets in the Active Zonesets data 
window, open the topology display, and then click the Active Zonesets data window tab. 

The Configured Zonesets data window uses display conventions for expanding and 
contracting entries that are similar to the fabric tree. An entry handle located to the left of an 
entry in the tree indicates that the entry can be expanded. Click this handle or double-click the 
following entries to expand or collapse them.

■ A zone set entry expands to show its member zones.

■ A zone entry expands to show its members by port number, World Wide Name, or Fibre 
Channel address.

■ The alias entry expands to show its entries. 

Figure 23:  Configured Zonesets data window
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Configuring port threshold alarms
You can configure the switch to generate alarms for selected events. Configuring an alarm 
involves choosing an event type, rising and falling triggers, a sample window, and finally 
enabling or disabling the alarm. 

1. Select Switch > Port Threshold Alarm Configuration. The Port Threshold Alarm 
Configuration dialog box is displayed (Figure 24).

The Port Threshold Alarm Configuration dialog box prompts you to enable or disable all 
alarms, select an event, set triggers, set a sample window and enable or disable an 
individual alarm.

Figure 24:  Port Threshold Alarm Configuration dialog box

2. Check Enable All Port Threshold Alarms to enable monitoring for all the individual 
alarm types that are enabled.

The Enable All Port Threshold Alarms check box is the master control for the 
individual alarms. For example, the switch monitors CRC errors only if both CRC Error 
Enable and Enable All Port Threshold Alarms are checked.

3. Select an event type from the Port Threshold Alarm drop-down list. Choose from the 
following options:

— CRC error monitoring

— Decode error monitoring

— Login monitoring

— Logout monitoring

— Loss of signal monitoring

4. Check Enable to make the alarm eligible for use. 

5. Enter a value for the rising trigger.

A rising trigger alarm is generated when the event count per interval exceeds the rising 
trigger. The switch does not generate another rising trigger alarm for that event until the 
count descends below the falling trigger and rises again above the rising trigger. Consider 
the example in Figure 25.

6. Enter a value for the falling trigger.

A falling trigger alarm is generated when the event count per interval descends below the 
falling trigger.

Note:  The switch disables a port if a rising trigger alarm is not cleared after three consecutive 
sample windows.

Download from Www.Somanuals.com. All Manuals Search And Download.



Switch Manager

67HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Figure 25:  Port Threshold Alarm example

7. Enter a sample window in seconds.

The sample window defines the period of time in which to count events.

8. Repeat step 3 through step 7 for each alarm you want to configure or enable. 

9. Click OK.

Exporting name server information to a file
To save name server information to a file, open the topology display and do the following:

1. Select one or more switches. If no switches are selected, name server information is 
gathered for all switches.

2. Select Switch > Export Name Server. The Save dialog box is displayed.

3. Enter a file name in the Save dialog box.

4. Click Save.

Paging a switch
You can use the beacon feature to page a switch. The beacon feature causes all Logged-In 
LEDs to flash, making it easier to recognize. 

To page a switch, select Switch > Toggle Beacon. 

To cancel the beacon, reselect Toggle Beacon.

Rising 
Trigger

Falling 
Trigger

Event 
Count

Sample Window

Generate falling 
trigger alarm; 
eligibility is reset

Generate rising 
trigger alarm; 
eligibility ends

Generate rising 
trigger alarm; 
eligibility ends
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Setting the date/time and NTP client
The Date/Time and Network Time Protocol (NTP) dialog box enables you to set the date and 
time manually on a switch, or to enable NTP Client to synchronize the date and time on the 
switch with an NTP server. Enabling the NTP client ensures the consistency of date and time 
stamps in alarms and log entries. An Ethernet connection to an NTP server is required.

1. Select a switch in the topology display, and open the faceplate display.

2. Select Switch > Set Date/Time. The Switch Date/Time dialog box is displayed.

3. Choose one of the following:

— Enter the year, month, day and time in the Switch Date/Time dialog box, and then 
click OK. The new date and time take effect immediately. 

— Click NTP Client Enabled to enable the switch to synchronize its time with an NTP 
server. Enter the IP address of the NTP server. Ethernet connection to NTP server is 
required.

4. Click OK. 

Resetting a switch
Resetting a switch reboots the switch using configuration parameters in memory. Depending 
on the reset type, a switch reset may or may not include a Power On Self Test. Table 12 
describes the types of switch resets.

1. Select the switch to be reset, and then open the faceplate display.

2. Select Switch > Reset Switch. 

— Select Reset to perform a standard reset.

— Select Hard Reset to perform a hard reset.

Configuring a switch
Switch configuration is divided into areas: 

■ Configuration wizard

■ Switch properties

■ Network properties

Switch properties specify switch-wide Fibre Channel settings and Network properties specify 
Ethernet and SNMP settings.

Each of these configuration options are discussed in the following sections.

Table 12:  Switch resets

Type Description
Reset without Power On Self 
Test (POST)

Resets a switch without a Power On Self Test. This reset 
activates the pending firmware and it is disruptive to switch 
traffic. 

Hard reset Resets a switch with a Power On Self Test. This reset activates 
the pending firmware and it is disruptive to switch traffic. 
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Configuration wizard
The Configuration wizard is a series of dialog boxes you can use to configure the IP address 
and other basic parameters on new or replacement switches. Switch Manager detects the first 
time use and present the Initial Start Dialog—Switch Manager dialog box, from which the 
Configuration wizard can be launched. You can also launch the Configuration wizard from the 
Wizards menu in either the topology display or the faceplate display by opening the Wizards 
menu, and then selecting Configuration Wizard.

Switch properties
To open the Switch Properties dialog box, either select a switch in the topology display or 
open the faceplate display for the switch you are configuring, and then select Switch > Switch 
Properties. You may also right-click a switch graphic in the topology display or faceplate 
display, and then select Switch Properties from the menu. 

Use the Switch Properties dialog box to change the following switch configuration 
parameters:

■ Symbolic Name parameter

■ Administrative State parameter

■ Domain ID and Domain ID Lock parameters

■ Broadcast Support parameter

■ In-band Management parameter

■ Interop Mode parameter

■ Legacy Address Format parameter

The timeout values are displayed only for reference purposes when the switch is online; they 
become active when the switch is taken offline. After making changes, click OK to put the 
new values into effect.

Figure 26:  Switch Properties dialog box

Symbolic Name parameter

The symbolic name is a user-defined name of up to 32 characters that identifies the switch. 
The symbolic name is used in the topology and faceplate displays, as well as many data 
windows to more easily identify switches. Illegal characters are the pound sign (#), semi-colon 
(;), and comma (,).
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Administrative State parameter

The switch administrative state determines the operational state of the switch. The switch 
administrative state exists in two forms: the configured administrative state and the current 
administrative state.

■ The configured administrative state is the state that is saved in the switch configuration 
and is preserved across switch resets. Switch Manager always makes changes to the 
configured administrative state. The configured administrative state is displayed in the 
Switch Properties dialog box.

■ The current administrative state is the state that is applied to the switch for temporary 
purposes and is not retained across switch resets. The current administrative state is set 
using the Set Switch command. See the “Set command” on page 135.

Table 13 describes the administrative state values.

Domain ID and Domain ID Lock parameters

The domain ID is a unique Fibre Channel identifier for the switch. The Fibre Channel address 
consists of the domain ID, port ID, and the Arbitrated Loop Physical Address (ALPA). The 
maximum number of switches within a fabric is 239 with each switch having a unique domain 
ID.

Switches come from the factory with the domain IDs unlocked. This means that if there is a 
domain ID conflict in the fabric, the switch with the highest principal priority, or the principal 
switch, reassigns any domain ID conflicts and establishes the fabric. If you lock the domain ID 
on a switch and a domain ID conflict occurs, one of the switches isolates as a separate fabric 
and the Logged-In LEDs on both switches flash to show the affected ports. See the “Set 
Config command” on page 137 for information about the switch keyword and the Domain ID 
Lock and Principal Priority parameters.

If you connect a new switch to an existing fabric with its domain ID unlocked, and a domain 
conflict occurs, the new switch isolates as a separate fabric. However, you can remedy this by 
resetting the new switch or taking it offline then back online. The principal switch reassigns 
the domain ID and the switch joins the fabric.

Note:  Domain ID reassignment is not reflected in zoning that is defined by domain ID and port 
number pair. You must reconfigure zones that are affected by domain ID reassignment.

Broadcast Support parameter

Broadcast is supported, which allows for TCP/IP support. Broadcast is implemented using the 
proposed standard specified in Multi-Switch Broadcast for FC-SW-3, T11 Presentation 
Number T11/02-031v0. Fabric Shortest Path First (FSPF) is used to set up a fabric spanning 
tree used in transmission of broadcast frames. Broadcast frames are retransmitted on all online 
F_Ports. Broadcast zoning is supported with Access Control List (ACL) hard zones. When a 
broadcast frame is received, these hard zones are enforced at the F_Port. If the originator of 

Table 13:  Switch administrative states

Parameter Description
Online The switch is available.
Offline The switch is unavailable.
Diagnostics The switch is in diagnostics mode, is unavailable, and tests 

can then be run on all ports of the switch.
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the broadcast is in a hard zone, the frame is retransmitted on all online F_Ports within the hard 
zone. If the originator of the broadcast frame is not in a hard zone, the frame is retransmitted 
on online F_Ports that are not in a hard zone. The default setting is disabled.

In-band Management parameter

In-band Management is the ability to manage switches across inter-switch links using Switch 
Manager, SNMP, management server. The switch comes from the factory with in-band 
management enabled. If you disable in-band management on a particular switch, you can no 
longer communicate with that switch by means other than a direct Ethernet or serial 
connection. In-band Management is not supported at this time.

Interop Mode parameter

When a zone set is activated, this and other FC-SW-2 compliant switches propagate the active 
zone set to all switches in the fabric. Some non-FC-SW-2 compliant switches propagate not 
only the active zone set, but the entire zoning database. Disabling the Interop Mode parameter 
causes the Switch switch to propagate the zoning database, and therefore, interoperate with 
non-FC-SW-2 switches. For FC-SW-2 compliant fabrics, the Interop Mode parameter should 
be enabled. Interop Mode is not supported at this time.

Legacy Address Format parameter

Legacy Address Format should be enabled only to permit interoperation with certain older 
non-FC-SW-2 switches. Enabling this setting under other circumstances disables zoning that 
is defined by domain ID and port number. This setting is available only when the Interop 
Mode setting is disabled. Contact your HP authorized service provider for assistance in using 
this feature. Legacy Address Format is not supported at this time.

Timeout Values parameters

The switch timeout values determine the timeout values for all ports on the switch. Table 14 
describes the switch timeout parameters. The timeout values must be the same for all switches 
in the fabric.

Note:  Mismatched timeout values disrupt the fabric. These values should not be changed unless 
absolutely necessary. The switch must be offline to change the values. Use the Switch Properties 
dialog box to take the switch offline.

Table 14:  Timeout values

Parameter Description
R_A_TOV Resource Allocation Timeout: Represents the maximum time a frame 

could be delayed in the fabric and still be delivered. The default is 
10000 milliseconds.

E_D_TOV Error Detect Timeout: Represents the maximum round trip time that an 
operation between two N_Ports could require. The default is 2000 
milliseconds.
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Network properties
Use the Network Properties dialog box to change the following network settings:

■ IP Configuration parameters

■ SNMP Configuration parameters

■ SNMP Trap Configuration

■ Remote Logging parameter

1. Select a switch in the topology display or open the faceplate display.

2. Select Switch > Network Properties. The Network Properties dialog box is displayed 
(Figure 27).

3. After making changes, click OK to put the new values into effect. 

Note:  Read Community, Trap Community, and Write Community are similar to passwords and are 
write-only boxes. Current settings are not displayed.

Figure 27:  Network Properties dialog box

IP Configuration parameters

The IP configuration identifies the switch on the Ethernet network and determines which 
network discovery method to use. Table 15 describes the IP configuration parameters.
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SNMP Configuration parameters

The SNMP configuration defines how authentication traps are managed. Table 16 describes 
the SNMP configuration parameters. Illegal characters for the user-defined boxes are the 
pound sign (#), semi-colon (;), and comma (,).

Table 15:  IP configuration parameters

Parameter Description
Network 
Discovery

Use one of the following methods to assign the IP address:
■ Static—Uses the IP configuration parameters entered in the Switch 

Properties dialog box.
■ BootP—Acquires the IP configuration from a BootP server.
■ RARP (Reverse Address Resolution Protocol)—Acquires the IP address from 

an RARP server. An RARP request is broadcast with up to three retries, 
each at 5 second intervals. If no IP address is obtained, the switch reverts to 
the previously configured IP address.

■ DHCP (Dynamic Host Configuration Protocol)—Acquires the IP 
configuration from a DHCP server. If no satisfactory lease is obtained, the 
DHCP client attempts to use the previously configured lease. If the previous 
lease cannot be used, no IP address is assigned to this switch in order to 
avoid an IP address conflict. The DHCP server must then be made 
available.

If a BootP, RARP, or DHCP server is not available, the switch attempts to use a 
previously assigned valid lease. If no lease was ever assigned, the switch 
attempts to use the previously assigned static IP address.

IP Address Internet Protocol (IP) address for the Ethernet port. Default: 10.0.0.1.
Subnet mask Subnet mask address for the Ethernet port. Default value: 255.0.0.0.
Gateway IP gateway address. Default: 10.0.0.254.

Table 16:  SNMP Configuration parameter

Parameter Description
SNMP Enabled Enables or disables SNMP communication with other switches 

in the fabric.
Contact Specifies the name (up to 64 characters) of the person who is 

to be contacted to respond to trap events. 
The default is “undefined”.

Read Community Read community password (up to 32 characters) that 
authorizes an SNMP agent to read information from the 
switch. This is a write-only box. The value on the switch and 
the SNMP management server must be the same. 
The default is “public”.

Trap Community Trap community password (up to 32 characters) that 
authorizes an SNMP agent to receive traps. This is a 
write-only box. The value on the switch and the SNMP 
management server must be the same. 
The default is “public”.

SNMP Proxy If enabled, you can use SNMP to monitor and configure any 
switch in the fabric. 
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SNMP Trap Configuration

The SNMP trap configuration defines how traps are set. Choose from the tabs Trap1 – Trap 5 
to configure each trap. Table 17 describes the SNMP configuration parameters.

Remote Logging parameter

The Remote Logging (syslog) parameter enables saving of the log information to a remote 
host that supports the syslog protocol. When enabled, the log entries are sent to the syslog host 
at the IP address entered in the Logging Host IP Address box. Log entries are saved in the 
internal switch log whether this feature is enabled or not.

Location Specifies the name (up to 64 characters) for the switch 
location. 
The default is “undefined”.

Authentication Trap Enables or disables the reporting of SNMP authentication 
failures. If enabled, a notification trap is sent when incorrect 
community string values are used. 
The default is “False”.

Write Community Write community password (up to 32 characters) that 
authorizes an SNMP agent to write information to the switch. 
This is a write-only box. The value on the switch and the 
SNMP management server must be the same. 
The default is “private”.

Table 17:  SNMP trap configuration parameters

Parameter Description
Trap Version Specifies the SNMP version (1 or 2) with which to format traps.
Trap 1 Enabled Enables or disables the trap. 

If disabled, traps are not configurable.
Trap Address* Specifies the IP address to which SNMP traps are sent. 

A maximum of 5 trap addresses are supported. 
The default address for trap 1 is 10.0.0.254.
The default address for traps 2–5 is 0.0.0.0.

Trap Port* The port number on which the trap is sent. 
The default is 162.

Trap Severity Specifies a severity level to assign to the trap. 
Open the menu and choose a level. The Trap 1 Enabled check box on 
the Network Properties dialog box must be enabled to access this 
menu. 
Trap severity levels include Unknown, Emergency, Alert, Critical, 
Error, Warning, Notify, Info, Debug, and Mark.

* Trap address (other than 0.0.0.0) and trap port combinations must be unique. For example, if 
trap 1 and trap 2 have the same address, they must have different port values. Similarly, if trap 
1 and 2 have the same port value, they must have different addresses.

Table 16:  SNMP Configuration parameter (Continued)

Parameter Description

Download from Www.Somanuals.com. All Manuals Search And Download.



Switch Manager

75HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

To save log information to a remote host, you must edit the syslog.conf file (located on 
the remote host) and then restart the syslog daemon. Consult your operating system 
documentation for information on how to configure Remote Logging. The syslog.conf 
file on the remote host must contain an entry that specifies the name of the log file in which to 
save error messages. 

Add the following line to the syslog.conf file:

local0.info <tab> /var/adm/messages.name

A <tab> separates the Selector (local0.info) and Action (/var/adm/messages/ 
messages.name).

Archiving a switch configuration
You can create an XML archive file containing the configuration parameters. Basically, any 
data received by Switch Manager is archived. However, user accounts and passwords are 
available only through the command line interface, and are not received by Switch Manager, 
and thus are not archived. Archived parameters include the following:

■ Switch properties and statistics

■ IP configuration

■ SNMP configuration

■ Port properties and statistics

■ Alarm configuration

■ Zoning configuration

This archive file can be used to restore the configuration on the same switch or on a 
replacement switch. You can also use the archive file as a template for configuring new 
switches to add to a fabric. User account information is not archived. The archive can be used 
later to restore the switch. See “Restoring a switch configuration” on page 75 for more 
information. 

1. Select Switch > Archive. The Save dialog box is displayed.

2. Enter a file name in the Save dialog box.

3. Click Save.

Restoring a switch configuration
Restoring a switch loads the archived switch configuration parameters to the switch. The 
switch configuration must be archived before it can be restored. See “Archiving a switch 
configuration” on page 75 for more information.

Caution:  The switch being restored should be physically disconnected from the fabric. 
Restoring a switch in a fabric can severely disrupt the fabric. After the restore process is 
complete, the switch can be reconnected to the fabric.

1. Log in to the fabric through the switch you want to restore.

2. Select Switch > Restore. The Restore dialog box is displayed (Figure 28).

The Restore dialog box offers a Full Restore and a Selective Restore tab.
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Figure 28:  Restore dialog boxes – Full and Selective

3. Enter the archive file name or browse for the file. This archive file must be one that was 
produced by the Switch Manager Archive function. Configuration backup files created 
with the Config Backup CLI command are not compatible with the Switch Manager 
Restore function.

4. To restore all configuration settings, click the Full Restore tab, and then click Restore. 
To restore selected configuration settings, click the Selective Restore tab and check one 
or more of the following boxes, and then click Restore:

— Network Properties—Restores all settings presented in the Network Properties 
dialog box except the IP address. Refer to“Network properties” on page 72.

— IP Address—Restores switch IP address in addition to the other network properties.

— Switch Properties: Restores all settings presented in the Switch Properties dialog box 
except the domain ID. Refer to“Switch properties” on page 69.

— Domain ID—Restores switch domain ID in addition to the other switch properties.

— Port Properties—Restores all settings presented in the Port Properties dialog box. 
Refer to“Configuring ports” on page 85.

— Configured Zoning—Restores all zone sets, zones, and aliases in the switches zoning 
database.

5. If you select the Configured Zoning or Full Restore option and the file contains zone 
sets, a dialog box prompts you to activate one of those zone sets.

6. Click Yes.

7. Select a zone set from the drop-down list in the Select Zone Set to be Activated dialog 
box.

8. Click OK and view the results in the top pane of the Restore dialog box.
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Restoring the factory default configuration
You can restore the switch and port configuration settings to the factory default values. To 
restore the factory configuration on a switch, select Switch > Restore Factory Defaults. 
Table 18 lists the factory default switch configuration settings.

Restoring the switch to the factory default configuration does not restore the account name and 
password settings. To restore user accounts, select Maintenance > Reset Password File. 
Refer to “Recovering a Switch” in the Installation Guide for your switch for information about 
maintenance mode and the Maintenance menu.

Table 18:  Factory default configuration settings

Setting Value
Symbolic Name 2/8q FC Switch
Administrative State Online
Domain ID 1
Domain ID Lock False
In-band Management True
Broadcast Support Enable
Resource Allocation Timeout (R_A_TOV) 10000 milliseconds
Interop Mode True (not supported)
I/O Stream Guard Disabled
Device Scan Enabled True
Interop Credits 0 (not supported)
Error Detect Timeout (E_D_TOV) 2000 milliseconds
SNMP Enabled True
SNMP Proxy True
IP Address 10.0.0.1
Subnet Mask Address 255.0.0.0
Gateway Address 10.0.0.254
Network Discovery Static
Remote Logging False
Remote Logging Host Ip Address 10.0.0.254
Contact Undefined
Location Undefined
Trap Enabled False
Trap Port 162
Trap Address Trap 1: 10.0.0.254; Traps 2-5: 0.0.0.0
Trap Community Public
Read Community Public
Write Community Private
Port State Online
Port Speed Auto-detect
Port Type GL
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Downloading a support file
The Download Support File menu option assembles all log files and switch memory data into 
a core dump file (dump_support.tgz zip). This file can be sent to technical support 
personnel for troubleshooting switch problems. The menu option is not displayed for switches 
that don't support the download support file function. 

1. Select Switch > Download Support File. The Download Support File dialog box is 
displayed. 

2. Click Browse to define a location for the support file or type the path in the Text box.

3. Click Start to begin the process of creating and downloading the support file to your 
workstation.

4. Observe the status in the Status area.

5. After the support file is saved to your workstation, click Close. 

Installing firmware
Installing firmware involves loading, unpacking, and activating the firmware image on the 
switch. Switch Manager does this in one operation. To provide consistent performance 
throughout the fabric, ensure that all switches are running the same version of firmware.

The switch only supports one firmware image, and thus there is no inactive firmware image. 
The pending firmware version only differs from the active version during the brief period 
while the switch is resetting to activate the firmware. Firmware management tools enable you 
to install and activate new firmware.

You can load and activate firmware on an operating switch without disrupting data traffic or 
having to re-initialize attached devices. If you attempt to perform a non-disruptive activation 
without satisfying the following conditions, the switch performs a disruptive activation:

■ No changes are being made to switches in the fabric including powering up, powering 
down, and switch configuration changes.

■ No port in the fabric is in the diagnostic state.

■ No zoning changes are being made in the fabric.

■ No changes are being made to attached devices including powering up, powering down, 
disconnecting, connecting, and HBA configuration changes.

Ports that are stable when the non-disruptive activation begins and then change states, are 
reset. When the non-disruptive activation is complete, Switch Manager sessions reconnect 
automatically. However, Telnet sessions must be restarted manually.

Select a switch in the topology display and double-click to open the Faceplate display.

6. Select Switch > Load Firmware. The Firmware Upload dialog box is displayed.

7. Click Select to browse and then select the firmware file to be uploaded.

8. Click Start to begin the firmware load process.

9. Click OK to continue firmware installation or click Cancel to cancel the firmware 
installation.

Switch Manager attempts a hot reset, if possible, to activate the firmware without disrupting 
data traffic. During a non-disruptive activation, all Logged-In LEDs are extinguished for 
several seconds. If a non-disruptive activation is not possible, Switch Manager gives you the 
opportunity to reset the switch and perform a disruptive activation.
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Displaying hardware status

To display a summary of the hardware status information in a popup text box, rest the cursor 
over the chassis LED cluster in the faceplate display. 

■ Input Power LED—Indicates the voltage status of the switch.

■ Heartbeat LED—Indicates the status of the switch processor and the results of the POST.

■ System Fault LED—Indicates an over temperature condition or a POST error.

Figure 29:  Hardware status LEDs
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Managing ports
This section describes the following tasks that manage ports and devices:

■ Displaying port information, page 80

■ Configuring ports, page 85

■ Resetting a port, page 89

■ Testing ports, page 89

Displaying port information
Port information is available primarily in the faceplate display (Figure 30) and includes: 

■ Port status

■ Port Statistics data window

■ Port Information data window

■ Name Server data window

The faceplate display data windows provide information and statistics for switches and ports. 
Use the topology display to view status information on fabrics, switches, and links between 
switches.

Figure 30:  Faceplate Display – Port Information data window

Port status
To display port number and status information for a port, position the cursor over a port on the 
faceplate display. The status information changes depending on the View menu option.

■ Displaying port types

■ Displaying port operational states

■ Displaying port speeds

■ Displaying transceiver media status
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Displaying port types

To display port type status, select View > View Port Types. Table 19 lists the possible port 
types and their meanings.

Displaying port operational states

To display the operational state on each port, select View > View Port States. Table 20 lists 
the possible operational states and their meanings. The port operational state refers to actual 
port state and not the administrative state you may have assigned.

Displaying port speeds

To display the speed of each port, select View > View Port Speeds. Table 21 lists the possible 
port speeds.

Displaying transceiver media status

To display transceiver media status, select View > View Port Media. Table 22 lists the port 
media states and their meanings.

Table 19:  Port type

State Description
F_Port Fabric port—Supports a single public device (N_Port). 
FL_Port Fabric loop port—Self discovers a single device (N_Port) or a loop of up to 

126 public devices (NL_Port). 
G_Port Generic port—Self discovers as an F_Port.
GL_Port Generic loop port—Self discovers as an F_Port or an FL_Port. GL_Port is the 

default port type. A single device on a public loop attempts to configure as an 
F_Port first, if that fails it attempts to configure as an FL_Port. 

Donor Donor port—Allows buffer credits to be used by another port. 

Table 20:  Port operational states

State Description
On Online—Port is active and ready to send data.
Ia Inactive—Port operational state is offline, but administrative state is online.
Off Offline—Port is active, can receive signal, but cannot accept a device login.
Dia Diagnostics—Port is in diagnostics mode in preparation for testing
Dn Down—Port is disabled, power is removed from the lasers, and cannot be 

logged in.

Table 21:  Port speeds

State Description
Au Auto-detect
1Gbps 1 Gbps transmission speed (not supported)
2Gbps 2 Gbps transmission speed

Download from Www.Somanuals.com. All Manuals Search And Download.



Switch Manager

82 HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Port Statistics data window
The Port Statistics data window displays statistics about port performance. To open the Port 
Statistics window, select one or more ports in the faceplate display, and then click the Port 
Stats tab below the data window. Table 23 describes the Port Statistics data window entries.

The Statistics menu is available on the Port Statistics data window, and provides different 
ways to view detailed port information. Click the down arrow to open the menu. Open the 
menu and then select Absolute to view the total count of statistics since the last switch or port 
reset. Select Rate to view the number of statistics counted per second over the polling period. 
Select Baseline to view the total count of statistics since the last time the baseline was set. 
When viewing baseline statistics, click Clear Baseline to set the current baseline. The 
baseline is also set when the switch status changes from unreachable to reachable. 

Table 22:  Port/transceiver states

State Description

Optical SFP, Online (Green) 

Optical SFP, Offline (Gray)

None Empty port, no transceiver installed

Table 23:  Port Statistics data window entries

Entry Description
Start Time The beginning of the period over which the statistics apply. The start 

time for the Absolute view is not applicable. The start time for the Rate 
view is the beginning of polling interval. The start time for the Baseline 
view is the last time the baseline was set.

End Time The last time the statistics were updated on the display.
Total Time Total time period from start time to end time.
Al Init Number of times the port entered the initialization state.
AL Init Error Number of times the port entered initialization and the initialization 

failed. Increments count when port has a sync loss.
Bad Frames Number of frames that were truncated due to a loss of sync or the 

frame did not end with an EOF.
Class 3 Frames In Number of class 3 frames received by this port.
Class 3 Frames Out Number of class 3 frames transmitted by this port.
Class 3 Toss Number of class 3 sequences discarded by this port. A sequence can 

be discarded because of detection of a missing frame (based on 
SEQ_CNT), detection of an E_D_TOV timeout, receiving a reject 
frame, receiving frames for a stopped sequence, or other causes.

Class 3 Words In Number of class 3 words received by this port.
Class 3 Words Out Number of class 3 words transmitted by this port.
Decode Errors Number of invalid transmission words detected during decoding. 

Decoding is from the 10-bit characters and special K characters.
Ep Connects Number of E_Port logins.
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FBusy Number of class 3 fabric busy (F_BSY) frames generated by this port 
in response to incoming frames. This usually indicates a busy condition 
on the fabric or N_port that is preventing delivery of this frame.

Flow Errors Number of times a frame is received and all the switch ports receive 
buffers are full. The normal Fabric Login exchange of flow control 
credit should prevent this from occurring. The frame is discarded.

FReject Number of frames, from devices, that have been rejected. Frames can 
be rejected for any of a large number of reasons.

Invalid CRC Number of invalid Cyclic Redundancy Check (CRC) frames detected.
Invalid Destination 
Address

Number of address identifier (S_ID, D_ID) errors. AL_PA equals 
non-zero AL_PA found on F_Port.

Link Failures Number of optical link failures detected by this port. A link failure is a 
loss of synchronization or by loss of signal while not in the offline 
state. A loss of signal causes the switch to attempt to re-establish the 
link. If the link is not re-established, a link failure is counted. A link 
reset is performed after a link failure.

LIP (AL_PD,AL_PS) Number of F7, AL_PS LIPs, or AL_PD (vendor specific) resets 
performed.

LIP(f7,AL_PS) Used to reinitialize the loop. An L_port, identified by AL_PS, may have 
noticed a performance degradation and is trying to restore the loop.

LIP(f7,f7) A loop initialization primitive frame used to acquire an AL_PA.
LIP(f8,AL_PS) Denotes a loop failure detected by the L_port identified by AL_PS.
Login Count Number of device logins that have occurred on the switch.
Logout Count Number of device logouts that have occurred on the switch.
Loop Timeouts Number of loop timeouts.
Loss Of Sync Number of synchronization losses (>100 ms) detected by this port. A 

loss of synchronization is detected by receipt of an invalid 
transmission word.

Primitive Sequence 
Errors

Number of bad primitives received by the port.

Rx Link Resets Number of link reset primitives received from an attached device.
Rx Offline Sequences Number of offline sequence primitives received by the port.
Total Errors Total number of primitive and non-primitive port link errors.
Total Link Resets Number of link-reset primitives the transmitted by the port.
Total LIPs Received Number of loop initialization primitive frames received.
Total LIPs Transmitted Number of loop initialization primitive frames transmitted.
Tx Offline Sequences Number of offline primitives transmitted by the port.
Total Rx Frames Total number of frames received by the port.
Total Rx Words Total number of words received by the port.
Total Tx Frames Total number of frames transmitted by the port.
Total Tx Words Total number of words transmitted by the port.
Tx Link Resets Number of link reset primitives sent from this port to an attached port.
Total Offline 
Sequences

Total number of offline sequences transmitted and received by the 
port.

Table 23:  Port Statistics data window entries (Continued)

Entry Description
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Port Information data window
The Port Information data window displays port detail information for the selected port. To 
open the Port Information data window, click the Port Info tab below the data window in the 
faceplate display. Table 24 describes the Port Information data window entries.

Table 24:  Port Information data window entries

Entry Description
Port Address Port Fibre Channel address.
Administrative Port 
Type

The port type (G, GL, F, FL, or Donor) that the port is configured as. 
This value is persistent; it is maintained during a switch reset. During a 
port auto-configuration it is used to determine which operational port 
states are allowed. 

Operational Port Type The port type that is currently active. This is set during port 
auto-configuration based on the administrative port type. 

Administrative Port 
State

The port state (Online, Offline, Diagnostics, or Down) which has been 
set by the user. This state may be different from the configured 
administrative state if the user has not saved it in the switch 
configuration. This state is used at the time it is set to try to set the port 
operational state. This value is not persistent and is lost on a switch 
reset.

Operational Port State The port state that is currently active. This value may be different from 
the administrative port state, for example due to an error condition.

Configured 
Administrative Port 
State

The port state (Online, Offline, Diagnostics, or Down) which is saved 
in the switch configuration, either by the user or at the factory. This 
value is persistent; it is maintained during a switch reset, and is used 
after a reset to set the port operational state. 

Logged In Indicates whether logged in or not.
MFS Mode Port tuning indicator.
I/O Stream Guard Whether RSCN suppression is enabled or disabled.
Administrative Port 
Speed

The speed requested by the user.

Operational Port 
Speed

The speed actually being used by the port.

Interop Credits Whether Interop credits have been set. (not supported)
Device Scan Queries the connected device during login for FC-4 descriptor 

information. Disable this parameter only if the scan creates a conflict 
with the connected device.

Symbolic Name Port symbolic name.
Ext Credits Requested Whether extended credits have been requested for ports.
Credits to Donate The number of credits available to be donated by the selected port.
Donor Group The donor group of the selected port.
Valid Donor Groups The number of separate groups within which extended credits may be 

donated and assigned.
Medium The transceiver type. 
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Name Server data window
The Name Server data window displays information about devices (hosts and storage targets) 
connected to the switch. To open the Name Server data window from the topology or faceplate 
display, click the Name Server tab below the data window. In the topology display, if no 
switches are selected, the name-server entries for the entire fabric are displayed in the data 
window; if switches are selected, only the devices attached to the selected switches are 
displayed. In the faceplate display, only the devices attached the switch being viewed are 
displayed. See Table 10 for a description of the Name Server data window entries.

Configuring ports
The port settings or characteristics are configured using the Port menu and the Port Properties 
dialog box as shown in Figure 31. To open the Port Properties dialog box for a port, select one 
or more ports, and then select Port > Port Properties. 

Figure 31:  Port Properties dialog box

The Port Properties dialog box displays the switch name and the selected port(s). Use the Port 
Properties dialog box to view and change the following:

■ Port States parameters

■ Port Speed parameters

■ Port Type parameters

■ Interoperability Credits parameters

■ I/O Stream Guard parameters

■ Device Scan parameter

■ Changing the port symbolic name

■ Extending port credits
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Port States parameters
The port administrative state determines the operational state of a port. The port administrative 
state exists in two forms: 

■ The configured administrative state is the state that is saved in the switch configuration 
and is preserved across switch resets. Switch Manager always makes changes to the 
configured administrative state.

■ The current administrative state is the state that is applied to the port for temporary 
purposes and is not preserved across switch resets. The current administrative state is set 
using the Set Port command. See the “Set Port command” on page 146.

Table 25 describes the port administrative states. 

1. Select one or more ports in the faceplate display.

2. Select Port > Port Properties. The Port Properties dialog box is displayed.

3. Click the Port States option that corresponds to the port state you want.

4. Click OK.

Port Speed parameters
Ports are capable of transmitting and receiving at 1 or 2 Gbps. The ports can be configured for 
either transmission speed or to sense the transmission speed of the device to which it is 
connected. Table 26 describes the port speeds. 

1. Select one or more ports in the faceplate display.

2. Select Port > Port Properties. The Port Properties dialog box is displayed.

3. Click the Port Speed option that corresponds to the port speed you want.

4. Click OK.

Table 25:  Port states

State Description
Online Activates and prepares port to send data.
Offline Prevents port from receiving signal and accepting a device login.
Diagnostics Prepares port for testing and prevents the port from accepting a device 

login.
Down Disables the port.

Table 26:  Port speeds

State Description
Auto-Detect Matches the transmission speed of the connected device. This is the 

default. 
1 Gbps Sets the transmission speed to 1 Gbps.
2 Gbps Sets the transmission speed to 2 Gbps.
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Port Type parameters
The ports can be configured to self-discover the proper type to match the device or switch to 
which it is connected. Table 27 describes the port types. 

1. Select one or more ports in the faceplate display.

2. Select Port > Port Properties. The Port Properties dialog box is displayed.

3. Click the Port Type option for the port type you want.

4. Click OK.

Interoperability Credits parameters

Note:  Interoperability Credits is not supported at this time.

Switches negotiate with other switches to resolve differences in the number of port buffer 
credits. 

I/O Stream Guard parameters
The I/O Stream Guard feature suppresses the generation of Registered State Change 
Notification (RSCN) messages on a port basis. I/O Stream Guard should be enabled only on 
ports connected to initiator devices. 

To suppress the generation of RSCN messages for the selected port, open the Port menu, and 
then click the Enable option in the I/O Stream Guard area of the Port Properties dialog box.

Device Scan parameter
The Device Scan feature queries the connected device during login for FC-4 descriptor 
information. Disable this parameter only if the scan creates a conflict with the connected 
device. 

Changing the port symbolic name
To change the symbolic name of a port from the faceplate display:

1. Open the faceplate display and then select a port.

2. Select Port > Port Symbolic Name. The Port Symbolic Name dialog box is displayed.

Table 27:  Port types

State Description
F_Port Fabric port—Supports a single public device (N_Port).
FL_Port Fabric loop port—Self discovers a single device (N_Port) or a loop of 

up to 126 public devices (NL_Port). 
G_Port Generic port—Self discovers as an F_Port.
GL_Port Generic loop port—Self discovers as an F_Port or an FL_Port. GL_Port 

is the default port type. A single device on a public loop attempts to 
configure as an F_Port first; if that fails it attempts to configure as an 
FL_Port.

Donor Donor port—Allows buffer credits to be used by another port. 
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3. Select one of the following in the Port Symbolic Name dialog box: 

— Enter a new name for the port in the Set Port Symbolic Name box.

— Check the Restore Default Port Symbolic Name check box to restore the default 
name.

4. Click OK.

Extending port credits
Each port is supported by a data-buffer with a 16-credit capacity; that is, 16 maximum sized 
frames. For fiber optic cables, this enables full bandwidth service over a distance of 10 
kilometers at 2 Gbps. For fiber optic cables, this enables full bandwidth service over a distance 
of 13 kilometers at 2 Gbps (1.2 credits/Km). Longer distances can be spanned at full 
bandwidth by borrowing credits from designated donor ports thus pooling the buffer 
capacities. This is called credit extension. Each donor port contributes 15 credits to the pool 
from which the recipient ports can draw. The recipient port also loses one credit in the process. 
For example, one donor port contributes 15 credits to the pool from which a recipient draws 
for a total of 30 credits (15+15). This provides approximately 25 Km at 2 Gbps (30÷1.2).

To extend credits, select Wizards > Ext Credit Wizard. The Extended Credit Wizard leads 
you through the following process to extend credits based on transmission distance 
requirements:

1. Extended Distance on Switch—Explains the concepts and principles of extending port 
credits. Click Next.

2. Extended Distance Requirements—Specify speed and distance requirements for each port. 
Click Next.

3. Designate Donor Ports—Select available ports and then click >> to move the port into the 
Selected Donor Port column (Figure 32). Match the number of ports needed with the 
number of designated donor ports. Click Next.

Figure 32:  Designating donor ports
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4. Verify Requested Changes—Review the extended distance requests and the selected 
donor ports. Click Finish to apply the changes, and redistribute the credits.

Note:  As credits are used, the Logged-In LEDs on the corresponding donor ports illuminate 
continuously. In addition, donor port Activity LEDs reflect the same traffic as the recipient port. 
Donor ports whose credits are being used are unavailable to devices that are connected to them.

Resetting a port
The Reset Port option reinitializes the port using the saved configuration.

1. In the faceplate display, select the port(s) to be reset.

2. Select Port > Reset Port.

Testing ports
The port loopback tests verify correct port operation by sending a frame out through the loop, 
and then verifying that the frame received matches the frame that was sent. Only one port can 
be tested at a time for each type of test. The Port Loopback Test dialog box presents the 
following loopback tests:

■ SerDes level (Internal)—The SerDes level test verifies port circuitry. The SerDes level 
test sends a test frame from the ASIC through the SerDes chip and back to the ASIC for 
the selected ports. The port passes the test if the frame that was sent by the ASIC matches 
the test frame that was received. This test requires that the port be in diagnostics mode, 
and therefore, disrupts communication.

■ SFP level (External)—The SFP level test verifies port circuitry. The SFP level test sends 
a test frame from the ASIC through the SerDes chip, through the SFP transceiver fitted 
with an external loopback plug, and back to the ASIC for the selected ports. The port 
passes the test if the test frame that was sent by the ASIC matches the test frame that was 
received. This test requires that the port be in diagnostics mode, and therefore, disrupts 
communication.

■ Node-to-Node (Online)—The Node-to-Node test verifies communications between the 
port and its device node or device loop. The port being tested must be online and 
connected to a remote device. The port passes the test if the frame that was sent by the 
ASIC matches the frame that was received. This test does not disrupt communication on 
the selected port. This test requires that the port be online, and therefore, does not disrupt 
communication.

To run the internal, external, or online port loopback test on a port:

1. In the faceplate display, select the port to be tested, and then select Port > Port Loopback 
Test. The Port Loopback Test dialog box is displayed (Figure 33).
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Figure 33:  Port Loopback Test dialog box

2. Select the type of loopback test to be run (Internal, External, or Online) in the Test 
Selection area.

If you choose the internal or external test, Switch Manager prompts you to confirm that 
the port state needs to be changed to the diagnostic state.

3. Click OK.

4. Enter the frame count in the Frame Count box.

5. Enter the frame size in the Frame Size (40-492) box.

6. Select a Test Pattern option.

You may use the default pattern or enter an 8-digit pattern (hex). For online test, you can 
select the Terminate Test Upon Error check box if you want the test to stop should it 
encounter an error.

7. Click Start Test.

The Test Results area displays the test status, number of frames sent, and number of errors 
found.

8. Click Close.
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Graphing port performance
The HP StorageWorks Fabric View application displays port performance using graphs. HP 
StorageWorks Fabric View plots data communication rates and total errors for selected ports 
as shown in Figure 34. When graphing data communication rates, you can choose either 
frames/second or KB/second.

Fabric status is displayed in text format after the fabric name in the fabric tree. The color of the 
icon indicates the current connection status as normal (green), warning (yellow), critical (red), 
or unmanageable (blue). 

Figure 34:  Fabric View graphs

This section describes the following:

■ Starting HP StorageWorks Fabric View, page 91

■ Exiting HP StorageWorks Fabric View, page 92

■ Saving and opening Fabric View files, page 92

■ Changing the Default Fabric View File encryption key, page 93

■ Setting HP StorageWorks Fabric View preferences, page 93

■ Setting the polling frequency, page 93

■ Displaying graphs, page 94

■ Arranging graphs in the display, page 94

■ Customizing graphs, page 94

■ Printing graphs, page 96

■ Rescaling a selected graph, page 96

■ Saving graph statistics to a file, page 96

Starting HP StorageWorks Fabric View
To start HP StorageWorks Fabric View from within Switch Manager, open the topology 
display and then select Fabric > Start Fabric View. 
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Exiting HP StorageWorks Fabric View
To exit a HP StorageWorks Fabric View session, select File > Exit. The current fabric view is 
automatically saved to your default fabric view file upon exit, if you have defined an 
encryption key. The key is encrypted and saved with your default fabric view file. A fabric 
view file contains the set of fabrics that have been added and the graphs that have been opened 
during a HP StorageWorks Fabric View session. If you have not yet defined an encryption 
key, the Save Default Fabric View File dialog box (Figure 2) prompts you to save the current 
fabric view as the default fabric view file. See “Changing the encryption key for the default 
fabric view file” on page 23 for information about defining and changing this encryption key. 

In the Save Default Fabric View File dialog box, enter an encryption key in the Default 
Fabric File Encryption Key box. Re-enter the encryption key in the Re-enter Encryption 
Key to Confirm box. Click OK to save the current set of HP StorageWorks Fabric View 
fabrics to the default fabric view file in the working directory.

To prevent HP StorageWorks Fabric View from prompting you to save the default fabric view 
file between sessions, set the Auto Load and Save Graphing Environment setting to Enable 
(default). See “Setting HP StorageWorks Fabric View preferences” on page 93 for more 
information.

Figure 35:  Save Default Fabric View File dialog box – HP StorageWorks Fabric View

In your next HP StorageWorks Fabric View session, the Load Default Fabric File dialog box 
(Figure 3) prompts you to load the default fabric view file and to specify its encryption key, if 
there is one. In the Default Fabric File Encryption Key box, enter the encryption key and 
then click Load View File. If you do not want to load the default fabric view file, click 
Continue Without Loading to open the HP StorageWorks Fabric View with no fabric 
displayed.

Figure 36:  Load Default Fabric File dialog box – HP StorageWorks Fabric View

Saving and opening Fabric View files
In addition to the HP StorageWorks Fabric View default fabric view file, you can save and 
open your own fabric view files. The fabric view file contains the set of fabrics, graphs, and 
graphing options. 

1. Select File > Save View As. The Save View dialog box is displayed.

2. Enter a name for the fabric file or click Browse to select an existing file.
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Files are saved in the working directory.

3. Enter a password.

When you attempt to open this fabric file, you are prompted for this password. If you leave 
the File Password box blank, no password is required.

To open a fabric view file:

1. Select File > Open View File. The Open View dialog box is displayed.

2. Enter a name for the fabric file or click Browse to select an existing file.

Changing the Default Fabric View File encryption key
1. Select File > Save Default File Fabric View File. The Save Default File Fabric View File 

dialog box is displayed. 

2. Enter the new password in the Default File Encryption Key box.

3. Re-enter the same password in the Re-enter Encryption Key to Confirm box.

4. Click OK to save the changes.

Setting HP StorageWorks Fabric View preferences
To set preferences, select File > Preferences. The Preferences dialog box is displayed 
(Figure 37). Set the following preferences and then click OK to save the changes:

■ Change the location of the working directory in which to save files.

■ Change the location of the browser used to view the online help.

■ Enable or disable the Auto Load and Auto Save Graphing Options preference. When 
enabled, HP StorageWorks Fabric View prompts you to save and load the default fabric 
file between sessions. See “Exiting HP StorageWorks Fabric View” on page 92 for more 
information on the default fabric view file.

Figure 37:  Preferences – HP StorageWorks Fabric View

Setting the polling frequency
Fabric View updates the graphs once per second by default. To change this polling frequency:

1. Select Graph > Set Polling Frequency. The Set Graph Polling Frequency dialog box is 
displayed.

2. Enter the new polling interval in seconds [1–60].

Fabric View updates the graphs once during the interval. For example, setting the polling 
frequency to 5 seconds returns 1 second’s worth of data every 5 seconds.

3. Click OK.
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Displaying graphs
1. Select Fabric > Add Fabric. The Add a New Fabric dialog box is displayed.

2. Enter a fabric name and an IP address.

3. Enter an account name and a password, if required.

4. Set the graphing options and polling frequency.

By default, HP StorageWorks Fabric View plots total bytes transmitted and received at a 
polling frequency of once per second. See “Customizing graphs” on page 94 for 
information about changing what is plotted and how it is plotted.

5. You can display graphs in the following ways:

— Click on a switch entry handle and select one or more ports.

— Right-click on a switch icon in the fabric tree, and then select Open Graph for All 
Ports on Switch or Open Graph for All Logged-In Ports on Switch from the menu.

6. You can move graphs around individually by clicking and dragging, or you can arrange 
them as a group. See “Arranging graphs in the display” on page 94 for more information.

Removing graphs
1. After viewing the graph, click Remove.

2. To remove all graphs, select Window > Close All.

To remove a fabric and its graphs:

1. Select the fabric in the fabric tree.

2. Select Fabric > Remove Fabric. You can also right-click on a fabric and then select 
Remove Fabric for the menu.

Right-clicking on a graph opens a menu from which you can change graph options, print a 
graph, or save the graph statistics to a file.

Arranging graphs in the display
To arrange and size graphs in the display, select Window > Cascade, Tile, or Close All.

■ Cascade overlaps the graphs so that all graphs are at least partially visible.

■ Tile arranges the graphs in non-overlapping rows and columns.

■ Close All closes all graphs.

You can also click a graph on the Window menu to bring that graph to the front.

Customizing graphs
You can customize the graph polling frequency, what is plotted in the graphs, and the graph 
color scheme. To set the polling frequency for all graphs, refer to “Setting the polling 
frequency” on page 93.

1. Select Graph > Modify Graph Options. The Default Graph Options dialog box is 
displayed (Figure 38).
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Figure 38:  Default Graph Options dialog box

You can also right-click on a graph, and then select Change Graph Options.

1. Choose the units for the graph:

— Select the Show Bytes Data on Graph check box to plot data in KBytes/second.

— Select the Show Frames Data on Graph check box to plot data in frames/second.

2. Choose what data type to plot. For example, if you selected Show Frames Data on 
Graph in step 1, you can plot one or all of the following:

— Total frames transmitted and received (Total Frames)

— Total frames transmitted (Total Tx Frames)

— Total frames received (Total Rx Frames)

Note:  In addition to these, you can also plot total errors by selecting the Total Errors check box.

3. Select Display Grid on Graph to display the unit grid.

4. Choose the color scheme for the graph:

a. Click Select Color to open its corresponding Select Color dialog box.

b. Select the color for each data type, the unit grid, and the background by clicking the 
corresponding color box or button.

In each case, you can choose a color using the Swatches, Red-Green-Blue (RGB), or 
Hue-Saturation-Brightness (HSB) method.
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Note:  Clicking Reset in the Swatches, HSB, and RGB tab pages of the Select Color dialog box 
resets the colors in the Preview area to the last saved color scheme. At this point you are only 
selecting a new color scheme to be saved. 

— Swatches – Click the Swatches tab. Select a swatch from the palette.

— HSB – Click the HSB tab. Select a color using any of the following methods:

— Click in the color palette.

— Select H, S, or B and use the slide to vary the selected value.

— Enter values in the H, S, or B input boxes.

— RGB – Click the RGB tab. Select a color by moving the slides to adjust the values for 
red, blue, and green; or enter values in the input boxes.

c. Click OK.

5. Click the corresponding option to apply changes to all graphs, the currently selected 
graph, or all new graphs.

6. Click OK.

Printing graphs
1. Select a graph.

2. Select File > Print Graph Window.

You can also right-click on a graph and then select Print Graph Window from the menu.

Rescaling a selected graph

The Rescale Selected Graph option auto-scales downward and re-positions the data within a 
graphic window to display all new data captured by the graph. 

1. Select a graph.

2. Select Graph > Rescale Selected Graph or right-click on the graph, and then select 
Rescale from the menu.

3. View the data in the graph window.

Saving graph statistics to a file

Statistics for graphs can be saved to a file that can be opened with a spreadsheet application. 

1. Select a graph.

2. Select File > Save Current Graph Statistics to a File or Save All Graph Statistics to a 
File. The Save dialog box is displayed.

You can also right-click on a graph and select Save Statistics to File.

3. Enter a path name for the file.

By default, the file is saved in the working directory.

4. Click Save.
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Interpreting Switch Manager messages
This section lists the Switch Manager messages by task, dialog box, or display. To find a 
message and what to do about it, consider what task you are performing, and refer to the 
corresponding subsection.

■ Fabrics File—Open, Save messages, page 97

■ Add a Fabric messages, page 97

■ Network Properties dialog box messages, page 98

■ Switch Properties dialog box messages, page 99

■ Port Properties dialog box messages, page 101

■ Faceplate display messages, page 102

■ Load Firmware dialog box messages, page 104

■ Port Loopback Test dialog box messages, page 104

■ Extended Credits wizard messages, page 106

■ Zoning dialog box messages, page 106

■ Restore Configuration dialog box messages, page 108

■ Save Fabric View dialog box messages, page 108

■ Trap Configuration dialog box messages, page 109

Fabrics File—Open, Save messages

Add a Fabric messages

Table 28:  Fabrics file—Open, Save messages

Message User action
Failed opening fabrics list file filename. Verify that the specified file exists on a file 

system that is reachable, and that the user has 
permissions to read the file.

Failed saving fabrics list file filename. Verify that the specified file system is 
reachable, and that the user has permissions 
to write to the file system, to the directory, and 
to the file.

Table 29:  Add a Fabric messages

Message User action
Fabric fabricname already exists!

or
Fabric name already in use.

Specify a name for the fabric that is not 
already assigned to an existing fabric.

Invalid IP Address Verify that the IP address specified is 
syntactically correctly.

The entry switch is of a type that is not 
supported.

The switch hardware or firmware version of 
the switch at the specified IP address is not 
supported. Choose the IP address of a different 
switch, or update the firmware using Telnet or 
the appropriate version of the application.
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Network Properties dialog box messages

The maximum number of management 
sessions on the entry switch has been 
exceeded.

The application cannot establish a session with 
the fabric because too many sessions are 
already open. Close any other application or 
Telnet sessions to the fabric and try again.

Unable to login to switch. Reason: … Verify that the user name and password 
entered in the dialog box are valid login 
information for an account on the switch 
specified by the IP address box.

Unknown host hostname. Verify that the host name specified for the IP 
address is a valid hostname for a switch in the 
fabric, and that the switch is reachable from 
the user’s workstation.

Verify correct user name and password and 
retry.

Either the user name or password is incorrect. 
Enter the correct values and retry.

Table 29:  Add a Fabric messages (Continued)

Message User action

Table 30:  Network Properties dialog box messages

Message User action
Attempt to change snmp community strings 
failed.

or
Attempt to change syslog configuration failed.

Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change.

Unable to apply invalid syslog host address. Verify that either a syntactically correct IP 
address was specified for the syslog host, or 
that a host name was specified for a valid 
syslog host that is reachable from the user’s 
workstation.
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Switch Properties dialog box messages
Table 31:  Switch Properties dialog box messages

Message User action
Attempt to change chassis name failed.

or
Attempt to set in-band management failed.

or
Attempt to change domain ID lock failed.

or
Attempt to change SNMP configuration failed.

or
Attempt to change IP configuration failed.
  or
Attempt to change chassis configuration 
failed.
  or
Attempt to change timeout values failed.
  or
Attempt to change broadcast support failed.

Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change.

Disabling in-band management makes the 
switch unreachable. Do you wish to continue 
with this change?

If this feature is disabled, this switch is no 
longer manageable through this session to the 
fabric.
If this is acceptable, continue; otherwise cancel 
the operation.

Duplicate domain ID specified. Verify that all information is valid and retry the 
configuration change. Consult the 
documentation for valid configurations.
Valid domain IDs must be in the range 1 to 
239, and must be unique within a fabric.

If you set this in-band switch offline you need 
an ethernet connection to the switch to put it 
back online. Do you want to set switch offline?
  or
If you set this in-band switch in diagnostics 
mode you need an ethernet connection to the 
switch to put it back online. Do you want to set 
switch in diagnostics mode?

These changes prevent the application from 
communicating with the switch in the fabric. 
Before applying the changes, verify that the 
switch is reachable through its own Ethernet 
port, and then add a new fabric (Fabric>Add 
Fabric) at the switch’s own IP address.

IP configuration changes do not take effect 
until switch is reset.

The new IP configuration has been set on the 
switch, but the user has decided not to reset 
the switch at this time. Arrange a time when it 
is acceptable to disrupt communications 
between the hosts and storage systems, and 
then reset the switch to make the changes 
effective.

Modification of IP configuration requires a 
switch reset to take effect. The reset may 
disrupt traffic. Do you wish to continue?

This configuration information does not 
become effective unless the switch is reset. 
Resetting a switch in the fabric causes the 
servers and storage systems attached to the 
fabric to lose communications until the switch 
reset is complete and the fabric has 
re-initialized. If this is acceptable, continue; 
otherwise cancel the reset operation.
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Out of range domain ID specified. Verify that all information is valid and retry the 
configuration change. Consult the 
documentation for valid configurations.
Valid domain IDs must be in the range 1 to 
239, and must be unique within a fabric. If the 
fabric contains Switch with E_Port switches, all 
domain IDs must be in the same range of 
sixteen values: 1…16, 17…32, and so on.

Received error in attempting to edit switch 
configuration.
  or
Received error in attempting to save switch 
configuration.
  or
Received error in attempting to activate switch 
configuration.

Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change.

Reset will complete shortly. There is a brief loss 
of connectivity with switch.

Wait for the switch to become reachable 
again. This may take up to one minute.

The new domain ID specified is invalid.
Unable to apply invalid chassis/fabric ID 
values

Verify that all information is valid and retry the 
configuration change. Consult the 
documentation for valid configurations.
Valid domain IDs must be in the range 1 to 
239, and must be unique within a fabric. If the 
fabric contains Switch with E_Port switches, all 
domain IDs must be in the same range of 
sixteen values: 1…16, 17…32, and so on.

Unable to apply changes. Failed to obtain 
admin privileges.

Verify that another user is not currently 
modifying the switch configuration, using 
either the management application, or a telnet 
login, or any application.

Unable to apply invalid timeout values.
  or
Unable to apply invalid IP address.
  or
Unable to apply invalid trap address.
  or
Unable to apply invalid subnet mask.
  or
Unable to apply invalid gateway address.
  or
Unable to apply invalid ARP timeout value.

Verify that all information is valid and retry the 
configuration change. Consult the 
documentation for valid configurations.
Valid domain IDs must be in the range 1 to 
239, and must be unique within a fabric. If the 
fabric contains Switch with E_Port switches, all 
domain IDs must be in the same range of 
sixteen values: 1…16, 17…32, and so on.

Table 31:  Switch Properties dialog box messages (Continued)

Message User action
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Port Properties dialog box messages
Table 32:  Port Properties dialog box messages

Message User action
Invalid value entered for interop credits.
  or
Failed to set I/O stream guard change.
  or
Failed to set new interop credits.
  or
Request to save and activate config failed.
  or
Received error in attempting to edit switch 
configuration.
  or
Received error in attempting to save switch 
configuration.
  or
Received error in attempting to activate switch 
configuration.

Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change. Interop Credits is not 
supported at this time.

Received error in attempting to release admin 
privileges.

The application did not receive a required 
response from the switch. This may be caused 
by a momentary or extended loss of 
communications with the fabric.
First refresh the information in the display to 
determine whether the changes took effect. If 
not, retry the changes.
If the error persists, determine whether 
communications with the switch have stopped, 
and resolve any network problems. When 
communication with the fabric has resumed, 
return to the application to view the properties 
for the port and verify whether the changes 
took effect. If not, retry the changes.

Request to save and activate config failed. Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change.
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Faceplate display messages

Unable to apply changes. Failed to obtain 
admin privileges.

Verify that another user is not currently 
modifying the switch configuration, using 
either the management application, or a Telnet 
login, or any other application, and then retry 
the operation.

Unable to confirm that port changes were 
successful.

The application did not receive a required 
response from the switch. This may be caused 
by a momentary or extended loss of 
communications with the fabric.
First refresh the information in the display to 
determine whether the changes took effect. If 
not, retry the changes.
If the error persists, determine whether 
communications with the switch have stopped, 
and resolve any network problems. When 
communication with the fabric has resumed, 
return to the application to view the properties 
for the port and verify whether the changes 
took effect. If not, retry the changes.

Unable to successfully apply port speed 
change.
  or
Unable to successfully apply port state change.
  or
Unable to successfully apply port type change.

Verify that the data is valid, that the user has 
permissions to modify the configuration on the 
switch, that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
configuration change.

Table 32:  Port Properties dialog box messages (Continued)

Message User action

Table 33:  Faceplate display messages

Message User action
Failed to clear the trap log. Verify that the user has permissions to modify 

the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the configuration change.

Necessary information is missing for this 
switch. Firmware version on this switch is 
unsupported.

The user has attempted an action which 
cannot be completed because it requires 
information from the switch which the switch 
does not support. Update the firmware on the 
switch to the latest version.

Necessary information is missing for this 
switch. Retry later.

The user has attempted an action which 
cannot be completed until specific information 
has been retrieved from the switch. This 
condition usually corrects within several 
seconds.
If the condition doesn’t correct itself, verify that 
the switch is reachable in the fabric, and that 
the fabric is reachable from the user’s 
workstation. When the switch is reachable 
again, wait for the application to retrieve 
complete information from the switch (this may 
take up to one minute), or refresh the display.
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One of the selected ports is currently in use as 
a donor port to allow for extended credits on 
another port. Modifications to donor ports are 
not permitted.

Deselect the donor ports, and then retry the 
operation.

Port reset failed.
  or
Request to reset to factory defaults has failed.
  or
Request for switch reset failed.

Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the configuration change.

Request for switch reset failed because admin 
access was not available.

Verify that another user is not currently 
modifying the switch configuration, using 
either the management application, or a telnet 
login, or any application, and then retry the 
operation.

Reset will complete shortly. There is a brief loss 
of connectivity with switch.

Wait for the switch to become reachable 
again. This may take up to one minute.

Resetting the switch will disrupt traffic. Do you 
wish to continue?
  or
Deactivating the active zone set will disrupt 
traffic. Do you wish to continue?

The requested action causes the servers and 
storage systems attached to the fabric to lose 
communications until the switch reset is 
complete and the fabric has re-initialized. If 
this is acceptable, continue; otherwise cancel 
the operation.

Resetting to factory defaults will disrupt traffic 
and cause current switch configuration to be 
lost.

This action is disruptive to the fabric. Verify 
that this is the action that you want to take.

Showing Last Known State. The switch state displayed by the application 
cannot be updated because the switch has 
become unreachable. Verify that the switch is 
reachable in the fabric, and that the fabric is 
reachable from the user’s workstation.

The file currently exists. The selected switch archive file already exists. 
If it is acceptable to overwrite the file, continue. 
Otherwise, return and select a different 
archive file.

The online port loopback test can only be 
performed on a single port at a time. There 
are multiple ports selected. Continue with 
loopback test on first selected port.

Select only a single port, and then retry the 
operation.

The zoning information you are about to edit 
is incomplete. If you apply changes you will 
possibly lose zoning information.

The application has not been able to 
completely read the current zoning database 
from the switch. If the user edits the incomplete 
database information and applies the 
changes, any information which has not been 
read from the switch is lost.
If this is acceptable, continue. Otherwise, 
verify that the switch is reachable in the fabric, 
and that the fabric is reachable from the user’s 
workstation then refresh the display and verify 
that the zoning database has been completely 
read, and then retry the operation.

Unable to perform request. Switch is currently 
unreachable.

Verify that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
operation.

Table 33:  Faceplate display messages (Continued)

Message User action
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Load Firmware dialog box messages

Port Loopback Test dialog box messages

Table 34:  Load Firmware dialog box messages

Message User action
Bad checksum/CRC for the firmware image or 
incorrect firmware image for this type of 
switch.

Select the correct firmware file for this switch.

File was not found. Verify that the firmware file specified actually 
exists, or specify a new firmware file.

Firmware image had a bad CRC or was 
invalid for this type of switch.

Select a valid firmware image for this type of 
switch and retry the operation.

Firmware upload status unknown. Image has 
been uploaded, but confirmation from the 
switch was not received.

The application lost communications with the 
switch while the switch was unpacking the 
firmware image. If the problem was 
temporary, examine the firmware versions on 
the switch to verify that the firmware was 
unpacked correctly, or upload a new firmware 
image to the switch.

The flash memory on the switch may be too 
small for this image.

Select an appropriate firmware image for this 
type of switch and retry the operation.

Unable to load firmware. An unspecified error has occurred. Verify that 
the user has permissions to modify the 
configuration on the switch, that the switch is 
reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the firmware upload.

Unable to read file. Verify that the firmware file specified exists 
and is readable by the user, on a file system 
readable by the user, or specify a new 
firmware file.

Table 35:  Port Loopback test dialog box messages

Message User action
Attempt to put port in diagnostic state has 
failed. Unable to continue with port test.

Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the configuration change.

External port test requires a loopback device 
be plugged into the selected port. Click “OK” 
when loopback device is installed.

Verify that a loopback device is attached to the 
port before starting loopback test.

Failed to correctly restore port states for one or 
more ports.

Return to the faceplate view and then select 
View>Port State to determine which port was 
not restored to its original state. Select the 
port, and then select Port>Port Properties to 
restore the port state.

Invalid frame count value.
  or
Invalid frame size. Must be 36 to 2148.
  or
Invalid hex pattern. Up to 8 hex digits 
allowed.

Verify that all information is valid, and then 
retry the loopback test.
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No device detected in selected port yet. Test 
will not be run on empty port.

Verify that a loopback device is attached to the 
port before starting loopback test.
Verify that the port is online with an active 
login before starting the loopback test.

Request to get admin privileges failed. Verify that another user is not currently 
modifying the switch configuration, using 
either the management application, or a telnet 
login, or any application, and then retry the 
operation.

Request to start loopback test failed.
or

Request to stop loopback test failed.
or

Request for loopback test results failed.
or

Request to reset loopback test results failed.

Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the configuration change.

Switch is currently unreachable. Unable to 
accurately report status of port test.

The application lost communications with the 
switch while the switch was running the 
loopback tests, and could not determine 
whether the tests completed. If the problem 
was temporary, restart the loopback tests.

The port selected for online port test must be 
online with active login.

Verify that the port is online with an active 
login before starting the loopback test.

Timed out on response notifications. Test 
terminated.

The application lost communications with the 
switch while the switch was running the 
loopback tests, and could not determine 
whether the tests completed. If the problem 
was temporary, restart the loopback tests.

Unable to perform loopback test on port...
■ because port is not in diagnostic state.
■ because port is a donor port.
■ because there is already a port test in 

progress.

Correct the error indicated, and then retry the 
loopback test.

Table 35:  Port Loopback test dialog box messages (Continued)

Message User action
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Extended Credits wizard messages

Zoning dialog box messages

Table 36:  Extended Credits wizard messages

Message User action
Request for admin failed. Verify that another user is not currently 

modifying the switch configuration, using 
either the management application, or a telnet 
login, or any application, and then retry the 
operation.

Request for extended credits failed. Verify that the switch is reachable in the 
fabric, and that the fabric is reachable from 
the user’s workstation, and then retry the 
operation.

Request to edit config failed.
or

Request to save and activate config failed.

Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the operation.

Table 37:  Zoning dialog box messages

Message User action
Error loading zoning. Verify that the specified zoning configuration 

file exists on a file system that is reachable, 
and that the user has permissions to read the 
file.

Error returned from switch. Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then refresh the zoning information from the 
switch to determine whether any of the zoning 
configuration has been applied.
If necessary, re-edit the zoning configuration 
and apply to the switch again.

Error saving zoning. Verify that the specified zoning configuration 
file exists on a file system that is reachable, 
and that the user has permissions to write the 
file.

Failed to obtain admin privileges. Verify that another user is not currently 
modifying the switch configuration, using 
either the management application, or a telnet 
login, or any application, and then retry the 
operation.

Invalid name. Valid names start with a letter 
and valid chars include:
all alphanumeric chars [aA - zZ] [0 - 9]
symbols ['$', '_', and '-'

Select a valid name for the object, and then 
retry the operation.

Maximum number of zones created. Remove unnecessary objects from the zoning 
configuration, and then retry the operation.

No member(s) selected; nothing to add. Select the members to add, and then retry the 
operation.
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No response from the switch.
  or
Saving zoning data failed.

Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then refresh the zoning information from the 
switch to determine whether any of the zoning 
configuration has been applied. If necessary, 
re-edit the zoning configuration and apply to 
the switch again.

The maximum number of members has been 
reached.
  or
The maximum number of members per zone 
has been reached

Remove unnecessary objects from the zoning 
configuration and retry the operation.

The Orphan set is a place a holder for zones 
that are not in a set. It can not be deleted.

Do not attempt to delete the orphan zone set.

The zone set you are attempting to activate 
contains port based zoning and there are 
switches in the fabric that might not support 
this type of zoning. Some E_Ports may isolate. 
Do you wish to continue?

Not all switch vendors support port-based 
zoning. Consult the manual for these vendors’ 
switches to determine whether to apply this 
zoning configuration to the fabric. This feature 
is not supported by HP.

The zoning configuration has been changed. 
Would you like to apply your changes?

The zoning configuration includes changes 
that have not been applied to the switch. Click 
Yes to apply the changes to the switch before 
continuing, or click No to discard the changes 
and continue.

There is already a zone by that name in a 
different Zone set. Would you like to add that 
zone to this Zone Set?

If the existing zone is the same as zone that the 
user wants to add to this zoneset, continue. 
Otherwise, select a unique name for the new 
zone, and then retry the operation.

There is already a zone set with that name.
  or
There is already a zone with that name.
  or
There is already a alias with that name.

Select a unique name for the new object, and 
then retry the operation.

This zoning configuration exceeds the limits for 
this switch.

Remove unnecessary objects from the zoning 
configuration, and then retry the operation.

Table 37:  Zoning dialog box messages (Continued)

Message User action
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Restore Configuration dialog box messages

Save Fabric View dialog box messages

Unable to create alias. The zoning configuration already contains the 
maximum allowed zoning aliases. Delete any 
unwanted aliases, and then retry the 
operation.

You are about to save a zoning configuration 
that was not completely read in. Saving this 
version will make the incomplete database 
permanent.

An error was encountered while reading the 
zoning database from the switch, and so the 
database edited by the user may be missing 
some zoning information.
Cancel the save, close the Zoning dialog, 
refresh the switch, and then retry the 
operation. 

You have zones in the orphan zone set. These 
are not saved in the switch. Would you like to 
continue?

Orphan zones are not applied to the switch. If 
the orphan zones are to be applied to the 
switch, they must first be added to a 
configured zoneset. Orphan set is not saved 
on 2/8q FC switches, and is used only in the 
application while configuring zoning 
information.

Table 37:  Zoning dialog box messages (Continued)

Message User action

Table 38:  Restore Configuration dialog box messages

Message User action
Failed parsing filename. Verify that the file specified is a valid archive 

file, and then retry the operation.
Possibly failed check switch! The application lost communications with the 

switch while restoring the archived 
configuration, and could not determine 
whether the operation completed. If the 
problem was temporary, retry the operation.

Restore failed! Verify that the user has permissions to modify 
the configuration on the switch, that the switch 
is reachable in the fabric, and that the fabric is 
reachable from the user’s workstation, and 
then retry the configuration restore.

Table 39:  Save Fabric View dialog box messages

Message User action
File filename already exists. Do you want to 
overwrite?

The specified view file already exists. Cancel, 
or continue to overwrite the file.
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Trap Configuration dialog box messages
Table 40:  Trap Configuration dialog box messages

Message User action
Invalid rising threshold.
  or
Invalid falling threshold.
  or
Invalid sample interval.

Verify that the information is correct, and then 
retry.

You must wait for trap information to be read 
first.
  or
You must wait for alarm threshold information 
to be read first.

The application has not completely read in 
some configuration information which is 
needed for this operation. 
Wait until the information has been completely 
read and then retry.
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2Command Line Interface

The command line interface (CLI) enables you to perform a variety of fabric and switch 
management tasks through an Ethernet or a serial port connection. 

This section describes the following:

■ Logging on to a switch, page 112 

■ Working with user accounts, page 112 

■ Working with switch configurations, page 113 

■ Commands, page 116
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Logging on to a switch

To log on to a switch using a Telnet session, open a command line window on the workstation 
and enter the Telnet command followed by the switch IP address:

# telnet ip_address

A Telnet window opens prompting you for a login. Enter an account name and password.

To log on to a switch through the serial port, configure the workstation port with the following 
settings and enter an account name and password when prompted.

Working with user accounts
Switches come from the factory with the following user account already defined:

This user account provides full access to the switch and its configuration. After planning your 
fabric management needs and creating your own user accounts, consider changing the 
password for this account. See “Commands” on page 116 for more information about 
authority levels. See the “User command” on page 171 for information about creating user 
accounts.

Note:  A switch supports a combined maximum of 19 logins or sessions reserved as follows:
■ 4 logins or sessions for internal applications such as management server and SNMP.
■ 9 high priority Telnet sessions.
■ 6 logins or sessions for Switch Manager inband and out-of-band logins, and Telnet logins. 

Additional logins are refused.

Table 41:  Workstation port settings

Parameter Setting
Baud rate 9600 bits per second
Data bits 8
Parity None
Stop bits 1

Table 42:  Predefined user accounts

Account name Password Authority
admin password admin
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Working with switch configurations
Successful management of switches and fabrics with the command line interface depends on 
the effective use of switch configurations. Key switch management tasks include:

■ Modifying a configuration

■ Backing up a switch configuration

■ Restoring a switch configuration

Modifying a configuration
A switch supports up to 10 configurations including the default configuration. Each switch 
configuration contains switch, port, port threshold alarm, and zoning components.

The Show Switch command displays the name of the active configuration. A 
configuration name can have up to 31 characters excluding the pound symbol (#), semicolon 
(;), and comma (,). By editing the latest configuration and saving the results under a new 
name, you can create a history of configuration changes. Use the Config List command to 
display the names of the configurations stored on the switch:

2/8q FC Switch #> config list

  Current list of configurations

  ------------------------------

  default

  config_10132003

To modify a switch configuration you must open an Admin session with the Admin Start 
command. An Admin session prevents other accounts from making changes at the same time 
either through Telnet or Switch Manager. You must also open a Config Edit session with the 
Config Edit command and indicate which configuration you want to modify. If you do not 
specify a configuration name, the active configuration is assumed. The Config Edit session 
provides access to the Set Config commands with which you make modifications to the port, 
switch, port threshold alarm, or zoning configuration components as shown:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config edit default

   The config named default is being edited.

2/8q FC Switch (admin-config)#> set config port . . .

2/8q FC Switch (admin-config)#> set config switch . . .

2/8q FC Switch (admin-config)#> set config threshold . . .

2/8q FC Switch (admin-config)#> set config zoning . . .

The Config Save command saves the changes you made during the Config Edit session. 
In this case, changes to the configuration named Default are being saved to a new 
configuration named config_10132003. However, the new configuration does not take 
effect until you activate it with the Config Activate command as shown:

2/8q FC Switch (admin-config)#> config save config_10132003

2/8q FC Switch (admin)#> config activate config_10132003

2/8q FC Switch (admin)#> admin end

2/8q FC Switch #>

The Admin End command releases the Admin session for other administrators when you are 
done making changes to the switch.

Download from Www.Somanuals.com. All Manuals Search And Download.



Command Line Interface

114 HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Backing up a switch configuration
Backing up and restoring a configuration is useful to protect your work or for use as a template 
in configuring other switches. The Config Backup command creates a file on the switch, 
named configdata. This file can be used to restore a switch configuration only from the 
command line interface; it cannot be used to restore a switch using Switch Manager.

2/8q FC Switch  #> admin start

2/8q FC Switch (admin) #> config backup

The configdata file contains all of the switch configuration information including the 
following:

■ All named switch configurations including the default configuration. This includes port, 
switch, port threshold alarm, and zoning configuration components.

■ All SNMP and network information defined with the Set Setup command.

■ The zoning database included all zone sets, zones, and aliases.

Use FTP to download the configdata file to your workstation for safe keeping and to 
upload the file back to the switch for the restore function. To download the configdata file, 
open an FTP session on the switch and login with the account name images and password 
images. Transfer the file in binary mode using the Get command as shown:

>ftp ip_address

user:images

password: images

ftp>bin

ftp>get configdata

    xxxxx bytes sent in xx secs.

ftp>quit

You should rename the configdata file on your workstation with the switch name and date, 
config_switch_169_10112003, for example.
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Restoring a switch configuration
The restore operation begins with FTP to upload the configuration file from the workstation to 
the switch, and then finishes with a Telnet session and the Config Restore command. To 
upload the configuration file, config_switch_169_10112003 in this case, open and 
FTP session with account name images and password images. Transfer the file in binary 
mode using the Put command as shown:

ftp ip_address

user:images

password: images

ftp> bin

ftp> put config_switch_169_10112003 configdata

  Local file config_switch_169_10112003

  Remote file configdata

ftp>quit

The restore process replaces all configuration information on the switch and afterwards the 
switch is automatically reset. If the restore process changes the IP address, all management 
sessions are terminated. Use the Set Setup System command to return the IP 
configuration to the values you want. See the “Set Setup command” on page 147. To restore 
the switch, open a Telnet session, and then enter the Config Restore command from 
within an Admin session as shown:

2/8q FC Switch  #> admin start

2/8q FC Switch (admin) #> config restore

  The switch will be reset after restoring the configuration.

  Please confirm (y/n): [n] y
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Commands
The command is followed by one or more keywords. Consider the following rules and 
conventions:

■ Commands and keywords are case insensitive.

■ Required keyword values appear in standard font: [value]. Optional values are shown in 
italics: [value].

■ Underlined portions of the keyword in the command format indicate the abbreviated form 
that can be used. For example the Delete keyword can be abbreviated Del.

The command-line completion feature makes entering and repeating commands easier. 
Table 43 describes the command-line completion keystrokes.

The command set performs monitoring and configuration tasks. Commands related to 
monitoring tasks are available to all account names. Commands related to configuration tasks 
are available only within an admin session. An account must have Admin authority to enter the 
Admin Start command, which opens an admin session. See the “Admin command” on 
page 117.

The commands and their page numbers are listed in Table 44.

Table 43:  Command line completion

Keystroke Effect
Tab Completes the command line. Enter at least one character and 

press Tab to complete the command line. If more than one 
possibility exists, press Tab again to display all possibilities.

Up Arrow Scrolls backward through the list of previously entered 
commands.

Down Arrow Scrolls forward through the list of previously entered 
commands.

Ctrl-A Moves the cursor to the beginning of the command line.
Ctrl-E Moves the cursor to the end of the command line.

Table 44:  Commands listed by Authority Level

Monitoring commands Administrative commands
Help command page 125 Admin command page 117
History command page 126 Alias command page 118
Ping command page 130 Config command page 119
Ps command page 130 Create Support 

command
page 122

Quit command page 131 Date command page 123
Show command page 150 Firmware Install 

command
page 123

Show Config 
command

page 160 Hardreset command page 124

Show Log command page 163 Hotreset command page 126
Show Perf command page 165 Image command page 127
Show Setup command page 166 Lip command page 129
Uptime command page 171 Passwd command page 129
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Admin command
Opens and closes an Admin session. The Admin session provides commands that change the 
fabric and switch configurations. Only one Admin session can be open on the switch at any 
time. An inactive Admin session times out after a period of time which can be changed using 
the Set Setup System command. See the “Set Setup command” on page 147.

Authority

Admin

Syntax

ADMIN

Keywords

START

Opens the admin session.

END

Closes the admin session. The Hardreset, Logout, Shutdown, and Reset 
Switch commands also end an admin session.

CANCEL

Terminates an Admin session opened by another user. Use this keyword with care 
because it terminates the Admin session without warning the other user and without 
saving pending changes.

Notes

Closing a Telnet window during an admin session does not release the session. In this 
case, you must either wait for the admin session to time out, or use the Admin Cancel 
command.

Whoami command page 173 Reset command page 131
Set command page 135
Set Config command page 137
Set Log Command page 144
Set Port command page 146
Set Setup command page 147
Shutdown command page 169
Test command page 169
User command page 171
Zone Command page 174
Zoneset command page 176

Table 44:  Commands listed by Authority Level (Continued)

Monitoring commands Administrative commands
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Examples

The following example shows how to open and close an Admin session:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #>

.

.

.

2/8q FC Switch (admin) #> admin end

2/8q FC Switch #>

Alias command
Creates a named set of ports/devices. Aliases make it easier to assign a set of ports/devices to 
many zones. An alias can not have a zone or another alias as a member.

Authority

Admin session for all keywords except List and Members.

Syntax

ALIAS

Keywords

ADD [ALIAS] [ MEMBER_LIST]

Specifies one or more ports/devices given by [member_list] to add to the alias named 
[alias]. Use a <space> to delimit ports/devices in [member_list]. An alias can have a 
maximum of 2000 members. The application verifies that the [alias] format is correct, 
but does not validate that such a port/device exists. A port/device in [member_list] can 
have any of the following formats:

— Domain ID and port number pair (Domain ID, Port Number). Domain IDs can be 
1–-239; port numbers can be 0–-255.

— 6-character hexadecimal device Fibre Channel address (hex)

— 16-character hexadecimal worldwide port name (WWPN) with the format 
xx:xx:xx:xx:xx:xx:xx:xx

COPY [ALIAS_SOURCE] [ALIAS_DESTINATION] 

Creates a new alias named [alias_destination] and copies the membership into it from 
the alias given by [alias_source].

CREATE [ALIAS]

Creates an alias with the name given by [alias]. An alias name must begin with a letter 
and be no longer than 64 characters. Valid characters are 0-9, A-Z, a-z, _, $, ^, and -. 
The zoning database supports a maximum of 256 aliases.
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DELETE [ALIAS]

Deletes the specified alias given by [alias] from the zoning database. If the alias is a 
member of the active zone set, the alias will not be removed from the active zone set 
until the active zone set is deactivated.

LIST

Displays a list of all aliases. This keyword does not require an admin session.

MEMBERS [ALIAS]

Displays all members of the alias given by [alias]. This keyword does not require an 
admin session.

REMOVE [ALIAS] [MEMBER_LIST]

Removes the ports/devices given by [member_list] from the alias given by [alias]. Use 
a <space> to delimit ports/devices in [member_list]. A port/device in [member_list] 
can have any of the following formats:

— Domain ID and port number pair (Domain ID, Port Number). Domain IDs can be 
1–-239; port numbers can be 0–-255.

— 6-character hexadecimal device Fibre Channel address (hex)

— 16-character hexadecimal worldwide port name (WWPN) for the device with the 
format xx:xx:xx:xx:xx:xx:xx:xx.

RENAME [ALIAS_OLD] [ALIAS_NEW]

Renames the alias given by [alias_old] to the alias given by [alias_new].

Config command
Manages the Fibre Channel configurations on a switch. For information about setting the port 
and switch configurations, refer to the “Set Config command” on page 137.

Authority

Admin session for all keywords except Backup and List.

Syntax

config

Keywords

ACTIVATE [config_name]

Activates the configuration given by [config_name]. If you omit [config_name], the 
currently active configuration is used. Only one configuration can be active at a time.

BACKUP

Creates a file named configdata, which contains the system configuration 
information. To download this file, open an FTP session, log in with account 
name/password of images for both, and type get configdata. See “Backing up 
a switch configuration” on page 114. This keyword does not require an Admin 
session.

CANCEL

Terminates the current configuration edit session without saving changes that were 
made.
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COPY [config_source] [config_destination]

Copies the configuration given by [config_source] to the configuration given by 
[config_destination]. The switch supports up to 10 configurations including the 
default configuration.

DELETE [config_name]

Deletes the configuration given by [config_name] from the switch.

EDIT [config_name]

Opens an edit session for the configuration given by [config_name]. If you omit 
[config_name], the currently active configuration is used.

LIST

Displays a list of all available configurations on the switch. This keyword does not 
require an admin session.

RESTORE

Restores configuration settings to an out-of-band switch from a backup file named 
configdata, which must be first uploaded on the switch using FTP. You create the 
backup file using the Config Backup command. Use FTP to load the backup file 
on a switch, and then enter the Config Restore command. After the restore is 
complete, the switch automatically resets. See “Backing up a switch configuration” on 
page 114.

Note:  
■ If the restore process changes the IP address, all management sessions are terminated. Use the 

Set Setup System command to return the IP configuration to the values you want. See the 
“Set Setup command” on page 147.

■ Configuration archive files created with the Switch Manager Archive function are not compatible 
with the Config Restore command.

SAVE [config_name]

Saves changes made during a configuration edit session in the configuration given by 
[config_name]. If you omit [config_name], the value for [config_name] you chose for 
the most recent Config Edit command is used. [config_name] can be up to 31 
characters excluding #, semicolon (;), and comma (,). The switch supports up to 10 
configurations including the default configuration.

Notes

If you edit the active configuration, changes are held in suspense until you reactivate the 
configuration or activate another configuration.

Examples

The following shows an example of how to open and close a Config Edit session:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config edit

   The config named default is being edited.

.

.
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2/8q FC Switch (admin-config) #> config cancel

  Configuration mode will be canceled. Please confirm (y/n): [n] y

2/8q FC Switch (admin) #> admin end

The following is an example of how to create a backup file (configdata) and download 
the file to the workstation:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config backup

2/8q FC Switch (admin) #> admin end

2/8q FC Switch #> exit

#>ftp symbolic_name or ip_address

user: images

password: images

ftp> bin

ftp> get configdata

ftp> quit

The following is an example of how to upload a configuration backup file (configdata) 
from the workstation to the switch, and then restore the configuration:

#> ftp symbolic_name or ip_address

user: images

password: images

ftp> bin

ftp> put configdata

ftp> quit

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config restore

The switch will be reset after restoring the configuration.

  Please confirm (y/n): [n] y

  Alarm Msg: [Tue Jun 10 09:25:56.938 2003][A1005.0021][SM][Configuration 
is being      restored -  this could take several minutes !]

  Alarm Msg: [Tue Jun 10 09:26:19.266 2003][A1000.000A][SM][The switch 
will be reset in 3 seconds due to a config restore]

2/8q FC Switch (admin) #> 

  Alarm Msg: [Tue Jun 10 09:26:22.296 2003][A1000.0005][SM][The switch is 
being reset]

Good bye.
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Create Support command
Assembles all log files and switch memory data into a core dump file (dump_support.tgz 
zip) and prompts you to send it to a remote host. This file is useful to technical support 
personnel for troubleshooting switch problems. Use this command when directed by your HP 
Authorized Service Provider. The command prompts for the IP address of the remote host, an 
account name and password on the remote host, and a pathname for an existing folder on the 
remote host.

Authority

Admin

Syntax

CREATE SUPPORT

Examples

2/8q FC Switch # (admin) #> create support

Log Msg: [day month date time UTC 2004][C][8400.003B][Switch][Creating the 
support file - this will take several seconds]

FTP the dump support file to another machine? (y/n): y

Enter IP Address of remote computer: 10.20.33.130

Login name: johndoe

Enter remote directory name: bin/support

Would you like to continue downloading support file? (y/n) [n]: y

Connected to 10.20.33.130 (10.20.33.130).

220 localhost.localdomain FTP server (Version wu-2.6.1-18) ready.

331 Password required for johndoe.

Password:  xxxxxxx

230 User johndoe logged in.

cd bin/support

250 CWD command successful.

lcd /itasca/conf/images

Local directory now /itasca/conf/images

bin

200 Type set to I.

put dump_support.tgz

local: dump_support.tgz remote: dump_support.tgz

227 Entering Passive Mode (10,20,33,130,232,133)

150 Opening BINARY mode data connection for dump_support.tgz.

226 Transfer complete.

43430 bytes sent in 0.292 secs (1.5e+02 Kbytes/sec)
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Remote system type is UNIX.

Using binary mode to transfer files.

221-You have transferred 43430 bytes in 1 files.

221-Total traffic for this session was 43888 bytes in 1 transfers.

221 Thank you for using the FTP service on localhost.localdomain.

FTP the dump support file to another machine? (y/n): n

Date command
This command displays or sets the system date and time. To set the date and time the 
information string must be provided in this format: MMDDhhmmCCYY. The new date and time 
takes effect immediately.

Authority

Admin session, except to display the date.

Syntax

DATE

Keywords

[MMDDhhmmCCYY]

Specifies the date—this requires an admin session. If you omit [MMDDhhmmCCYY], 
the current date is displayed, which does not require an admin session.

Examples

2/8q FC Switch #> date

  Mon Apr 07 07:51:24 2003

Firmware Install command
Downloads firmware from a remote host to the switch, installs the firmware, and then resets 
the switch (without a power-on self test) to activate the firmware. If possible, a non-disruptive 
firmware activation is performed. The command prompts you for the IP address of the remote 
host, an account name and password on the remote host, and a pathname for the firmware 
image file.

Authority

Admin

Syntax

FIRMWARE INSTALL
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Examples

2/8q FC Switch (admin) #> firmware install

 Warning: Installing new firmware requires a switch reset.

 Continuing with this action will terminate all management sessions,

 including any Telnet sessions. When the firmware activation is complete,

 you may log in to the switch again.

 Do you want to continue? [y/n]: y

    Press 'q' and the ENTER key to abort this command.

  User Account    : johndoe

  IP Address      : 10.20.33.130

  Source Filename : 4.0.3.04.00_mpc

  About to install image.  Do you want to continue? [y/n] y

Connected to 10.20.33.130 (10.20.33.130).

220 localhost.localdomain FTP server (Version wu-2.6.1-18) ready.

331 Password required for johndoe.

Password: xxxxxxxxx

230 User johndoe logged in.

bin

200 Type set to I.

verbose

Verbose mode off.

  This may take several seconds...

  The switch will now reset.

Connection closed by foreign host.

Hardreset command
Resets the switch and performs a power-on self test. This reset disrupts traffic, activates the 
pending firmware, and clears the alarm log. To save the alarm log before resetting, refer to the 
“Set Log Command” on page 144.

Authority

Admin

Syntax

HARDRESET

Notes

To reset the switch without a power-on self test, refer to the “Reset command” on 
page 131.
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Help command
Displays a brief description of the specified command, its keywords, and usage.

Authority

None

Syntax

HELP [COMMAND] [KEYWORD]

Keywords

[COMMAND]

Displays a summary of the command given by [command] and its keywords. If you 
omit [command], the system displays all available commands.

[KEYWORD]

Displays a summary of the keyword given by [keyword] belonging to the command 
given by [command]. If you omit [keyword], the system displays the available 
keywords for the specified command.

ALL

Displays a list of all available commands (including command variations).

Examples

2/8q FC Switch #> help config

config CONFIG_OPTIONS

The config command operates on configurations.

  Usage: config   { activate | backup   | cancel   | copy     | delete   |

                    edit     | list     | restore  | save }

The following is an example of the Help Config Edit command:

2/8q FC Switch #> help config edit

config edit [CONFIG_NAME]

This command initiates a configuration session and places the current 
session

into config edit mode.

If CONFIG_NAME is given and it exists, it gets edited; otherwise, it gets

created.  If it is not given, the currently active configuration is 
edited.

Admin mode is required for this command.

  Usage: config edit [CONFIG_NAME]
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History command
Displays a numbered list of the previously entered commands from which you can re-execute 
selected commands.

Authority

None

Syntax

HISTORY

Notes

Use the History command to provide context for the ! command:

■ Enter ![command] to re-enter the most recent execution of that command.

■ Enter ![line number] to re-execute the corresponding command from the History 
display.

■ Enter ![partial command string] to re-execute a command that matches the command 
string.

■ Enter !! to re-execute the most recent command.

Examples

2/8q FC Switch #> history

   1 show switch

   2 date

   3 help set

   4 history

2/8q FC Switch #> !3

help set

set SET_OPTIONS

There are many attributes that can be set.

Type help with one of the following to get more information:

  Usage: set   { alarm     | beacon    | config    | log       | pagebreak |

                 port      | setup     | switch }

Hotreset command
Resets the switch for the purpose of activating the pending firmware without disrupting traffic. 
This command terminates all management sessions, saves all configuration information, and 
clears the alarm log. After the pending firmware is activated, the configuration is recovered. 
This process takes less than 80 seconds. To save the alarm log to a file before resetting, refer to 
the “Set Log Command” on page 144.

Authority

Admin
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Syntax

hotreset

Notes

You can load and activate firmware on an operating switch without disrupting data traffic 
or having to re-initialize attached devices under the following conditions:

■ No changes are being made to switches in the fabric including powering up, powering 
down, and switch configuration changes.

■ No port in the fabric is in the diagnostic state.

■ No zoning changes are being made in the fabric.

■ No changes are being made to attached devices including powering up, powering 
down, disconnecting, connecting, and HBA configuration changes.

Ports that are stable when the non-disruptive activation begins and then change states, are 
reset. When the non-disruptive activation is complete, Switch Manager sessions reconnect 
automatically. However, Telnet sessions must be restarted manually. This command clears 
the event log and all counters.

Image command
Manages and installs switch firmware.

Authority

Admin

Syntax

IMAGE

Keywords

CLEANUP

Removes all firmware image files from the switch. All firmware image files are 
removed automatically each time the switch is reset.

FETCH [ACCOUNT_NAME] [IP_ADDRESS] [FILE_SOURCE] [FILE_DESTINATION]

Retrieves image file given by [file_source] and stores it on the switch with the file 
name given by [file_destination]. The image file is retrieved from the FTP server with 
the IP address given by [ip_address] and an account name given by [account_name]. If 
an account name needs a password to access the FTP server, the system prompts you 
for it.

INSTALL

Downloads firmware from a remote host to the switch, unpacks the firmware, and then 
activates the firmware. The command prompts you for IP address of the remote host, 
an account name and password, and path name for the firmware image file.

LIST

Displays the list of image files that reside on the switch.

UNPACK [FILE]

Installs the firmware file given by [file]. After unpacking the file, a message is 
displayed confirming successful unpacking. The switch must be reset for the new 
firmware to take effect.
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Notes

To install firmware when the management workstation has an FTP server, use the Image 
Install command or the “Firmware Install command” on page 123. To install firmware 
when the management workstation does not have an FTP server:

1. Connect to the switch through the Ethernet or the serial port.

2. Move to the folder or directory on the workstation that contains the new firmware image 
file.

3. Establish communications with the switch using the File Transfer Protocol (FTP). Enter 
one of the following on the command line:

>ftp xxx.xxx.xxx.xxx

or

>ftp switchname

where xxx.xxx.xxx.xxx is the switch IP address, and switchname is the switch 
name associated with the IP address. 

4. Enter the following account name and password:

user:images

password: images

5. Activate binary mode and copy the firmware image file on the switch:

ftp>bin

ftp>put filename

6. Wait for the transfer to complete, and then close the FTP session.

xxxxx bytes sent in xx secs.

ftp>quit

7. Establish communications with the switch using the CLI. Enter one of the following on the 
command line:

telnet xxx.xxx.xxx.xxx

or

telnet switchname

where xxx.xxx.xxx.xxx is the switch IP address, and switchname is the switch name 
associated with the IP address.

8. A Telnet window opens prompting you for a login. Enter an account name and password. 
The default account name and password are (admin, password).

9. Open an Admin session to acquire the necessary authority.

2/8q FC Switch $>admin start

10. Display the list of firmware image files on the switch to confirm that the file was loaded.

2/8q FC Switch (admin) $>image list

11. Unpack the firmware image file to install the new firmware in flash memory.

2/8q FC Switch (admin) $>image unpack filename

12. Wait for the unpack to complete.

image unpack command result: Passed
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13. A message prompts you to reset the switch to activate the firmware. 

Enter the hotreset command to perform a non-disruptive firmware activation.

2/8q FC Switch (admin) $>hotreset

Lip command
Reinitializes the specified loop port.

Authority

Admin

Syntax

LIP [PORT_NUMBER]

Keywords

[PORT_NUMBER]

The number of the port to be reinitialized.

Examples

2/8q FC Switch (admin) #> lip 2

Passwd command
Changes a user account’s password.

Authority

Admin account name and an admin session to change another account’s password; you 
can change you own password without an Admin session.

Syntax

PASSWD [ACCOUNT_NAME]

Keywords

[ACCOUNT_NAME]

The user account name. To change the password for an account name other than your 
own, you must open an admin session with the account name Admin. If you omit 
[account_name], you are prompted to change the password for the current account 
name.

Examples

2/8q FC Switch (admin) #> passwd user2

      Press 'q' and the ENTER key to abort this command.

  account OLD password               : ********

  account NEW password (4-20 chars)  : ********

  please confirm account NEW password: ********

  password has been changed.
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Ping command
Initiates an attempt to communicate with another switch over an Ethernet network and reports 
the result.

Authority

None

Syntax

PING

Keywords

IP_ADDRESS

The IP address of the switch to query.

Examples

The following is an example of a successful Ping command:

2/8q FC Switch #> ping 10.20.11.57

  Ping command issued. Waiting for response...

2/8q FC Switch #>

  Response successfully received from 10.20.11.57.

This following is an example of an unsuccessful Ping command:

2/8q FC Switch #> ping 10.20.10.100

  Ping command issued. Waiting for response...

  No response from 10.20.10.100. Unreachable.

Ps command
Displays current system process information.

Authority

None

Syntax

PS

Examples

2/8q FC Switch #> ps

PID  PPID %CPU     TIME     ELAPSED COMMAND

338   327  0.0 00:00:00  3-01:18:35 cns

339   327  0.0 00:00:01  3-01:18:35 ens

340   327  0.0 00:00:21  3-01:18:35 dlog

341   327  0.1 00:05:35  3-01:18:35 ds

342   327  0.2 00:11:29  3-01:18:35 mgmtApp

343   327  0.0 00:00:04  3-01:18:35 fc2

344   327  0.0 00:02:16  3-01:18:35 nserver

345   327  0.0 00:02:44  3-01:18:35 mserver
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346   327  0.8 00:35:12  3-01:18:35 util

347   327  0.0 00:00:29  3-01:18:35 snmpservicepath

348   327  0.0 00:02:46  3-01:18:34 eport

349   327  0.0 00:00:21  3-01:18:34 PortApp

350   327  5.6 04:08:24  3-01:18:34 port_mon

351   327  0.0 00:01:38  3-01:18:34 zoning

352   327  0.0 00:00:01  3-01:18:34 diagApp

404   327  0.0 00:00:04  3-01:18:27 snmpd

405   327  0.0 00:00:02  3-01:18:27 snmpmain

406   405  0.0 00:00:00  3-01:18:26 snmpmain

Quit command
Closes the Telnet session.

Authority

None

Syntax

QUIT 

or

EXIT 

or

LOGOUT

Notes

You can also press Ctrl+D to close the Telnet session.

Reset command
Resets the switch configuration parameters. If you omit the keyword, the default is the Reset 
Switch command.

Authority

Admin

Syntax

RESET
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Keywords

CONFIG [CONFIG_NAME]

Resets the configuration given by [config_name] to the factory default values for 
switch, port, port threshold alarm, and zoning configuration. If [config_name] does 
not exist on the switch, a configuration with that name is created. If you omit 
[config_name], the active configuration is reset. You must activate the configuration 
for the changes to take effect. See Table 45 through Table 47 for switch, port, and port 
threshold alarm configuration default values.

FACTORY

Resets switch configuration, port configuration, port threshold alarm configuration, 
zoning configuration, SNMP configuration, system configuration, and zoning to the 
factory default values. The switch configuration is activated automatically. See 
Table 45 through Table 50.

Note:  Because this keyword changes network parameters, the workstation could lose 
communication with the switch and release the Admin session.

PORT [PORT_NUMBER]

Reinitializes the port given by [port_number]. Ports are numbered beginning with 0.

SNMP

Resets the SNMP configuration settings to the factory default values. See Table 49 for 
SNMP configuration default values.

SWITCH

Resets the switch without a power-on self test. This is the default. This reset disrupts 
traffic and does the following:

— Activates the pending firmware.

— Closes all management sessions.

— Clears the alarm log. To save the alarm log before resetting, refer to the “Set Log 
Command” on page 144.

To reset the switch with a power-on self test, refer to the “Hardreset command” on 
page 124.

SYSTEM

Resets the system configuration settings to the factory default values. See Table 50 for 
system configuration default values.

Note:  Because this keyword changes network parameters, the workstation could lose 
communication with the switch.

ZONING

Clears the zoning database and deactivates the active zone set. The zoning 
configuration values (autosave, default visibility) remain unchanged.
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Notes

The following tables specify the various factory default settings:

Table 45:  Switch configuration default settings

Parameter Default setting
Admin State Online
Broadcast Enabled True
Inband Enabled True
Domain ID 1 (0x Hex)
Domain ID Lock False
Symbolic Name 2/8q FC Switch
R_A_TOV 10000
E_D_TOV 2000
Principal Priority 254
Configuration Description HP StorageWorks 2/8q FC Switch

Table 46:  Port configuration default settings

Parameter Default setting
Admin State Online
Link Speed Auto
Port Type GL
Symbolic Name Port n, where n is the port number
ALFairness False
DeviceScanEnabled True
ForceOfflineRSCN False
ARB_FF False
InteropCredit 0
ExtCredit 0
FANEnable True
LCFEnable False
MFSEnable True
MSEnable True
NoClose False
IOStreamGuard Disabled
VIEnable False
PDISCPingEnable True
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Table 47:  Port threshold alarm configuration default settings

Parameter Default setting
ThresholdMonitoringEnabled False
CRCErrorsMonitoringEnabled
RisingTrigger
FallingTrigger
SampleWindow

True
25
1
10

DecodeErrorsMonitoringEnabled
RisingTrigger
FallingTrigger
SampleWindow

True
200
0
10

LoginMonitoringEnabled
RisingTrigger
FallingTrigger
SampleWindow

True
5
1
10

LogoutMonitoringEnabled
RisingTrigger
FallingTrigger
SampleWindow

True
5
1
10

LOSMonitoringEnabled
RisingTrigger
FallingTrigger
SampleWindow

True
100
5
10

Table 48:  Zoning configuration default settings

Parameter Default setting
InteropAutoSave True (not supported)
Default Visibility All

Table 49:  SNMP configuration default settings

Parameter Default setting
SNMPEnabled True
Contact <syscontact undefined>
Location <sysLocation undefined>
Description HP StorageWorks 2/8q FC Switch
Trap [1-5] Address Trap 1: 10.0.0.254; Traps 2–5: 0.0.0.0
Trap [1-5] Port 162
Trap [1-5] Severity Warning
Trap [1-5] Version 2
Trap [1-5] Enabled False
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Set command
Sets a variety of switch parameters.

Authority

Admin for all keywords except Alarm, Beacon, and Pagebreak.

Syntax

SET

Keywords

ALARM [option]

Controls the display of alarms in the session output stream or clears the alarm log. 
[option] can be one of the following:

CLEAR—Clears the alarm log history. This value requires an Admin session.

ON—Enables the display of alarms in the session output stream.

OFF—Disables the display of alarms in the session output stream.

BEACON [state]

Enables or disables the flashing of the Logged-In LEDs according to [state]. This 
keyword does not require an admin session. [state] can be one of the following:

ON—Enables the flashing beacon.

OFF—Disables the flashing beacon.

Object ID 1.3.6.1.4.1.1663.1.1.1.1.31
AuthFailureTrap False
ProxyEnabled True

Table 50:  System configuration default settings

Parameter Default setting
Ethernet Network Discovery Static
Ethernet Network IP Address 10.0.0.1
Ethernet Network IP Mask 255.0.0.0
Ethernet Gateway Address 10.0.0.254
Admin Timeout 30 minutes
LocalLogEnabled True
RemotelogEnabled False
RemoteLogHostAddress 10.0.0.254
NTPClientEnabled False
NTPServerAddress 10.0.0.254

Table 49:  SNMP configuration default settings (Continued)

Parameter Default setting
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CONFIG [option]

Sets switch, port, port threshold alarm, and zoning configuration parameters. See the 
“Set Config command” on page 137.

LOG [option]

Specifies the type of entries to be entered in the event log. See the “Set Log 
Command” on page 144.

PAGEBREAK [state]

Specifies how much information is displayed on the screen at a time according to the 
value given by [state]. This keyword does not require an admin session. [state] can be 
one of the following:

ON—Limits the display of information to 20 lines at a time. The page break functions 
affects the following commands: Alias (List, Members), Show (Alarm, 
Log), Zone (List, Members), Zoneset (List, Zones), Zoning 
(Active, List).

OFF—Allows continuous display of information without a break.

PORT [option]

Sets port state and speed for the specified port. The previous Set Config Port settings 
are restored after a switch reset or a reactivation of a switch configuration. See the 
“Set Port command” on page 146.

SETUP [option]

Changes SNMP and system configuration settings. See the “Set Setup command” on 
page 147.

SWITCH [state]

Changes the administrative state for all ports on the switch to the state given by [state]. 
The previous Set Config Switch settings are restored after a switch reset or a 
reactivation of a switch configuration. [state] can be one of the following:

ONLINE—Places all ports online

OFFLINE—Places all ports offline.

DIAGNOSTICS—Prepares all ports for testing.

Examples

2/8q FC Switch #> set beacon on

2/8q FC Switch $> set beacon off
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Set Config command
Sets switch, port, port threshold alarm, and zoning configuration parameters. The changes you 
make with this command are not retained when you reset or power cycle the switch unless you 
save them using the Config Save command. See the “Config command” on page 119.

Authority

Admin and Config Edit

Syntax

SET CONFIG

Keywords

PORT [port_number]

Initiates an edit session in which to change configuration parameters for the port 
number given by [port_number]. If you omit [port_number], the system begins with 
port 0 and proceeds in order through the last port. For each parameter, enter a new 
value or press Enter to accept the current value shown in brackets. Enter q to end the 
configuration for one port, or qq to end the configuration for all ports. Table 51 
describes the port parameters.

PORTS [port_number]

Initiates an editing session in which to change configuration parameters for all ports 
based on the configuration for the port given by [port_number]. If you omit 
[port_number], port 0 is used. For each parameter, enter a new value or press Enter to 
accept the current value shown in brackets. Enter q to end the configuration. Table 51 
describes the port parameters.
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Table 51:  Set Config port parameters

Parameter Description
AdminState Port administrative state:

■ Online – Activates and prepares the port to send data. This 
is the default.

■ Offline – Prevents the port from receiving signal and 
accepting a device login.

■ Diagnostics – Prepares the port for testing and prevents the 
port from accepting a device login.

■ Down – Disables the port by removing power from the port 
lasers.

LinkSpeed Transmission speed: 2 Gbps or Auto. The default is Auto.
PortType Port type: GL, G, F, FL, Donor. The default is GL.
SymbolicPortName Descriptive name for the port. The name can be up to 32 

characters excluding #, semicolon (;), and comma (,). The 
default is Port n where n is the port number.

ALFairness Arbitration loop fairness. Enables (True) or disables (False) the 
switch’s priority to arbitrate on the loop. The default is False.

DeviceScanEnabled Enables (True) or disables (False) the scanning of the 
connected device for FC-4 descriptor information during login. 
The default is True.

ForceOfflineRSCN Enables (False) or disables (True) the immediate transmission 
of RSCN messages when communication between a port and 
a device is interrupted. If enabled, the RSCN message is 
delayed for 200 ms for locally attached devices and 400 ms 
for devices connected through other switches. The default is 
False. This parameter is ignored if IOStreamGuard is enabled.

ARB_FF Send ARB_FF (True) instead of IDLEs (False) on the loop. The 
default is False.

InteropCredit Interoperability credit. The number of buffer-to-buffer credits 
per port. 0 means the default (16) is unchanged. Changing 
interoperability credits is necessary only for E_Ports that are 
connected to non-FC-SW-2-compliant switches. (not 
supported)

ExtCredit Extended credits. The number of port buffer credits that this 
port can acquire from donor ports. The default is 0.

FANEnable Fabric address notification. Enables (True) or disables (False) 
the communication of the FL_Port address, port name, and 
node name to the logged-in NL_Port. The default is True.

LCFEnable Link control frame preference routing. Enables (True) or 
disables (False) preferred routing of frames with R_CTL = 
1100. The default is False. Enabling LCFEnable will disable 
MFSEnable.

MFSEnable Multi-Frame Sequence bundling. Prevents (True) or allows 
(False) the interleaving of frames in a sequence. The default is 
False. Enabling MFSEnable disables LCFEnable and 
VIEnable.

MSEnable Management server enable. Enables (True) or disables (False) 
management server on this port. The default is True.
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SWITCH

Initiates an editing session in which to change switch configuration settings. The 
system displays each parameter one line at a time and prompts you for a value. For 
each parameter, enter a new value or press Enter to accept the current value shown in 
brackets. Table 52 describes the Set Config Switch parameters.

NoClose Loop circuit closure prevention. Enables (True) or disables 
(False) the loop’s ability to remain in the open state 
indefinitely. True reduces the amount of arbitration on a loop 
when there is only one device on the loop. The default is 
False.

IOStreamGuard I/O Stream Guard. Enable (Enable) or disables (Disable) the 
suppression of RSCN messages. I/O Stream Guard should be 
enabled only for ports connected to initiator devices. The 
default is Disable.

VIEnable Enables (True) or disables (False) VI preference routing. The 
default is False. Enabling VIEnable will disable MFSEnable.

PDISCPingEnable Enables (True) or disables (False) the transmission of ping 
messages from the switch to all devices on a loop port. The 
default is True.

Table 52:  Set config switch parameters

Parameter Description
AdminState Switch administrative state: online, offline, or diagnostics. The 

default is Online.
BroadcastEnabled Broadcast. Enables (True) or disables (False) forwarding of 

broadcast frames. The default is True.
DefaultDomainID Default domain ID. The default is 1.
DomainIDLock Prevents (True) or allows (False) dynamic reassignment of the 

domain ID. The default is False.
SymbolicName Descriptive name for the switch. The name can be up to 32 

characters excluding #, semicolon (;), and comma (,). The 
default is 2/8q FC Switch.

R_A_TOV Resource Allocation Timeout Value. The number of 
milliseconds the switch waits to allow two ports to allocate 
enough resources to establish a link. The default is 10000.

E_D_TOV Error Detect Timeout Value. The number of milliseconds a port 
is to wait for errors to clear. The default is 2000.

PrincipalPriority The priority used in the FC-SW-2 principal switch selection 
algorithm. 1 is high, 255 is low. The default is 254.

ConfigDescription Switch configuration description. The configuration description 
can be up to 32 characters excluding #, semicolon (;), and 
comma (,). The default is 2/8q FC Switch.

InteropMode Propagates just the active zone set throughout the fabric (True, 
compliant) or the entire zoning database (False, 
non-compliant). The default is True. (not supported)

LegacyAddressFormat Available only when the InteropMode parameter is False, this 
parameter enables (True) or disables (False) the use of legacy 
address formatting for interoperating with non-FC-SW-2 
switches. See Table 52. The default is False. (not supported)

Table 51:  Set Config port parameters (Continued)

Parameter Description
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THRESHOLD

Initiates a configuration session by which to generate and log alarms for selected 
events. The system displays each event, its triggers, and sampling window one line at a 
time and prompts you for a value. For each parameter, enter a new value or press 
Enter to accept the current value shown in brackets. These parameters must be saved 
in a configuration and activated before they take effect. See the “Config command” on 
page 119 for information about saving and activating a configuration. Table 53 
describes the Set Config Threshold parameters. The switch shuts down a port if an 
alarm condition is not cleared within three consecutive sampling windows (by default 
30 seconds). Reset the port to bring it back online. An alarm is cleared when the 
threshold monitoring detects that the error rate has fallen below the falling trigger.

Table 53:  Set config threshold parameters

Parameter Description
Threshold Monitoring Enabled Master enable/disable parameter for all events. 

Enables (True) or disables (False) the generation of all 
enabled event alarms. The default is False.

CRCErrorsMonitoringEnabled
DecodeErrorsMonitoringEnabled
LoginMonitoringEnabled
LogoutMonitoringEnabled
LOSMonitoringEnabled

The event type enable/disable parameter. Enables 
(True) or disables (False) the generation of alarms for 
each of the following events:
■ CRC errors
■ Decode errors
■ Device login errors
■ Device logout errors
■ Loss-of-signal errors

Rising Trigger The event count above which a rising trigger alarm is 
logged. The switch will not generate another rising 
trigger alarm for that event until the count descends 
below the falling trigger and again exceeds the rising 
trigger.

Falling Trigger The event count below which a falling trigger alarm is 
logged. The switch will not generate another falling 
trigger alarm for that event until the count exceeds 
the rising trigger and descends again below the 
falling trigger.

Sample Window The period of time in seconds in which to count 
events.
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ZONING

Initiates an editing session in which to change switch zoning attributes. The system 
displays each parameter one line at a time and prompts you for a value. For each 
parameter, enter a new value or press Enter to accept the current value shown in 
brackets.

Examples

The following is an example of the SET CONFIG PORT command:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config edit

2/8q FC Switch (admin-config) #> set config port 1

  A list of attributes with formatting and current values will follow.

  Enter a new value or simply press the ENTER key to accept the current 
value.

  If you wish to terminate this process before reaching the end of the 
list

  press 'q' or 'Q' and the ENTER key to do so.

  Configuring Port Number:  1

  ------------------------

  AdminState    (1=Online, 2=Offline, 3=Diagnostics, 4=Down)       [Online]

  LinkSpeed     (1=1Gb/s, 2=2Gb/s, 3=Auto)                         [Auto  ]

  PortType      (GL / G / F / FL / Donor)                          [GL    ]

  SymPortName   (string, max=32 chars)                             [Port1 ]

  ALFairness    (True / False)                                     [False ]

  DeviceScanEnable (True / False)                                  [True  ]

  ForceOfflineRSCN (True / False)                                  [False ]

  ARB_FF        (True / False)                                     [False ]

  InteropCredit (decimal value, 0-255)                             [0     ]

Table 54:  Set config zoning parameters

Parameter Description
InteropAutoSave Available only when the InteropMode parameter is True, this 

parameter enables (True) or disables (False) the saving of 
changes to active zone set in the switch’s permanent memory. 
See “Set config threshold parameters” on page 140. The 
default is True. (not supported)
Disabling the Autosave parameter can be useful to prevent 
the propagation of zoning information when experimenting 
with different zoning schemes. However, leaving the Autosave 
parameter disabled can disrupt device configurations should 
a switch have to be reset. For this reason, the Autosave 
parameter should be enabled in a production environment.

Default Visibility Enables (All) or disables (None) communication among the 
switch’s ports/devices and the fabric in the absence of an 
active zone set. The default is All.
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  ExtCredit     (dec value, increments of 15, non-loop only)       [0     ]

  FANEnable     (True / False)                                     [True  ]

  LCFEnable     (True / False)                                     [False ]

  MFSEnable     (True / False)                                     [False ]

  MSEnable      (True / False)                                     [True  ]

  NoClose       (True / False)                                     [False ]

  IOStreamGuard (Enable / Disable)                                 [Disable]

  VIEnable      (True / False)                                     [False ]

  PDISCPingEnable  (True / False)                                  [True  ]

  Finished configuring attributes.

  This configuration must be saved (see config save command) and

  activated (see config activate command) before it can take effect.

  To discard this configuration use the config cancel command.

2/8q FC Switch (admin-config) #>

The following is an example of the SET CONFIG SWITCH command:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config edit

2/8q FC Switch (admin-config) #> set config switch

  A list of attributes with formatting and default values will follow.

  Enter a new value or simply press the ENTER key to accept the current 
value.

  If you wish to terminate this process before reaching the end of the 
list

  press 'q' or 'Q' and the ENTER key to do so.

  AdminState         (1=Online, 2=Offline, 3=Diagnostics) [Online       ]

  BroadcastEnable    (True / False)                       [False        ]

  InbandEnabled      (True / False)                       [False        ]

  DefaultDomainID    (decimal value, 1-239)               [11           ]

  DomainIDLock       (True / False)                       [True         ]

  SymbolicName       (string, max=32 chars)               [2/8q FC Switch]

  R_A_TOV            (decimal value, 100-100000 msec)     [10000        ]

  E_D_TOV            (decimal value, 10-20000 msec)       [2000         ]

  PrincipalPriority  (decimal value, 1-255)               [254          ]

  ConfigDescription  (string, max=32 chars)               [2/8q FC Switch]
  InteropMode        (True / False)                       [True         ]
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The following is an example of the SET CONFIG THRESHOLD command:

2/8q FC Switch #> admin start

2/8q FC Switch  (admin) #> config edit

2/8q FC Switch (admin-config) #> set config threshold

A list of attributes with formatting and current values will follow.

Enter a new value or simply press the ENTER key to accept the current 
value.

If you wish to terminate this process before reaching the end of the list

press 'q' or 'Q' and the ENTER key to do so.

  

ThresholdMonitoringEnabled     (True / False)              [False     ]

  

CRCErrorsMonitoringEnabled     (True / False)              [True      ]

  RisingTrigger                (decimal value, 1-1000)     [25        ]

  FallingTrigger               (decimal value, 0-1000)     [1         ]

  SampleWindow                 (decimal value, 1-1000 sec) [10        ]

DecodeErrorsMonitoringEnabled  (True / False)              [True      ]

  RisingTrigger                (decimal value, 1-1000)     [200       ]

  FallingTrigger               (decimal value, 0-1000)     [0         ]

  SampleWindow                 (decimal value, 1-1000 sec) [10        ]

LoginMonitoringEnabled         (True / False)              [True      ]

  RisingTrigger                (decimal value, 1-1000)     [5         ]

  FallingTrigger               (decimal value, 0-1000)     [1         ]

  SampleWindow                 (decimal value, 1-1000 sec) [10        ]

LogoutMonitoringEnabled        (True / False)              [True      ]

  RisingTrigger                (decimal value, 1-1000)     [5         ]

  FallingTrigger               (decimal value, 0-1000)     [1         ]

  SampleWindow                 (decimal value, 1-1000 sec) [10        ]

  

LOSMonitoringEnabled           (True / False)               [True     ]

  RisingTrigger                (decimal value, 1-1000)      [100      ]

  FallingTrigger               (decimal value, 0-1000)      [5        ]

  SampleWindow                 (decimal value, 1-1000 sec)  [10       ]

  

Finished configuring attributes.
This configuration must be saved (see config save command) and
activated (see config activate command) before it can take effect.
To discard this configuration use the config cancel command.
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The following is an example of the SET CONFIG ZONING command:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> config edit

2/8q FC Switch (admin-config) #> set config zoning

A list of attributes with formatting and current values will follow.

Enter a new value or simply press the ENTER key to accept the current 
value.

If you wish to terminate this process before reaching the end of the list 
press 'q' or 'Q' and the ENTER key to do so.

  InteropAutoSave     (True / False)  [True]

  Default Visibility   (All / None)    [All ]

  Finished configuring attributes.

  This configuration must be saved (see config save command) and

  activated (see config activate command) before it can take effect.

  To discard this configuration use the config cancel command.

Set Log Command
Specifies the events to record in the event log and display on the screen. You determine what 
events to record in the switch event log using the Component, Level, and Port keywords. 
You determine what events are automatically displayed on the screen using the Display 
keyword. Alarms are always displayed on the screen.

Authority

Admin

Syntax

SET LOG

Keywords

ARCHIVE

Collects the most recent 200 entries plus the previous 1000 entries and stores the 
result in new file named logfile that is maintained in switch memory where it can 
be downloaded using FTP. To download logfile, open an FTP session, log in with 
account name/password of images for both, and type get logfile.

CLEAR

Clears all log entries.

COMPONENT [filter_list]

Specifies one or more components given by [filter_list] to monitor for events. A 
component is a firmware module that is responsible for a particular portion of switch 
operation. Use a <space> to delimit values in the list. [filter_list] can be one or more 
of the following:

MGMTSERVER—Monitors management server status.

NAMESERVER—Monitors name server status.
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PORT—Monitors all port events.

SNMP—Monitors SNMP events.

SWITCH—Monitors switch management events.

ZONING—Monitors zoning conflict events.

ALL—Monitors all components.

NONE—Monitor none of the component events.

DISPLAY [filter]

Specifies the log events to automatically display on the screen according to the event 
severity levels given by [filter]. [filter] can be one of the following values:

CRITICAL—Critical severity level events. The critical level describes events that are 
generally disruptive to the administration or operation of the fabric, but require no 
action.

WARN—Warning severity level events. The warning level describes events that are 
generally not disruptive to the administration or operation of the fabric, but are more 
important than the informative level events.

INFO—Informative severity level events. The informative level describes routine 
events associated with a normal fabric.

NONE—Specifies no severity levels for display on the screen.

LEVEL [filter]

Specifies the severity level given by [filter] to use in monitoring and logging events 
for the specified components or ports. [filter] can be one of the following values:

CRITICAL—Monitors critical events. The critical level describes events that are 
generally disruptive to the administration or operation of the fabric, but require no 
action.

WARN—Monitors warning and critical events. The warning level describes events that 
are generally not disruptive to the administration or operation of the fabric, but are 
more important than the informative level events.

INFO—Monitors informative, warning, and critical events. The informative level 
describes routine events associated with a normal fabric. This is the default severity 
level.

NONE—Monitors none of the severity levels.

PORT [port_list]

Specifies one or more ports to monitor for events. Choose one of the following values:

[port_list]—Specifies port or ports to monitor. Use a <space> to delimit values in 
the list. Ports are numbered beginning with 0.

ALL—Specifies all ports.

NONE—Disables monitoring on all ports.

RESTORE

Restores and saves the port, component, and level settings to the default values.
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SAVE

Saves the log settings for the component, severity level, port, and display level. These 
settings remain in effect after a switch reset. The log settings can be viewed using the 
Show Log Settings command. To export log entries to a file, use the Set Log 
Archive command.

START

Starts the logging of events based on the Port, Component, and Level keywords 
assigned to the current configuration. The logging continues until you enter the Set 
Log Stop command.

STOP

Stops logging of events.

Notes

In addition to critical, warn, and informative severity levels, the highest event severity 
level is alarm. The alarm level describes events that are disruptive to the administration or 
operation of a fabric and require administrator intervention. Alarms are always logged and 
always displayed on the screen.

Set Port command
Sets port state and speed for the specified port temporarily until the next switch reset or new 
configuration activation. This command also clears port counters.

Authority

Admin, except for the Clear keyword

Syntax

SET PORT [PORT_NUMBER}

Keywords

[PORT_NUMBER]

Specifies the port. Ports are numbered beginning with 0.

BYPASS [ALPHA]

Sends a Loop Port Bypass (LPB) to a specific Arbitrated Loop Physical Address 
(ALPA) or to all ALPAs on the arbitrated loop. [alpa] can be a specific ALPA or the 
keyword ALL to choose all ALPAs.

CLEAR

Clears the counters on the port. This keyword does not require an admin session.

ENABLE

Sends a Loop Port Enable (LPE) to all ALPAs on the arbitrated loop.

SPEED [TRANSMISSION_SPEED]

Specifies the transmission speed for the specified port. Choose one of the following 
port speed values:

2Gb/s—Two gigabits per second.

Auto—The port speed is automatically detected.
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STATE [STATE]

Specifies one of the following administrative states for the specified port:

Online—Places the port online. This activates and prepares the port to send data.

Offline—Places the port offline. This prevents the port from receiving signal and 
accepting a device login.

Diagnostics—Prepares the port for testing. This prepares the port for testing and 
prevents the port from accepting a device login.

Down—Disables the port by removing power from the port lasers.

Set Setup command
Changes SNMP and system configuration settings. The switch maintains one SNMP 
configuration and one system configuration.

Authority

Admin

Syntax

SET SETUP

Keywords

SNMP

Prompts you in a line-by-line fashion to change SNMP configuration settings. 
Table 55 describes the SNMP parameters. For each parameter, enter a new value or 
press Enter to accept the current value shown in brackets.

Table 55:  SNMP configuration settings

Entry Description
SNMPEnabled Enables (True) or disables (False) SNMP on the switch. The 

default is True.
Contact Specifies the name of the person to be contacted to respond to 

trap events. The name can be up to 64 characters excluding #, 
semicolon (;), and comma (,). The default is undefined.

Location Specifies the name of the switch location. The name can be up 
to 64 characters excluding #, semicolon (;), and comma (,). 
The default is undefined.

Trap [1-5] Address Specifies the workstation IP address to which SNMP traps are 
sent. The default address for trap 1 is 10.0.0.254. The default 
address for traps 2–5 is 0.0.0.0. Addresses, other than 
0.0.0.0, for all traps must be unique.

Trap [1-5] Port Specifies the workstation port to which SNMP traps are sent. 
Valid workstation port numbers are 1–65535. The default is 
162.

Trap [1-5] Severity Specifies the severity level to use when monitoring trap events. 
The default is Warning

Trap [1-5] Version Specifies the SNMP version (1 or 2) to use in formatting traps. 
The default is 2.

Trap [1-5] Enabled Specifies whether traps (event information) are enabled or 
disabled (default).
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system

Prompts you in a line-by-line fashion to change system configuration settings. 
Table 56 describes the system configuration parameters. For each parameter, enter a 
new value or press Enter to accept the current value shown in brackets.

Note:  Changing the IP address will terminate all Ethernet management sessions.

ReadCommunity Read community password that authorizes an SNMP agent to 
read information from the switch. This is a write-only field. The 
value on the switch and the SNMP management server must 
be the same. The read community password can be up to 32 
characters excluding #, semicolon (;), and comma (,). The 
default is “public”.

WriteCommunity Write community password that authorizes an SNMP agent to 
write information to the switch. This is a write-only field. The 
value on the switch and the SNMP management server must 
be the same. The write community password can be up to 32 
characters excluding #, semicolon (;), and comma (,). The 
default is “private”.

TrapCommunity Trap community password that authorizes an SNMP agent to 
receive traps. This is a write-only field. The value on the switch 
and the SNMP management server must be the same. The 
trap community password can be up to 32 characters 
excluding #, semicolon (;), and comma (,). The default is 
“public”.

AuthFailureTrap Enables (True) or disables (False) the generation of traps in 
response to trap authentication failures. The default is False.

ProxyEnabled Enables (True) or disables (False) SNMP communication with 
other switches in the fabric. The default is True.

Table 56:  System configuration settings

Entry Description
Eth0NetworkDiscovery Ethernet boot method: 1 - Static, 2 - Bootp, 3 - DHCP,

4 - RARP. The default is 1 - Static.
Eth0NetworkAddress Ethernet Internet Protocol (IP) address. The default is 10.0.0.1.
Eth0NetworkMask Ethernet subnet mask address.
Eth0GatewayAddress Ethernet IP address gateway.
AdminTimeout Specifies the amount of time in minutes the switch waits before 

terminating an idle Admin session. Zero (0) disables the time 
out threshold. The default is 30, the maximum is 1440.

LocalLogEnabled Enables (True) or disables (False) the saving of log information 
on the switch. The default is True.

RemoteLogEnabled Enables (True) or disables (False) the recording of the switch 
event log on a remote host that supports the syslog protocol. 
The default is False.

Table 55:  SNMP configuration settings (Continued)

Entry Description
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Examples

The following is an example of the Set Setup SNMP command:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> set setup snmp

  A list of attributes with formatting and current values will follow.

  Enter a new value or simply press the ENTER key to accept the current value.

  If you wish to terminate this process before reaching the end of the list

  press 'q' or 'Q' and the ENTER key to do so.

  Trap Severity Options

  ---------------------

  unknown, emergency, alert, critical, error, warning, notify, info, debug, mark

  SNMPEnabled         (True / False)               [True             ]

  Contact             (string, max=64 chars)       [<sysContact undefined]

  Location            (string, max=64 chars)       [sysLocation undefined]

  Trap1Address        (dot-notated IP Address)     [10.20.71.15      ]

  Trap1Port           (decimal value)              [162              ]

  Trap1Severity       (see allowed options above)  [warning          ]

  Trap1Version        (1 / 2)                      [2                ]

  Trap1Enabled        (True / False)               [False            ]

  Trap2Address        (dot-notated IP Address)     [0.0.0.0          ]

  Trap2Port           (decimal value)              [162              ]

  Trap2Severity       (see allowed options above)  [warning          ]

  Trap2Version        (1 / 2)                      [2                ]

  Trap2Enabled        (True / False)               [False            ]

  Trap3Address        (dot-notated IP Address)     [0.0.0.0          ]

  Trap3Port           (decimal value)              [162              ]

  Trap3Severity       (see allowed options above)  [warning          ]

  Trap3Version        (1 / 2)                      [2                ]

  Trap3Enabled        (True / False)               [False            ]

  Trap4Address        (dot-notated IP Address)     [0.0.0.0          ]

Trap4Port           (decimal value)              [162              ]

  Trap4Severity       (see allowed options above)  [warning          ]

  Trap4Version        (1 / 2)                      [2                ]

  Trap4Enabled        (True / False)               [False            ]

RemoteLogHostAddress The IP address of the host that will receive the switch event log 
information if remote logging is enabled. The default is 
10.0.0.254.

NTPClientEnabled Enables (True) or disables (False) the Network Time Protocol 
(NTP) client on the switch. This client enables the switch to 
synchronize its time with an NTP server. This feature supports 
NTP version 4 and is compatible with version 3. An Ethernet 
connection to the server is required and you must first set an 
initial time and date on the switch. The synchronized time 
becomes effective immediately. The default is False.

NTPServerAddress The IP address of the NTP server from which the NTP client 
acquires the time and date. The default is 10.0.0.254.

Table 56:  System configuration settings (Continued)

Entry Description

Download from Www.Somanuals.com. All Manuals Search And Download.



Command Line Interface

150 HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

  Trap5Address        (dot-notated IP Address)     [0.0.0.0          ]

  Trap5Port           (decimal value)              [162              ]

  Trap5Severity       (see allowed options above)  [warning          ]

  Trap5Version        (1 / 2)                      [2                ]

  Trap5Enabled        (True / False)               [False            ]

  ReadCommunity       (string, max=32 chars)       [public           ]

  WriteCommunity      (string, max=32 chars)       [private          ]

  TrapCommunity       (string, max=32 chars)       [public           ]

  AuthFailureTrap     (True / False)               [False            ]

  ProxyEnabled        (True / False)               [True             ]

The following is an example of the Set Setup System command:
2/8q FC Switch (admin) #> set setup system

  A list of attributes with formatting and current values will follow.

  Enter a new value or simply press the ENTER key to accept the current value.

  If you wish to terminate this process before reaching the end of the list

  press 'q' or 'Q' and the ENTER key to do so.

Eth0NetworkDiscovery    (1=Static, 2=Bootp, 3=Dhcp, 4=Rarp)  [Static       ]

Eth0NetworkAddress      (dot-notated IP Address)             [10.0.0.1     ]

Eth0NetworkMask         (dot-notated IP Address)             [255.255.255.0]

Eth0GatewayAddress      (dot-notated IP Address)             [10.0.0.254   ]

AdminTimeout            (dec value 0-1440 minutes, 0=never)  [30           ]

LocalLogEnabled         (True / False)                       [True         ]

RemoteLogEnabled        (True / False)                       [False        ]

RemoteLogHostAddress    (dot-notated IP Address)             [10.0.0.254   ]

NTPClientEnabled        (True / False)                       [False        ]

NTPServerAddress        (dot-notated IP Address)             [10.0.0.254   ]

Show command
Displays fabric, switch, and port operational information.

Authority

None

Syntax

SHOW

Keywords

about

Displays an introductory set of information about operational attributes of the switch. 
This keyword is equivalent to the Version keyword.
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alarm [option]

Displays the alarm log and session display setting. If you omit [option], the command 
displays the last 200 alarm entries. The alarm log is cleared when the switch is reset or 
power cycled. [option] has the following value:

setting—Displays the status of the parameter that controls the display of alarms in 
the session output stream. This parameter is set using the Set Alarm command.

broadcast

Displays the broadcast tree information and all ports that are currently transmitting 
and receiving broadcast frames.

chassis

Displays chassis component status and temperature.

config [option]

Displays switch, port, and zoning configuration attributes. See the “Show Config 
command” on page 160.

domains

Displays list of each domain and its worldwide name in the fabric.

donor

Displays list of current donor configuration for all ports.

fabric

Displays list of each domain, symbolic name, worldwide name, node IP address, and 
port IP address.

interface

Displays the status of the active network interfaces.

log [option]

Displays log entries. See the “Show Log command” on page 163. The log is cleared 
when the switch is reset or power cycled.

lsdb

Displays Link State database information.

mem [count]

Displays information about memory activity for the number of seconds given by 
[count]. If you omit [count], the value 1 is used. Displayed memory values are in 1K 
block units.

Note:  This keyword will display memory activity updates until [count] is reached – it cannot be 
interrupted. Therefore, avoid using large values for [count].

ns [option]

Displays name server information for the specified [option]. If you omit [option], 
name server information for the local domain ID is displayed. [option] can have the 
following values:

all—Displays name server information for all switches and ports.

[domain_id]—Displays name server information for the switch given by 
[domain_id]. [domain_id] is a switch domain ID.
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[port_id]—Displays name server information for the port given by [port_id]. 
[port_id] is a port Fibre Channel address.

pagebreak

Displays the current pagebreak setting. The pagebreak setting limits the display of 
information to 20 lines (On) or allows the continuous display of information without a 
break (Off).

perf [option]

Displays performance information for all ports. See the “Show Perf command” on 
page 165.

port [port_number]

Displays operational information for the port given by [port_number]. Ports are 
numbered beginning with 0. If [port number] is omitted, information is displayed for 
all ports. Table 57 describes the port parameters.

Table 57:  Show Port parameters

Entry Description
AIinit Incremented each time the port begins AL initialization.
AIinitError Number of times the port entered initialization and the 

initialization failed.
Bad Frames Number of frames that have framing errors.
ClassXFramesIn Number of class x frames received by this port.
ClassXFramesOut Number of class x frames sent by this port.
ClassXWordsIn Number of class x words received by this port.
ClassXWordsOut Number of class x words sent by this port.
ClassXToss Number of times an SOFi3 or SOFn3 frame is tossed from 

TBUF.
DecodeError Number of decode errors detected
FBusy Number of class 3 fabric busy (F_BSY) frames generated by 

this port in response to incoming frames. This usually indicates 
a busy condition on the fabric or N_Port that is preventing 
delivery of this frame.

Flowerrors Received a frame when there were no available credits.
FReject Number of frames from devices that were rejected.
InvalidCRC Invalid CRC detected.
InvalidDestAddr Invalid destination address detected.
LIP_AL_PD_ALPS Number of F7, AL_PS LIPs, or AL_PD (vendor specific) resets, 

performed.
LIP_F7_AL_PS This LIP is used to reinitialize the loop. An L_Port, identified by 

AL_PS, may have noticed a performance degradation and is 
trying to restore the loop.

LIP_F8_AL_PS This LIP denotes a loop failure detected by the L_Port identified 
by AL_PS.

LIP_F7_F7 A loop initialization primitive frame used to acquire a valid 
AL_PA.

LIP_F8_F7 A loop initialization primitive frame used to indicate that a 
loop failure has been detected at the receiver.
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post log

Displays the Power On Self Test (POST) log which contains results from the POST.

setup [option]

Displays setup attributes for the system, SNMP, and the switch manufacturer. See the 
“Show Setup command” on page 166.

steering [domain_id]

Displays the routes that data takes to the switch given by [domain_id]. If you omit 
[domain_id], the system displays routes for all switches in the fabric.

Link Failures Number of optical link failures detected by this port. A link 
failure is a loss of synchronization or a loss of signal while not 
in the offline state. A loss of signal causes the switch to 
attempt to re-establish the link. If the link is not re-established, 
a link failure is counted. A link reset is performed after a link 
failure.

Login Number of device logins
Logout Number of device logouts
LoopTimeouts A two (2) second timeout as specified by FC-AL-2.
LossOfSync Number of synchronization losses (>100 ms) detected by this 

port. A loss of synchronization is detected by receipt of an 
invalid transmission word.

PrimSeqErrors Primitive sequence errors detected.
RxLinkResets Number of link reset primitives received from an attached 

device.
RxOfflineSeq Number of offline sequences received. An OLS is issued for 

link initialization, a Receive & Recognize Not_Operational 
(NOS) state, or to enter the offline state.

TotalErrors Total number of errors detected.
TotalLIPsRecvd Number of loop initialization primitive frames received by this 

port.
TotalLIPsXmitd Number of loop initialization primitive frames transmitted by 

this port.
TotalLinkResets Total number of link reset primitives. 
TotalOfflineSeq Total number of Offline Sequences issued and received by this 

port.
TotalRxFrames Total number of frames received by this port.
TotalRxWords Total number of words received by this port.
TotalTxFrames Total number of frames issued by this port.
TotalTxWords Total number of words issued by this port.
TxLinkResets Number of Link Resets issued by this port.
TxOfflineSeq Total number of Offline Sequences issued by this port.

Table 57:  Show Port parameters (Continued)

Entry Description
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support

Executes a series of commands that display a complete description of the switch, its 
configuration, and operation. The display can be captured from the screen and used 
for diagnosing problems. This keyword is intended for use at the request of your HP 
Authorized Service Provider. The commands that are executed include the following:

— Alias List

— Config List

— Date

— History

— Ps

— Show (About, Alarm, Backtrace, Chassis, Config Port, 
Config Switch, Config Threshold, Dev, Dev Settings, 
Domains, Donor, Fabric, Log, Log Archive, Log Settings, 
Lsdb, Mem, Ns, Perf, Port, Setup Mfg, Setup Snmp, Setup 
System, Steering, Switch, Topology, Users)

— Uptime

— User Accounts

— Whoami

— Zoneset (Active, List)

— Zoning (History, Limits, List)

switch

Displays switch operational information.

topology

Displays all connected devices.

users

Displays a list of logged-in users. This is equivalent to the User List command.

version

Displays an introductory set of information about operational attributes of the switch. 
This keyword is equivalent to the About keyword.

Examples

The following is an example of the Show Chassis command:

2/8q FC Switch #> show chassis

  Chassis Information

  -------------------

  BoardTemp (1) - Degrees Celsius   23

  PowerSupplyStatus (1)             Good

  HeartBeatCode                     1

  HeartBeatStatus                   Normal
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The following is an example of the Show Domains command:

2/8q FC Switch #> show domains

  Principal switch is (remote): 10:00:00:60:69:50:0b:6c

  Domain ID List:

        Domain 97  (0x61)  WWN = 10:00:00:c0:dd:00:71:ed

        Domain 98  (0x62)  WWN = 10:00:00:60:df:22:2e:0c

        Domain 99  (0x63)  WWN = 10:00:00:c0:dd:00:72:45

        Domain 100 (0x64)  WWN = 10:00:00:c0:dd:00:ba:68

        Domain 101 (0x65)  WWN = 10:00:00:60:df:22:2e:06

        Domain 102 (0x66)  WWN = 10:00:00:c0:dd:00:90:ef

        Domain 103 (0x67)  WWN = 10:00:00:60:69:50:0b:6c

        Domain 104 (0x68)  WWN = 10:00:00:c0:dd:00:b8:b7

The following is an example of the Show Fabric command:
2/8q FC Switch #> show fabric

 Domain     WWN                     Enet IP Addr    FC IP Addr      SymbolicName

 ------     ---                     ------------    ----------      ------------

 16 (0x10)  10:00:00:c0:dd:00:77:81 10.20.68.11     0.0.0.0         gui sb1 .11

 17 (0x11)  10:00:00:c0:dd:00:6a:2d 10.20.68.12     0.0.0.0         sw12

 18 (0x12)  10:00:00:c0:dd:00:c3:04 10.20.68.160    0.0.0.0         sw .160

 19 (0x13)  10:00:00:c0:dd:00:bc:56 10.20.68.108    0.0.0.0         Sb2 .108

The following is an example of the Show NS [local domain] command:
2/8q FC Switch #> show ns

  Seq Domain    Port   Port

  No  ID        ID     Type COS PortWWN                 NodeWWN

  --- ------    ------ ---- --- -------                 -------

  1   19 (0x13) 1301e1 NL   3   21:00:00:20:37:73:13:69 20:00:00:20:37:73:13:69

  2   19 (0x13) 1301e2 NL   3   21:00:00:20:37:73:12:9b 20:00:00:20:37:73:12:9b

  3   19 (0x13) 1301e4 NL   3   21:00:00:20:37:73:05:26 20:00:00:20:37:73:05:26

  4   19 (0x13) 130d00 N    3   21:01:00:e0:8b:27:a7:bc 20:01:00:e0:8b:27:a7:bc

The following is an example of the Show NS [domain_ID] command:
2/8q FC Switch #> show ns 18

    Seq Domain    Port   Port

  No  ID        ID     Type COS PortWWN                 NodeWWN

  --- ------    ------ ---- --- -------                 -------

  1   18 (0x12) 120700 N    3   21:00:00:e0:8b:07:a7:bc 20:00:00:e0:8b:07:a7:bc
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The following is an example of the Show NS [port_ID] command:

2/8q FC Switch #> show ns 1301e1

  Port ID: 1301e1

  --------

  PortType          NL

  PortWWN           21:00:00:20:37:73:13:69

  SymbolicPortName

  NodeWWN           20:00:00:20:37:73:13:69

  SymbolicNodeName

  NodeIPAddress     0.0.0.0

  ClassOfService    3

  PortIPAddress     0.0.0.0

  FabricPortName    20:01:00:c0:dd:00:bc:56

  FC4Type           FCP

  FC4Desc           (NULL)

The following is an example of the Show Interface command:

2/8q FC Switch #> show interface

eth0      Link encap:Ethernet  HWaddr 00:C0:DD:00:BD:ED

          inet addr:10.20.68.107  Bcast:10.20.68.255  Mask:255.255.255.0

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:4712 errors:0 dropped:0 overruns:0 frame:0

          TX packets:3000 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:100

          RX bytes:415313 (405.5 Kb)  TX bytes:716751 (699.9 Kb)

          Interrupt:11 Base address:0xfcc0

lo        Link encap:Local Loopback

          inet addr:127.0.0.1  Mask:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:304 errors:0 dropped:0 overruns:0 frame:0

          TX packets:304 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:20116 (19.6 Kb)  TX bytes:20116 (19.6 Kb)
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The following is an example of the Show Port command:
2/8q FC Switch #> show port 1

    Port Number: 1

  ------------

  AdminState       Online              PortID           150100

  AsicNumber       0                   PortWWN          20:01:00:c0:dd:00:bc:b8

  AsicPort         1                   RunningType      Unknown

  ConfigType       G                   SFPPartNumber    Unknown

  DiagStatus       Passed              SFPRevision      0

  EpConnState      None                SFPType          NotInstalled

  EpIsoReason      NotApplicable       SFPVendor        Unknown

  LinkSpeed        2Gb/s               SFPVendorID      00000000

  LinkState        Inactive            SymbolicName     Port1

  LoginStatus      NotLoggedIn         SyncStatus       SyncLost

  MaxCredit        16                  XmitterEnabled   True

  OperationalState Offline

  ALInit          0                      LIP_F8_AL_PS    0

  ALInitError     0                      LIP_F8_F7       0

  BadFrames       0                      LinkFailures    26

  Class2FramesIn  0                      Login           25

  Class2FramesOut 0                      Logout          24

  Class2WordsIn   0                      LoopTimeouts    0

  Class2WordsOut  0                      LossOfSync      1

  Class3FramesIn  0                      PrimSeqErrors   0

  Class3FramesOut 0                      RxLinkResets    23

  Class3Toss      0                      RxOfflineSeq    45

  Class3WordsIn   0                      TotalErrors     26

  Class3WordsOut  0                      TotalLIPsRecvd  0

  DecodeErrors    0                      TotalLIPsXmitd  0

  EpConnects      25                     TotalLinkResets 77

  FBusy           0                      TotalOfflineSeq 59

  FlowErrors      0                      TotalRxFrames   0

  FReject         0                      TotalRxWords    0

  InvalidCRC      0                      TotalTxFrames   0

  InvalidDestAddr 0                      TotalTxWords    0

  LIP_AL_PD_AL_PS 0                      TxLinkResets    54

  LIP_F7_AL_PS    0                      TxOfflineSeq    14

  LIP_F7_F7       0                      
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The following is an example of the Show Switch command:

  2/8q FC Switch #> show switch

  Switch Information

  ------------------

  SymbolicName                      2/8q FC Switch

  SwitchWWN                         10:00:00:c0:dd:03:cf:cc

  SwitchType                        2/8q FC Switch

  BootVersion                       V1.1.0.6-0 (Tue Apr 27 13:31:56 2004)

  CreditPool                        0

  DomainID                          1 (0x1)

  FirstPortAddress                  110000

  FlashSize - MBytes                64

  LogFilterLevel                    Info

  MaxPorts                          8

  NumberOfResets                    2

  ReasonForLastReset                PowerUp

  ActiveImageVersion - build date V04.0.3.4-0 (Thu Sep 2 18:41:02 2004)

  PendingImageVersion - build date V4.0.3.4-0 (Thu Sep 2 18:41:02 2004)

  ActiveConfiguration               default

  AdminState                        Online

  AdminModeActive                   False

  BeaconOnStatus                    False

  OperationalState                  Online

  PrincipalSwitchRole               True

  BoardTemp (1) - Degrees Celsius   29

  SwitchDiagnosticsStatus           Passed

  SwitchTemperatureStatus           Normal

The following is an example of the Show Topology command:
2/8q FC Switch #> show topology

Unique ID Key

-------------

A = ALPA,  D = Domain ID,  P = Port ID

Port   Local Local                    Remote  Remote                    Unique

Number Type  PortWWN                  Type    NodeWWN                   ID

------ ----- -------                  ------  -------                   ------

5      F     20:05:00:c0:dd:00:bd:ec   N      20:00:00:00:c9:22:1e:93   010500 P

10     E     20:0a:00:c0:dd:00:bd:ec   E      10:00:00:c0:dd:00:80:21   4(0x4) D 
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The following is an example of the Show Topology command for port 1:

2/8q FC Switch  #> show topology 1

  Local Link Information

  ----------------------

  PortNumber 1

  PortID     650100

  PortWWN    20:01:00:c0:dd:00:91:11

  PortType   F

Remote Link Information

----------------------- 

Device 0 

NodeWWN 50:80:02:00:00:06:d5:38

PortType NL

Description (NULL)

IPAddress 0.0.0.0 

Device 1 

NodeWWN 20:00:00:20:37:2b:08:c9

PortType NL

Description (NULL)

IPAddress 0.0.0.0 

Device 2 

Description (NULL)

IPAddress 0.0.0.0

Device 3

NodeWWN 20:00:00:20:37:2b:05:c9

PortType NL

Description (NULL)

IPAddress 0.0.0.0
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The following is an example of the Show Version command:

2/8q FC Switch #> show version

       *****************************************************

       *                                                   *

       *       Command Line Interface SHell  (CLISH)       *

       *                                                   *

       *****************************************************

       SystemDescription HP StorageWorks 2/8q FC Switch
       Eth0NetworkAddress 10.0.0.1 (use 'set setup system' to update)

       MACAddress         00:c0:dd:03:cf:cc

       WorldWideName      10:00:00:c0:dd:03:cf:cc

       ChassisSerialNumber 0346A00032

       SymbolicName       2/8q FC Switch

       ActiveSWVersion V4.0.0.4-0

       ActiveTimestamp    Thu Sep 2 18:41:02 2004

       DiagnosticsStatus  Passed

Show Config command
Displays switch, port, alarm threshold, and zoning for the current configuration.

Authority

None

Syntax

SHOW CONFIG

Keywords

PORT [port_number]

Displays configuration parameters for the port number given by [port_number]. Ports 
are numbered beginning with 0. If [port_number] is omitted, all ports are specified.

SWITCH

Displays configuration parameters for the switch.

THRESHOLD

Displays alarm threshold parameters for the switch.

AONING

Displays zoning configuration parameters for the switch.

Examples

The following is an example of the Show Config Port command:

2/8q FC Switch #> show config port 3

    Port Number: 3

  ------------

  AdminState         Offline
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  LinkSpeed          Auto

  PortType           GL

  SymbolicName       Port3

  ALFairness         False

  DeviceScanEnabled  True

  ForceOfflineRSCN   False

  ARB_FF             False

  InteropCredit      0

  ExtCredit          0

  FANEnabled         True

  LCFEnabled         False

  MFSEnabled         True

  MSEnabled          True

  NoClose            False

  IOStreamGuard      Disabled

  VIEnabled          False

  PDISCPingEnable    True

The following is an example of the Show Config Switch command:

2/8q FC Switch #> show config switch

 Configuration Name: default

 -------------------

  Switch Configuration Information

  --------------------------------

  AdminState            Online

  BroadcastEnabled      False

  InbandEnabled         True

  DomainID              19 (0x13)

  DomainIDLock          True

  SymbolicName          sw108

  R_A_TOV               10000

  E_D_TOV               2000

  PrincipalPriority     254

  ConfigDescription 2/8q FC Switch
  ConfigLastSavedBy     admin@OB-session5

  ConfigLastSavedOn     day month date time year

  InteropMode          True

  Legacy Address Format False1

1. Appears only if FC-SW-2 Compliant is False.
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The following is an example of the Show Config Threshold command:

  2/8q FC Switch #> show config threshold

  Configuration Name: default

  ------------

  

  Threshold Configuration Information

  -----------------------------------

  ThresholdMonitoringEnabled    False

  CRCErrorsMonitoringEnabled    True

  RisingTrigger                 25

  FallingTrigger                1

  SampleWindow                  10

  DecodeErrorsMonitoringEnabled True

  RisingTrigger                 25

  FallingTrigger                0

  SampleWindow                  10

  LoginMonitoringEnabled        True

  RisingTrigger                 5

  FallingTrigger                1

  SampleWindow                  10

  LogoutMonitoringEnabled       True

  RisingTrigger                 5

  FallingTrigger                1

  SampleWindow                  10

  LOSMonitoringEnabled          True

  RisingTrigger                 100

  FallingTrigger                5

  SampleWindow                  10

The following is an example of the Show Config Zoning command:

2/8q FC Switch #> show config zoning

 Configuration Name: default

  -------------------

  Zoning Configuration Information

  --------------------------------

  InteropAutoSave      True

  Default Visibility    All
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Show Log command
Displays the contents of the log or the parameters used to create and display entries in the log. 
The log contains a maximum of 1200 entries. When the log reaches its entry capacity, 
subsequent entries overwrite the existing entries, beginning with the oldest.

Authority

None

Syntax

SHOW LOG

Keywords

[number of events]

Specifies the number of the most recent events to display from the event log. [number 
of events] must be a positive integer.

COMPONENTS

Displays the components currently being monitored for events. The components are as 
follows:

Mgmtserver—Management server events

Nameserver—Name server events

Port—Port events

SNMP—SNMP events.

Switch—Switch management events.

Zoning—Zoning conflict events.

DISPLAY [filter]

Displays log events on the screen according to the component or severity level filter 
given by [filter]. [filter] can be one of the following:

Info—Displays all informative events.

Warning—Displays all warning events.

Critical—Displays all critical events.

Eport—Displays all events related to E_Ports.

Mgmtserver—Displays all events related to the management server.

Nameserver—Displays all events related to the name server.

Port [port_number]—Displays all events related to the port given by [port_number].

SNMP—Displays all events related to SNMP.

Switch—Displays all events related to switch management.

Zoning—Displays all events related to zoning.

level

Displays the event severity level logging setting and the display level setting.

options

Download from Www.Somanuals.com. All Manuals Search And Download.



Command Line Interface

164 HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Displays the options that are available for configuring event logging and automatic 
display to the screen. See the “Set Log Command” on page 144 for information about 
how to configure event logging and display level.

port

Displays the ports being monitored for events. If an event occurs which is of the 
defined level and on a defined component, but not on a defined port, no entry is made 
in the log.

settings

Displays the current filter settings for component, severity level, port, and display 
level. This command is equivalent to executing the following commands separately: 
Show Log Component, Show Log Level, and Show Log Port.

Examples

The following is an example of the Show Log Component command:
2/8q FC Switch #> show log component

Current settings for log

   ------------------------

   FilterComponent   NameServer MgmtServer Zoning Switch Blade Port Eport Snmp

The following is an example of the Show Log Level command:

2/8q FC Switch #> show log level

   Current settings for log

   ------------------------

   FilterLevel       Info

   DisplayLevel      Critical

The following is an example of the Show Log Options command:

2/8q FC Switch #> show log options

  Allowed options for log

  -----------------------

   FilterComponent

All,None,NameServer,MgmtServer,Zoning,Switch,Blade,Port,Eport,Snmp

   FilterLevel       Critical,Warn,Info,None

   DisplayLevel      Critical,Warn,Info,None

The following is an example of the Show Log command:

  2/8q FC Switch #> show log

   [327][day month date time year][I][Eport Port:0/8][Eport State=
   E_A0_GET_DOMAIN_ID]

   [328][day month date time year][I][Eport Port: 0/8][FSPF PortUp state=0]

   [329][day month date time year][I][Eport Port: 0/8][Sending init hello]

   [330][day month date time year][I][Eport Port: 0/8][Processing EFP, oxid= 0x8]

   [331][day month date time year][I][Eport Port: 0/8][Eport State = E_A2_IDLE]

   [332][day month date time year][I][Eport Port: 0/8][EFP,WWN= 0x100000c0dd00b845,
   len= 0x30]
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   [333][day month date time year][I][Eport Port: 0/8][Sending LSU oxid=0xc:type=1]

   [334][day month date time year][I][Eport Port: 0/8][Send Zone Merge Request]

   [335][day month date time year][I][Eport Port: 0/8][LSDB Xchg timer set]

   [336][day month date time year][I][Eport Port: 0/8][Setting attribute
   Oper.UserPort.0.8.EpConnState Connected]

Show Perf command
Displays port performance in frames/second and bytes/second. If you omit the keyword, the 
command displays data transmitted (out), data received (in), and total data transmitted and 
received in frames/second and bytes per second.

Authority

None

Syntax

SHOW PERF

Keywords

BYTE

Displays continuous performance data in total bytes/second transmitted and received 
for all ports. Enter q to stop the display.

INBYTE

Displays continuous performance data in bytes/second received for all ports. Type q 
and press Enter to stop the display.

OUTBYTE

Displays continuous performance data in bytes/second transmitted for all ports. Enter 
q to stop the display.

FRAME

Displays continuous performance data in total frames/second transmitted and received 
for all ports. Enter q to stop the display.

INFRAME

Displays continuous performance data in frames/second received for all ports. Enter q 
to stop the display.

OUTFRAME

Displays continuous performance data in frames/second transmitted for all ports. 
Enter q to stop the display.

ERRORS

Displays continuous error counts for all ports. Enter q to stop the display.
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Examples

The following is an example of the Show Perf command:

2/8q FC Switch #> show perf

Port   Bytes/s    Bytes/s    Bytes/s    Frames/s   Frames/s   Frames/s

  Number   (in)       (out)    (total)      (in)       (out)    (total)

  ------ -------    -------    -------    --------   --------   --------

  0      7K         136M       136M       245        68K        68K

  1      58K        0          58K        1K         0          1K

  2      0          0          0          0          0          0

  3      0          0          0          0          0          0

  4      0          0          0          0          0          0

  5      0          0          0          0          0          0

  6      0          7K         7K         0          245        245

  7      136M       58K        136M       68K        1K         70K

The following is an example of the Show Perf Byte command:
2/8q FC Switch $> show perf byte

Displaying bytes/sec data...  (Press 'q' and the ENTER key to stop display)

  0    1    2    3    4    5    6    7

  -----------------------------------------------------------------------------

  76M  0    0    32M  0    0    0    43M

  78M  0    0    34M  0    0    0    43M

  78M  0    0    34M  0    0    0    43M

  77M  0    0    33M  0    0    0    44M

  77M  0    0    33M  0    0    0    44M

  84M  0    0    40M  0    0    0    43M

  83M  0    0    39M  0    0    0    43M

  80M  0    0    35M  0    0    0    45M

  77M  0    0    33M  0    0    0    44M

  78M  0    0    33M  0    0    0    44M

  75M  0    0    29M  0    0    0    45M

  74M  0    0    28M  0    0    0    46M

q

Show Setup command
Displays the current SNMP and system settings.

Authority

None

Syntax

SHOW SETUP
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Keywords

MFG

Displays manufacturing information about the switch.

SNMP

Displays the current SNMP settings.

SYSTEM

Displays the current system settings.

Examples

The following is an example of the Show Setup Mfg command:

2/8q FC Switch #> show setup mfg

  Manufacturing Information

  -------------------------

  BrandName                HP 

  BuildDate                Thursday, September 16, 2004 12:09

ChassisPartNumber A7450-63001 A

  ChassisSerialNumber 0346A00032

CPUBoardSerialNumber 0346A00032

  MACAddress               00:c0:dd:03:cf:cc

  PlanarPartNumber         310077-00 A

  SwitchSymbolicName       2/8q FC Switch

  SwitchWWN                10:00:00:c0:dd:03:cf:cc

  SystemDescription HP StorageWorks 2/8q FC Switch
  SystemObjectID  1.3.6.1.4.1.1663.1.1.1.1.31

The following is an example of the Show Setup SNMP command:

2/8q FC Switch #> show setup snmp

  SNMP Information

  ----------------

  SNMPEnabled           True

  Contact               <sysContact undefined>

  Location              N_107 System Test Lab

  Description 2/8q FC Switch
  Trap1Address          10.0.0.254

  Trap1Port             162

  Trap1Severity         warning

  Trap1Version          2
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  Trap1Enabled          False

  Trap2Address          0.0.0.0

  Trap2Port             162

  Trap2Severity         warning

  Trap2Version          2

  Trap2Enabled          False

  Trap3Address          0.0.0.0

  Trap3Port             162

  Trap3Severity         warning

  Trap3Version          2

  Trap3Enabled          False

  Trap4Address          0.0.0.0

  Trap4Port             162

  Trap4Severity         warning

  Trap4Version          2

  Trap4Enabled          False

  Trap5Address          0.0.0.0

  Trap5Port             162

  Trap5Severity         warning

  Trap5Version          2

  Trap5Enabled          False

  ObjectID              1.3.6.1.4.1.1663.1.1.1.1.31

  AuthFailureTrap       True

  ProxyEnabled          True

The following is an example of the Show Setup System command:

2/8q FC Switch #> show setup system

  System Information

  ------------------

  Eth0NetworkDiscovery     Static

  Eth0NetworkAddress       10.20.11.32

  Eth0NetworkMask          255.255.252.0

  Eth0GatewayAddress       10.20.8.254

  AdminTimeout             30

  LocalLogEnabled          True

  RemoteLogEnabled         False

  RemoteLogHostAddress     10.0.0.254

  NTPClientEnabled         False

  NTPServerAddress         10.0.0.254

Download from Www.Somanuals.com. All Manuals Search And Download.



Command Line Interface

169HP StorageWorks 2/8q Fibre Channel Switch Management User Guide

Shutdown command
Terminates all data transfers on the switch at convenient points and closes the Telnet session. 
Always power cycle the switch after entering this command.

Authority

Admin

Syntax

SHUTDOWN

Notes

Always use this command to perform an orderly shut down before removing power from 
the switch.

When the shutdown is complete, the Heartbeat LED is extinguished.

Test command
Tests ports using internal (SerDes level), external (transceiver), and online loopback tests. 
Internal and external tests require that the port be placed in diagnostic mode. See the “Set 
command” on page 135 for information about changing the port administrative state. While 
the test is running, the remaining ports on the switch remain fully operational.

Authority

Admin

Syntax

TEST

Keywords

PORT [port_number] [test_type]

Tests the port given by [port_number] using the test given by [test_type]. If you omit 
[test_type], Internal is used. [test_type] can have the following values:

internal—Tests the SerDes. This is the default. The port must be in diagnostics 
mode to perform this test.

external—Tests both the SerDes and transceiver. The port must be in diagnostics 
mode to perform this test, and a loopback plug must be installed in the transceiver.

online—Tests communications between the port and its device node or device loop. 
The port being tested must be online and connected to a remote device. The port 
passes if the test frame that was sent by the ASIC matches the frame that is received. 
This test does not disrupt communication on the port.

CANCEL—Cancels the online test in progress.

STATUS—Displays the status of a test in progress, or if there is no test in progress, 
the status of the test that was executed last.

Examples

To run an internal or external port test:

1. To start an admin session, enter the following command:

admin start
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2. Place the port in Diagnostics mode by entering the following command (x = port number):

set port x state diagnostics

3. Choose the type of port loopback test to run:

■ To run an internal loopback test, enter the following:

test port x internal

■ To run an external loopback test, enter the following command. A loopback plug must 
be installed for this test to pass. 

test port x external

4. A series of test parameters are displayed on the screen. Press Enter to accept each default 
parameter value, or enter a new value for each parameter. The TestLength parameter is the 
number of frames sent, the FrameSize (256 byte maximum in some cases) parameter is the 
number of bytes in each frame, and the DataPattern parameter is the pattern in the payload.

5. After the test type has been chosen and the command executed, a message on the screen 
will appear detailing the test results.

6. After the test is run, put the port back into online state by entering the following command 
(x = port number). 

set port x state online

7. To verify port is back online, enter the following command. The contents of the 
AdminState box should display Online.

show port x

8. The online loopback (node-to-node) test requires that port be online and connected to a 
remote device. To run the online loopback test:

9. To start an admin session, enter the following command.

admin start

10. To run the online loopback test, enter the following command. 

test port x online

11. A series of test parameters are displayed on the screen. Press Enter to accept each default 
parameter value, or enter a new value for each parameter. The TestLength parameter is the 
number of frames sent, the FrameSize (256 byte maximum in some cases) parameter is the 
number of bytes in each frame, and the DataPattern parameter is the pattern in the payload. 
Before running the test, make sure that the device attached to the port can handle the test 
parameters.

2/8q FC Switch (admin) #> test port x online

A list of attributes with formatting and current values will follow. Enter 
a new value or simply press the ENTER key to accept the default value. If 
you wish to terminate this process before reaching the end of the list 
press 'q' or 'Q' and the ENTER key to do so.

  TestLength    (decimal value, 1-4294967295)   [100    ]

  FrameSize     (decimal value, 36-2148)        [256    ]

  DataPattern   (32-bit hex value or 'Default') [Default]

  StopOnError   (True/False)                    [False  ]

  Do you want to start the test? (y/n) [n]

12. After all parameter values are defined, press Y to start the test. After the command 
executes, a message on the screen appears detailing the test results.
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Uptime command
Displays the elapsed up time since the switch was last reset and reset method. A hot reset or 
non-disruptive firmware activation does not reset the elapsed up time reported by this 
command.

Authority

None

Syntax

UPTIME

Examples

2/8q FC Switch #> uptime

  Elapsed up time  : 0 day(s), 2 hour(s), 28 min(s), 44 sec(s)

  Reason last reset: NormalReset

User command
Administers and displays user accounts.

Authority

Admin, except for the List option.

Syntax

USER

Keywords

ACCOUNTS

Displays all user accounts that exist on the switch. This keyword is available to all 
account names without an Admin session.

ADD

Add a user account to the switch. You will be prompted for an account name, a 
password, authority, and an expiration date.

— A switch can have a maximum of 15 user accounts.

— Account names are limited to 15 characters; passwords must be 4–20 characters.

— Admin authority grants permission to use the Admin command to open an admin 
session, from which all commands can be entered. Without Admin authority, you 
are limited to view-only commands.

— The expiration date is expressed in the number of days until the account expires 
(2000 maximum). The switch will issue an expiration alarm every day for seven 
days prior to expiration. 0 (zero) specifies that the account has no expiration date.

DELETE [account_name]

Deletes the account name given by [account_name] from the switch.
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EDIT

Initiates an edit session that prompts you for the account name for which to change the 
expiration date and authority.

LIST

Displays the list of users currently logged in and their session numbers. Provides the 
same function as the Show Users command. This keyword is available to all 
account names without an Admin session.

Examples

The following is an example of the User Accounts command:

2/8q FC Switch (admin) #> user accounts

    Current list of user accounts

  -----------------------------

  images       (admin authority = False, never expires)

  admin        (admin authority = True , never expires)

  chuckca      (admin authority = False, expires in < 50 days)

  gregj        (admin authority = True , expires in < 100 days)

  fred         (admin authority = True , never expires)

The following is an example of the User Add command:

2/8q FC Switch (admin) #> user add

    Press 'q' and the ENTER key to abort this command.

account name (1-15 chars)      : user1

account password (4-20 chars)  : *******

please confirm account password: *******

set account expiration in days (0-2000, 0=never): [0] 100

should this account have admin authority? (y/n): [n] y

OK to add user account 'user1' with admin authority

and to expire in 100 days?

Please confirm (y/n): [n] y
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The following is an example of the User Edit command:

2/8q FC Switch (admin) #> user edit

      Press 'q' and the ENTER key to abort this command.

  account name (1-15 chars)      : user1

  set account expiration in days (0-2000, 0=never): [0]

  should this account have admin authority? (y/n): [n]

  OK to modify user account 'user1' with no admin authority

  and to expire in 0 days?

  Please confirm (y/n): [n]

The following is an example of the User Delete command:

2/8q FC Switch (admin) #> user del user3

  The user account will be deleted.  Please confirm (y/n): [n] y

The following is an example of the User List command:
2/8q FC Switch (admin) #> user list

    User                           Ethernet Addr-Port    Logged in Since

    ----                           ------------------    ---------------

  admin@OB-session1              10.20.68.108-1031     day month date time year

  admin@OB-session2              10.20.68.108-1034     day month date time year

  snmp@OB-session3               Unknown               day month date time year

  snmp@IB-session4               Unknown               day month date time year

  admin@OB-session5              Unknown               day month date time year

Whoami command
Displays the account name, session number, and switch domain ID for the Telnet session.

Authority

None

Syntx

WHOAMI

Examples

2/8q FC Switch #> whoami

User name       : admin@session2

Switch name     : 2/8q FC Switch

Switch domain ID: 21 (0x15)
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Zone Command
Manages zones and zone membership on a switch.

Authority

Admin and a Zoning Edit. See the “Zoning command” on page 178 for information about 
starting a Zoning Edit session. The List, Members, and Zonesets keywords are 
available without an Admin session.

Syntax

ZONE

Keywords

ADD [zone] [member_list]

Specifies one or more ports/devices given by [members] to add to the zone named 
[zone]. Use a <space> to delimit aliases and ports/devices in [member_list]. A zone 
can have a maximum of 2000 members. [member_list] can have any of the following 
formats:

— Domain ID and port number pair (Domain ID, Port Number). Domain IDs can be 
1-239; port numbers can be 0-255.

— 6-character hexadecimal device Fibre Channel address (hex)

— 16-character hexadecimal worldwide port name (WWPN) with the format 
xx:xx:xx:xx:xx:xx:xx:xx.

— Alias name

The application verifies that the [members] format is correct, but does not validate that 
such a member exists.

COPY [zone_source] [zone_destination]

Creates a new zone named [zone_destination] and copies the membership into it from 
the zone given by [zone_source].

CREATE [zone]

Creates a zone with the name given by [zone]. An zone name must begin with a letter 
and be no longer than 64 characters. Valid characters are 0-9, A-Z, a-z, _, $, ^, and -. 
The zoning database supports a maximum of 1000 zones.

DELETE [zone]

Deletes the specified zone given by [zone] from the zoning database. If the zone is a 
component of the active zone set, the zone will not be removed from the active zone 
set until the active zone set is deactivated.

LIST

Displays a list of all zones and the zone sets of which they are components. This 
keyword does not require an Admin session.

MEMBERS [zone]

Displays all members of the zone given by [zone]. This keyword does not require an 
Admin session.
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REMOVE [zone] [member_list]

Removes the ports/devices given by [member_list] from the zone given by [zone]. 
Use a <space> to delimit aliases and ports/devices in [member_list]. [member_list] 
can have any of the following formats:

— Domain ID and port number pair (Domain ID, Port Number). Domain IDs can be 
1-239; port numbers can be 0-255.

— 6-character hexadecimal device Fibre Channel address (hex)

— 16-character hexadecimal worldwide port name (WWPN) with the format 
xx:xx:xx:xx:xx:xx:xx:xx.

— Alias name

RENAME [zone_old] [zone_new]

Renames the zone given by [zone_old] to the zone given by [zone_new].

TYPE [zone] [zone_type]

Specifies the zone type given by [zone_type] to be assigned to the zone name given by 
[zone]. If you omit the [zone_type], the system displays the zone type for the zone 
given by [zone]. [zone_type] can be one of the following:

soft—name server zone

hardACL—Access control list hard zone. This keyword is case sensitive.

ZONESETS [zone]

Displays all zone sets of which the zone given by [zone] is a component. This 
keyword does not require an Admin session.

Examples

The following is an example of the Zone List command:

2/8q FC Switch #> zone list

 

  Zone        ZoneSet

  -------------------

  wwn_b0241f

              zone_set_1

 

  wwn_23bd31

              zone_set_1

 

  wwn_221416

              zone_set_1

 

  wwn_2215c3

              zone_set_1

 

  wwn_0160ed

              zone_set_1
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  wwn_c001b0

              zone_set_1

 

  wwn_401248

              zone_set_1

 

  wwn_02402f

              zone_set_1

 

  wwn_22412f

              zone_set_1

The following is an example of the Zone Members command:

2/8q FC Switch #> zone members wwn_b0241f

  Current List of Members for Zone: wwn_b0241f

  ---------------------------------

  50:06:04:82:bf:d2:18:c2

  50:06:04:82:bf:d2:18:d2

  21:00:00:e0:8b:02:41:2f

The following is an example of the Zone Zonesets command:

2/8q FC Switch #> zone zonesets zone1

  Current List of ZoneSets for Zone: zone1

  ----------------------------------

  zone_set_1 

Zoneset command
Manages zone sets and component zones across the fabric.

Authority

Admin and Zoning Edit. See the “Zoning command” on page 178 for information about 
starting a Zoning Edit session. The Active, List, and Zones keywords are available 
without an Admin session. You must close the Zoning Edit session before using the 
Activate and Deactivate keywords.

Syntx

ZONESET

Keywords

ACTIVATE [zone_set]

Activates the zone set given by [zone_set]. This keyword deactivates the active zone 
set. Close the Zoning Edit session before using this keyword.
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ACTIVE

Displays the name of the active zone set. This keyword does not require Admin 
session.

ADD[zone_set] [zone_list]

Adds a list of zones and aliases given by [zone_list] to the zone set given by 
[zone_set]. Use a <space> to delimit zone and alias names in [zone_list].

COPY [zone_set_source] [zone_set_destination]

Creates a new zone set named [zone_set_destination] and copies into it the zones from 
the zone set given by [zone_set_source].

CREATE [zone_set]

Creates the zone set with the name given by [zone_set]. A zone set name must begin 
with a letter and be no longer than 64 characters. Valid characters are 0-9, A-Z, a-z, _, 
$, ^, and -. The zoning database supports a maximum of 256 zone sets.

DEACTIVATE

Deactivates the active zone set. Close the Zoning Edit session before using this 
keyword.

DELETE[zone_set]

Deletes the zone set given by [zone_set]. If the specified zone set is active, the 
command is suspended until the zone set is deactivated.

LIST

Displays a list of all zone sets. This keyword does not require an Admin session.

REMOVE[zone_set] [zone_list]

Removes a list of zones given by [zone_list] from the zone set given by [zone_set]. 
Use a <space> to delimit zone names in [zone_list]. If [zone_set] is the active zone 
set, the zone will not be removed until the zone set has been deactivated.

RENAME [zone_set_old] [zone_set_new]

Renames the zone set given by [zone_set_old] to the name given by [zone_set_new]. 
You can rename the active zone set. 

ZONES [zone_set]

Displays all zones that are components of the zone set given by [zone_set]. This 
keyword does not require an Admin session.

Notes

■ A zone set must be active for its definitions to be applied to the fabric.

■ Only one zone set can be active at one time.

■ A zone can be a component of more than one zone set.

Examples

The following is an example of the Zoneset Active command:

2/8q FC Switch #> zoneset active

  ActiveZoneSet    Bets

  LastActivatedBy  admin@OB-session6

  LastActivatedOn  day month date time year
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The following is an example of the Zoneset List command:

2/8q FC Switch #> zoneset list

  Current List of ZoneSets

  ------------------------

  alpha

  beta

The following is an example of the Zoneset Zones command:

2/8q FC Switch #> zoneset zones ssss

  Current List of Zones for ZoneSet: ssss

  ----------------------------------

  zone1

  zone2

  zone3

Zoning command
Opens a Zoning Edit session in which to create and manage zone sets and zones. See the 
“Zoning command” on page 178 and the “Zoneset command” on page 176.

Authority

Admin, except for the Active, History, Limits, and List keywords.

Syntax

ZONING

Keywords

ACTIVE

Displays information for the active zone set including component zones and zone 
members. This keyword does not require an Admin session.

CANCEL

Closes the current Zoning Edit session. Any unsaved changes are lost.

CLEAR

Clears all inactive zone sets from the volatile edit copy of the zoning database. This 
keyword does not affect the non-volatile zoning database. However, if you enter the 
Zoning Clear command followed by the Zoning Save command, the 
non-volatile zoning database is cleared from the switch.

Note:  The preferred method for clearing the zoning database from the switch is the Reset 
Zoning command.

EDIT

Opens a Zoning Edit session.
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HISTORY

Displays a history of zoning modifications. This keyword does not require an Admin 
session. History information includes the following:

— Time of the most recent zone set activation or deactivation and the user who 
performed it

— Time of the most recent modifications to the zoning database and the user who 
made them.

— Checksum for the zoning database

LIMITS

Displays the number of zone sets, zones, aliases, members per zone, members per 
alias, and total members in the zoning database. This keyword also displays the switch 
zoning database limits, excluding the active zone set, which are described in Table 58. 
This keyword does not require an Admin session.

LIST

Lists all fabric zoning definitions. This keyword does not require an Admin session.

RESTORE

Reverts the changes to the zoning database that have been made during the current 
Zoning Edit session since the last Zoning Save command was entered.

SAVE

Saves changes made during the current Zoning Edit session. The system will inform 
you that the zone set must be activated to implement any changes. This does not apply 
if you entered the Zoning Clear command during the Zoning Edit session.

Table 58:  Zoning limits

Limit Description
MaxZoneSets Maximum number of zone sets (256).
MaxZones Maximum number of zones (256).
MaxAliases Maximum number of aliases (256).
MaxTotalMembers Maximum number of zone and alias members 

(2000) that can be stored in the switch’s 
zoning database.

MaxZonesInZoneSets Maximum number of zones that are 
components of zone sets (1000), excluding the 
orphan zone set, that can be stored in the 
switch’s zoning database. Each instance of a 
zone in a zone set counts toward this 
maximum.

MaxMembersPerZone Maximum number of members in a zone 
(2000) that can be stored in the switch’s 
zoning database.

MaxMembersPerAlias Maximum number of members in all zones 
and aliases (2000)
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Examples

The following is an example of the Zoning Edit command:

2/8q FC Switch #> admin start

2/8q FC Switch (admin) #> zoning edit

2/8q FC Switch (admin-zoning) #>

.

.

2/8q FC Switch (admin-zoning) #> zoning cancel

  Zoning edit mode will be canceled.  Please confirm (y/n): [n]   y

2/8q FC Switch (admin) #> admin end

The following is an example of the Zoning Limits command:

2/8q FC Switch #> zoning limits

  Zoning Attribute     Maximum   Current   [Name]

  ----------------     -------   -------   ------

  MaxZoneSets          256       6

  MaxZones             256       19

  MaxAliases           256       1

  MaxTotalMembers      2000      149

  MaxZonesInZoneSets   1000      15

  MaxMembersPerZone    2000

                                 10        D_1_JBOD_1

                                 23        D_1_Photons

                                 9         D_2_JBOD1

                                 16        D_2_NewJBOD_2

                                 5         E1JBOD1

                                 5         E2JBOD2

                                 3         LinkResetZone

                                 3         LinkResetZone2

                                 8         NewJBOD1

                                 8         NewJBOD2

                                 12        Q_1Photon1

                                 12        Q_2Photon2

                                 8         Q_1_NewJBOD1

                                 13        Q_1_Photon_1
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                                 13        Q_2_Photon_2

  MaxMembersPerAlias   2000

                                 2         AliasInAZone

The following is an example of the Zoning List command:

2/8q FC Switch #> zoning list

 

  Active ZoneSet Information
 

  ZoneSet     Zone      ZoneMember

  --------------------------------

  wwn

              wwn_b0241f

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        21:00:00:e0:8b:02:41:2f

 

              wwn_23bd31

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:23:bd:31

 

              wwn_221416

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:22:14:16
 

              wwn_2215c3

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:22:15:c3 

 

  Configured Zoning Information

 

ZoneSet     Zone      ZoneMember

  --------------------------------

  wwn

              wwn_b0241f

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        21:00:00:e0:8b:02:41:2f
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              wwn_23bd31

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:23:bd:31
 

              wwn_221416

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:22:14:16

 

              wwn_2215c3

                        50:06:04:82:bf:d2:18:c2

                        50:06:04:82:bf:d2:18:d2

                        10:00:00:00:c9:22:15:
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remove  57
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Alias command  118
Arbitrated Loop Physical Address  146
archive configuration  75
audience  14
authentication

trap  74
authority  116
authorized reseller, HP  18
auto save

default fabric view file  24
graphing options  93
zoning configuration  48

B
beacon  135
BootP boot method  73
broadcast  70,  151
browser

location  24,  93

C
chassis

status  151
Command Line Interface  111
command syntax  116
commands  116
Config command  119
configuration

activate  119
archive  75
backup  119
copy  120
delete  120
edit  120
list  120
reset  132
restore  75,  120
save  120

configured administrative state  70
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conventions

document  15
equipment symbols  16
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CRC error  66
Create Support command  122
credits  88
current administrative state  70
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D
data window

Active Zoneset  44
Configured Zonesets  65
description  31,  32,  34
Name Server  63
port information  84
port statistics  82
switch  63

database
fabric  36
zoning  49

date  68
Date command  123
Decode error  66
default

configuration  77
visibility  48,  52
zoning  48

default fabric view file
auto save  24
Switch Manager  24

device scan  87
distance  88
document

conventions  15
related documentation  14

domain ID
description  70
display  151
lock  70

donor port  81,  87,  151
Dynamic Host Configuration Protocol  73

E
E_Port isolation  70
equipment symbols  16
Error Detect Timeout  71
event browser

filter  43
preference  24
sort  43

event logging
by component  144,  163
by port  145,  164
by severity level  163
display  163
restore defaults  145
save settings  146
settings  164
severity level  145
start  146
stop  146

external test  89,  169

F
F_Port  81,  87
fabric

add  36
add a switch  38
database  36
delete  37
discovery interval  24
displaying information  40
loop port  81,  87
management  35
port  81,  87
rediscovery  38
services  36
status  40
tree  29
zoning  45

fabric services  36
Fabric View

arrange graphs  94
customize graphs  94
display graphs  94
preferences  93
start  91

fabric view file  92
auto save  93
open  37
password  92
save  38

faceplate display
data window  34
description  25,  33
open  33

factory defaults  77,  132
FC-4 descriptor  87
File Transfer Protocol  128
firmware

image file  78,  127
install with Switch Manager  78
installation  123
list image files  127
non-disruptive activation  78,  126,  127
remove image files  127
retrieve image file  127
unpack image  127
version  154

Firmware Install command  123
FL_Port  81,  87

G
gateway address  73
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generic
port  81,  87

generic port  81,  87
getting help  18
graphic window  30

H
hard reset  68
Hardreset command  124
help  25
Help command  125
help, obtaining  17
History command  126
Hotreset command  126
HP

authorized reseller  18
storage web site  18
technical support  18

I
I/O Steam Guard  87
Image command  127
in-band management  71
Initial Start Dialog  24
internal

test  169
internal test  89
Interop mode  71
IP

address  73
configuration  72

L
layout  33
legacy address format  71
link

delete  39
selecting  32
status  32

Link data window  64
link state database  151
Lip command  129
log

archive  144
clear  144
event  144,  163
power-on self test  153

logged in users  154
loop port

bypass  146
enable  146
fabric  81,  87
initialization  129

loopback test  89
loss of signal monitoring  66

M
management workstation  20
manufacturer information  167
media status  81
memory

activity  151
menu  33
menu structure  26
messages  97

N
name server

display  151
export  67
zone  46

Name Server data window  63
network

configuration reset  132
discovery  73
interfaces  151
properties  72

Network Time Protocol
client  149
server  149

node-to-node test  89
non-disruptive activation  78,  126

O
online

help  25
test  89

online test  169
orphan zone set  46

P
page break  136
Passwd command  129
password

change  129
default fabric file  93
default fabric view file  23
switch  37,  129
user account  60,  112

performance graphs  94
Ping command  130
port

administrative state  86,  147
buffer credits  87,  88
configuration  85,  137
configuration display  160
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counters  146
displaying information  80
external test  169
initialize  132
internal test  169
loopback test  169
mode  81
online test  169
operational information  152
operational state  81
performance  91,  152,  165
reset  89
selecting  34
speed  81,  86,  146
status  33
test  89
view  24,  33

Port Information data window  65,  84
Port Statistics data window  64,  82
port/device tree  50
power on self test

log  153
preferences

Fabric View  93
Switch Manager  24

principal switch  70
properties

network  72
port  85

Ps command  130

Q
Quit command  131

R
read community  73
receive buffer  87
refresh  40,  62
Registered State Control Notification  87
related documentation  14
remote logging  74
reset

with POST  68
without POST  68

Reset command  131
Resource Allocation Timeout  71
restore configuration  75
Reverse Address Resolution Protocol  73

S
scan device  87
SerDes level test  89
Set command  135

Set Config command  137
Set Log command  144
Set Port command  146
Set Setup command  147
SFP level test  89
Show command  150
Show Config command  160
Show Log command  163
Show Perf command  165
Show Setup command  166
Shutdown command  169
Simple Network Management Protocol

configuration  73,  147
configuration display  167
proxy  73
reset  132
trap configuration  74

SNMP enabled  73
soft zone  46,  56
static boot method  73
status icon color  30
steering  153
subnet mask address  73
switch

add  38
administrative state  70,  136
configuration  68,  139
configuration display  160
delete  39
displaying information  62
hard reset  68,  124
icons  40
location  74
manufacturer information  167
operational information  154
paging  67
properties  69
replace  39
reset  171
reset without POST  68,  132
restore factory defaults  77
selecting  32
status  32

Switch data window  63
Switch Manager

default fabric file  22
exit  22
preferences  24,  93
uninstall  23
user interface  25
version  25

Switch Manager installation
Linux  21
Windows  20
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symbolic name  69
symbols in text  15
symbols on equipment  16
syslog  74
system configuration

change  148
display  167

T
technical support, HP  18
temperature  151
Test command  169
testing ports  89
text symbols  15
time  68,  123
timeout values  71
tool bar

standard  29
zoning  50

topology display
arrange icons  32
data windows  32
description  25
usage  31

transceiver status  81
transmission speed  86
trap

authentication  74
community  73
configuration  74
SNMP version  74

U
Uptime command  171
user

account  112
logged in  154

user account
create  59
modify  61
password  60
remove  59
security  35

User command  171

V
version  25

W
warning

symbols on equipment  16
web sites

HP storage  18

Whoami command  173
working

directory  24,  93
status indicator  31

write community  74

Z
zone

access control list  46
add member port  55,  174
copy  53,  174
create  54,  174
definition  45
delete  174
delete member port  175
list  174
list members  174
name server  46
remove  53,  56
remove all  56
remove member port  55
rename  55,  175
soft  46
type  56,  175

Zone command  174
zone merge

failure recovery  49
zone set

activate  52
active  44,  46,  178
add member zone  177
create  52,  177
deactivate  52,  132,  177
definition  46
delete  177
delete member zone  53,  177
display  177
display active  177
display members  177
display zones  175
management  52
orphan  46
remove  53
rename  55,  177
tree  50

Zoneset command  176
zoning

configuration  48,  141
configuration display  160
database  46,  49,  71,  132
default  48
edit  178
history  179
limits  179
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list definitions  179
remove all  53
revert changes  179

save edits  179
Zoning command  178
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http://www.manual-lib.com/
http://www.404manual.com/
http://www.luxmanual.com/
http://aubethermostatmanual.com/
http://www.golfingnear.com/
http://emailbydomain.com/
http://auto.somanuals.com/
http://tv.somanuals.com/
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